set_subfolder löscht bestehende Verknüpfungen

thomas.besser
Beiträge: 314
Registriert: 09 Sep 2009, 09:40

set_subfolder löscht bestehende Verknüpfungen

Beitragvon thomas.besser » 24 Sep 2010, 12:16

Hallo,

ich will Verknüpfungen im gemeinsamen Startmenü haben und zwar z.B. mehrere Tools in einem "Sub-Folder":

Code: Alles auswählen

[LinkFolder_install]
set_basefolder common_startmenu
set_subfolder "Tools"
set_link
   name: VLC Media Player
   target: $NewExe$
   parameters:
   working_dir:
   icon_file:
   icon_index:
end_link


Problem: obige Anweisung löscht schon vorhandene Verknüpfung im ebenfalls vorhandenen Subfolder "Tools". Läßt sich das verhindern, also dass der Link nur hinzugefügt wird.

Danke und Gruß
Thomas Besser

Benutzeravatar
d.oertel
uib-Team
Beiträge: 3269
Registriert: 04 Jun 2008, 14:27

Re: set_subfolder löscht bestehende Verknüpfungen

Beitragvon d.oertel » 25 Sep 2010, 19:58

Hi,

kann ich erstmal nicht nachvollziehen. Hier ein Log:

Code: Alles auswählen

[5] [25.09.2010 19:46:49]       If
[6] [25.09.2010 19:46:49]           Starting query if file exist ...
[5] [25.09.2010 19:46:49]         FileExists("C:\Dokumente und Einstellungen\All Users\Desktop\Dummy\Dummy2.LNK")   <<< result true
[5] [25.09.2010 19:46:49]         
[5] [25.09.2010 19:46:49]         Execution of LinkFolder_Dummy
[6] [25.09.2010 19:46:49]           Base folder is the COMMON DESKTOPDIRECTORY folder
[6] [25.09.2010 19:46:49]           Opened "Dummy" in the COMMON DESKTOPDIRECTORY folder
[6] [25.09.2010 19:46:49]             ShellLink "Dummy" overwritten
[5] [25.09.2010 19:46:49]       If
[6] [25.09.2010 19:46:49]           Starting query if file exist ...
[5] [25.09.2010 19:46:49]         FileExists("C:\Dokumente und Einstellungen\All Users\Desktop\Dummy\Dummy2.LNK")   <<< result true



gruss
d.oertel
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org

thomas.besser
Beiträge: 314
Registriert: 09 Sep 2009, 09:40

Re: set_subfolder löscht bestehende Verknüpfungen

Beitragvon thomas.besser » 27 Sep 2010, 10:38

Hallo,

danke für die Antwort. Das Studium des Log-Files hat mir weitergeholfen ;-)

Ich hatte versehentlich eine 'delete_subfolder' Anweisung in delsub.ins drin. Wurde also nicht überschrieben.

Danke und Gruß
Thomas Besser