pcproto.ini und REINS Mode

Benutzeravatar
Der-Matze
uib-Team
Beiträge: 69
Registriert: 16 Mär 2009, 11:00

pcproto.ini und REINS Mode

Beitragvon Der-Matze » 13 Sep 2010, 11:14

Hallo zusammen

Erst einmal ein großes Lob an das Team.
OPSI 4.0 ist soweit ich es getestet habe ein sehr gereiftes und durchdachtes Produkt geworden.
Es hat sich wirklich viel getan.

Aber nun zu meinem Problem:
Ich habe auf zwei Testservern (ubuntu 10.04) OPSI 4.0 frisch installiert.
Soweit funktioniert auch alles, nur leider ist auf beiden Servern die Datei /var/lib/opsi/config/templates/pcproto.ini leer.

Wird ein neuer Client am Server angelegt und der Bootmode auf "REINS" gestellt können somit auch keine Standard Pakete installiert werden.
Auch nicht wenn eine an einem OPSI 3.4 Server funktionierende Version der Datei in das Verzeichnis kopiert wird.

Des Weiteren werden auch keine Pakete installiert wenn das Betriebssystem eines am Server schon angelegten Clients neu installiert wird und nach der Installation des opsi-client-agents der Bootmode auf REINS gestellt wird.

Im Handbuch bin ich leider auch nicht fündig geworden.

Eine Suche im Forum ergab auch nur folgendes:
viewtopic.php?f=7&t=1676&p=8369&hilit=templates#p8369

Hat sich an der Struktur der Datei etwas wesentliches verändert?
Oder wird sie gar nicht mehr verwendet und ist durch eine andere Methode ersetzt worden?

Schöne Grüße ans Team

Benutzeravatar
j.schneider
Ex-uib-Team
Beiträge: 1414
Registriert: 29 Mai 2008, 15:14

Re: pcproto.ini und REINS Mode

Beitragvon j.schneider » 13 Sep 2010, 12:02

Hallo,

beim Anlegen eines neuen Clients wird die pcproto.ini als Vorlage für die <client-fqdn>.ini verwendet (kopiert).
Die Syntax in den ini-Dateien hat sich mit opsi 4.0 geändert.
Daher kann eine pcroto.ini von opsi 3.4 nicht einfach übernommen werden.
Am besten eine <client-fqdn>.ini kopieren und als pcproto.ini hinterlegen.

Gruß,
Jan Schneider

Benutzeravatar
Der-Matze
uib-Team
Beiträge: 69
Registriert: 16 Mär 2009, 11:00

Re: pcproto.ini und REINS Mode

Beitragvon Der-Matze » 13 Sep 2010, 15:30

Hallo Herr Schneider,

vielen Dank erst einmal für die schnelle Beantwortung meiner Fragen.

Ich habe auf einem Testclient sämtliche Softwarepakete installiert, die ich als Template verwenden möchte und danach die .ini Datei des Clients nach /var/lib/opsi/config/templates kopiert und in pcproto.ini umbenannt.

Bei neu angelegten Clients ist jetzt im Webinterface auch wie gewohnt der Stand der in der pcproto.ini vorhandenen Pakete auf "installed" gesetzt.

Wenn der opsi-client-agent allerdings im REINS Modus startet, setzt er den Status "(setup)" in der Spalte "Report", und nicht in der Spalte "Angefordert".

Danach meldet der agent zwar "Reloading products list after reinstallation", es werden aber nur zwei Produkte ordnungsgemäß installiert. Der Rest wird ignoriert.

Danach steht der Bootmode natürlich wieder auf BKSTD.

Ich habe mal die instlog.txt angehängt. Vielleicht hilft das ja.

instlog.txt


MfG

Benutzeravatar
d.oertel
uib-Team
Beiträge: 3278
Registriert: 04 Jun 2008, 14:27

Re: pcproto.ini und REINS Mode

Beitragvon d.oertel » 13 Sep 2010, 21:41

Hi,

sehr rätselhaft.

Die Logdatei sagt 'ich mach alles richtig'.
Ich habe versucht das hier auf einem System mit file backend nach zu vollziehen- Klappt aber alles.

Hilfreich wäre die opsiconfd.log zeitlich parallel zur instlog.txt.

gruss
d.oertel
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org

Benutzeravatar
Der-Matze
uib-Team
Beiträge: 69
Registriert: 16 Mär 2009, 11:00

Re: pcproto.ini und REINS Mode

Beitragvon Der-Matze » 14 Sep 2010, 08:37

Guten Morgen

Hier noch einmal die Logdateien von einem weiteren gescheiterten Versuch.
Diesmal wurde ein schon am OPSI Server bekannter Rechner neu installiert. Die .ini Datei wurde diesmal also nicht aus der pcproto.ini generiert.
Das Problem besteht jedoch weiterhin. Es werden nur die beiden Produkte setacl und pcwrunas installiert. Beide Pakete sind Abhängigkeiten des Pakets image-einrichtung.
Von diesem Paket hängen wiederum alle anderen zu installierenden Pakete ab.
Vielleicht hilft das ja weiter. Im Webinterface sieht man auch dass nur diese beiden Pakete in der Spalte "Angefordert" auf setup gestellt werden. Bei den anderen Paketen taucht nur unter der Spalte "Report" ein (setup) auf.


instlog.txt

opsiclientd.log

Benutzeravatar
j.schneider
Ex-uib-Team
Beiträge: 1414
Registriert: 29 Mai 2008, 15:14

Re: pcproto.ini und REINS Mode

Beitragvon j.schneider » 14 Sep 2010, 10:00

Es könnte sein, dass zirkuläre Abhängigkeiten zwischen den Produkten existieren.
Bsp.:
produkt-a setup requires produkt-b installed before
produkt-b setup requires produkt-a installed before

Benutzeravatar
d.oertel
uib-Team
Beiträge: 3278
Registriert: 04 Jun 2008, 14:27

Re: pcproto.ini und REINS Mode

Beitragvon d.oertel » 14 Sep 2010, 10:27

Hi,

Hilfreich wäre die opsiconfd.log zeitlich parallel zur instlog.txt.


Clientspezifischer Log file des opsiconfd - nicht opsiclientd.

gruss
d.oertel
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org

Benutzeravatar
Der-Matze
uib-Team
Beiträge: 69
Registriert: 16 Mär 2009, 11:00

Re: pcproto.ini und REINS Mode

Beitragvon Der-Matze » 14 Sep 2010, 12:16

Sorry, da hab ich mich beim Dateinamen verlesen.

Im clientspezifischen Log file des opsiconfd scheint tatsächlich des Rätsels Lösung versteckt zu sein:

product 'inventarisierung' defines dependency to product 'image-einrichtung', which is not avaliable (<string>|41)

Wie vorher schon erwähnt haben die beiden Produkte die problemlos installiert werden (setacl und pcwrunas) keine eigenen Abhängigkeiten.
Von diesen beiden Paketen hängt nur das Paket image-einrichtung ab. Und dieses Paket haben alle anderen Pakete als Abhängigkeit vor der Installation gesetzt, damit die Image-Einrichtung immer vor allen anderen Paketen installiert wird.
Das lässt sich ja inzwischen durch die Priorisierung geschickter lösen.

Trotzdem frage ich mich warum das Produkt 'image-einrichtung' nicht gefunden werden kann. Das Paket ist mit genau diesem Namen am Server vorhanden, taucht ganz normal im Webinterface auf und kann auch problemlos installiert werden. Verstößt der Paketname gegen eine seit OPSI 4.0 neue Konvention?

10.9.90.11.log

Benutzeravatar
d.oertel
uib-Team
Beiträge: 3278
Registriert: 04 Jun 2008, 14:27

Re: pcproto.ini und REINS Mode

Beitragvon d.oertel » 14 Sep 2010, 12:43

Hi,

hieß das paket vorher image_einrichtung (mit unterstrich) ?

gruss
d.oertel
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org

Benutzeravatar
Der-Matze
uib-Team
Beiträge: 69
Registriert: 16 Mär 2009, 11:00

Re: pcproto.ini und REINS Mode

Beitragvon Der-Matze » 14 Sep 2010, 13:33

d.oertel hat geschrieben:Hi,

hieß das paket vorher image_einrichtung (mit unterstrich) ?

gruss
d.oertel


Nein, das Paket wurde unverändert aus einem OPSI 3.4 Server übernommen.