Verbindung zum Opsi Config Server fehgeschlagen

Kay96
Beiträge: 73
Registriert: 06 Dez 2018, 09:23

Verbindung zum Opsi Config Server fehgeschlagen

Beitragvon Kay96 » 12 Mai 2021, 09:54

Hallo,
heute Nacht habe ich über das Auto Update Paket einige Clients aktualisieren lassen und nun funktioniert die Kommunikation zwischen den Clients und Opsi nicht mehr.
Alle Clients stehen beim Auto Update auf Step 2 mit Reboot Flag 2 und haben anscheinend den Opsi Client Agent aktualisiert.

Folgende Fehlermeldung wird angezeigt, wenn man es OnDemand ausführt:
verbindung zu Config-Server "https://xxx:447/rpc" fehlgeschlagen: ("Received response with content-encoding: gzip, but failed to decode it.", error("Error -3 while decrompressing data: incorrect header check"))

Hat jemand eine Idee?

Liebe Grüße

Benutzeravatar
ThomasT
uib-Team
Beiträge: 326
Registriert: 26 Jun 2013, 12:26

Re: Verbindung zum Opsi Config Server fehgeschlagen

Beitragvon ThomasT » 18 Mai 2021, 10:40

Was hast du denn für eine Server Version?
also dpkg -l | grep opsi
Kein Support per DM!
_________________________
opsi support - https://www.uib.de/
For productive opsi installations we recommend support contracts.

Kay96
Beiträge: 73
Registriert: 06 Dez 2018, 09:23

Re: Verbindung zum Opsi Config Server fehgeschlagen

Beitragvon Kay96 » 25 Mai 2021, 08:06

Entschuldige bitte die späte Antwort.
opsi-server Version: 4.1.1.4-10

Die Aktualisierung an anderen Clients hat nun wunderbar funktioniert und verursacht keinen Fehler, jedoch weiß ich nicht wie ich die bestehenden Rechenr "reparieren" kann. Eine Deinstallation und Installation hat nichts gebracht.

Jan.Schmidt
Beiträge: 201
Registriert: 08 Jul 2017, 12:02

Re: Verbindung zum Opsi Config Server fehgeschlagen

Beitragvon Jan.Schmidt » 25 Mai 2021, 08:48

Kay96 hat geschrieben:Entschuldige bitte die späte Antwort.
opsi-server Version: 4.1.1.4-10

Die Aktualisierung an anderen Clients hat nun wunderbar funktioniert und verursacht keinen Fehler, jedoch weiß ich nicht wie ich die bestehenden Rechenr "reparieren" kann. Eine Deinstallation und Installation hat nichts gebracht.


Hast du noch einen der Rechner bei dem das passiert ist in unangetastet?
Bei uns ist div. mal folgendes passiert, die config auf dem Rechner hatte keinen server und keinen clientkey mehr.
Erkenntlich ist das auf den ersten Blick, wenn der OPSI Start auf opsi.uib (oder so ähnlich) statt deinem OPSI Server zeigt.

Dein reparatur Versuch ist der mit stoppen beider Dienste, entfernen aus programm in systemsteuerung und löschen des opsi Ordners in programx86 geschehen?

Benutzeravatar
wolfbardo
uib-Team
Beiträge: 1238
Registriert: 01 Jul 2008, 12:10

Re: Verbindung zum Opsi Config Server fehgeschlagen

Beitragvon wolfbardo » 25 Mai 2021, 08:53

das sieht mir nach

viewtopic.php?f=1&t=12319

aus


opsi remote-workshops

https://uib.de/de/support-schulung/schulung/

Basis

14.-17.06. 2021
06.-09.09 2021

Einführung in die Software-Paketierung
09./10.06 2021

opsi support by uib gmbh

http://www.uib.de

Kay96
Beiträge: 73
Registriert: 06 Dez 2018, 09:23

Re: Verbindung zum Opsi Config Server fehgeschlagen

Beitragvon Kay96 » 26 Mai 2021, 11:42

@Jan.Schmidt
Danke für deine Antwort!
Ja ich hab nur an einem Client Reparaturversuche vorgenommen.
Ich habe die Deinstallation und Installation über den Administrator durchgefürt und vorher die Dienste gestoppt, deinstalliert, Verzeichnisse gelöscht und neu installiert.

@wolfbardo
Dankeschön für die Rückmeldung.
Ich habe nun den Server gesichert und führe eine Aktualisierung aller Bestandteile durch.

Danach werde ich mich wieder melden.

Kay96
Beiträge: 73
Registriert: 06 Dez 2018, 09:23

Re: Verbindung zum Opsi Config Server fehgeschlagen

Beitragvon Kay96 » 27 Mai 2021, 12:56

Problem ist behoben.

Leider habe ich mir einmal den gesamten Server zerschossen, da ich von Ubuntu 1604 auf Ubuntu 2004 gegangen bin und dann erst gemerkt habe, dass meine Opsi Version dafür nicht geeignet ist.
Viele Reperaturversuche blieben erfolglos, sodass ich dann das Backup eingespielt habe.

Jetzt läuft der Server erstmal auf Ubuntu 1804 und mit den dafür vorgesehenen aktuellsten Paketen.

Das wichtigste ist aber, dass der Fehler endlich weg ist und alle Clients wieder laufen.

Danke für eure Unterstützung!