windows10-upgrade: Problem mit Autologon

damien.leviet
Beiträge: 106
Registriert: 24 Feb 2014, 11:30

windows10-upgrade: Problem mit Autologon

Beitragvon damien.leviet » 20 Jan 2020, 12:47

Hallo zusammen,

zunächst einmal ein großes Dankeschön für das Upgrade Skript, welches uns viel Arbeit abnehmen wird.
Leider gibt es einen unschönen Fehler, und zwar wird nach der Vorbereitung der Computer neugestartet und eigentlich sollte der opsiSetupUser automatisch angemeldet und die Installation gestartet werden.

Dies geschieht jedoch nicht und erst nach manueller Anmeldung wird der Rest der Installation ausgeführt.

Anbei das Logfile. Einen Fehler kann ich jetzt nicht wirklich erkennen:

Code: Alles auswählen

[5] [Jan 20 10:37:38:302] [windows10-upgrade]   message Preparing windows10-upgrade install step 1...
[5] [Jan 20 10:37:38:306] [windows10-upgrade]   comment: prepare AutoLogon
[6] [Jan 20 10:37:38:307] [windows10-upgrade]   
[6] [Jan 20 10:37:38:307] [windows10-upgrade]   ~~~~~~~ Start Sub ~~~~~~~  sub_Prepare_AutoLogon
[5] [Jan 20 10:37:38:310] [windows10-upgrade]   Execution of: Files_copy_event_starter
[5] [Jan 20 10:37:38:310] [windows10-upgrade]   
[7] [Jan 20 10:37:38:310] [windows10-upgrade]     copy -s "p:\windows10-upgrade\event_starter\*.*" "C:\opsi.org\applog\event_starter\"
[6] [Jan 20 10:37:38:310] [windows10-upgrade]         path C:\opsi.org\applog\event_starter\ created
[6] [Jan 20 10:37:38:321] [windows10-upgrade]     Copying  p:\windows10-upgrade\event_starter\*.* -----> C:\opsi.org\applog\event_starter\
[6] [Jan 20 10:37:38:321] [windows10-upgrade]       3 File(s) found
[6] [Jan 20 10:37:38:323] [windows10-upgrade]       Source p:\windows10-upgrade\event_starter\libeay32.dll
[6] [Jan 20 10:37:38:459] [windows10-upgrade]         p:\windows10-upgrade\event_starter\libeay32.dll copied to C:\opsi.org\applog\event_starter\
[6] [Jan 20 10:37:38:461] [windows10-upgrade]       Source p:\windows10-upgrade\event_starter\opsiclientd_event_starter_asInvoker.exe
[6] [Jan 20 10:37:40:706] [windows10-upgrade]         p:\windows10-upgrade\event_starter\opsiclientd_event_starter_asInvoker.exe copied to C:\opsi.org\applog\event_starter\
[6] [Jan 20 10:37:40:716] [windows10-upgrade]       Source p:\windows10-upgrade\event_starter\ssleay32.dll
[6] [Jan 20 10:37:40:816] [windows10-upgrade]         p:\windows10-upgrade\event_starter\ssleay32.dll copied to C:\opsi.org\applog\event_starter\
[6] [Jan 20 10:37:40:817] [windows10-upgrade]       3 File(s) treated
[5] [Jan 20 10:37:40:822] [windows10-upgrade]   comment: read current Autologon and LastLoggedOnUser values for backup
[6] [Jan 20 10:37:40:822] [windows10-upgrade]   Set  $AutoName$ = GetRegistryStringValueSysnative("[HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] DefaultUserName")
[7] [Jan 20 10:37:40:823] [windows10-upgrade]   Registry started readonly
[7] [Jan 20 10:37:40:823] [windows10-upgrade]   Registry started without redirection (64 Bit)
[6] [Jan 20 10:37:40:823] [windows10-upgrade]   Registry key [HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]  opened
[6] [Jan 20 10:37:40:823] [windows10-upgrade]   Key closed
[6] [Jan 20 10:37:40:823] [windows10-upgrade]     The value of the variable "$AutoName$" is now: "Administrator"
[6] [Jan 20 10:37:40:823] [windows10-upgrade]   If
[7] [Jan 20 10:37:40:823] [windows10-upgrade]     $AutoName$="opsiSetupUser"   <<< result false
[6] [Jan 20 10:37:40:823] [windows10-upgrade]     ($AutoName$="opsiSetupUser")   <<< result false
[6] [Jan 20 10:37:40:823] [windows10-upgrade]   Then
[6] [Jan 20 10:37:40:823] [windows10-upgrade]   Else
[6] [Jan 20 10:37:40:823] [windows10-upgrade]     Set  $AutoPass$ = GetRegistryStringValueSysnative("[HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] DefaultPassword")
[7] [Jan 20 10:37:40:823] [windows10-upgrade]     Registry started readonly
[7] [Jan 20 10:37:40:823] [windows10-upgrade]     Registry started without redirection (64 Bit)
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Registry key [HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]  opened
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Variable "DefaultPassword"  not found. Code: 2
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Variable "DefaultPassword"  not found. Code: 2
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Key closed
[6] [Jan 20 10:37:40:824] [windows10-upgrade]       The value of the variable "$AutoPass$" is now: ""
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Set  $AutoDom$ = GetRegistryStringValueSysnative("[HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] DefaultDomainName")
[7] [Jan 20 10:37:40:824] [windows10-upgrade]     Registry started readonly
[7] [Jan 20 10:37:40:824] [windows10-upgrade]     Registry started without redirection (64 Bit)
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Registry key [HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]  opened
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Key closed
[6] [Jan 20 10:37:40:824] [windows10-upgrade]       The value of the variable "$AutoDom$" is now: ""
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Set  $AutoLogon$ = GetRegistryStringValueSysnative("[HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] AutoAdminLogon")
[7] [Jan 20 10:37:40:825] [windows10-upgrade]     Registry started readonly
[7] [Jan 20 10:37:40:825] [windows10-upgrade]     Registry started without redirection (64 Bit)
[6] [Jan 20 10:37:40:825] [windows10-upgrade]     Registry key [HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]  opened
[6] [Jan 20 10:37:40:825] [windows10-upgrade]     Key closed
[6] [Jan 20 10:37:40:825] [windows10-upgrade]       The value of the variable "$AutoLogon$" is now: "1"
[6] [Jan 20 10:37:40:825] [windows10-upgrade]   EndIf
[6] [Jan 20 10:37:40:825] [windows10-upgrade]   Set  $LastLogon$ = GetRegistryStringValueSysnative("[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI] LastLoggedOnUser")
[7] [Jan 20 10:37:40:825] [windows10-upgrade]   Registry started readonly
[7] [Jan 20 10:37:40:825] [windows10-upgrade]   Registry started without redirection (64 Bit)
[6] [Jan 20 10:37:40:825] [windows10-upgrade]   Registry key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI]  opened
[6] [Jan 20 10:37:40:825] [windows10-upgrade]   Key closed
[6] [Jan 20 10:37:40:825] [windows10-upgrade]     The value of the variable "$LastLogon$" is now: ".\Administrator"
[6] [Jan 20 10:37:40:826] [windows10-upgrade]   Set  $LastLoggedOnSAMUser$ = GetRegistryStringValueSysnative("[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI] LastLoggedOnSAMUser")
[7] [Jan 20 10:37:40:826] [windows10-upgrade]   Registry started readonly
[7] [Jan 20 10:37:40:826] [windows10-upgrade]   Registry started without redirection (64 Bit)
[6] [Jan 20 10:37:40:826] [windows10-upgrade]   Registry key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI]  opened
[6] [Jan 20 10:37:40:826] [windows10-upgrade]   Key closed
[6] [Jan 20 10:37:40:826] [windows10-upgrade]     The value of the variable "$LastLoggedOnSAMUser$" is now: ".\Administrator"
[5] [Jan 20 10:37:40:826] [windows10-upgrade]   comment: backup AutoLogon values
[5] [Jan 20 10:37:40:828] [windows10-upgrade]   Execution of: Registry_backup_autologon /32bit
[5] [Jan 20 10:37:40:828] [windows10-upgrade]   
[7] [Jan 20 10:37:40:828] [windows10-upgrade]     Registry started with redirection (32 Bit)
[7] [Jan 20 10:37:40:828] [windows10-upgrade]     Key is: HKLM\SOFTWARE\opsi.org\winst\windows10-upgrade\AutoLogonBackup
[6] [Jan 20 10:37:40:828] [windows10-upgrade]     Registry key [HKLM\SOFTWARE\opsi.org\winst\windows10-upgrade\AutoLogonBackup]  created
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Variable "DefaultUserName"  set to "Administrator"
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Variable "DefaultPassword"  set to ""
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Variable "DefaultDomainName"  set to ""
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Variable "AutoAdminLogon"  set to "1"
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Variable "LastLogon"  set to ".\Administrator"
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Variable "LastLoggedOnSAMUser"  set to ".\Administrator"
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Key closed
[5] [Jan 20 10:37:40:829] [windows10-upgrade]   comment: prepare the opsiSetupUser AutoLogon
[6] [Jan 20 10:37:40:830] [windows10-upgrade]   LogLevel was 7
[6] [Jan 20 10:37:40:967] [windows10-upgrade]     LogLevel set to 7
[5] [Jan 20 10:37:40:972] [windows10-upgrade]     Execution of: Registry_run /sysnative
[5] [Jan 20 10:37:40:972] [windows10-upgrade]     
[7] [Jan 20 10:37:40:972] [windows10-upgrade]       Registry started without redirection (64 Bit)
[7] [Jan 20 10:37:40:972] [windows10-upgrade]       Key is: HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
[6] [Jan 20 10:37:40:972] [windows10-upgrade]       Registry key [HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]  opened
[6] [Jan 20 10:37:40:972] [windows10-upgrade]               Variable "opsi_autologon_setup"  set to "C:\opsi.org\applog\event_starter\opsiclientd_event_starter_asinvoker.exe"
[6] [Jan 20 10:37:40:973] [windows10-upgrade]               Key closed
[6] [Jan 20 10:37:40:973] [windows10-upgrade]   EndIf
[6] [Jan 20 10:37:40:973] [windows10-upgrade]   If
[7] [Jan 20 10:37:40:974] [windows10-upgrade]     $LockKeyboard$="true"   <<< result false
[6] [Jan 20 10:37:40:974] [windows10-upgrade]     ($LockKeyboard$="true")   <<< result false
[6] [Jan 20 10:37:40:974] [windows10-upgrade]   Then
[6] [Jan 20 10:37:40:974] [windows10-upgrade]   EndIf
[5] [Jan 20 10:37:40:975] [windows10-upgrade]   comment: cleanup the registry key which stores a fatal result of the local script
[5] [Jan 20 10:37:40:977] [windows10-upgrade]   Execution of: Registry_clean_fatal_flag /32bit
[5] [Jan 20 10:37:40:977] [windows10-upgrade]   
[7] [Jan 20 10:37:40:977] [windows10-upgrade]     Registry started with redirection (32 Bit)
[7] [Jan 20 10:37:40:977] [windows10-upgrade]     Key is: HKLM\SOFTWARE\opsi.org\winst\windows10-upgrade
[6] [Jan 20 10:37:40:977] [windows10-upgrade]     Registry key [HKLM\SOFTWARE\opsi.org\winst\windows10-upgrade]  opened
[6] [Jan 20 10:37:40:977] [windows10-upgrade]           Variable "with-admin-fatal"  not found. Code: 2
[6] [Jan 20 10:37:40:977] [windows10-upgrade]           Key closed
[6] [Jan 20 10:37:40:977] [windows10-upgrade]   
[6] [Jan 20 10:37:40:977] [windows10-upgrade]   ~~~~~~~ End Sub   ~~~~~~~  sub_Prepare_AutoLogon
[6] [Jan 20 10:37:40:977] [windows10-upgrade]   
[5] [Jan 20 10:37:40:987] [windows10-upgrade]   comment: handle Rebootflag
[6] [Jan 20 10:37:40:996] [windows10-upgrade]   Set  $RebootFlag$ = "2"
[6] [Jan 20 10:37:40:997] [windows10-upgrade]     The value of the variable "$RebootFlag$" is now: "2"
[5] [Jan 20 10:37:40:999] [windows10-upgrade]   Execution of: Registry_SaveRebootFlag /32bit
[5] [Jan 20 10:37:40:999] [windows10-upgrade]   
[7] [Jan 20 10:37:40:999] [windows10-upgrade]     Registry started with redirection (32 Bit)
[7] [Jan 20 10:37:40:999] [windows10-upgrade]     Key is: HKLM\SOFTWARE\opsi.org\winst\windows10-upgrade
[6] [Jan 20 10:37:40:999] [windows10-upgrade]     Registry key [HKLM\SOFTWARE\opsi.org\winst\windows10-upgrade]  opened
[6] [Jan 20 10:37:40:999] [windows10-upgrade]           Variable "RebootFlag"  had value  "1"
[6] [Jan 20 10:37:40:999] [windows10-upgrade]           Info:    "RebootFlag"  changed to "2"
[6] [Jan 20 10:37:40:999] [windows10-upgrade]           Key closed
[5] [Jan 20 10:37:41:000] [windows10-upgrade]   comment: reboot needed to check that the autologon works
[6] [Jan 20 10:37:41:000] [windows10-upgrade]   ExitWindows set to Immediate Reboot
[6] [Jan 20 10:37:41:000] [windows10-upgrade]   Process stopped


Habt ihr eine Idee?
Wir upgraden von Windows 10 1803 auf 1909

Gruß,
Damien

damien.leviet
Beiträge: 106
Registriert: 24 Feb 2014, 11:30

Re: windows10-upgrade: Problem mit Autologon

Beitragvon damien.leviet » 20 Jan 2020, 13:15

Hallo nochmal,

ich glaube es hat sich erledigt:

Achtet darauf, dass der User opsiSetupUser ein für eure Umgebung gültiges Passwort generiert bekommt.
Bei uns gelten mindestens 9 Zeichen; das Passwort hier hatte nur 8.

Da war der Hund begraben, jetzt geht alles wunderbar durch ;)

Gruß,
Damien

kinzi
Beiträge: 121
Registriert: 27 Okt 2010, 11:38

Re: windows10-upgrade: Problem mit Autologon

Beitragvon kinzi » 26 Jun 2020, 10:53

Servus,

noch eine Ergänzung: Bei uns dürfen sich nicht alle Benutzer an allen Systemen anmelden, wir steuern das über GPOs. Insbesondere lokale Benutzer betrifft das auch - wodurch sich der "opsiSetupUser" nicht per Autologon anmelden kann.

Abhilfe:
Die Datei "sections-local.opsiscript" im win10upgrade-Ordner auf dem Depot editieren. Die Zeilen 204 und 205 sehen so aus:

comment "create opsiSetupUser"
shellCall("NET USER opsiSetupUser "+$OpsiAdminPass$+" /ADD")

Bei uns gibt es eine lokale Gruppe namens "UsersAllowedToLogonLocally", deren Mitglieder das Recht zur lokalen Anmeldung bekommen, also das Script um diese Zeile ergänzen:

shellcall("NET LOCALGROUP UsersAllowedToLogonLocally opsiSetupUser /ADD")

Sonst zur Not halt den opsiSetupUser in die Gruppe der Administratoren aufnehmen, auch wenn das unschön ist. Vielleicht weiß auch jemand einen anderen Einzeiler, der das Recht explizit an den User abtritt.

Gruß
kinzi

g.burck
Beiträge: 107
Registriert: 23 Mai 2018, 16:44

Re: windows10-upgrade: Problem mit Autologon

Beitragvon g.burck » 20 Aug 2020, 08:18

Moin,

damien.leviet hat geschrieben:Hallo nochmal,
Achtet darauf, dass der User opsiSetupUser ein für eure Umgebung gültiges Passwort generiert bekommt.
Bei uns gelten mindestens 9 Zeichen; das Passwort hier hatte nur 8.

Da war der Hund begraben, jetzt geht alles wunderbar durch ;)


Vorsicht es gibt noch einen Dackel: das Passwort darf auch nicht zu lang sein, ich habe eine kleine Ewigkeit gebraucht das herauszufinden,...

kinzi
Beiträge: 121
Registriert: 27 Okt 2010, 11:38

Re: windows10-upgrade: Problem mit Autologon

Beitragvon kinzi » 07 Mai 2021, 12:35

Hallo,

zusätzlich zu o. a. Problem mit der Logon-Policy kommt nun bei 20.09-3 offenbar ein weiteres Problem dazu:

Das Setup wird trotz angemeldetem Benutzer nicht gestartet. Die Fehlermeldung im opsiconfd lautet sinngemäß, dass der geplante Task nicht gestartet wurde. Nach einigen Versuchen, wo ich von einem anderen PC auf den Taskplanner geschaut habe, habe ich dort die Fehlermeldung

Die Aufgabenplanung konnte die Aktion nicht starten [...] Zusätzliche Daten: Fehlerwert: 2147943140

gefunden. Dieser Code bedeutet anscheinend:

2147943140 = 0x800702E4 = ERROR_ELEVATION_REQUIRED = The requested operation requires elevation

SCHTASKS bietet wohl keine Option, beim Task den Haken "Mit höchsten Privilegien ausführen" zu setzen. :-(

Ich habe mir damit beholfen, dass ich in der "declarations.opsiinc" alle diese Zeilen auf "true" gestellt habe:

Code: Alles auswählen

Set $DisableUAC$ = "true"
Set $GrantAdminRights$ = "true"

Damit scheint es nun zu laufen. Würde mich interessieren, ob das anderswo auch auftritt.

Gruß
kinzi

Benutzeravatar
skranz1982
Beiträge: 70
Registriert: 09 Okt 2014, 08:01

Re: windows10-upgrade: Problem mit Autologon

Beitragvon skranz1982 » 07 Mai 2021, 13:35

Moin, moin!

Bei dem Autologon vom windows10-upgrade gibt es noch eine Feinheit zu beachten: Wenn ein Client im WAN-Modus läuft, setzt das Paket zwingend lokale Administrationsrechte voraus! In einer von uns betreuten Domäne gab es aber eine GPO, die die lokale Gruppe der Admins fein säuberlich neu aufbaute und so flog der opsiSetupUser dort immer wieder raus = keine Adminrechte = kein Upgrade. War aber aus den Logs nicht so einfach ablesbar, denn das opsiclientd.log ist in so einem Fall nur rund 20 Zeilen lang und meldet, dass es keine opsiclientd.conf gäbe ^^

Wisst ihr Bescheid, ne? :roll:
Sebastian Kranz,
regio iT gesellschaft für informationstechnologie mbh
www.regioit.de

kinzi
Beiträge: 121
Registriert: 27 Okt 2010, 11:38

Re: windows10-upgrade: Problem mit Autologon

Beitragvon kinzi » 07 Mai 2021, 15:37

Das wäre alles kein Problem, wenn es eine vernünftige Doku zu diesem Paket gäbe. Ich habe mir stundenlang einen Wolf gesucht - außer den "Release Notes" habe ich nichts gefunden. Nicht mal mehr das README der vorigen Versionen gibt es. :-(

Oder ich bin zu blöd zum Suchen - dann lasse ich mich gerne hier "vorführen", das ist es mir wert. :-D

Jan.Schmidt
Beiträge: 202
Registriert: 08 Jul 2017, 12:02

Re: windows10-upgrade: Problem mit Autologon

Beitragvon Jan.Schmidt » 09 Mai 2021, 09:28

Hi,

ganz ganz ganz ehrlich...
Es gibt ein paar Wege Win10 zu aktualisieren, OPSI würde ich da niemals für nehmen.

Warum?:
angemeldeter Admin Benutzer
Versionierung seitens MS

Entwerder baut man eine GPO und eine Wsus Gruppe und sagt dann per GPO & WSUS Gruppe diese Kisten kriegen (mit oder ohne Installationszeitraum) das Win10 aufgebügelt

Oder man baut sich einen Domainbenutzer, in dessen Homelaufwerk das entpackte Iso liegt und zwei scripte.
Eines lädt sporadisch die neueste Iso runter und entpackt die in das Homelaufwerk des spezial Benutzers

Eines, das der Spezial Benutzer ausführt und wo er die aktuell installierte Version mit der des Isos vergleicht, Plattenlatz prüft und dann loslegt oder nicht.

Warum nicht per OPSI?
Weil jedes neuere ISO einen aktuelleren Stand hat, wenn man den via dism nachpflegt dann wächst das Paket ungemein an und ist viel größer als ein frisches von MS.
Würde man das so oder so machen, hätte man zwei Probleme:
1) ich ändere die opsi Paketversion nicht - dann kann es durchaus passieren, dass ein depotserver trotz -f das paket nicht aktualisiert
2) Ich ändere die Paket# dann klappt das mit dem depotserver wieder, ich hab aber keinen überblick welcher Rechner "alt" ist.

Ergo, hat man keinen Wsus und keine depotserver dann kann man das Paket nutzen, für alle anderen gibt es bessere (s.o) Lösungen.

kinzi
Beiträge: 121
Registriert: 27 Okt 2010, 11:38

Re: windows10-upgrade: Problem mit Autologon

Beitragvon kinzi » 12 Mai 2021, 13:35

Hi,

ganz, ganz, ganz ehrlich: Das hier ist das OPSI-Forum. ;-)

2) Ich ändere die Paket# dann klappt das mit dem depotserver wieder, ich hab aber keinen überblick welcher Rechner "alt" ist.

Das Paket macht eh nichts und meldet "Successful", wenn die aktuelle Version schon drauf ist. Ansonsten vor der Aktualisierung des Pakets einfach alle Rechner markieren, Status zurücksetzen auf "not installed", fertig - schon hast du deine Übersicht.

Ich würde das NIE anders als über OPSI machen, denn: Ich hätte gerne die Kontrolle, wann das passiert. MS darf bei mir genau das, was absolut unbeeinflussbar notwendig ist. Am liebsten also nix. :D

Jan.Schmidt
Beiträge: 202
Registriert: 08 Jul 2017, 12:02

Re: windows10-upgrade: Problem mit Autologon

Beitragvon Jan.Schmidt » 13 Mai 2021, 21:08

ganz, ganz, ganz ehrlich: Wenn dein einziges Werkzeug nur ein Hammer ist, dann sieht jedes Problem aus wie ein Nagel :D

Nun schaust du bitte mal in die Bug Abteilung und dann überlegen wir gerne gemeinsam - wenn schon der dotnet installer sowas anstellen kann, "wenn" der Teufel ein Eichhörnchen ist und was ein nicht (mehr) gefundes wim file dann machen kann, das bedeutend länger genutzt wird, als das popelige dotnet msi 'chen.
Und im Fall des Wan Modul Einsatzes ist das dann zwar nicht gegeben, aber auch da wird der Benutzer auf deinen Wunsch
Ich hätte gerne die Kontrolle, wann das passiert. MS darf bei mir genau das

dann nett morgens vorm arbeiten abgehalten weil er nicht wußte, wielange das Paket nun installiern wird, als er die Installation abgenickt hat, weil die anderen waren ja meistens nach 10 minuten durch :lol: :lol: :lol: :lol:.

Ich kann da nur raten, und wenn es in dem Fall ein abraten ist, jeder darf was und wie er will.

Von daher
liebe Grüße