windows10-upgrade: Problem mit Autologon

damien.leviet
Beiträge: 96
Registriert: 24 Feb 2014, 11:30

windows10-upgrade: Problem mit Autologon

Beitragvon damien.leviet » 20 Jan 2020, 12:47

Hallo zusammen,

zunächst einmal ein großes Dankeschön für das Upgrade Skript, welches uns viel Arbeit abnehmen wird.
Leider gibt es einen unschönen Fehler, und zwar wird nach der Vorbereitung der Computer neugestartet und eigentlich sollte der opsiSetupUser automatisch angemeldet und die Installation gestartet werden.

Dies geschieht jedoch nicht und erst nach manueller Anmeldung wird der Rest der Installation ausgeführt.

Anbei das Logfile. Einen Fehler kann ich jetzt nicht wirklich erkennen:

Code: Alles auswählen

[5] [Jan 20 10:37:38:302] [windows10-upgrade]   message Preparing windows10-upgrade install step 1...
[5] [Jan 20 10:37:38:306] [windows10-upgrade]   comment: prepare AutoLogon
[6] [Jan 20 10:37:38:307] [windows10-upgrade]   
[6] [Jan 20 10:37:38:307] [windows10-upgrade]   ~~~~~~~ Start Sub ~~~~~~~  sub_Prepare_AutoLogon
[5] [Jan 20 10:37:38:310] [windows10-upgrade]   Execution of: Files_copy_event_starter
[5] [Jan 20 10:37:38:310] [windows10-upgrade]   
[7] [Jan 20 10:37:38:310] [windows10-upgrade]     copy -s "p:\windows10-upgrade\event_starter\*.*" "C:\opsi.org\applog\event_starter\"
[6] [Jan 20 10:37:38:310] [windows10-upgrade]         path C:\opsi.org\applog\event_starter\ created
[6] [Jan 20 10:37:38:321] [windows10-upgrade]     Copying  p:\windows10-upgrade\event_starter\*.* -----> C:\opsi.org\applog\event_starter\
[6] [Jan 20 10:37:38:321] [windows10-upgrade]       3 File(s) found
[6] [Jan 20 10:37:38:323] [windows10-upgrade]       Source p:\windows10-upgrade\event_starter\libeay32.dll
[6] [Jan 20 10:37:38:459] [windows10-upgrade]         p:\windows10-upgrade\event_starter\libeay32.dll copied to C:\opsi.org\applog\event_starter\
[6] [Jan 20 10:37:38:461] [windows10-upgrade]       Source p:\windows10-upgrade\event_starter\opsiclientd_event_starter_asInvoker.exe
[6] [Jan 20 10:37:40:706] [windows10-upgrade]         p:\windows10-upgrade\event_starter\opsiclientd_event_starter_asInvoker.exe copied to C:\opsi.org\applog\event_starter\
[6] [Jan 20 10:37:40:716] [windows10-upgrade]       Source p:\windows10-upgrade\event_starter\ssleay32.dll
[6] [Jan 20 10:37:40:816] [windows10-upgrade]         p:\windows10-upgrade\event_starter\ssleay32.dll copied to C:\opsi.org\applog\event_starter\
[6] [Jan 20 10:37:40:817] [windows10-upgrade]       3 File(s) treated
[5] [Jan 20 10:37:40:822] [windows10-upgrade]   comment: read current Autologon and LastLoggedOnUser values for backup
[6] [Jan 20 10:37:40:822] [windows10-upgrade]   Set  $AutoName$ = GetRegistryStringValueSysnative("[HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] DefaultUserName")
[7] [Jan 20 10:37:40:823] [windows10-upgrade]   Registry started readonly
[7] [Jan 20 10:37:40:823] [windows10-upgrade]   Registry started without redirection (64 Bit)
[6] [Jan 20 10:37:40:823] [windows10-upgrade]   Registry key [HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]  opened
[6] [Jan 20 10:37:40:823] [windows10-upgrade]   Key closed
[6] [Jan 20 10:37:40:823] [windows10-upgrade]     The value of the variable "$AutoName$" is now: "Administrator"
[6] [Jan 20 10:37:40:823] [windows10-upgrade]   If
[7] [Jan 20 10:37:40:823] [windows10-upgrade]     $AutoName$="opsiSetupUser"   <<< result false
[6] [Jan 20 10:37:40:823] [windows10-upgrade]     ($AutoName$="opsiSetupUser")   <<< result false
[6] [Jan 20 10:37:40:823] [windows10-upgrade]   Then
[6] [Jan 20 10:37:40:823] [windows10-upgrade]   Else
[6] [Jan 20 10:37:40:823] [windows10-upgrade]     Set  $AutoPass$ = GetRegistryStringValueSysnative("[HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] DefaultPassword")
[7] [Jan 20 10:37:40:823] [windows10-upgrade]     Registry started readonly
[7] [Jan 20 10:37:40:823] [windows10-upgrade]     Registry started without redirection (64 Bit)
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Registry key [HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]  opened
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Variable "DefaultPassword"  not found. Code: 2
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Variable "DefaultPassword"  not found. Code: 2
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Key closed
[6] [Jan 20 10:37:40:824] [windows10-upgrade]       The value of the variable "$AutoPass$" is now: ""
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Set  $AutoDom$ = GetRegistryStringValueSysnative("[HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] DefaultDomainName")
[7] [Jan 20 10:37:40:824] [windows10-upgrade]     Registry started readonly
[7] [Jan 20 10:37:40:824] [windows10-upgrade]     Registry started without redirection (64 Bit)
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Registry key [HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]  opened
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Key closed
[6] [Jan 20 10:37:40:824] [windows10-upgrade]       The value of the variable "$AutoDom$" is now: ""
[6] [Jan 20 10:37:40:824] [windows10-upgrade]     Set  $AutoLogon$ = GetRegistryStringValueSysnative("[HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] AutoAdminLogon")
[7] [Jan 20 10:37:40:825] [windows10-upgrade]     Registry started readonly
[7] [Jan 20 10:37:40:825] [windows10-upgrade]     Registry started without redirection (64 Bit)
[6] [Jan 20 10:37:40:825] [windows10-upgrade]     Registry key [HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]  opened
[6] [Jan 20 10:37:40:825] [windows10-upgrade]     Key closed
[6] [Jan 20 10:37:40:825] [windows10-upgrade]       The value of the variable "$AutoLogon$" is now: "1"
[6] [Jan 20 10:37:40:825] [windows10-upgrade]   EndIf
[6] [Jan 20 10:37:40:825] [windows10-upgrade]   Set  $LastLogon$ = GetRegistryStringValueSysnative("[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI] LastLoggedOnUser")
[7] [Jan 20 10:37:40:825] [windows10-upgrade]   Registry started readonly
[7] [Jan 20 10:37:40:825] [windows10-upgrade]   Registry started without redirection (64 Bit)
[6] [Jan 20 10:37:40:825] [windows10-upgrade]   Registry key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI]  opened
[6] [Jan 20 10:37:40:825] [windows10-upgrade]   Key closed
[6] [Jan 20 10:37:40:825] [windows10-upgrade]     The value of the variable "$LastLogon$" is now: ".\Administrator"
[6] [Jan 20 10:37:40:826] [windows10-upgrade]   Set  $LastLoggedOnSAMUser$ = GetRegistryStringValueSysnative("[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI] LastLoggedOnSAMUser")
[7] [Jan 20 10:37:40:826] [windows10-upgrade]   Registry started readonly
[7] [Jan 20 10:37:40:826] [windows10-upgrade]   Registry started without redirection (64 Bit)
[6] [Jan 20 10:37:40:826] [windows10-upgrade]   Registry key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI]  opened
[6] [Jan 20 10:37:40:826] [windows10-upgrade]   Key closed
[6] [Jan 20 10:37:40:826] [windows10-upgrade]     The value of the variable "$LastLoggedOnSAMUser$" is now: ".\Administrator"
[5] [Jan 20 10:37:40:826] [windows10-upgrade]   comment: backup AutoLogon values
[5] [Jan 20 10:37:40:828] [windows10-upgrade]   Execution of: Registry_backup_autologon /32bit
[5] [Jan 20 10:37:40:828] [windows10-upgrade]   
[7] [Jan 20 10:37:40:828] [windows10-upgrade]     Registry started with redirection (32 Bit)
[7] [Jan 20 10:37:40:828] [windows10-upgrade]     Key is: HKLM\SOFTWARE\opsi.org\winst\windows10-upgrade\AutoLogonBackup
[6] [Jan 20 10:37:40:828] [windows10-upgrade]     Registry key [HKLM\SOFTWARE\opsi.org\winst\windows10-upgrade\AutoLogonBackup]  created
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Variable "DefaultUserName"  set to "Administrator"
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Variable "DefaultPassword"  set to ""
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Variable "DefaultDomainName"  set to ""
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Variable "AutoAdminLogon"  set to "1"
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Variable "LastLogon"  set to ".\Administrator"
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Variable "LastLoggedOnSAMUser"  set to ".\Administrator"
[6] [Jan 20 10:37:40:828] [windows10-upgrade]             Key closed
[5] [Jan 20 10:37:40:829] [windows10-upgrade]   comment: prepare the opsiSetupUser AutoLogon
[6] [Jan 20 10:37:40:830] [windows10-upgrade]   LogLevel was 7
[6] [Jan 20 10:37:40:967] [windows10-upgrade]     LogLevel set to 7
[5] [Jan 20 10:37:40:972] [windows10-upgrade]     Execution of: Registry_run /sysnative
[5] [Jan 20 10:37:40:972] [windows10-upgrade]     
[7] [Jan 20 10:37:40:972] [windows10-upgrade]       Registry started without redirection (64 Bit)
[7] [Jan 20 10:37:40:972] [windows10-upgrade]       Key is: HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
[6] [Jan 20 10:37:40:972] [windows10-upgrade]       Registry key [HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]  opened
[6] [Jan 20 10:37:40:972] [windows10-upgrade]               Variable "opsi_autologon_setup"  set to "C:\opsi.org\applog\event_starter\opsiclientd_event_starter_asinvoker.exe"
[6] [Jan 20 10:37:40:973] [windows10-upgrade]               Key closed
[6] [Jan 20 10:37:40:973] [windows10-upgrade]   EndIf
[6] [Jan 20 10:37:40:973] [windows10-upgrade]   If
[7] [Jan 20 10:37:40:974] [windows10-upgrade]     $LockKeyboard$="true"   <<< result false
[6] [Jan 20 10:37:40:974] [windows10-upgrade]     ($LockKeyboard$="true")   <<< result false
[6] [Jan 20 10:37:40:974] [windows10-upgrade]   Then
[6] [Jan 20 10:37:40:974] [windows10-upgrade]   EndIf
[5] [Jan 20 10:37:40:975] [windows10-upgrade]   comment: cleanup the registry key which stores a fatal result of the local script
[5] [Jan 20 10:37:40:977] [windows10-upgrade]   Execution of: Registry_clean_fatal_flag /32bit
[5] [Jan 20 10:37:40:977] [windows10-upgrade]   
[7] [Jan 20 10:37:40:977] [windows10-upgrade]     Registry started with redirection (32 Bit)
[7] [Jan 20 10:37:40:977] [windows10-upgrade]     Key is: HKLM\SOFTWARE\opsi.org\winst\windows10-upgrade
[6] [Jan 20 10:37:40:977] [windows10-upgrade]     Registry key [HKLM\SOFTWARE\opsi.org\winst\windows10-upgrade]  opened
[6] [Jan 20 10:37:40:977] [windows10-upgrade]           Variable "with-admin-fatal"  not found. Code: 2
[6] [Jan 20 10:37:40:977] [windows10-upgrade]           Key closed
[6] [Jan 20 10:37:40:977] [windows10-upgrade]   
[6] [Jan 20 10:37:40:977] [windows10-upgrade]   ~~~~~~~ End Sub   ~~~~~~~  sub_Prepare_AutoLogon
[6] [Jan 20 10:37:40:977] [windows10-upgrade]   
[5] [Jan 20 10:37:40:987] [windows10-upgrade]   comment: handle Rebootflag
[6] [Jan 20 10:37:40:996] [windows10-upgrade]   Set  $RebootFlag$ = "2"
[6] [Jan 20 10:37:40:997] [windows10-upgrade]     The value of the variable "$RebootFlag$" is now: "2"
[5] [Jan 20 10:37:40:999] [windows10-upgrade]   Execution of: Registry_SaveRebootFlag /32bit
[5] [Jan 20 10:37:40:999] [windows10-upgrade]   
[7] [Jan 20 10:37:40:999] [windows10-upgrade]     Registry started with redirection (32 Bit)
[7] [Jan 20 10:37:40:999] [windows10-upgrade]     Key is: HKLM\SOFTWARE\opsi.org\winst\windows10-upgrade
[6] [Jan 20 10:37:40:999] [windows10-upgrade]     Registry key [HKLM\SOFTWARE\opsi.org\winst\windows10-upgrade]  opened
[6] [Jan 20 10:37:40:999] [windows10-upgrade]           Variable "RebootFlag"  had value  "1"
[6] [Jan 20 10:37:40:999] [windows10-upgrade]           Info:    "RebootFlag"  changed to "2"
[6] [Jan 20 10:37:40:999] [windows10-upgrade]           Key closed
[5] [Jan 20 10:37:41:000] [windows10-upgrade]   comment: reboot needed to check that the autologon works
[6] [Jan 20 10:37:41:000] [windows10-upgrade]   ExitWindows set to Immediate Reboot
[6] [Jan 20 10:37:41:000] [windows10-upgrade]   Process stopped


Habt ihr eine Idee?
Wir upgraden von Windows 10 1803 auf 1909

Gruß,
Damien

damien.leviet
Beiträge: 96
Registriert: 24 Feb 2014, 11:30

Re: windows10-upgrade: Problem mit Autologon

Beitragvon damien.leviet » 20 Jan 2020, 13:15

Hallo nochmal,

ich glaube es hat sich erledigt:

Achtet darauf, dass der User opsiSetupUser ein für eure Umgebung gültiges Passwort generiert bekommt.
Bei uns gelten mindestens 9 Zeichen; das Passwort hier hatte nur 8.

Da war der Hund begraben, jetzt geht alles wunderbar durch ;)

Gruß,
Damien