Nach opsi-linux-bootimage update keine Installation mehr möglich

Grugi
Beiträge: 63
Registriert: 07 Dez 2017, 08:57

Nach opsi-linux-bootimage update keine Installation mehr möglich

Beitragvon Grugi » 31 Okt 2019, 11:48

Hallo zusammen,

ich habe gerade den Hotfix eingespielt. Leider ist es jetzt nicht mehr möglich einen Client zu installieren. Das Anlegen des Rechners über den Config Editor geht. Sobald der Rechner über PXE booten will bleibt er bei dem "OPSI Logo" stehen und es passiert nichts mehr.

Gibt es noch jemanden der das Problem bestätigen kann und/oder mir helfen kann?

Mit den besten Grüßen

Grugi

Benutzeravatar
ThomasT
uib-Team
Beiträge: 200
Registriert: 26 Jun 2013, 12:26

Re: Nach opsi-linux-bootimage update keine Installation mehr möglich

Beitragvon ThomasT » 31 Okt 2019, 12:39

Kannst du bitte mal während das Logo angezeigt wird auf enter drücken? Dann sollte dir angezeigt werden, was er gerade tut...
Kein Support per DM!
_________________________
opsi support - https://www.uib.de/
For productive opsi installations we recommend support contracts.

Grugi
Beiträge: 63
Registriert: 07 Dez 2017, 08:57

Re: Nach opsi-linux-bootimage update keine Installation mehr möglich

Beitragvon Grugi » 31 Okt 2019, 12:51

ThomasT hat geschrieben:Kannst du bitte mal während das Logo angezeigt wird auf enter drücken? Dann sollte dir angezeigt werden, was er gerade tut...


FAILED Failed to start Dispatcher daemon for systemd-networkd.
See 'systemctl status networkd-dispatcher.service' for details.

Wenn ich mir den Status jedoch ansehen will, bekomme ich "Unit networkd-dispatcher.service could not be found."

Auf einem anderen Rechner bekomme ich wenn ich "Enter" drücke, bekomme ich "Failed to start opsi.service. Dependency failed for Job that starts the master.py."

Hier vielleicht noch meine Version die ich verwende.

⚡ root@opsi  /var/log  dpkg -l | grep opsi
rc opsi-atftpd 0.7.dfsg-9 amd64 advanced TFTP server - opsi version with pcre, fifo and max-blksize patches
ii opsi-configed 4.0.7.6.34-2 all OPSI config editor
ii opsi-directory-connector 31.1-1 all opsi directory connector.
ii opsi-linux-bootimage 20191015-3 all opsi bootimage for netboot tasks.
ii opsi-linux-support 4.1.1-3 all Configure system to be able to deploy Linux with opsi.
ii opsi-server 4.1.1.8-1 all opsi server configuration package
ii opsi-tftpd-hpa 5.2.8-51 amd64 HPA's tftp server
ii opsi-utils 4.1.1.33-2 all utilites for working with opsi.
ii opsiconfd 4.1.1.20-1 all opsi configuration service
ii opsipxeconfd 4.1.1.17-1 all opsi pxe configuration daemon
ii python-opsi 4.1.1.79-2 all opsi python library



Grugi

Benutzeravatar
m.radtke
uib-Team
Beiträge: 785
Registriert: 10 Jun 2015, 12:19

Re: Nach opsi-linux-bootimage update keine Installation mehr möglich

Beitragvon m.radtke » 04 Nov 2019, 13:19

Hi Grugi,

kannst du mittels STRG+ALT+F(1-10) ein Terminal öffnen, an dem du dich mittels root mit pw linux123 anmelden kannst?

Wenn ja, hol doch mal das Log unter /tmp/log auf einen USB Stick, zusätzlich am Besten noch den Inhalt von /etc/dhcp/dhclient.conf.

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

Grugi
Beiträge: 63
Registriert: 07 Dez 2017, 08:57

Re: Nach opsi-linux-bootimage update keine Installation mehr möglich

Beitragvon Grugi » 04 Nov 2019, 14:37

m.radtke hat geschrieben:Hi Grugi,

kannst du mittels STRG+ALT+F(1-10) ein Terminal öffnen, an dem du dich mittels root mit pw linux123 anmelden kannst?

Wenn ja, hol doch mal das Log unter /tmp/log auf einen USB Stick, zusätzlich am Besten noch den Inhalt von /etc/dhcp/dhclient.conf.

Gruß
Mathias


Hallo Mathias,

sehr gerne poste ich hier mal schnell den Inhalt der beiden Dateien:
dhclient.conf:

Code: Alles auswählen

# Configuration file for /sbin/dhclient.
#
# This is a sample configuration file for dhclient. See dhclient.conf's
#   man page for more information about the syntax of this file
#   and a more comprehensive list of the parameters understood by
#   dhclient.
#
# Normally, if the DHCP server provides reasonable information and does
#   not leave anything out (like the domain name, for example), then
#   few changes must be made to this file, if any.
#

option rfc3442-classless-static-routes code 121 = array of unsigned integer 8;

send host-name = gethostname();
request subnet-mask, broadcast-address, time-offset, routers,
   domain-name, domain-name-servers, domain-search, host-name,
   dhcp6.name-servers, dhcp6.domain-search, dhcp6.fqdn, dhcp6.sntp-servers,
   netbios-name-servers, netbios-scope, interface-mtu,
   rfc3442-classless-static-routes, ntp-servers;

#send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
#send dhcp-lease-time 3600;
#supersede domain-name "fugue.com home.vix.com";
#prepend domain-name-servers 127.0.0.1;
#require subnet-mask, domain-name-servers;
timeout ;
#retry 60;
#reboot 10;
#select-timeout 5;
#initial-interval 2;
#script "/sbin/dhclient-script";
#media "-link0 -link1 -link2", "link0 link1";
#reject 192.33.137.209;

#alias {
#  interface "eth0";
#  fixed-address 192.5.5.213;
#  option subnet-mask 255.255.255.255;
#}

#lease {
#  interface "eth0";
#  fixed-address 192.33.137.200;
#  medium "link0 link1";
#  option host-name "andare.swiftmedia.com";
#  option subnet-mask 255.255.255.0;
#  option broadcast-address 192.33.137.255;
#  option routers 192.33.137.250;
#  option domain-name-servers 127.0.0.1;
#  renew 2 2000/1/12 00:00:01;
#  rebind 2 2000/1/12 00:00:01;
#  expire 2 2000/1/12 00:00:01;
#}


/tmp/log :

Code: Alles auswählen

Nov 04 14:01:07 [opsiinit] opsi init script started
Nov 04 14:01:07 [opsiinit] opsi linux bootimage version: 20191015 (4.1)
Nov 04 14:01:17 [opsiinit] getBootParam(pwh): cmdline: initrd=miniroot-x64.bz2 video=vesa:ywrap,mtrr vga=791 quiet splash --no-log console=tty1 console=ttyS0 dn=XXX product=win10-x64 hn=c11pavtww000740 pckey=*** confidential *** service=https://opsi.XXX:4447 BOOT_IMAGE=install-x64
Nov 04 14:01:17 [opsiinit] boot param pwh=
Nov 04 14:01:17 [opsiinit] getBootParam(nodhcp): cmdline: initrd=miniroot-x64.bz2 video=vesa:ywrap,mtrr vga=791 quiet splash --no-log console=tty1 console=ttyS0 dn=XXX product=win10-x64 hn=c11pavtww000740 pckey=*** confidential *** service=https://opsi.XXX:4447 BOOT_IMAGE=install-x64
Nov 04 14:01:17 [opsiinit] boot param nodhcp=0
Nov 04 14:01:17 [opsiinit] getBootParam(hn): cmdline: initrd=miniroot-x64.bz2 video=vesa:ywrap,mtrr vga=791 quiet splash --no-log console=tty1 console=ttyS0 dn=XXX product=win10-x64 hn=c11pavtww000740 pckey=*** confidential *** service=https://opsi.XXX:4447 BOOT_IMAGE=install-x64
Nov 04 14:01:17 [opsiinit] boot param hn=c11pavtww000740
Nov 04 14:01:17 [opsiinit] getBootParam(dhclienttimeout): cmdline: initrd=miniroot-x64.bz2 video=vesa:ywrap,mtrr vga=791 quiet splash --no-log console=tty1 console=ttyS0 dn=XXX product=win10-x64 hn=c11pavtww000740 pckey=*** confidential *** service=https://opsi.XXX:4447 BOOT_IMAGE=install-x64
Nov 04 14:01:17 [opsiinit] new dhclient timeout is now
Nov 04 14:01:17 [opsiinit] getBootParam(lang): cmdline: initrd=miniroot-x64.bz2 video=vesa:ywrap,mtrr vga=791 quiet splash --no-log console=tty1 console=ttyS0 dn=XXX product=win10-x64 hn=c11pavtww000740 pckey=*** confidential *** service=https://opsi.XXX:4447 BOOT_IMAGE=install-x64
Nov 04 14:01:17 [opsiinit] boot param lang=
Nov 04 14:01:17 [opsiinit] loading keymap de-latin1-nodeadkeys
Nov 04 14:01:17 [opsiinit] setting language environment (LANG=de_DE.UTF8, LANGUAGE=de, LC_ALL=de_DE.UTF8)
Nov 04 14:01:17 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:17 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:17 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:17 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:20 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:20 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:20 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:20 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:23 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:23 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:23 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:23 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:26 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:26 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:26 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:26 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:29 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:29 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:29 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:29 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:32 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:32 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:32 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:32 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:35 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:35 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:35 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:35 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:38 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:38 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:38 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:38 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:41 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:41 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:41 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:41 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:44 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:44 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:44 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:44 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:47 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:47 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:47 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:47 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:50 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:50 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:50 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:50 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:53 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:53 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:53 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:53 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:56 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:56 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:56 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:56 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:01:59 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:01:59 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:01:59 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:01:59 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:02:02 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:02:02 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:02:02 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:02:02 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:02:05 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:02:05 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:02:05 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:02:05 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:02:08 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:02:08 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:02:08 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:02:08 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:02:11 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:02:11 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:02:11 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:02:11 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:02:14 [opsiinit] getNetworkDevices(): link forced
Nov 04 14:02:14 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:02:14 [opsiinit] getNetworkDevices(): no devices with link found, returning error
Nov 04 14:02:14 [opsiinit] no devices found, sleeping 3 seconds
Nov 04 14:02:17 [opsiinit] getNetworkDevices(): device(s) found:  enp1s5 enp0s25, device(s) with link:
Nov 04 14:02:17 [opsiinit] getNetworkDevices(): no devices with link found, returning  enp1s5 enp0s25
Nov 04 14:02:17 [opsiinit] using dhcp, adding entry for device enp1s5 to /etc/netplan/01-enp1s5.yaml


Unter "dn=" steht natürlich im Log unsere Domain und nicht XXX. Das nur um Missverständnisse auszuschließen.

Beste Grüße

der Grugi

Benutzeravatar
m.radtke
uib-Team
Beiträge: 785
Registriert: 10 Jun 2015, 12:19

Re: Nach opsi-linux-bootimage update keine Installation mehr möglich

Beitragvon m.radtke » 04 Nov 2019, 15:51

Hi Grugi,

in Kürze sollten hier neue Bootimages für die jeweiligen Distros gebaut werden.

opsi-linux-bootimage_20191104-1

Aus irgendeinem grund wird auf bestimmten Maschinen Code ausgeführt der eigentlich nur beim kernel Parameter dhclienttimeout=INT ausgeführt werden sollte. Unnd aus irgendeinem grund ist der Wert leer. Habe jetzt mal einen leeren und einen nicht Zahl Wert abgefangen.

Würde mich über Feedback freuen.

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

Benutzeravatar
skranz1982
Beiträge: 61
Registriert: 09 Okt 2014, 08:01

Re: Nach opsi-linux-bootimage update keine Installation mehr möglich

Beitragvon skranz1982 » 05 Nov 2019, 17:50

Hiho!

Mein erster Eindruck des neuen Bootimages ist gut: Ein Lenovo thinkPad T590, das mit 20191015-3 noch die Arbeit verweigerte, hat jetzt brav gespurt. Weitere Geräte teste ich noch und melde mich dann wieder.

MfG,
Sebastian

Update:
Auch ein HP 640 G2 bootet jetzt wieder sauber *Daumen hoch*
Sebastian Kranz,
civitec Zweckverband kommunale Datenverarbeitung
www.civitec.de