Opsi-Depot nicht erreichbar

skylines
Beiträge: 7
Registriert: 08 Okt 2019, 15:11

Opsi-Depot nicht erreichbar

Beitragvon skylines » 15 Okt 2019, 11:24

Hallo,

ich habe das Problem, dass das Opsi-Depot zeitweise nicht erreichbar ist. Das Depot ist auf dem Server angelegt im Verzeichnis: /var/lib/opsi/depot, jedoch funktioniert der Zugriff der Netzwerkfreigabe von einem Client nicht.
Samba ist installiert mit der Version: 4.7.6 Ubuntu.
Ich nutze die vorkonfigurierte VM von UIB.
Wie bereits gesagt ist der Zugriff manchmal möglich und manchmal nicht. Hat jemand eine Idee woran das liegen könnte?

Vielen Dank schon mal für die Antworten

larsg
Beiträge: 222
Registriert: 16 Dez 2014, 18:06

Re: Opsi-Depot nicht erreichbar

Beitragvon larsg » 15 Okt 2019, 16:02

opsi-setup --auto-configure-samba ausgeführt?

Ist wirklich nur ein Client betroffen?

Gibt es eine Fehlermeldung?
Kommt eine Anmeldeaufforderung?
Gibt es irgend eine Regelmäßigkeit oder Muster wann es geht und wann nicht?

Es gibt unter Windows 10 eine neue Gruppenrichtlinie, welche je nach Konfiguration den Zugriff auf gewisse Netzwerkfreigaben verhindert.
Habe den genauen Pfad gerade nicht griffbereit, aber Google sollte hier weiterhelfen können.
Wenn das die Ursache bei dir ist, bekommst du eine spezifische Fehlermeldung, das der Zugriff auf eine unsichere Freigabe nicht möglich ist (oder so ähnlich)

skylines
Beiträge: 7
Registriert: 08 Okt 2019, 15:11

Re: Opsi-Depot nicht erreichbar

Beitragvon skylines » 16 Okt 2019, 12:57

Den Befehl habe ich schön öfters probiert. Bringt aber auch nichts.

Nein. Jeder Client ist betroffen, wenn das depot nicht erreichbar ist.

Ich drücke "Netzlaufwerk verbinden" im Explorer, gebe die IP\opsi_depot ein und dann kommt das Anmeldefenster. Sobald ich Benutzername und Passwort eingegeben habe versucht er zu verbinden und dann kommt die Fehlermeldung "Auf IP konnte nicht zugegriffen werden".
Benutzername und Passwort und auch die eingegebene IP sind 100% richtig. Manchmal, sage ich ja, klappt es auch und das liegt sicher nicht daran, dass ich etwas falsches eingebe. Ich habe auch einen Partner der dies alles bestätigen kann.

Da ich eine andere Fehlermeldung bekomme, schließe ich das mit der Gruppenrichtlinie mal aus.

skylines
Beiträge: 7
Registriert: 08 Okt 2019, 15:11

Re: Opsi-Depot nicht erreichbar

Beitragvon skylines » 17 Okt 2019, 10:46

Jetzt ist Depot zum Beispiel wieder nicht erreichbar.
Gestern noch den Raum verlassen während es funktionierte. Den Opsi Server habe ich auch angelassen. Ich habe also überhaupt nichts verändert. Nur meinen PC/Client habe ich heruntergefahren und heute wieder eingeschaltet.

Was vielleicht noch hilfreich zu wissen ist: Wenn ich bei der Fehlermeldung "... nicht erreichbar" auf "Diagnose" klicke kommt folgende Information:

Die Verbindung wird vom Remotegerät bzw. der Ressource nicht akzeptiert.

Das Gerät bzw. die Ressource (130.83.225.209) ist nicht für das Akzeptieren von Verbindungen an Port "Datei- und Druckerfreigabe (SMB)" eingerichtet.

Benutzeravatar
skranz1982
Beiträge: 61
Registriert: 09 Okt 2014, 08:01

Re: Opsi-Depot nicht erreichbar

Beitragvon skranz1982 » 17 Okt 2019, 12:40

Moin, moin!

Hast du mal einen Blick in die smb.conf auf deinem Depot geworfen? Sieht bei uns zB so aus:

Code: Alles auswählen

[opsi_depot]
   available = yes
   comment = opsi depot share (ro)
   path = /var/lib/opsi/depot
   follow symlinks = yes
   writeable = no
   invalid users = root
   admin users = @pcpatch
Was für ein Benutzerkonto verwendest du für den Zugriff? Und was sagt dir "c:\opsi.org\log\opsiclientd.log" dazu? Vielleicht kannst du mir einer Fehlermeldung aus dem Log mehr anfangen, als mit einer kryptischen Info von Windows.
Sebastian Kranz,
civitec Zweckverband kommunale Datenverarbeitung
www.civitec.de

skylines
Beiträge: 7
Registriert: 08 Okt 2019, 15:11

Re: Opsi-Depot nicht erreichbar

Beitragvon skylines » 18 Okt 2019, 09:21

Hallo skranz,

die smb.conf ist genau gleich.
Benutzerkonto ist auf jedenfall ein admin in der Gruppe "pcpatch". Aber auch mit dem Benutzer root klappts nicht.

Die log Datei habe ich gar nicht. Ich habe nur "opsi-client-agent" log-Datei.

JensWalk
Beiträge: 6
Registriert: 06 Nov 2019, 11:48

Re: Opsi-Depot nicht erreichbar

Beitragvon JensWalk » 06 Nov 2019, 12:23

Hallo

bei mir ist es das gleiche. Samba log:
[2019/11/05 11:29:32.714899, 0] ../source3/param/loadparm.c:3350(process_usershare_file)
process_usershare_file: stat of /var/lib/samba/usershares/opsi-depot failed. Keine Berechtigung
[2019/11/05 11:29:32.720410, 0] ../source3/param/loadparm.c:3350(process_usershare_file)
process_usershare_file: stat of /var/lib/samba/usershares/opsi-depot failed. Datei oder Verzeichnis nicht gefunden

also keine Berechtigung:

[global]
security = ads
realm=S....
password server 192.168.x.x
workgroup = SCHULEN
winbind enum users = yes
log level =1
winbind enum groups = yes
winbind cache time =10
winbind use default domain = yes
template homedir = /home/%U
template shell = /bin/bash
client ntlmv2 auth = yes
encrypt passwords = yes
restrict anonymous = 2
domain master = no
local master = no
preferred master = no
os level = 0
client lanman auth = yes
client ntlmv2 auth = yes
client use spnego = no
server max protocol =SMB3
server signing =auto
idmap uid = 10000-20000
idmap gid = 10000-20000

und die Freigaben alle wie:

[opsi_depot]
#walko
guest ok = yes
public = yes
#walko
available = yes
comment = opsi depot share (ro)
path = /var/lib/opsi/depot
follow symlinks = yes
writeable = no
invalid users = root
admin users = @pcpatch

ich habe so gar mal public zum Test eingefügt.

Ich bin mit dem Rechner im AD, funktioniert auch, die AD user und Gruppen werden angezeigt.

ich gehe auch mit IP\useradmin drauf. Geht auch nicht.

Ich finde den Fehler nicht.Vielleicht sieht einer das Problem.

Besten Dank und viele Grüße

J. Walkowiak

Benutzeravatar
ThomasT
uib-Team
Beiträge: 199
Registriert: 26 Jun 2013, 12:26

Re: Opsi-Depot nicht erreichbar

Beitragvon ThomasT » 06 Nov 2019, 13:40

Damit ich dich richtig verstehe:
Du versuchst mit einem Windows 10 Client (1809 oder neuer?) auf den SAMBA Share eines OPSI-Depotserver zuzugreifen.
Dabei verwendest du den Windows Explorer und versuchst auf \\IP-ODER-FQDN-DES-OPSIDEPOTSERVERS\opsi_depot_rw zu gelangen?

Grundsätzlich funktioniert jedoch das installieren von Software mit OPSI und dem opsi-client-agent?

Kannst du in der Anmeldeinformationsverwaltung von deinem Benutzer auf dem Client mal die entsprechenden Credentials hinterlegen?
Alternativ kannst du auch folgende Kommandozeile nutzen:
cmdkey /add:IP-ODER-FQDN-DES-OPSIDEPOTSERVERS /user:USER-IN-DER-PCPATCH-GRUPPE /pass:PASSWORD
Kein Support per DM!
_________________________
opsi support - https://www.uib.de/
For productive opsi installations we recommend support contracts.

JensWalk
Beiträge: 6
Registriert: 06 Nov 2019, 11:48

Re: Opsi-Depot nicht erreichbar

Beitragvon JensWalk » 08 Nov 2019, 09:22

Hallo Thomas,

danke für die schnelle Reaktion.

Du versuchst mit einem Windows 10 Client (1809 oder neuer?) auf den SAMBA Share eines OPSI-Depotserver zuzugreifen.
Dabei verwendest du den Windows Explorer und versuchst auf \\IP-ODER-FQDN-DES-OPSIDEPOTSERVERS\opsi_depot_rw zu gelangen?


Ja, die Ordner werden angezeigt. Gehen ich drauf kommt Zugriffsverweigerung.

Kannst du in der Anmeldeinformationsverwaltung von deinem Benutzer auf dem Client mal die entsprechenden Credentials hinterlegen?


Ja, habe ich gemacht. Kein Erfolg.

Viele Grüße
Jens

Benutzeravatar
ThomasT
uib-Team
Beiträge: 199
Registriert: 26 Jun 2013, 12:26

Re: Opsi-Depot nicht erreichbar

Beitragvon ThomasT » 08 Nov 2019, 09:43

Ähm warum versucht er denn in /var/lib/samba/usershares ein depot zu finden???
Kein Support per DM!
_________________________
opsi support - https://www.uib.de/
For productive opsi installations we recommend support contracts.