PXE-Server liefert keine Images aus

svens
Beiträge: 1
Registriert: 28 Aug 2019, 09:02

PXE-Server liefert keine Images aus

Beitragvon svens » 28 Aug 2019, 11:17

Hallo,

ich habe ein Problem mit dem PXE-Server von OPSI. Die Clients booten nicht vom PXE-Server und brechen dann ab. Im Log des Servers kann ich den Verbindungsversuch des Clients sehen:
/var/log/messages:
Aug 28 09:11:35 ###### in.tftpd[18802]: RRQ from ###.###.###.### filename linux/pxelinux.0
Aug 28 09:11:35 ###### in.tftpd[18802]: tftp: client does not accept options
Aug 28 09:11:35 ###### in.tftpd[18803]: RRQ from ###.###.###.### filename linux/pxelinux.0


Wenn ich aber mit tftp linux/pxelinux.0 herunter lade, klappt das problemlos:
tftp
(to) ######
tftp> get linux/pxelinux.0
tftp>


Unterhalb von /tftpboot/linux/pxelinux.cfg wird auch die PIPE mit der Mac-Adresse des Clients angelegt:

[1] [Aug 27 17:43:05] ==================================================================
= opsi pxe configuration service starting =
================================================================== (Logger.py|888)
[5] [Aug 27 17:43:05] Starting opsipxeconfd main thread (opsipxeconfd|201)
[5] [Aug 27 17:43:05] Ignoring module 'OpsiPXEConfd', backend 'opsipxeconfd' (BackendManager.py|387)
[5] [Aug 27 17:43:05] Creating unix socket u'/var/run/opsipxeconfd/opsipxeconfd.socket' (opsipxeconfd|148)
[5] [Aug 27 17:43:05] Start setting initial boot configurations (opsipxeconfd|649)
[5] [Aug 27 17:43:07] Special pxe config template u'install3264' will be used used for host u'########', product u'opsi-clonezilla' (opsipxeconfd|561)
[5] [Aug 27 17:43:07] PXE boot configuration for host pc059.fondsnet.de is now set at u'/tftpboot/linux/pxelinux.cfg/01-##-##-##-##-##-##' (opsipxeconfd|451)
[5] [Aug 27 17:43:07] Finished setting initial boot configurations (opsipxeconfd|674)


Hat jemand eine Idee wo ich noch nachschauen kann?

Benutzeravatar
m.radtke
uib-Team
Beiträge: 758
Registriert: 10 Jun 2015, 12:19

Re: PXE-Server liefert keine Images aus

Beitragvon m.radtke » 28 Aug 2019, 13:16

Hi

weitere Meldungen gibt es nicht in /var/log/messages?

Du kannst die Ausgabe vom opsi-tftpd-hpa mittels

Code: Alles auswählen

systemctl edit --full opsi-tftpd-hpa.service

erhöhen indem du -v durch --verbosity 8 ersetzt.

danach den Dienst neu starten und beobachten.

Passiert sonst noch etwas auf dem Client?

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3175
Registriert: 04 Apr 2013, 12:15

Re: PXE-Server liefert keine Images aus

Beitragvon n.wenselowski » 29 Aug 2019, 10:57

Hi,

svens hat geschrieben:
Aug 28 09:11:35 ###### in.tftpd[18802]: RRQ from ###.###.###.### filename linux/pxelinux.0
Aug 28 09:11:35 ###### in.tftpd[18802]: tftp: client does not accept options
Aug 28 09:11:35 ###### in.tftpd[18803]: RRQ from ###.###.###.### filename linux/pxelinux.0

Physikalische Hardware? Falls ja, dann kann es bei dieser Meldung helfen das UEFI zu aktualisieren.


Gruß

Niko
opsi development - uib gmbh
For productive opsi installations we recommend support contracts.

Benutzeravatar
SisterOfMercy
Beiträge: 1016
Registriert: 22 Jun 2012, 19:18

Re: PXE-Server liefert keine Images aus

Beitragvon SisterOfMercy » 30 Aug 2019, 12:00

n.wenselowski hat geschrieben:Hi,

svens hat geschrieben:
Aug 28 09:11:35 ###### in.tftpd[18802]: RRQ from ###.###.###.### filename linux/pxelinux.0
Aug 28 09:11:35 ###### in.tftpd[18802]: tftp: client does not accept options
Aug 28 09:11:35 ###### in.tftpd[18803]: RRQ from ###.###.###.### filename linux/pxelinux.0

Physikalische Hardware? Falls ja, dann kann es bei dieser Meldung helfen das UEFI zu aktualisieren.


If it loads pxelinux.0 it would seem it is not in uefi mode. Or the client is in uefi mode, but the dhcp server is not configured correctly.
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!