Lenovo T490s

djdodo
Beiträge: 152
Registriert: 12 Jan 2011, 10:54

Lenovo T490s

Beitragvon djdodo » 06 Aug 2019, 11:43

Hallo zusammen!

Wir haben als neuen Hardwaretyp das im Betreff genannte Modell bekommen.
Damit haben wir enorme Probleme.
Vielleicht hat hier jemand eine Lösung....
Im Gegensatz zu den bisherigen Systemen hat dieses Modell keinen LAN-Anschluss mehr.
Bei anderen Geräten ohne diesen Anschluss konnten wir immer einen USB3 -> LAN adapter verwenden und damit den PXE-Boot machen, dieses Modell erkennt diesen aber leider nicht mehr.
Wir mussten etliche Einstellungen im BIOS anpassen, damit der PXE-Boot über die USB-C - Docks geht.
Es wird auch das Bootimage geladen, hier fehlt aber wiederum der Treiber im Opsi-bootimage.
Bei zusätzlichem Anschluss eines USB3 - LAN - Adapters geht es hier weiter,
allerdings ist das rootfs zu klein für alle zu übertragenden Treiber.
Im Post viewtopic.php?f=7&t=11253 wurde mir hier eine Lösung genannt, die aber nur funktioniert, wenn man das pro Client einträgt, setzt man es als Depot-Default wirkt es leider nicht.
Sobald die Treiber etc übertragen sind, kommt die Meldung, das das Netboot-Produkt fertig ist, "Waiting for Reboot". Dieser passiert aber nicht automatisch, man muss den Rechner hart ausschalten.
Dann läd wie gewohnt das WinPE, dieses erkennt aber wiederum das Dock nicht und hat somit kein Netzwerk und bricht ab. Es muss also der USB3 - LAN - Adapter zusätzlich angeschlossen werden.

Hat jemand hier einen besseren Weg?


LG
Dominik

Benutzeravatar
ThomasT
uib-Team
Beiträge: 236
Registriert: 26 Jun 2013, 12:26

Re: Lenovo T490s

Beitragvon ThomasT » 06 Aug 2019, 13:28

Sind das denn WinPE-Treiber, also Textmode-Treiber?
Teilweise wird der USB3-Controller auch gar nicht erkannt.
Kein Support per DM!
_________________________
opsi support - https://www.uib.de/
For productive opsi installations we recommend support contracts.

djdodo
Beiträge: 152
Registriert: 12 Jan 2011, 10:54

Re: Lenovo T490s

Beitragvon djdodo » 06 Aug 2019, 13:38

Hallo ThomasT,
ja, es sind PE-Treiber.
Aktuelle Frage ist bei mir gerade, wie ich die Treiber fürs opsi-linux-bootimage integrieren kann...

lg
Dominik

Benutzeravatar
SisterOfMercy
Beiträge: 1146
Registriert: 22 Jun 2012, 19:18

Re: Lenovo T490s

Beitragvon SisterOfMercy » 07 Aug 2019, 10:17

djdodo hat geschrieben:Hat jemand hier einen besseren Weg?


If the boot image is available seperately, why not put that iso file on a USB stick, and boot of off that?
Of course you need to fill in all information, but perhaps you can change some configuration file, so it's only hostname.

Or perhaps see if you can boot to the network with wifi?
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

Benutzeravatar
m.radtke
uib-Team
Beiträge: 923
Registriert: 10 Jun 2015, 12:19

Re: Lenovo T490s

Beitragvon m.radtke » 08 Aug 2019, 09:45

Hi Dominik

kannst Du mir sagen um welches Dock es sich genau handelt?

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

djdodo
Beiträge: 152
Registriert: 12 Jan 2011, 10:54

Re: Lenovo T490s

Beitragvon djdodo » 16 Dez 2019, 10:54

Hallo,
sorry für die sehr späte Antwort....
Wir haben 2 Typen von Docks:
Lenovo Thinkpad USB-C Dock (40A9)
Lenoc Thinkpad USB-C mit USB-A Hybrid (40AF)

Darin ist nach meinem Wissenstand eine Realtek-Karte verbaut.
Problem ist an dem ganzen nicht der Netzwerktreiber, sondern der Thunderbolt 3-Treiber, damit das Dock überhaupt erkannt wird.
Da die neuen Modelle mittlerweile ausser USB-C keine Schnittstellen haben, fällt auch der Boot vom Stick weg.

Die Treiber ins PE zu integrieren ist einfach, ins Opsi-Bootimage wohl eher nicht.

Ich habe Ähnliches vor langer langer Zeit (2002 mit Novell Bootdisk) schon mal gemacht, aber das Wissen wie es geht ist etwas in Vergessenheit geraten.
Wenn ihr mir kurz auf die Sprünge helft, wie man das Image selbst mounted etc. kann ich mich daran versuchen.

Lg
Dodo

Benutzeravatar
m.radtke
uib-Team
Beiträge: 923
Registriert: 10 Jun 2015, 12:19

Re: Lenovo T490s

Beitragvon m.radtke » 16 Dez 2019, 12:03

Hi Dodo,

mein Kollege Thomas hat ein T490s im Dock.

Eben hat er erfolgreich ein hwinvent durchgeführt. Er hat im BIOS die interne Netzwerkkarte als Netzwerkkarte eingestellt.
Verwendet wurde das opsi-linux-bootimage_20191211-1

Kannst du das nachvollziehen?

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.