Seite 1 von 1

Kann opsi-server nicht installieren Ubuntu LTS 18.04

Verfasst: 19 Jul 2019, 11:25
von Susie1703
Hallo zusammen,

da ich neben SCCM auch den OPSI testen möchte, habe ich mir heute ein Ubuntu in einer VM installiert und wollte mir den OPSI Server installieren, bin nach dem ofiziellen manual gegangen, allerdings bekomme ich einen Fehler wenn ich

Code: Alles auswählen

sudo apt install opsi-server

mache kommt folgendes

Code: Alles auswählen

cp: cannot stat '/tftpboot/linux/pxelinux.cfg/default.nomenu': No such file or directory
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/opsi-linux-bootimage_20190522-1_all.deb (--unpack):
 new opsi-linux-bootimage package pre-installation script subprocess returned error exit status 1
Vormals nicht ausgewähltes Paket opsi-server wird gewählt.
Vorbereitung zum Entpacken von .../opsi-server_4.1.1.7-1_all.deb ...
Entpacken von opsi-server (4.1.1.7-1) ...
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/opsi-linux-bootimage_20190522-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Da ich ein ziemlicher Linux Neuling bin komme ich hier nicht weiter.
Vielleicht könnt ihr mir ja weiterhelfen.

Danke
LG
Susie

Re: Kann opsi-server nicht installieren Ubuntu LTS 18.04

Verfasst: 19 Jul 2019, 11:43
von tobias
@UIB den Fehler hatte ich neulich auch. Gibt es da ggf. ein Bug?

Ursache war, dass die files in '/tftpboot/linux/pxelinux.cfg/' zwar vorhanden waren, aber alle hinten dran ein .OPSI kleben hatten.
Nach dem ich das .opsi entfernt hatte, war die Installation erfolgreich.


Gruß
Tobias

Re: Kann opsi-server nicht installieren Ubuntu LTS 18.04

Verfasst: 19 Jul 2019, 12:37
von Susie1703
Hallo Tobias,

danke für den Hinweis, allerdings habe ich unter dem Folder gar nichts liegen.

Gruß
Susie

Re: Kann opsi-server nicht installieren Ubuntu LTS 18.04

Verfasst: 19 Jul 2019, 13:40
von uncle_scrooge
Bist Du sicher, daß
apt install opsi-tftpd-hpa
erfolgreich gelaufen ist?

Re: Kann opsi-server nicht installieren Ubuntu LTS 18.04

Verfasst: 22 Jul 2019, 07:48
von Susie1703
Ja, habe es gerade noch einmal probiert, allerdings kommt auch folgende Meldung

Code: Alles auswählen

opsi-tftpd-hpa ist schon die neueste Version (5.2.8-49).
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 opsi-server : Hängt ab von: opsi-linux-bootimage (>= 20170620) soll aber nicht installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

Re: Kann opsi-server nicht installieren Ubuntu LTS 18.04

Verfasst: 22 Jul 2019, 09:05
von Susie1703
Ich habe mein ubuntu nun einfach nochmal neu installiert und siehe da alles funktioniert :-)

Trotzdem danke für die Hilfe