Fragen/Probleme rund um windows10-upgrade Paket

g.burck
Beiträge: 58
Registriert: 23 Mai 2018, 16:44

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon g.burck » 24 Jul 2019, 16:06

Tschuldigung, ich habe hierzu einen eigenen Thread geöffnet,...
viewtopic.php?f=7&t=11244
Zuletzt geändert von g.burck am 25 Jul 2019, 15:34, insgesamt 1-mal geändert.

Benutzeravatar
CKoehler
Beiträge: 29
Registriert: 14 Sep 2015, 21:12
Wohnort: Braunschweig

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon CKoehler » 25 Jul 2019, 15:30

g.burck hat geschrieben:Noch ein Problem:

Beim Versuch von 1803 auf 1903 zu aktualisieren hängt der PC ewig im Preparing.
Files_copy_event_starter finished ist die letzte Meldung die ausgegeben wird.

Einen aktuellen log eintrag im configed sehe ich auch nicht.

Ich habe es sowohl mit einem vorhandenen Rechner mit 1803 wie auch mit einer frisch aufgesetzten VM versucht.


Darauf habe ich dir nun auf deinen eigenen Thread geantwortet. Sorry, war die letzten Tage leider verhindert.

menno
Beiträge: 7
Registriert: 27 Dez 2014, 15:22

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon menno » 26 Okt 2019, 11:28

Hallo,

gibt es einen oder mehrere Schalter, der Windows 10 dazu bringt, das Update ohne Nachfrage zu installieren und wenn notwendig, selbstständig neu zu starten?
Bei meinem Test musst ich das Update in Windows auslösen sowie einen Neustart anstoßen.

Im "setup.opsiscript" des Paketes finde ich die auskommentierte Variable "DefVar $RebootFlag$"
Diese Variable wird im Script sehr oft abgefragt.

Alles andere hat super funktioniert. Vielen Dank für dieses Paket.


EDIT: Da saß das Problem wohl vor dem Rechner. Ein weiteres Upgrade von 1803 auf 1903 ist problemlos ohne Eingriff meinerseits durchgelaufen.

Benutzeravatar
tobias
Beiträge: 1275
Registriert: 20 Aug 2008, 12:36
Wohnort: Braunschweig
Kontaktdaten:

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon tobias » 27 Okt 2019, 00:24

menno hat geschrieben:Hallo,

gibt es einen oder mehrere Schalter, der Windows 10 dazu bringt, das Update ohne Nachfrage zu installieren und wenn notwendig, selbstständig neu zu starten?


Also das Paket ist eigentlich so gedacht, wenn du es auf setup gesetzt hast, es auch automatisch installiert wird und der rechner natürlich auch automatisch neu startet.

Die $rebootflag$ variablen im Script sind dafür da, damit nach einem notwenigen neustart das ganze script nicht wieder von vorn läuft.


Gruß
Tobias
Veröffentliche deine WINST Scripte im OPSI Wiki und leiste so einen wertvollen Beitrag für die Community !!!
https://forum.opsi.org/wiki/

Mike153
Beiträge: 1
Registriert: 20 Nov 2019, 08:44

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon Mike153 » 27 Nov 2019, 16:25

Hallo, wir haben ebenfalls ein Problem, allerdings nur in der Darstellung vom opsi config editor.

Folgendes Scenario: Windows 10 1903 wird auf 1909 upgegradet, der Vorgang läuft überall einwandfrei durch, sobald das Upgrad fertig ist, kommt im opsi config editor folgender Fehler:
Report: Failed: Not on Targetversion 10.0 release id 1903 targetversion was X:\windows10-upgrade\\ (setup) failed.
Wie bekomm ich diese Fehlermeldung wieder aus dem config editor wieder raus. Bzw. wie wird mir die korrekte installation richtig mit der richtigen Versionsnummer angezeigt.

Benutzeravatar
2nd_bass
Beiträge: 13
Registriert: 08 Mär 2012, 10:31
Wohnort: Wien
Kontaktdaten:

windows10-upgrade Paket - "Server kennt die Eigenschaft nicht"

Beitragvon 2nd_bass » 29 Nov 2019, 12:57

Hallo,
ich habe mir gerade das Paket 19.09-6 runtergeladen und am Server eingespielt. Wieso ist das Property "installfiles_dir" rot und fett markiert (Tooltip sagt: "Server kennt die Eigenschaft nicht")?
Ich nehme an, solange ich das stehen habe, brauchen wir gar nicht testen, ob das Upgrade läuft...

MfG Hubert

*******
Ergänzung: ich habe gerade "zum Spaß" in den Produkt-DefaultProperties auf den Button "Setze die Paket Defaultwerte" gedrückt, dann verschwindet der Eintrag "installfiles", damit aber auch die rote Markierung...
???

*******
Ergänzung, die 2.: ich habe jetzt manuell installfiles als Wert eingegeben und OK gedrückt, daraufhin kommt eine Fehlermeldung, dass das Property nicht vorhanden ist - ist da ein Schreibfehler in der control o.ä.?

Benutzeravatar
tobias
Beiträge: 1275
Registriert: 20 Aug 2008, 12:36
Wohnort: Braunschweig
Kontaktdaten:

Re: windows10-upgrade Paket - "Server kennt die Eigenschaft nicht"

Beitragvon tobias » 29 Nov 2019, 19:31

2nd_bass hat geschrieben:Hallo,
ich habe mir gerade das Paket 19.09-6 runtergeladen und am Server eingespielt. Wieso ist das Property "installfiles_dir" rot und fett markiert (Tooltip sagt: "Server kennt die Eigenschaft nicht")?
Ich nehme an, solange ich das stehen habe, brauchen wir gar nicht testen, ob das Upgrade läuft...



Oh da wird ein Bug sein, ist bei mir auch so - das Paket funktioniert aber trotz dem Problemlos.

Hab das mal über den Support gemeldet.
Veröffentliche deine WINST Scripte im OPSI Wiki und leiste so einen wertvollen Beitrag für die Community !!!
https://forum.opsi.org/wiki/

Benutzeravatar
Der-Matze
uib-Team
Beiträge: 69
Registriert: 16 Mär 2009, 11:00

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon Der-Matze » 02 Dez 2019, 12:25

Mike153 hat geschrieben:Hallo, wir haben ebenfalls ein Problem, allerdings nur in der Darstellung vom opsi config editor.

Folgendes Scenario: Windows 10 1903 wird auf 1909 upgegradet, der Vorgang läuft überall einwandfrei durch, sobald das Upgrad fertig ist, kommt im opsi config editor folgender Fehler:
Report: Failed: Not on Targetversion 10.0 release id 1903 targetversion was X:\windows10-upgrade\\ (setup) failed.
Wie bekomm ich diese Fehlermeldung wieder aus dem config editor wieder raus. Bzw. wie wird mir die korrekte installation richtig mit der richtigen Versionsnummer angezeigt.


Bitte mal ein Logfile zukommen lassen damit man sich das genauer anschauen kann.

Benutzeravatar
Der-Matze
uib-Team
Beiträge: 69
Registriert: 16 Mär 2009, 11:00

Re: windows10-upgrade Paket - "Server kennt die Eigenschaft nicht"

Beitragvon Der-Matze » 02 Dez 2019, 12:27

tobias hat geschrieben:
2nd_bass hat geschrieben:Hallo,
ich habe mir gerade das Paket 19.09-6 runtergeladen und am Server eingespielt. Wieso ist das Property "installfiles_dir" rot und fett markiert (Tooltip sagt: "Server kennt die Eigenschaft nicht")?
Ich nehme an, solange ich das stehen habe, brauchen wir gar nicht testen, ob das Upgrade läuft...



Oh da wird ein Bug sein, ist bei mir auch so - das Paket funktioniert aber trotz dem Problemlos.

Hab das mal über den Support gemeldet.


Danke für den Hinweis. Kann das ganze hier reproduzieren und arbeite an einem Fix.
Melde mich sobald ich was testbares gebaut habe.

xBr0th3rs
Beiträge: 13
Registriert: 03 Dez 2019, 15:47

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon xBr0th3rs » 03 Dez 2019, 15:51

Hallo zusammen,

ich bin auch aktuell dabei mich besser mit dem windows10-upgrade Paket besser zu befassen.
Nun meine frage wenn ich ein Client Upgrade von z.b. 7 Pro auf 10 wird automatisch die Version 10 Pro auswählt.
Ich würde aber gerne auf die Version 10 Pro N Upgraden gibt es da eine Möglichkeit das anzupassen in den Configs oder ist das fest gesetzt?

Mfg