Fragen/Probleme rund um windows10-upgrade Paket

Benutzeravatar
CKoehler
Beiträge: 29
Registriert: 14 Sep 2015, 21:12
Wohnort: Braunschweig

Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon CKoehler » 01 Jul 2019, 11:03

Moin,

ich habe letze Woche mal ein Windows 10 Upgrade mit dem Paket windows10-upgrade(19.03-1) ausprobiert.
Ich habe das Paket runtergeladen und mit der id win10-ltsc-upgrade installiert. Wie man nun aus dem Namen schließen kann, will ich damit die LTSB/LTSC Versionen upgraden. Bei meinen Tests sind ein paar Fragen/Probleme aufgetreten.
Das Paket wurde mit dem Inhalt des Windows 10 Enterprise 1809 LTSC-Images gefüllt. Die Dateien liegen im Ordner installfiles.
Produkt Properties:
  • installfiles_dir installfiles
  • lock_keyboard false
  • mode upgrade
  • productkey M7XTQ-FN8P6-TTKYV-9D4CC-J462D
  • quiet true
  • setup_after_install -> leer
  • showoobe None
  • telemetry disable
  • temp_dir_for_eventstartet applog
  • temp_user_password NTup12_!
  • upgrade-to-version 1809
  • wan-extension false

Die Fragen/Probleme:
  1. Wenn ich ein Image in den Ordner schiebe, wozu dient dann das property mit der Versionsnummer?
  2. Kann man in dem Paket sinnvoll versch. Images hinterlegen und mit dem property dann die Verisonsnummer festlegen, auf die man upgraden möchte?
  3. Der temporäre User, der für eine Anmeldung benötigt wird, scheint nicht korrekt angelegt zu werden. Nach dem Neustart stand die Meldung, dass das Passwort falsch ist und die Anmeldung fehlgeschlagen ist. Nach einer manuellen Anmeldung mit dem lokalen Administrator lief die Installation dann an. Ich werde das gleich nochmal ausprobieren und schauen, ob der temporäre User ggf. manuell funktioniert und nur die automatische Anmeldung fehlschlägt.
  4. Nach dem Upgrade-Prozess (inkl. div. Neustarts) sollte man ja normal wieder weitermachen. Dann kam allerdings wieder die typischen Abfragen zu div. neueren "Datenschutzeinstellungen". Sollte das nicht durch das showoobe verhindert werden? Das ganze verkompliziert sich beim Manuellen durchklicken dann noch durch die aktivierte UAC (GPO), da die Abfrage zum Abschluss dann im Hintergrund ist und man sie mit ALT+TAB in den "Vordergrund" holen muss.
  5. Gibt es bei dieser Art des Upgrades Unterschiede zwischen den normalen Windows 10 Versionen zur Windows 10 LTSB/LTSC Version?

Wir testen das gerade primär für die LTSB/LTSC Versionen, da diese das Update über den WSUS nicht machen/können.
In diesem Fall habe ich von Windows 10 Enterprise 1607 LTSB auf die Windows 10 Enterprise 1809 LTSC geupgradet.

Viele Grüße
Christopher

uncle_scrooge
Beiträge: 579
Registriert: 21 Feb 2012, 12:03
Wohnort: Mainz

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon uncle_scrooge » 01 Jul 2019, 12:55

1. Gute Frage. Nächste Frage. Ist mir (und anderen) ebenfalls unklar. Leider hat sich Bardo Wolf hier https://forum.uib.de/viewtopic.php?t=10221 nur kryptisch geäußert.

2. Über installfiles_dir kannst Du unterschiedliche Pfade - und damit 'Images' - ansteuern. Siehe auch hier: viewtopic.php?f=7&t=11128. Das bezieht sich zwar auf das 'normale' netboot-Produkt, aber beim Upgrade-Paket wird in declarations-local.opsiscript das Property ausgewertet. Sollte also auch damit funktionieren.

Bei 3., 4., 5. hülle ich mich in Schweigen. Meine Ahnungslosigkeit muß ich nicht auch noch breittreten.

Benutzeravatar
CKoehler
Beiträge: 29
Registriert: 14 Sep 2015, 21:12
Wohnort: Braunschweig

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon CKoehler » 01 Jul 2019, 13:11

uncle_scrooge hat geschrieben:1. Gute Frage. Nächste Frage. Ist mir (und anderen) ebenfalls unklar. Leider hat sich Bardo Wolf hier https://forum.uib.de/viewtopic.php?t=10221 nur kryptisch geäußert.

Hatte ich auch schon gesehen und bin auch nicht ganz schlau daraus geworden. Aufgrund meiner zusätzlichen Fragen hatte ich einfach einen neuen Thread aufgemacht.
uncle_scrooge hat geschrieben:2. Über installfiles_dir kannst Du unterschiedliche Pfade - und damit 'Images' - ansteuern. Siehe auch hier: viewtopic.php?f=7&t=11128. Das bezieht sich zwar auf das 'normale' netboot-Produkt, aber beim Upgrade-Paket wird in declarations-local.opsiscript das Property ausgewertet. Sollte also auch damit funktionieren.

Okay. so hätte ich es jetzt auch verstanden. Dann bleibt aber immernoch die Frage 1. offen, wozu man dann das andere property hat ¯\_(ツ)_/¯
Oder gibt es eine mir noch nicht bekannte Möglichkeit, versch. Images aus unterschiedlichen Versionen, zu einem Image zusammen zu führen und dann mit dem Property die gewünschte Version anzugeben?

Vielleicht kann uib hier mehr Infos zu dem Paket bzw. zu der Nutzung des Pakets geben? Es scheint ja dann doch für einige noch nicht ganz klar zu sein.

An dieser Stelle vielleicht auch noch ein kleiner Vorschlag: Eine Möglichkeit wie beim wim-capture Paket, vorher mit clonezilla automatisiert ein Backup vom Client zu erstellen.

Benutzeravatar
wolfbardo
uib-Team
Beiträge: 1140
Registriert: 01 Jul 2008, 12:10

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon wolfbardo » 01 Jul 2019, 15:15

Hallo,

vorab: das windows10-upgrade benoetigt sicher das ein oder andere code-cleanup sowie Verbesserungen, den Einbau von im Forum genannten Wünschen wie viewtopic.php?f=5&t=11102


CKoehler hat geschrieben:Moin,

ich habe letze Woche mal ein Windows 10 Upgrade mit dem Paket windows10-upgrade(19.03-1) ausprobiert.
Ich habe das Paket runtergeladen und mit der id win10-ltsc-upgrade installiert. Wie man nun aus dem Namen schließen kann, will ich damit die LTSB/LTSC Versionen upgraden.


Normalerweise sollte auch hier das upgrade "einfach so funktionieren" gemaess

https://docs.microsoft.com/en-us/window ... rade-paths

d.h. z.B.

Code: Alles auswählen

Windows 10 Enterprise 2015 LTSB   nach Windows 10 Enterprise LTSC 2019 (1809)

und

Windows 10 Enterprise 2016 LTSB (1607) nach Windows 10 Enterprise LTSC 2019 (1809)



geht, aber z.B.

Code: Alles auswählen

Windows 10 Enterprise N 2016 LTSB (1607) nach Windows 10 Enterprise LTSC 2019 (1809)

scheitert wg. dem "N"



Insbesondere sollte es normalerweise nicht noetig sein, einen KEY mitzugeben.

CKoehler hat geschrieben:[*]Wenn ich ein Image in den Ordner schiebe, wozu dient dann das property mit der Versionsnummer?


Das Property mode gibt an , auf welche Version soll das Upgrade erfolgen

- ob eine passende setup.exe bei den installfiles hinterlegt ist
- und das ganze am Schluss gklappt hat (gewunschte version installiert)

CKoehler hat geschrieben:[*]Kann man in dem Paket sinnvoll versch. Images hinterlegen und mit dem property dann die Verisonsnummer festlegen, auf die man upgraden möchte?


war mal so gedacht, vermute aber, dass es momentan nicht funktioniert.


CKoehler hat geschrieben:[*]Der temporäre User, der für eine Anmeldung benötigt wird, scheint nicht korrekt angelegt zu werden. Nach dem Neustart stand die Meldung, dass das Passwort falsch ist und die Anmeldung fehlgeschlagen ist. Nach einer manuellen Anmeldung mit dem lokalen Administrator lief die Installation dann an. Ich werde das gleich nochmal ausprobieren und schauen, ob der temporäre User ggf. manuell funktioniert und nur die automatische Anmeldung fehlschlägt.


das haengt moeglicherweise mit einer policy von Euch zusammen?

CKoehler hat geschrieben:[*]Nach dem Upgrade-Prozess (inkl. div. Neustarts) sollte man ja normal wieder weitermachen. Dann kam allerdings wieder die typischen Abfragen zu div. neueren "Datenschutzeinstellungen". Sollte das nicht durch das showoobe verhindert werden? Das ganze verkompliziert sich beim Manuellen durchklicken dann noch durch die aktivierte UAC (GPO), da die Abfrage zum Abschluss dann im Hintergrund ist und man sie mit ALT+TAB in den "Vordergrund" holen muss.


Die Hoffnung hatte ich auch gemaess

https://docs.microsoft.com/en-us/window ... ne-options

Evtl hilft hier

setup_after_install "config-win10"


CKoehler hat geschrieben:[*]Gibt es bei dieser Art des Upgrades Unterschiede zwischen den normalen Windows 10 Versionen zur Windows 10 LTSB/LTSC Version?[/list]


Sind mir nicht bekannt,

Gruss
Bardo Wolf


opsi-Konferenz in Mainz am 02. / 03. März 2020

opsi workshops

https://uib.de/de/support-schulung/schulung/

Basis 4.-7.11.2019


opsi support by uib gmbh

http://www.uib.de

Benutzeravatar
CKoehler
Beiträge: 29
Registriert: 14 Sep 2015, 21:12
Wohnort: Braunschweig

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon CKoehler » 01 Jul 2019, 15:47

zunächst einmal vielen dank für die ausführliche Antwort.
wolfbardo hat geschrieben:Insbesondere sollte es normalerweise nicht noetig sein, einen KEY mitzugeben.

Das ist der default "KMS-Key". Die gebe ich immer vorsichtshalber mit an. schadet ja nicht: https://docs.microsoft.com/de-de/window ... clientkeys


wolfbardo hat geschrieben:Das Property mode gibt an , auf welche Version soll das Upgrade erfolgen

- ob eine passende setup.exe bei den installfiles hinterlegt ist
- und das ganze am Schluss gklappt hat (gewunschte version installiert)

ersteres konnte ich insofern schon testen. Ich hatte es erst mit latest ausprobiert. Aber da das Image ja 1809 ist, wollte er es nicht durchführen, da es ja theoretisch schon die 1903 gibt. Aber bei den LTSC Versionen ist das ja wieder anders...
wolfbardo hat geschrieben:
CKoehler hat geschrieben:[*]Kann man in dem Paket sinnvoll versch. Images hinterlegen und mit dem property dann die Verisonsnummer festlegen, auf die man upgraden möchte?


war mal so gedacht, vermute aber, dass es momentan nicht funktioniert.

Dafür dann div. Unterordner im installfiles, die Images da reinkopieren und dann im property den Pfad und die Versionsnummer anpassen oder wie war das vorgehen dafür mal geplant?

wolfbardo hat geschrieben:
CKoehler hat geschrieben:[*]Der temporäre User, der für eine Anmeldung benötigt wird, scheint nicht korrekt angelegt zu werden. Nach dem Neustart stand die Meldung, dass das Passwort falsch ist und die Anmeldung fehlgeschlagen ist. Nach einer manuellen Anmeldung mit dem lokalen Administrator lief die Installation dann an. Ich werde das gleich nochmal ausprobieren und schauen, ob der temporäre User ggf. manuell funktioniert und nur die automatische Anmeldung fehlschlägt.


das haengt moeglicherweise mit einer policy von Euch zusammen?

Scheinbar... Ich habe es gerade mit einem längeren Passwort probiert. Damit ists jetzt angelaufen.

wolfbardo hat geschrieben:
CKoehler hat geschrieben:[*]Nach dem Upgrade-Prozess (inkl. div. Neustarts) sollte man ja normal wieder weitermachen. Dann kam allerdings wieder die typischen Abfragen zu div. neueren "Datenschutzeinstellungen". Sollte das nicht durch das showoobe verhindert werden? Das ganze verkompliziert sich beim Manuellen durchklicken dann noch durch die aktivierte UAC (GPO), da die Abfrage zum Abschluss dann im Hintergrund ist und man sie mit ALT+TAB in den "Vordergrund" holen muss.


Die Hoffnung hatte ich auch gemaess

https://docs.microsoft.com/en-us/window ... ne-options

Evtl hilft hier

setup_after_install "config-win10"

Upgrade läuft gerade. Ich berichte später, ob das geklappt/geholfen hat.

Benutzeravatar
CKoehler
Beiträge: 29
Registriert: 14 Sep 2015, 21:12
Wohnort: Braunschweig

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon CKoehler » 01 Jul 2019, 18:35

CKoehler hat geschrieben:Upgrade läuft gerade. Ich berichte später, ob das geklappt/geholfen hat.

Also: Wenn ich mich mit dem lokalen Administrator Konto anmelde, kommt trotzdem das OOBE, wenn ich aber z.B. den Dom-Admin nehme, dann nicht.
Da hat das config-win10 scheinbar nicht geholfen. Ist aber auf jeden Fall durchgelaufen.

Ansonsten funktioniert das upgrade soweit. Gibt aber leider noch viel zu beachten. Ist aber durchaus eine Erleichterung, als wenn ich das Überall manuell machen muss...

larsg
Beiträge: 220
Registriert: 16 Dez 2014, 18:06

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon larsg » 02 Jul 2019, 08:44

es gibt die property installfiles_dir, dort legt man fest welche sourcen genommen werden (1809 enterprise, 1809 pro, 1709 enterprise, etc)
die einträge entsprechen dem jeweiligen ordnernamen im paketverzeichnis, also z.b. installfiles_1809ent
da man die sourcen mutmaßlich bereits in den netboot-produkten liegen hat, reichen auch symlinks.

hiermit verändert man die property nachträglich

Code: Alles auswählen

opsi-admin -d method createProductPropertyDefinition windows10-upgrade "installfiles_dir" "installfiles dir to use as installation source" "installfiles_1809ent" '["installfiles_1809ent","installfiles_1809pro"]'




die property upgrade-to-version legt die zu installierende zielversion fest und prüft ob die ausgewählten sourcen dieser version entsprechen.

g.burck
Beiträge: 37
Registriert: 23 Mai 2018, 16:44

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon g.burck » 23 Jul 2019, 14:25

Moin,

ich hänge ich mal hier dran:
wolfbardo hat geschrieben:
CKoehler hat geschrieben:[*]Nach dem Upgrade-Prozess (inkl. div. Neustarts) sollte man ja normal wieder weitermachen. Dann kam allerdings wieder die typischen Abfragen zu div. neueren "Datenschutzeinstellungen". Sollte das nicht durch das showoobe verhindert werden? Das ganze verkompliziert sich beim Manuellen durchklicken dann noch durch die aktivierte UAC (GPO), da die Abfrage zum Abschluss dann im Hintergrund ist und man sie mit ALT+TAB in den "Vordergrund" holen muss.


Die Hoffnung hatte ich auch gemaess

https://docs.microsoft.com/en-us/window ... ne-options

Evtl hilft hier

setup_after_install "config-win10"


Ich habe erfolgreich ein upgrade durchgeführt, bin auch über das zu kurze Passwort gestolpert (dabei habe ich die Policy selbst geschrieben).
Vergebe ich ein längeres wird der temp. User auch eingeloggt. Allerdings musste ich bei diesem die Einstelllungen durchklicken, obwogl showoobe standardmäßig auf none steht.

Gibt es dazu schon einen Workaround?, eine völlig unbeaufsichtigte Installation wäre ja das Ziel.

Ach ja, bei mir war es ein upgrade von 1809 auf 1903, ein config-win10 war mit den Standardwerten drüber gelaufen.

Grüße

Gregor

Benutzeravatar
tobias
Beiträge: 1250
Registriert: 20 Aug 2008, 12:36
Wohnort: Braunschweig
Kontaktdaten:

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon tobias » 23 Jul 2019, 15:19

Moin,

also wir haben das OOBE via Gruppenrichtlinie auf den Clients ausgeschaltet, seit dem kommt es nicht mehr.

Die Einstellung findet man hier (man braucht das ADMX Template für Windows 10 1809 auf seinen DCs damit man die Einstellung hat):
-> Computer Configuration\Administrative Templates\Windows Components\OOBE

Da es via GPO zu gehen scheint, gibt es sicher auch Registry Keys um das gleiche zu erreichen.

Gruß
Tobias
Veröffentliche deine WINST Scripte im OPSI Wiki und leiste so einen wertvollen Beitrag für die Community !!!
https://forum.opsi.org/wiki/

g.burck
Beiträge: 37
Registriert: 23 Mai 2018, 16:44

Re: Fragen/Probleme rund um windows10-upgrade Paket

Beitragvon g.burck » 24 Jul 2019, 10:54

tobias hat geschrieben:Moin,
Die Einstellung findet man hier (man braucht das ADMX Template für Windows 10 1809 auf seinen DCs damit man die Einstellung hat):
-> Computer Configuration\Administrative Templates\Windows Components\OOBE

Da es via GPO zu gehen scheint, gibt es sicher auch Registry Keys um das gleiche zu erreichen.


Ich schaue mir das mal an, wäre ein Workaround. Allerdings haben wir im Netz noch viele 1803er. Ob da die GPO zieht,...