Silent Installation

Kay96
Beiträge: 50
Registriert: 06 Dez 2018, 09:23

Silent Installation

Beitragvon Kay96 » 26 Feb 2019, 08:17

Guten Morgen,

wir haben eine "neue" Software erhalten, die leider keine SIlent Installation bietet. Nun hatte ich noch im Hinterkopf, dass man einfach eine .iss generieren kann und es mit dieser probieren kann. Nun scheitert es schon daran, die .iss zu generieren. Ich bin ganz normal über cmd in das Installationsverzeichnis gewechselt und habe dort "setup.exe /r" ausgeführt. Nun öffnen sich die Dialoge vom Installer (Installshield Wizard) und ich führe die angepasste Installation durch.
Nach der Installation gibt es keine *.iss im Windows oder System32 Ordner.
Ich habe nun etwas im Internet recheriert und alle möglichen Schreibweisen probiert, aber leider immer mit dem selben Ergebnis. Es wird keine Antwortdatei generiert. Auch über "setup.exe -f1″C:\tmp\setup.iss“ wird keine Antwortdatei im "tmp" Ordner generiert.

Ich habe auch über den Opsi Package Builder probiert, eine Silent Installation zu erstellen, aber hier wird immer direkt "unknown Setup Type" gemeldet.

kennt jemand diese Problematik? Habt ihr ein kleines Hilfstool? Oder habt ihr es anders lösen können?

Ich würde mich über jegliche Hilfe sehr freuen!

thomas.besser
Beiträge: 322
Registriert: 09 Sep 2009, 09:40

Re: Silent Installation

Beitragvon thomas.besser » 26 Feb 2019, 09:51

Wenn man nach "silent iss file" sucht, dann findet man sehr schnell heraus, dass das eine Technik des "InstallShield" Installers ist (siehe auch das 'opsi-template' Paket von UIB).

Wenn der "opsi-setup-detector" einen "unknown setup type" erkennt, dann dürfte der Installer kein "installShield" sein. Leider meinen manche Softwarehersteller den Installer auch selber programmieren zu müssen und nicht einen der gängigen, z.T. als OSS verfügbaren Tools zu verwenden.

Gruß
Thomas

fredfanatics
Beiträge: 36
Registriert: 10 Nov 2016, 09:33

Re: Silent Installation

Beitragvon fredfanatics » 26 Feb 2019, 10:12

Ich würde damit ganz stumpf den Support des Softwareherstellers belästigen! Wer in der heutigen Zeit keine silent-Option im Installer hat, muss schlichtweg solange genervt werden, bis er das einbaut. Ein Admin hat i.d.R. keine Zeit jede Maschine von Hand aufzusetzen.

Ansonsten kann man manchmal die Installation manuell anschubsen und unter C:\Users\<Benutzername>\AppData\Local\Temp die aus dem Installer entpackten Dateien finden. Dort liegt manchmal ein msi-File, mit dem man ggf. weiterarbeiten kann....

In letzter Konsequenz geht dann vielleicht auch nur AutoIt...

Kay96
Beiträge: 50
Registriert: 06 Dez 2018, 09:23

Re: Silent Installation

Beitragvon Kay96 » 26 Feb 2019, 11:11

@thomas.besser das verwunderliche hierbei ist nur, dass durchgängig im Titel während der Installation "xy - Installshield Wizard" steht. Wahrscheinlich sollte man die Gründe nicht weiter hinterfragen :D

@fredfanatics den Hersteller habe ich schon etwas genervt, aber bisher steht es wohl nicht bei denen auf der Agenda. Da wir die Software aber zwingend benötigen und ich auch zukünftig nicht darauf vertraue, dass sich etwas tut, wollte ich mir selber eine Lösung herleiten.
Der Tipp mit dem AppData Ordner ist wirklich gut, ich versuche mich dort mal zu bedienen (falls es etwas gibt).

thomas.besser
Beiträge: 322
Registriert: 09 Sep 2009, 09:40

Re: Silent Installation

Beitragvon thomas.besser » 26 Feb 2019, 11:35

Kay96 hat geschrieben:@thomas.besser das verwunderliche hierbei ist nur, dass durchgängig im Titel während der Installation "xy - Installshield Wizard" steht. Wahrscheinlich sollte man die Gründe nicht weiter hinterfragen :D


Ups, das habe ich überlesen :roll:

Hast du nur den 'opsi-package-builder' verwendet oder auch mal mit dem 'opsi-setup-detector' probiert?

Und von welcher "Software" sprichst du konkret? Es könnte ja durchaus sein, dass hier im Forum das Problem ja schon jemand gelöst hat. Aber solange du die Katze nicht aus dem Sack lässt ... :D

Kay96
Beiträge: 50
Registriert: 06 Dez 2018, 09:23

Re: Silent Installation

Beitragvon Kay96 » 26 Feb 2019, 13:18

@thomas.besser oh sorry, ich meinte den "opsi-setup-detector"...
Die Software ist kein Geheimnis, aber ich gehe mal davon aus, dass sie keiner kennt.
Es ist die Installation vom Apogee PrePress Client.

Ich bin jetzt dabei es über Autoit zu lösen, aber das Skript möchte mich etwas ärgern. Ohne Sperre von Tastatur und Maus funktioniert bereits alles, mit Blockinput bleibt er nach einer automatische Eingabe hängen (mitten in der Installation).

uncle_scrooge
Beiträge: 596
Registriert: 21 Feb 2012, 12:03
Wohnort: Mainz

Re: Silent Installation

Beitragvon uncle_scrooge » 26 Feb 2019, 13:51

Welche Version?

Ich habe mir gerade mal Agfa-Apogee-Prepress-Client-Win-1.50.19.zip heruntergefischt. Angeblich die aktuellste. (Aus 2012/2013?)
Wenn Du das ZIP auspackst, hast Du unter x64 einen Ordner redist. Das Zeugs daraus vorher installieren, so noch nicht vorhanden. Sind Klassiker: VC runtime, .NET4.
Und im Verzeichnis x64 gibt es ein MSI Apogee Prepress Clients (x64).msi. Das kannst Du ganz klassisch silent installieren.

Ich habe das mal eben durchexerziert. Der Client startet zumindest. Ob die Verbindung zum Backend funktioniert - keine Ahnung. Ob mehr als Anmeldung geht - keine Ahnung.

Kay96
Beiträge: 50
Registriert: 06 Dez 2018, 09:23

Re: Silent Installation

Beitragvon Kay96 » 26 Feb 2019, 14:40

@uncle_scrooge ich möchte jetzt gerade gerne im Erdboden versinken... Es funktioniert händisch nicht mit der .msi, aber über msiexec geht es.
Ich habe mich irgendwie so darauf verlassen, was der zuständige Mitarbeiter gesagt hat, dass ich garnicht mehr in den Installationsordnern nach einer .msi geguckt habe. Er hat mir direkt gesagt, dass es keine silent Installation gibt und diese auch nicht geplant ist.
Du hast mir wirklich sehr geholfen!

Leider wird bei der Silent Installation der QMS_Client mit installiert, weil natürlich eine vollständige Installation gemacht wird. Jetzt guck ich mich nochmal um, dass ich eine .ini mitgebe o.ä. und dann hab ich es hoffentlich geschafft.

syntaggs
Beiträge: 6
Registriert: 07 Jan 2019, 15:32

Re: Silent Installation

Beitragvon syntaggs » 14 Mär 2019, 14:12

nicht jede installshield unterstützt /r /f1 - manchmal gehen nur vom Anbieter der Software vorgegebene Flags - hatte gestern erst ein ähnliches Beispiel - für Unterprogramme deren Installation ich über eine setup.iss an- oder abwählen wollte gab es einzelne Flags - eine *.iss hat dieser Installer nicht akzeptiert.