[gelöst] VMware linux-bootimage Bootprobleme

benjaminr
Beiträge: 7
Registriert: 08 Feb 2019, 17:02

[gelöst] VMware linux-bootimage Bootprobleme

Beitragvon benjaminr » 12 Feb 2019, 10:50

Hallo zusammen,

mit einer virtuellen Maschine mit virtueller Hardware Version 14 (eingeführt mit vSphere 6.7) oder neuer bootet leider der im linux-bootimage-20181213 integrierte Kernel 4.19.7 nicht.
Ich komme nur bis dahin:
Bild

Wenn ich die virtuelle Hardwareversion auf 13 oder kleiner stelle, funktioniert alles wie es soll.

Zum Testen habe ich mal nur den aktuellen Ubuntu Mainline LTS Kernel Build genommen (https://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19.20/linux-image-unsigned-4.19.20-041920-generic_4.19.20-041920.201902061341_amd64.deb) und das Kernelimage in das tftpboot Verzeichnis gelegt sowie den install-x64 Symlink angepasst. Damit bootet die Maschine grundsätzlich wieder auch mit virtueller Hardware Version 14 und 15. Da das Rootfs nicht angepasst ist, funktioniert aber der restliche Installationsablauf natürlich nicht.

Hat zufällig jemand eine Idee, mit welche Bootoptionen ich den 4.19.7er Kernel zum Booten überreden kann? Macht es Sinn auf das nächste experimental linux-bootimage mit neuerem Kernel zu warten oder ist Eigeninitiative sinnvoller? VMs mit alter Hardwareversion anzulegen würde ich trotz Testumgebung gerne vermeiden.

Viele Grüße
Benjamin
Zuletzt geändert von benjaminr am 15 Feb 2019, 12:56, insgesamt 1-mal geändert.

benjaminr
Beiträge: 7
Registriert: 08 Feb 2019, 17:02

Re: VMware linux-bootimage Bootprobleme

Beitragvon benjaminr » 14 Feb 2019, 16:26

Hallo zusammen,

nach Prüfung habe ich die Variante Eigeninitiative verworfen. Leider habe ich nirgendwo eine Kernelbuildkonfig sowie eine Info über den verwendeten Sourcetree inkl. ggf. vorhandener Patches gefunden. Ein Kernelupdate kommt damit einer Neuentwicklung nahe, weil diese Informationen alle neu erarbeitet werden müssten.

Wenn sich keine Lösung mit Kerneloptions in Verbindung mit der bestehenden Kernelversion mehr findet, wird es wohl leider auf ein Downgrade zur virtuellen Hardwareversion 13 herauslaufen. Schade.

Viele Grüße
Benjamin

Benutzeravatar
tobias
Beiträge: 1190
Registriert: 20 Aug 2008, 12:36
Wohnort: Braunschweig
Kontaktdaten:

Re: VMware linux-bootimage Bootprobleme

Beitragvon tobias » 14 Feb 2019, 17:55

Moin,

kann ich nicht nachvollziehen, ich bin schon den ganzen Tag dabei wild Netboot Produkte auf einer v14 VM zu booten.

Allerdings hatte ich gestern das Problem auch direkt nach dem anlegen einer VM. Dabei hatte ich versehentlich die Option "Auf Virtualisierung basierende Sicherheit" aktiviert. Danach ging erstmal gar nix weil dadurch Secure Boot aktiviert wird.
Das nachträgliche deaktivieren dieser Option führte dann zu exakt deinen Symptomen.
Ich musste die VM löschen und neu anlegen, dann ging es wieder.

Das mag aber auch Zufall gewesen sein ;)
Veröffentliche deine WINST Scripte im OPSI Wiki und leiste so einen wertvollen Beitrag für die Community !!!
https://forum.opsi.org/wiki/

Benutzeravatar
m.radtke
Beiträge: 655
Registriert: 10 Jun 2015, 12:19

Re: VMware linux-bootimage Bootprobleme

Beitragvon m.radtke » 15 Feb 2019, 09:38

Hi

du könntest das aktuelle experimental Bootimage von gestern bzw heute probieren. Das hat einen Kernel 4.20.8, vielleicht hilft das ja

Wir verwenden einen vanilla Kernel, mir je einem Patch für HyperV und Micrsoft Surface Docking Stations Gen3.

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

benjaminr
Beiträge: 7
Registriert: 08 Feb 2019, 17:02

Re: VMware linux-bootimage Bootprobleme

Beitragvon benjaminr » 15 Feb 2019, 12:55

Hallo zusammen,

der Tipp von Tobias hat den entscheidenden Hinweis gebracht. Vielen Dank dafür.
VBS und Secure Boot sind natürlich in der alten VM deaktiviert. In einer neu angelegten VM mit Virtual Hardware V14 funktioniert es bei mir auch sofort, wenn VBS und SecureBoot von Anfang an deaktiviert sind.

Ich habe die beiden VMX Dateien verglichen und heraus bekommen, dass es an der Option "Virtualize IOMMU (IO Memory Management Unit)" in den CPU settings hängt. Die Option wird mit der Aktivierung von VBS automatisch eingeschaltet. Deaktivierung von VBS verändert die IOMMU Einstellung nicht.

Offensichtlich hat Kernel 4.19.7 mit IOMMU ein Problem. Die Kerneloptions iommu=off und intel_iommu=off habe ich kurz getestet. Damit funktioniert es nicht. Das spielt allerdings für mich keine Rolle, weil ich die Funktion nicht benötige. VBS und SecureBoot wird derzeit ja noch nicht unterstützt.

Ich vermute, dass es mit dem neuen experimental Image auch funktioniert. Das habe ich allerdings nicht getestet.

Lösung:
Wer Virtualisation Based Security (VBS) in einer VMware VM mit Virtual Hardware V14+ einmalig aktiviert hat, muss nach dem Deaktivieren auch den Haken bei "Virtualize IOMMU (IO Memory Management Unit)" entfernen, damit das linux-bootimage_20181213-1 funktioniert.
In der VMX Datei heißt die Option: vvtd.enable = "FALSE"

Viele Grüße
Benjamin