Kein TFTP-Service nach Update 4.1

djdodo
Beiträge: 144
Registriert: 12 Jan 2011, 10:54

Kein TFTP-Service nach Update 4.1

Beitragvon djdodo » 22 Jan 2019, 14:25

Hallo!
Zunächst einmal habe ich nach Handbuch auf 4.1 aktualisiert.
Im Handbuch fanden sich allerding ein paar Fehler, z.B. das Starten der Dienste ging nicht über systemctl, sondern über "service".
Vermutlich liegt hier auch mein nächstes Promlem.
Der neue opsi-tftpd-hpa ist zwar als Paket installiert, nicht aber als Dienst.
Mit keinem Befehl bekomme ich den gestartet.
Die Datei /lib/systemd/system/opsi-tftpd-hpa.service existiert und sieht so aus:

Code: Alles auswählen

[Unit]
Description=Opsi TFTPD HPA Configuration Service
After=network.target

[Service]
Type=forking
ExecStart=/usr/sbin/in.tftpd -v --ipv4 --listen --address :69 --secure /tftpboot/
Restart=on-failure
RestartSec=5
KillMode=process
TimeoutStopSec=10

[Install]
WantedBy=multi-user.target


Was muss ich jetzt tun, damit der Service auch aktiv ist und beim nächsten Systemstart automatisch startet?


Lg
Dodo

uncle_scrooge
Beiträge: 577
Registriert: 21 Feb 2012, 12:03
Wohnort: Mainz

Re: Kein TFTP-Service nach Update 4.1

Beitragvon uncle_scrooge » 22 Jan 2019, 16:15

Welches Linux?

djdodo
Beiträge: 144
Registriert: 12 Jan 2011, 10:54

Re: Kein TFTP-Service nach Update 4.1

Beitragvon djdodo » 23 Jan 2019, 12:53

Hat sich erledigt.
Die .service-Datei musste noch nach /etc/systemd/system kopiert werden.
Dann konnte ich mit systemctl starten und aktivieren.
Jetzt tuts.

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3148
Registriert: 04 Apr 2013, 12:15

Re: Kein TFTP-Service nach Update 4.1

Beitragvon n.wenselowski » 23 Jan 2019, 14:44

Hi,

djdodo hat geschrieben:Hat sich erledigt.
Die .service-Datei musste noch nach /etc/systemd/system kopiert werden.
Dann konnte ich mit systemctl starten und aktivieren.
Jetzt tuts.

Das sollte niemals notwendig sein!

Welcher Befehl wird ausgeführt und was wird dabei zurück gemeldet?
Welches OS ist auf dem Server?


Gruß

Niko
opsi development - uib gmbh
For productive opsi installations we recommend support contracts.

djdodo
Beiträge: 144
Registriert: 12 Jan 2011, 10:54

Re: Kein TFTP-Service nach Update 4.1

Beitragvon djdodo » 23 Jan 2019, 15:28

Es ist ein Ubuntu 14.04 Trusty

uncle_scrooge
Beiträge: 577
Registriert: 21 Feb 2012, 12:03
Wohnort: Mainz

Re: Kein TFTP-Service nach Update 4.1

Beitragvon uncle_scrooge » 23 Jan 2019, 15:52

Hatte schon einen Grund, warum ich nach der Linux-Variante gefragt hatte....
https://download.uib.de/opsi_stable/doc ... atrix.html
Out of support.

djdodo
Beiträge: 144
Registriert: 12 Jan 2011, 10:54

Re: Kein TFTP-Service nach Update 4.1

Beitragvon djdodo » 29 Jan 2019, 08:42

Out of support lass ich nicht gelten.
1. Es ist Linux, dass läuft ewig
2. Das letzte Mal, als ich auf dem Opsi-Server ein Release-Upgrade von Ubuntu gemacht habe, ging gar nichts mehr
3. Einen Neuen Config-Server aufsetzen durch sämtliche angepasste Config dauert Wochen.

Wenn es natürlich garantiert wird, dass 14.04 auf 18.04 problemlos geht, dann kann ich es mal versuchen.
Lg
Dodo

uncle_scrooge
Beiträge: 577
Registriert: 21 Feb 2012, 12:03
Wohnort: Mainz

Re: Kein TFTP-Service nach Update 4.1

Beitragvon uncle_scrooge » 29 Jan 2019, 10:24

>>Out of support lass ich nicht gelten.
Das diskutiere bitte mit uib.

SirTux
Beiträge: 276
Registriert: 05 Feb 2011, 18:37

Re: Kein TFTP-Service nach Update 4.1

Beitragvon SirTux » 29 Jan 2019, 11:16

djdodo hat geschrieben:Out of support lass ich nicht gelten.
1. Es ist Linux, dass läuft ewig
2. Das letzte Mal, als ich auf dem Opsi-Server ein Release-Upgrade von Ubuntu gemacht habe, ging gar nichts mehr
3. Einen Neuen Config-Server aufsetzen durch sämtliche angepasste Config dauert Wochen.

Wenn es natürlich garantiert wird, dass 14.04 auf 18.04 problemlos geht, dann kann ich es mal versuchen.


Es kann keiner garantieren, daß ein Dist-Upgrade problemlos funktioniert. Jedenfalls scheint es mir sinnvoller dies einmal zu probieren statt weiterhin ein unsupportetes Setup zu fahren. Ein Backup sollte man natürlich vorher anlegen sofern nicht vorhanden.

Falls es beruhigt: Ich habe schon einmal reibungslos einen opsi-Server von 12.04 auf 16.04 hochgezogen. Wenn dieser noch in meinem Verantwortungsbereich wäre, hätte ich ihn vermutlich ebenso problemlos auf 18.04 hochgezogen.

djdodo
Beiträge: 144
Registriert: 12 Jan 2011, 10:54

Re: Kein TFTP-Service nach Update 4.1

Beitragvon djdodo » 29 Jan 2019, 11:34

@SirTux
Dein Wort in Root's Ohr.
Wenn ich mal nix zu tun hab, versuch ichs. (Also gefühlt nie)

Trotzdem Danke.