Failed to mount depot share Code 53 beim Client-Reboot

Valentino-46
Beiträge: 195
Registriert: 05 Aug 2011, 14:24

Failed to mount depot share Code 53 beim Client-Reboot

Beitragvon Valentino-46 » 10 Sep 2018, 14:42

Hallo Opsi-Gemeinde,

ich habe vor einigen Wochen auf OPSI 4.1 geupgraded. Stand heute sollten sämtliche Pakete Up-To-Date sein.
Leider ist mir direkt nach dem Upgrade aufgefallen, dass Testclients nach dem Reboot manchmal keine Pakete installieren.
Irgendwann hat es dann wieder etwas besser funktioniert, heute finde ich aber heraus, dass ganz viele Clients aktuell keine OPSI Pakete mehr beziehen. Der Opsi-Client-Agent startet, er erkennt, dass etwas zu tun ist und bricht mit Fehler ab.

Was noch funktioniert ist "on_demand" aber eben nach dem Reboot des Rechners klappt es nicht mehr häufig.
In der clientconnect Log kommt folgender Fehler (Aktuell bei jedem Reboot):

Code: Alles auswählen

Failed to Mount '\\192.168.26.86\opsi_depot': (53, 'WNetAddConnection2', 'Der Netzwerkpfad wurde nicht gefunden.')   (Windows.pyo|788)

Ich habe nun einiges in den Handbüchern gelesen. Beim Upgrade auf Version 4.1 wurden manche Parameter oder Shares als deprecated markiert, wodurch ich dann die genannten veralteten Konfigurationen auf den heutigen Stand von OPSI angehoben habe. Auch in der smb.conf gab es manche Share-Anpassungen. Nichts gravierendes aber. Aber genau danach fingen die Probleme an.

Ich habe nun auch schon die mDNS Thematik erschlagen, indem ich einfach direkt die IP-Adresse eintrage (Depot-Konfiguration).
Leider keinen Erfolg. Das Ubuntu Linux ist auch Up-To-Date, zumindest auf Xenial 16.04 LTS.

Er erkennt aber definitiv am Anfang sauber eine Netzwerkverbindung, fragt Pakete an und merkt, dass etwas installiert werden soll. Daraufhin möchte der Client-Agent dann das Depot Share verbinden und fällt dann auf die Nase.

Hier mal etwas Code:

Code: Alles auswählen

(666)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Dynamic depot selection enabled   (Config.pyo|445)
(667)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Master depot for products [u'rebootwanted_prio-97', u'rebootwanted_prio94', u'shutdownwanted'] is opsi-wgt.kk.local   (Config.pyo|473)
(668)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Got alternative depots for products: [u'rebootwanted_prio-97', u'rebootwanted_prio94', u'shutdownwanted']   (Config.pyo|477)
(669)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] 1. alternative depot is opsi-br.kk.local   (Config.pyo|479)
(670)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] 2. alternative depot is opsi-dd.kk.local   (Config.pyo|479)
(671)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] 3. alternative depot is opsi-gv.kk.local   (Config.pyo|479)
(672)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] 4. alternative depot is opsi-sifi.kk.local   (Config.pyo|479)
(673)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Found network interface: <OPSI.System.Windows.IP_ADAPTER_INFO object at 0x03215D00>   (Config.pyo|488)
(674)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Found network interface: <OPSI.System.Windows.IP_ADAPTER_INFO object at 0x032158A0>   (Config.pyo|488)
(675)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Found network interface: <OPSI.System.Windows.IP_ADAPTER_INFO object at 0x03215D00>   (Config.pyo|488)
(676)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Found network interface: <OPSI.System.Windows.IP_ADAPTER_INFO object at 0x032158A0>   (Config.pyo|488)
(677)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Found network interface: <OPSI.System.Windows.IP_ADAPTER_INFO object at 0x03215D00>   (Config.pyo|488)
(678)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Found network interface: <OPSI.System.Windows.IP_ADAPTER_INFO object at 0x032158A0>   (Config.pyo|488)
(679)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Found network interface: <OPSI.System.Windows.IP_ADAPTER_INFO object at 0x03215D00>   (Config.pyo|488)
(680)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Found network interface: <OPSI.System.Windows.IP_ADAPTER_INFO object at 0x032158A0>   (Config.pyo|488)
(681)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Found network interface: <OPSI.System.Windows.IP_ADAPTER_INFO object at 0x03215D00>   (Config.pyo|488)
(682)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Found network interface: <OPSI.System.Windows.IP_ADAPTER_INFO object at 0x032158A0>   (Config.pyo|488)
(683)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Choosing depot from list of depots:   (<string>|4)
(684)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}]    Master depot: <OpsiConfigserver(id=u'opsi-wgt.kk.local', isMasterDepot=True)>   (<string>|5)
(685)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}]    Alternative depot: <OpsiDepotserver(id=u'opsi-br.kk.local', isMasterDepot=True, masterDepotId=u'opsi-br.kk.local')>   (<string>|7)
(686)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}]    Alternative depot: <OpsiDepotserver(id=u'opsi-dd.kk.local', isMasterDepot=True, masterDepotId=u'opsi-dd.kk.local')>   (<string>|7)
(687)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}]    Alternative depot: <OpsiDepotserver(id=u'opsi-gv.kk.local', isMasterDepot=True, masterDepotId=u'opsi-gv.kk.local')>   (<string>|7)
(688)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}]    Alternative depot: <OpsiDepotserver(id=u'opsi-sifi.kk.local', isMasterDepot=True, masterDepotId=u'opsi-sifi.kk.local')>   (<string>|7)
(689)     [5] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Choosing depot with networkAddress 192.168.20.0/255.255.255.0 for ip 192.168.20.164   (<string>|24)
(690)     [5] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Selected depot is: <OpsiConfigserver(id=u'opsi-wgt.kk.local', isMasterDepot=True)>   (Config.pyo|517)
(691)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Setting config value depot_server.depot_id   (Config.pyo|204)
(692)     [6] [Sep 10 14:27:19] [ event processing gui_startup{installation_pending}] Setting config value depot_server.url   (Config.pyo|204)
(693)     [6] [Sep 10 14:27:19] [ opsiclientd                   ] Searching pids of process name winlogon.exe (session id: 1)   (Windows.pyo|1447)
(694)     [6] [Sep 10 14:27:19] [ opsiclientd                   ] Found process winlogon.exe with matching name (pid 724, session 1)   (Windows.pyo|1470)
(695)     [5] [Sep 10 14:27:19] [ opsiclientd                   ] Executing: 'C:\Program Files (x86)\opsi.org\opsi-client-agent\\opsiclientd_rpc.exe "pc1608-00855.kk.local" "*** confidential ***" "4441" "setCurrentActiveDesktopName("1", System.getActiveDesktopName())"' in session '1' on desktop 'winsta0\winlogon'   (Windows.pyo|1634)
(696)     [6] [Sep 10 14:27:20] [ opsiclientd                   ] Process startet, pid: 5104   (Windows.pyo|1637)
(697)     [6] [Sep 10 14:27:20] [ opsiclientd                   ] Waiting for process ending: 5104 (timeout: 60 seconds)   (Windows.pyo|1640)
(698)     [6] [Sep 10 14:27:20] [ control server                ] Worker <ocdlib.ControlServer.WorkerOpsiclientdJsonRpc instance at 0x030BAAD0> started processing   (Worker.pyo|251)
(699)     [5] [Sep 10 14:27:20] [ control server                ] New session created   (Session.pyo|184)
(700)     [5] [Sep 10 14:27:20] [ control server                ] Authorization request from pc1608-00855.kk.local@127.0.0.1 (application: opsi jsonrpc module version 4.0.7.28)   (ControlServer.pyo|162)
(701)     [5] [Sep 10 14:27:20] [ opsiclientd                   ] -----> Executing: backend_getInterface()   (JsonRpc.pyo|134)
(702)     [6] [Sep 10 14:27:20] [ opsiclientd                   ] Got result   (JsonRpc.pyo|142)
(703)     [6] [Sep 10 14:27:20] [ control server                ] Worker <ocdlib.ControlServer.WorkerOpsiclientdJsonRpc instance at 0x03284E68> started processing   (Worker.pyo|251)
(704)     [6] [Sep 10 14:27:20] [ control server                ] Reusing session for client '127.0.0.1', application 'opsi jsonrpc module version 4.0.7.28'   (Worker.pyo|397)
(705)     [5] [Sep 10 14:27:20] [ control server                ] Authorization request from pc1608-00855.kk.local@127.0.0.1 (application: opsi jsonrpc module version 4.0.7.28)   (ControlServer.pyo|162)
(706)     [5] [Sep 10 14:27:20] [ opsiclientd                   ] -----> Executing: setCurrentActiveDesktopName(1, u'Winlogon')   (JsonRpc.pyo|134)
(707)     [5] [Sep 10 14:27:20] [ opsiclientd                   ] rpc setCurrentActiveDesktopName: current active desktop name for session 1 set to 'Winlogon'   (ControlServer.pyo|565)
(708)     [6] [Sep 10 14:27:20] [ opsiclientd                   ] Got result   (JsonRpc.pyo|142)
(709)     [6] [Sep 10 14:27:20] [ control server                ] Worker <ocdlib.ControlServer.WorkerOpsiclientdJsonRpc instance at 0x03262F30> started processing   (Worker.pyo|251)
(710)     [6] [Sep 10 14:27:20] [ control server                ] Reusing session for client '127.0.0.1', application 'opsi jsonrpc module version 4.0.7.28'   (Worker.pyo|397)
(711)     [5] [Sep 10 14:27:20] [ control server                ] Authorization request from pc1608-00855.kk.local@127.0.0.1 (application: opsi jsonrpc module version 4.0.7.28)   (ControlServer.pyo|162)
(712)     [5] [Sep 10 14:27:20] [ opsiclientd                   ] -----> Executing: backend_exit()   (JsonRpc.pyo|134)
(713)     [6] [Sep 10 14:27:20] [ opsiclientd                   ] Got result   (JsonRpc.pyo|142)
(714)     [5] [Sep 10 14:27:20] [ opsiclientd                   ] Process 5104 ended with exit code 0   (Windows.pyo|1650)
(715)     [5] [Sep 10 14:27:20] [ event processing gui_startup{installation_pending}] Updating action processor   (EventProcessing.pyo|398)
(716)     [5] [Sep 10 14:27:20] [ event processing gui_startup{installation_pending}] Mounting depot share smb://192.168.26.86/opsi_depot   (EventProcessing.pyo|366)
(717)     [6] [Sep 10 14:27:20] [ event processing gui_startup{installation_pending}] Added depot '192.168.26.86' to trusted domains   (EventProcessing.pyo|375)
(718)     [5] [Sep 10 14:27:20] [ event processing gui_startup{installation_pending}] Mounting '\\192.168.26.86\opsi_depot' to 'p:'   (Windows.pyo|775)
(719)     [3] [Sep 10 14:27:23] [ event processing gui_startup{installation_pending}] Failed to mount '\\192.168.26.86\opsi_depot': (53, 'WNetAddConnection2', 'Der Netzwerkpfad wurde nicht gefunden.')   (Windows.pyo|788)
(720)     [3] [Sep 10 14:27:23] [ event processing gui_startup{installation_pending}] Failed to update action processor: Failed to mount '\\192.168.26.86\opsi_depot': (53, 'WNetAddConnection2', 'Der Netzwerkpfad wurde nicht gefunden.')   (EventProcessing.pyo|531)
(721)     [5] [Sep 10 14:27:23] [ event processing gui_startup{installation_pending}] Starting action processor in session '1' on desktop 'winlogon'   (EventProcessing.pyo|819)
(722)     [6] [Sep 10 14:27:23] [ event processing gui_startup{installation_pending}] Running command "C:\Program Files (x86)\opsi.org\opsi-client-agent\action_processor_starter.exe" "pc1608-00855.kk.local" "*** confidential ***" "4441" "c:\\opsi.org\\log\\opsiclientd.log" "6" "smb://192.168.26.86/opsi_depot" "p:" "pcpatch" "*** confidential ***" "1" "winlogon" "\"C:\Program Files (x86)\opsi.org\opsi-client-agent\\opsi-winst\\winst32.exe\" /opsiservice \"https://192.168.26.86:4447/rpc\" /clientid pc1608-00855.kk.local /username pc1608-00855.kk.local /password *** confidential *** " 10800 "" "" false in session '1' on desktop 'winlogon'   (EventProcessing.pyo|298)
(723)     [6] [Sep 10 14:27:23] [ event processing gui_startup{installation_pending}] Searching pids of process name winlogon.exe (session id: 1)   (Windows.pyo|1447)
(724)     [6] [Sep 10 14:27:23] [ event processing gui_startup{installation_pending}] Found process winlogon.exe with matching name (pid 724, session 1)   (Windows.pyo|1470)
(725)     [5] [Sep 10 14:27:23] [ event processing gui_startup{installation_pending}] Executing: '"C:\Program Files (x86)\opsi.org\opsi-client-agent\action_processor_starter.exe" "pc1608-00855.kk.local" "*** confidential ***" "4441" "c:\\opsi.org\\log\\opsiclientd.log" "6" "smb://192.168.26.86/opsi_depot" "p:" "pcpatch" "*** confidential ***" "1" "winlogon" "\"C:\Program Files (x86)\opsi.org\opsi-client-agent\\opsi-winst\\winst32.exe\" /opsiservice \"https://192.168.26.86:4447/rpc\" /clientid pc1608-00855.kk.local /username pc1608-00855.kk.local /password *** confidential *** " 10800 "" "" false' in session '1' on desktop 'winsta0\winlogon'   (Windows.pyo|1634)
(726)     [6] [Sep 10 14:27:24] [ event processing gui_startup{installation_pending}] Process startet, pid: 4740   (Windows.pyo|1637)
(727)     [6] [Sep 10 14:27:24] [ event processing gui_startup{installation_pending}] Waiting for process ending: 4740 (timeout: 0 seconds)   (Windows.pyo|1640)
(728)     [3] [Sep 10 14:27:24] [ action_processor_starter.exe  ] Failed to read version info from file u'/etc/opsi/version': [Errno 2] No such file or directory: u'/etc/opsi/version'   (Backend.pyo|206)
(729)     [6] [Sep 10 14:27:24] [ control server                ] Worker <ocdlib.ControlServer.WorkerOpsiclientdJsonRpc instance at 0x03262DA0> started processing   (Worker.pyo|251)
(730)     [5] [Sep 10 14:27:24] [ control server                ] New session created   (Session.pyo|184)
(731)     [5] [Sep 10 14:27:24] [ control server                ] Authorization request from pc1608-00855.kk.local@127.0.0.1 (application: opsi jsonrpc module version 4.0.7.28)   (ControlServer.pyo|162)
(732)     [5] [Sep 10 14:27:24] [ opsiclientd                   ] -----> Executing: backend_getInterface()   (JsonRpc.pyo|134)
(733)     [6] [Sep 10 14:27:24] [ opsiclientd                   ] Got result   (JsonRpc.pyo|142)
(734)     [6] [Sep 10 14:27:24] [ action_processor_starter.exe  ] <JSONRPCBackend(host=u'localhost', deflate=False)>: Connected to service   (JSONRPC.pyo|497)
(735)     [6] [Sep 10 14:27:24] [ action_processor_starter.exe  ] Impersonating network account 'pcpatch'   (action_processor_starter.py|98)
(736)     [5] [Sep 10 14:27:24] [ action_processor_starter.exe  ] Mounting depot share smb://192.168.26.86/opsi_depot   (action_processor_starter.py|103)
(737)     [6] [Sep 10 14:27:24] [ control server                ] Worker <ocdlib.ControlServer.WorkerOpsiclientdJsonRpc instance at 0x0328C670> started processing   (Worker.pyo|251)
(738)     [6] [Sep 10 14:27:24] [ control server                ] Reusing session for client '127.0.0.1', application 'opsi jsonrpc module version 4.0.7.28'   (Worker.pyo|397)
(739)     [5] [Sep 10 14:27:24] [ control server                ] Authorization request from pc1608-00855.kk.local@127.0.0.1 (application: opsi jsonrpc module version 4.0.7.28)   (ControlServer.pyo|162)
(740)     [5] [Sep 10 14:27:24] [ opsiclientd                   ] -----> Executing: setStatusMessage(u'1', u'Verbinde mit Depot-Freigabe smb://192.168.26.86/opsi_depot')   (JsonRpc.pyo|134)
(741)     [5] [Sep 10 14:27:24] [ opsiclientd                   ] DEBUG: [<EventProcessingThread(Thread-18, started daemon 3480)>]    (Opsiclientd.pyo|431)
(742)     [5] [Sep 10 14:27:24] [ opsiclientd                   ] DEBUG: 1    (Opsiclientd.pyo|433)
(743)     [5] [Sep 10 14:27:24] [ opsiclientd                   ] rpc setStatusMessage: Setting status message to 'Verbinde mit Depot-Freigabe smb://192.168.26.86/opsi_depot'   (ControlServer.pyo|541)
(744)     [6] [Sep 10 14:27:24] [ opsiclientd                   ] Got result   (JsonRpc.pyo|142)
(745)     [5] [Sep 10 14:27:24] [ action_processor_starter.exe  ] Mounting '\\192.168.26.86\opsi_depot' to 'p:'   (Windows.pyo|775)
(746)     [3] [Sep 10 14:27:24] [ action_processor_starter.exe  ] Failed to mount '\\192.168.26.86\opsi_depot': (53, 'WNetAddConnection2', 'Der Netzwerkpfad wurde nicht gefunden.')   (Windows.pyo|788)
(747)     [2] [Sep 10 14:27:24] [ action_processor_starter.exe  ] Traceback:   (Logger.pyo|757)
(748)     [2] [Sep 10 14:27:24] [ action_processor_starter.exe  ]   File "action_processor_starter.py", line 109, in <module>
(749)        (Logger.pyo|757)
(750)     [2] [Sep 10 14:27:24] [ action_processor_starter.exe  ]   File "OPSI\System\Windows.pyo", line 789, in mount
(751)        (Logger.pyo|757)
(752)     [2] [Sep 10 14:27:24] [ action_processor_starter.exe  ]      ==>>> Failed to mount '\\192.168.26.86\opsi_depot': (53, 'WNetAddConnection2', 'Der Netzwerkpfad wurde nicht gefunden.')   (action_processor_starter.py|121)
(753)     [6] [Sep 10 14:27:24] [ control server                ] Worker <ocdlib.ControlServer.WorkerOpsiclientdJsonRpc instance at 0x0326EE18> started processing   (Worker.pyo|251)
(754)     [6] [Sep 10 14:27:24] [ control server                ] Reusing session for client '127.0.0.1', application 'opsi jsonrpc module version 4.0.7.28'   (Worker.pyo|397)
(755)     [5] [Sep 10 14:27:24] [ control server                ] Authorization request from pc1608-00855.kk.local@127.0.0.1 (application: opsi jsonrpc module version 4.0.7.28)   (ControlServer.pyo|162)
(756)     [5] [Sep 10 14:27:24] [ opsiclientd                   ] -----> Executing: setStatusMessage(u'1', u"Failed to process action requests: Failed to mount '\\\\192.168.26.86\\opsi_depot': (53, 'WNetAddConnection2', 'Der Netzwerkpfad wurde nicht gefunden.')")   (JsonRpc.pyo|134)
(757)     [5] [Sep 10 14:27:24] [ opsiclientd                   ] DEBUG: [<EventProcessingThread(Thread-18, started daemon 3480)>]    (Opsiclientd.pyo|431)
(758)     [5] [Sep 10 14:27:24] [ opsiclientd                   ] DEBUG: 1    (Opsiclientd.pyo|433)
(759)     [5] [Sep 10 14:27:24] [ opsiclientd                   ] rpc setStatusMessage: Setting status message to 'Failed to process action requests: Failed to mount '\\192.168.26.86\opsi_depot': (53, 'WNetAddConnection2', 'Der Netzwerkpfad wurde nicht gefunden.')'   (ControlServer.pyo|541)
(760)     [6] [Sep 10 14:27:24] [ opsiclientd                   ] Got result   (JsonRpc.pyo|142)
(761)     [3] [Sep 10 14:27:24] [ action_processor_starter.exe  ] Failed to process action requests: Failed to mount '\\192.168.26.86\opsi_depot': (53, 'WNetAddConnection2', 'Der Netzwerkpfad wurde nicht gefunden.')   (action_processor_starter.py|128)
(762)     [6] [Sep 10 14:27:24] [ control server                ] Worker <ocdlib.ControlServer.WorkerOpsiclientdJsonRpc instance at 0x0328ABC0> started processing   (Worker.pyo|251)
(763)     [6] [Sep 10 14:27:24] [ control server                ] Reusing session for client '127.0.0.1', application 'opsi jsonrpc module version 4.0.7.28'   (Worker.pyo|397)
(764)     [5] [Sep 10 14:27:24] [ control server                ] Authorization request from pc1608-00855.kk.local@127.0.0.1 (application: opsi jsonrpc module version 4.0.7.28)   (ControlServer.pyo|162)
(765)     [5] [Sep 10 14:27:24] [ opsiclientd                   ] -----> Executing: backend_exit()   (JsonRpc.pyo|134)
(766)     [6] [Sep 10 14:27:24] [ opsiclientd                   ] Got result   (JsonRpc.pyo|142)
(767)     [5] [Sep 10 14:27:24] [ event processing gui_startup{installation_pending}] Process 4740 ended with exit code 0   (Windows.pyo|1650)
(768)     [6] [Sep 10 14:27:24] [ event processing gui_startup{installation_pending}] Session id set to 1   (EventProcessing.pyo|173)


Opsi-Client-Agent ist auch up-to-date.

Ich weiß nun nicht mehr was ich noch tun könnte. Wisst ihr Rat?

Vielen Dank im voraus!
Grüße,
Valentino

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3195
Registriert: 04 Apr 2013, 12:15

Re: Failed to mount depot share Code 53 beim Client-Reboot

Beitragvon n.wenselowski » 11 Sep 2018, 15:29

Hi,

mit welcher Adresse verbinden sich die Clients zum Service?

Kannst du manuell die Adresse mounten, die angegeben ist?

Läuft auf dem entsprechenden Server Samba?

Ich würde für einfacheres Debugging vermutlich die dyn. Depotzuweisung deaktivieren und versuchen die Ursache auf einem Server zu finden. Anschließend die anderen wieder glatt ziehen.


Gruß

Niko

Code: Alles auswählen

import OPSI

Valentino-46
Beiträge: 195
Registriert: 05 Aug 2011, 14:24

Re: Failed to mount depot share Code 53 beim Client-Reboot

Beitragvon Valentino-46 » 11 Sep 2018, 16:13

Hi Niko,

sorry die erste Frage habe ich nicht ganz verstanden, was du damit meinst? Welche Adresse? \\192.168.26.86\opsi_depot und die Clients kommen aus dem 192.168.20.x Netz.

Manuell geht, es geht auch direkt danach "on_demand" dann verbindet es sich auch.

Also auf dem OPSI Server läuft ein Samba ja, klar, muss doch oder verstehe ich die Frage auch nicht ganz? :-)

Die dynamische Depotzuweisung liefert ja immer den richtigen und identischen Host, den Haupt Opsi Server.
Ich sehe das Problem bisher auch nur dort.

Wo genau könnte ich denn bzgl des Debuggings nachschauen??

Vielen Dank!
Grüße,
Valentino

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3195
Registriert: 04 Apr 2013, 12:15

Re: Failed to mount depot share Code 53 beim Client-Reboot

Beitragvon n.wenselowski » 12 Sep 2018, 14:37

Hi Valentino,

Valentino-46 hat geschrieben:sorry die erste Frage habe ich nicht ganz verstanden, was du damit meinst? Welche Adresse? \\192.168.26.86\opsi_depot und die Clients kommen aus dem 192.168.20.x Netz.

Die Clients reden mit dem opsi-Webservice. Im Instlog des Clients sollte bei Loglevel 6 (oder Höher) eine Zeile mit dem Inhalt opsi service URL gefolgt von einer Adresse sein.
Ist das die gleiche Adresse, von welcher der Client auch seinen Netzwerkshare beziehen soll?

Valentino-46 hat geschrieben:Also auf dem OPSI Server läuft ein Samba ja, klar, muss doch oder verstehe ich die Frage auch nicht ganz? :-)

Ja, der muss grundsätzlich laufen. Aber ist der Dienst in dem Moment auch am Laufen?

Code: Alles auswählen

service samba status

Im Zweifel mal Neustarten und probieren, ob es was ändert.

Code: Alles auswählen

service samba restart


Valentino-46 hat geschrieben:Die dynamische Depotzuweisung liefert ja immer den richtigen und identischen Host, den Haupt Opsi Server.
Ich sehe das Problem bisher auch nur dort.

Andere Server sind also nicht betroffen?
Meine Idee war eine der variablen Stellen (dyn. Depotzuweisung) aus der Fehlersuche gleich ausschließen zu können, damit wir sicher sind, dass alles wie geplant funktioniert.
Dadurch, dass dann klar ist wohin der Client sich verbindet, muss man nur auf einem Server debuggen (und nicht auf möglicherweise allen, die für dyn. Depot in Frage kommen könnten). Generell würde ich beim Debug-Versuch immer mit dem selben Client arbeiten, damit man nicht ständig Wechseln muss - das verwirrt sonst nur ;)


Hat der Client mehrere Netzwerkinterfaces oder nur eines?

Viele Grüße

Niko

Code: Alles auswählen

import OPSI

Valentino-46
Beiträge: 195
Registriert: 05 Aug 2011, 14:24

Re: Failed to mount depot share Code 53 beim Client-Reboot

Beitragvon Valentino-46 » 12 Sep 2018, 17:17

Hi Niko,

ja genau, das ist die gleiche Adresse:

Code: Alles auswählen

opsi service URL https://192.168.26.86:4447

Samba wurde glaub auf den Ubuntus umbenannt. Über

Code: Alles auswählen

service samba status
kommt:

Code: Alles auswählen

Warning: samba.service changed on disk. Run 'systemctl daemon-reload' to reload units.
* samba.service
   Loaded: masked (/dev/null; bad)
   Active: inactive (dead)

Sobald ich aber

Code: Alles auswählen

service smbd status
eingebe kommt

Code: Alles auswählen

smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
   Loaded: loaded (/etc/init.d/smbd; bad; vendor preset: enabled)
   Active: active (running) since Wed 2018-09-12 14:42:57 CEST; 2h 19min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 19492 ExecStop=/etc/init.d/smbd stop (code=exited, status=0/SUCCESS)
  Process: 19508 ExecStart=/etc/init.d/smbd start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/smbd.service
           |- 1951 /usr/sbin/smbd -D
           |- 4955 /usr/sbin/smbd -D
           |- 5694 /usr/sbin/smbd -D
           |-19525 /usr/sbin/smbd -D
           |-19528 /usr/sbin/smbd -D
           |-19570 /usr/sbin/smbd -D
           |-19572 /usr/sbin/smbd -D
           |-19782 /usr/sbin/smbd -D
           |-20907 /usr/sbin/smbd -D
           |-27326 /usr/sbin/smbd -D
           `-27820 /usr/sbin/smbd -D

Sep 12 16:20:10 opsi-wgt smbd[1117]: [2018/09/12 16:20:10.034095,  0] ../source3/lib/util_sock.c:1055(get_remote_hostname)
Sep 12 16:20:10 opsi-wgt smbd[1117]:   matchname failed on nb1307-00441.kk.local
Sep 12 16:57:07 opsi-wgt smbd[5686]: [2018/09/12 16:57:07.372894,  0] ../source3/lib/util_sock.c:876(matchname)
Sep 12 16:57:07 opsi-wgt smbd[5686]:   matchname: host name/name mismatch: 192.168.97.25 != (NULL)
Sep 12 16:57:07 opsi-wgt smbd[5686]: [2018/09/12 16:57:07.437563,  0] ../source3/lib/util_sock.c:1055(get_remote_hostname)
Sep 12 16:57:07 opsi-wgt smbd[5686]:   matchname failed on 192.168.97.25
Sep 12 16:57:13 opsi-wgt smbd[5694]: [2018/09/12 16:57:13.156677,  0] ../source3/lib/util_sock.c:876(matchname)
Sep 12 16:57:13 opsi-wgt smbd[5694]:   matchname: host name/name mismatch: 192.168.97.25 != (NULL)
Sep 12 16:57:13 opsi-wgt smbd[5694]: [2018/09/12 16:57:13.156757,  0] ../source3/lib/util_sock.c:1055(get_remote_hostname)
Sep 12 16:57:13 opsi-wgt smbd[5694]:   matchname failed on 192.168.97.25


Er läuft also, aber es gibt schon ab und zu Fehler. Denke das ist aber hier nicht der Fehler...

Den Server habe ich bereits mehrfach neugestartet, den Dienst somit ja auch mit.

Hat der Client mehrere Netzwerkinterfaces oder nur eines?

Der Client hat 1 Interface!

Übrigens bin ich bei ca. 99% der Clients noch auf der OPSI-Client-Agent Version 4.0.7.24-2 drauf. Vielleicht habe ich das Problem deshalb auch nur auf wenigen Rechnern. Ich werde heute mal noch auf mehr Rechnern upgraden auf 4.1.0.0-15 ... aber ich habe das Problem auch jetzt schon bei jemandem mit 4.0.7 gesehen.

Sehr seltsam alles :-(
Ich installiere jetzt mal so ca. 10 Rechner mit 4.1.0.0-15 und dann schauen wir weiter.

Danke nochmal!

Gruß
Valentino

Valentino-46
Beiträge: 195
Registriert: 05 Aug 2011, 14:24

Re: Failed to mount depot share Code 53 beim Client-Reboot

Beitragvon Valentino-46 » 05 Aug 2019, 14:44

Hallo zusammen,

jetzt ist dann fast 1 Jahr später und leider habe ich das Problem immernoch regelmäßig.
Habt Ihr hier nochmal eine Idee, wie man das debuggen könnte? Rechner die teilweise wunderbar funktioniert haben fangen auf einmal an, das Problem zu entwickeln.

Per on_demand Ausführung kommt keine Meldung und das Paket installiert sich. Nur beim Boot des Rechners tritt das Problem auf.

Mit freundlichen Grüßen,
Valentino

Benutzeravatar
koepkek
uib-Team
Beiträge: 230
Registriert: 11 Jan 2012, 11:27

Re: Failed to mount depot share Code 53 beim Client-Reboot

Beitragvon koepkek » 09 Sep 2019, 10:52

Hi Valentino,

die Clients sind Windows10 Rechner? Kann es sein das diese noch Fast_Boot enabled haben. Dazu würden das von dir beschriebene Phänomen passen.
Auch wenn es nicht zu den früher beschriebenen Samba Problemen passt.

Gruß Karsten
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.
http://uib.de
http://opsi.org

Benutzeravatar
SisterOfMercy
Beiträge: 1060
Registriert: 22 Jun 2012, 19:18

Re: Failed to mount depot share Code 53 beim Client-Reboot

Beitragvon SisterOfMercy » 16 Sep 2019, 11:28

Valentino-46 hat geschrieben:

Code: Alles auswählen

Warning: samba.service changed on disk. Run 'systemctl daemon-reload' to reload units.
* samba.service
   Loaded: masked (/dev/null; bad)
   Active: inactive (dead)



Uh, why not run systemctl daemon-reload?

Then start samba by running systemctl start samba ?
I think samba starts more services than smbd.
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!