setup.py hängt / GPT anlegen schlägt fehl

Thomas Moch
Beiträge: 3
Registriert: 17 Feb 2015, 10:39

setup.py hängt / GPT anlegen schlägt fehl

Beitragvon Thomas Moch » 13 Aug 2018, 14:57

Hallo,
es ist nicht mehr möglich Windows 10 auf einen PC mit Intel Onboard RAID1 zu installieren. Hat jemand ein Idee, woran es liegen könnte?

Bereits beim booten vom Bootimage läuft das RAID in rebuild (kurz bevor das OPSI-Logo kommt). Im Kernel-log steht:
/md/raid1:md126 not clean – starting background reconstruction
md126 detected capicity change from 0 to 1234.....
Warum passiert dies?
Im Installationsprozess nach der Hardwareinventarisierung kommt die Meldung: „Found no Partitions“. Das ist vollkommen korrekt.

Dann passiert weiter nichts. Hier wird meines Wissens in der Setup.py dann folgende Zeile aufgerufen um /dev/md126 mit GPT zu versehen:
Zeile 860: execute('/usr/sbin/sgdisk --zap-all %s' % (disk.device))

Durch Wechsel auf eine Konsole fällt auf, dass kein GPT gemacht wird, sondern MBR (fdisk -l zeigt "dos" an).

Nach probieren wurde festgestellt, dass „sgdisk –zap-all /dev/md126“ ausgeführt wird aber wohl der Kernel „hängt“ (strg+c funktioniert nicht). Hier hilft nur ein Wechsel auf eine neue Konsole (tty).

Dies ist die aktuelle Konfiguration:
System:
ASUS Prime Q270M-C, BIOS 1206
Intel RST mit 2x 1TB als RAID1
md126, sda, sdb
UEFI
Windows10 Enterprise 1703

OPSI:
Windows10 OPSI-Package 4.1.0.0-10
Winst 4.12.0.21-1

opsipxeconfd-4.0.7.9-2.2.noarch
opsi-linux-bootimage-20180621-1.1.noarch
opsi-configed-4.0.7.6.34-2.2.noarch
python-opsi-4.0.7.57-1.2.noarch
opsiconfd-4.0.7.14-2.3.noarch
opsi-utils-4.0.7.18-7.2.noarch
opsi-depotserver-4.0.7.3-3.2.noarch
opsi-atftp-0.7.dfsg-15.1.x86_64

Die Installation läuft Problemlos auf Laptops und PCs mit "älterer" Hardware und aktuelle PCs ohne RAID.

Mit freundlichen Gruß
Thomas Moch
Thomas Moch
Fraunhofer Institut fuer Fertigungstechnik und Materialforschung