Firefox Quantum update deaktivieren

IvicaE
Beiträge: 100
Registriert: 13 Sep 2016, 14:10

Firefox Quantum update deaktivieren

Beitragvon IvicaE » 06 Apr 2018, 15:40

Hallo Leute,

ich widme mich mal wieder dem Thema Firefox mit opsi installieren.
Ich habe mich zum ersten mal mit dem Quantum befasst, also ein Paket erstellt und es installieren lassen. Es scheint auch gut zu funktionieren im Gegensatz zu den vorhergegangenen Versionen (die Installation konnte sich nicht immer beenden).

Aber meine Vorgehensweise die Updates zu deaktivieren scheint mit dem neuen Browser nicht mehr zu funktionieren.
Ich habe das bisher so gelöst gehabt das ich eine INI-Datei und eine CFG-Datei mitangegeben hatte in der die MaintenanceService auf "false" gesetzt wurde und somit nicht installiert wurde. In noch früheren Versionen habe ich die Maintenance auch selber deinstalliert und die Updates waren somit nicht möglich.

So, in der neuen Quantum-Version scheint das so nicht mehr zu funktionieren. Ich habe auch die Maintenance selber manuell deinstalliert und der Firefox konnte sich dennoch aktualisieren (ich bin mir gar nicht mehr so sicher das diese Maintenance zur neuen Version gehört hat? Nach nochmaligem de- und wieder installieren war der Ordner gar nicht mehr vorhanden -> updaten ging dennoch).

So, jetzt die Frage an euch in der Hoffnung das der Eine oder Andere bereits ein FF-Paket für den neuen Quantum erstellt hat und die Updates unterbunden hat: Hat das jemand schon so umgesetzt und kann sagen wie man die Updates deaktivieren kann?
Die Version ist: Mozilla Firefox 59.02

Danke schon einmal im Voraus für eure Hilfe oder zumindest das Lesen bis hierher ;)

dropped91
Beiträge: 42
Registriert: 11 Mai 2017, 16:29

Re: Firefox Quantum update deaktivieren

Beitragvon dropped91 » 09 Apr 2018, 08:16

Hi,

schau dir mal cck2 an.
Damit unterbinden wir unter anderem die Update Funktion.
Da ich gerade in der Bahn sitze, kann ich dir kein Code Schnipsel zur Verfügung stellen.


Viele Grüße

dropped

feltel
Beiträge: 78
Registriert: 09 Dez 2014, 07:22

Re: Firefox Quantum update deaktivieren

Beitragvon feltel » 09 Apr 2018, 10:09

Die Einstellungen in der entsprechenden cfg-Datei ziehen -zumindest bei mir im Netz- auch mit dem aktuellsten Firefox 59.0.2 x64:

Code: Alles auswählen

// Disable updater
lockPref("app.update.enabled", false);
lockPref("app.update.auto", false);
lockPref("app.update.mode", 0);
lockPref("app.update.service.enabled", false);

Zusätzlich dazu deinstalliere ich seit jeher aber auch im OPSI-Paket den Maintenance-Serivce.

IvicaE
Beiträge: 100
Registriert: 13 Sep 2016, 14:10

Re: Firefox Quantum update deaktivieren

Beitragvon IvicaE » 09 Apr 2018, 11:02

@dropped91

Bin mal gespannt. cck2 sagt mir nichts aber immer her mit neuen Möglichkeiten ;)

@feltel
Das habe ich in meinen Scripten so, und es hat vor dem Quantum auch geklappt sofern die Installation überhaupt geklappt hat (ich hatte oft das sich das OPSI-Script einfach nicht beenden wollte, aber das ist ein anderes Thema). Aber nun sehe ich keine "Maintainence Service" Ordner mehr nach der Installation von FF Quantum und gehe davon aus das dies nun anders gehandhabt wird?

Ich habe eine INI-Datei in welcher bei der Installation eine Mozilla-cfg-Datei 'mitgegeben' wird. Diese CFG-Datei ist jedoch leer und ich patche diese, abhängig von welchen Properies gesetzt wurden, diese Preferences in diese cfg-Datei. Dann sieht es so wie bei deinem Script aus.
Aber das nutzt nichts, Mozilla updatet sich dennoch von alleine. Ich würde gerne dafür sorgen daß die FF-Versionen bei allen Clients gleich sind und bei Bedarf zentral vom OPSI alle auf eine neuere Version bringen.

feltel
Beiträge: 78
Registriert: 09 Dez 2014, 07:22

Re: Firefox Quantum update deaktivieren

Beitragvon feltel » 09 Apr 2018, 14:14

Also wie gesagt, das Abschalten des Auto-Updates funktioniert auf bei neueren Firefox-Versionen nach dem üblichen Verfahren. Wird die Config-Datei denn überhaupt geladen und wirken sich deren Einstellungen aus? Schau mal bei about:config, ob Deine Einstellungen da als Status:gesperrt oder Status:geändert auftauchen. Die Config-Datei liegt auch im Firefox-Programm-Verzeichnis? Hast Du vielleicht kürzlich vom 32-Bit Firefox zum 64-Bit Firefox migriert? Dann muss die Datei auch in C:\Programme\Mozilla Firefox\ liegen.

Ich würde fast vermuten, das da irgendwo die Fehlerursache liegt.

IvicaE
Beiträge: 100
Registriert: 13 Sep 2016, 14:10

Re: Firefox Quantum update deaktivieren

Beitragvon IvicaE » 12 Apr 2018, 11:54

Also, es war so daß ich eine JS-Config-Datei im Mozillaverzeichniss hatte im Unterverzeichnis \defaults\pref, wo auch die channels-prefs.js vorzufinden ist.
Der Name meiner Datei hat mit dem Buchstaben "m" begonnen und ist unterhalb der "channels-pref.js" gelandet. Dort wurde sie wohl ignoriert komischerweise? Ich habe irgendwann mal den Namen meiner Configdatei geändert (autoconfig.js), sie ist im Verzeichnis an erster Stelle gelistet worden, und siehe da -> es funktioniert.
Diese Config-Datei gibt ja an welche Config-Datei für Mozilla verwendet werden soll

Code: Alles auswählen

pref("general.config.obscure_value", 0);
pref("general.config.filename", "mozilla.cfg");


(in dem Falle "mozilla.cfg")

Wenn dies ignoriert wird, dann wird ja nichts daraus. Warum diese ignoriert wurde, kann ich jedoch nicht sagen, aber wenn diese Datei an oberster Stelle steht, dann funktioniert es.

Vielen Dank für eure Hilfe! ;)