UEFI Netboot - Could not detect current boot!

isnoguter
Beiträge: 50
Registriert: 23 Jul 2014, 07:03

UEFI Netboot - Could not detect current boot!

Beitragvon isnoguter » 08 Okt 2018, 16:05

Hallo,

wir haben die Erweiterung "UEFI-Support" gekauft. Die Installation von UEFI-Clients funktioniert mit Clients unterschiedlicher Hersteller.

Bei einem Intel NUC7i5DNB entsteht nach der Treiberintegration folgender Fehler. Gibt es hierzu eine Idee zur Problemlösung?

(10484) [5] [Okt 08 15:37:29] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/MEDIA/Intel(R) Display-Audio' (WindowsDrivers.py|199)
(10523) [5] [Okt 08 15:37:30] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/Display/Intel(R) HD Graphics 620' (WindowsDrivers.py|199)
(11230) [5] [Okt 08 15:39:00] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/Ports/Intel(R) Active Management Technology - SOL' (WindowsDrivers.py|199)
(11263) [5] [Okt 08 15:39:00] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/System/Intel(R) Serial IO GPIO Host Controller - INT344B' (WindowsDrivers.py|199)
(11298) [5] [Okt 08 15:39:00] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/System/Mobile 6th-7th Generation Intel(R) Processor Family I-O PMC - 9D21' (WindowsDrivers.py|199)
(11331) [5] [Okt 08 15:39:00] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/System/Mobile 6th-7th Generation Intel(R) Processor Family I-O SMBUS - 9D23' (WindowsDrivers.py|199)
(11364) [5] [Okt 08 15:39:00] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/System/Intel(R) Serial IO I2C Host Controller - 9D61' (WindowsDrivers.py|199)
(11399) [5] [Okt 08 15:39:00] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/System/Intel(R) Management Engine Interface' (WindowsDrivers.py|199)
(11436) [5] [Okt 08 15:39:01] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/System/Intel(R) Xeon(R) E3 - 1200 v6-7th Gen Intel(R) Core(TM) Host Bridge-DRAM Registers - 5904' (WindowsDrivers.py|199)
(11469) [5] [Okt 08 15:39:01] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/System/Mobile 6th-7th Generation Intel(R) Processor Family I-O PCI Express Root Port #3 - 9D12' (WindowsDrivers.py|199)
(11502) [5] [Okt 08 15:39:01] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/System/Mobile 6th-7th Generation Intel(R) Processor Family I-O Thermal subsystem - 9D31' (WindowsDrivers.py|199)
(11535) [5] [Okt 08 15:39:01] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/System/Intel(R) Serial IO I2C Host Controller - 9D60' (WindowsDrivers.py|199)
(11570) [5] [Okt 08 15:39:01] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/System/Mobile 7th Generation Intel(R) Processor Family I-O LPC Controller (U with iHDCP2.2 Premium) - 9D4E' (WindowsDrivers.py|199)
(11603) [5] [Okt 08 15:39:01] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/System/Intel(R) Xeon(R) E3 - 1200-1500 v5-6th Gen Intel(R) Core(TM) Gaussian Mixture Model - 1911' (WindowsDrivers.py|199)
(11636) [5] [Okt 08 15:39:01] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/Net/Intel(R) Dual Band Wireless-AC 8265' (WindowsDrivers.py|199)
(11683) [5] [Okt 08 15:39:03] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/Net/Intel(R) Ethernet Connection I219-LM' (WindowsDrivers.py|199)
(11740) [5] [Okt 08 15:39:04] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/HDC/Intel(R) 6th Generation Core Processor Family Platform I-O SATA AHCI Controller' (WindowsDrivers.py|199)
(11783) [5] [Okt 08 15:39:05] Integrating driver dir 'win10-x64/drivers/drivers/additional/byAudit/Intel Corporation/NUC7i5DNHE ()/Bluetooth/Intel(R) Wireless Bluetooth(R)' (WindowsDrivers.py|199)

(11842) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11844) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11846) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11848) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11850) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11852) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11854) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11856) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11858) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11860) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11862) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11864) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11866) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11868) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11870) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11872) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11874) [3] [Okt 08 15:39:05] PCI_DEVICE vendor directory 'win10-x64/drivers/pciids/8086' not found (WindowsDrivers.py|100)
(11903) [3] [Okt 08 15:39:05] HDAUDIO_DEVICE vendor directory 'win10-x64/drivers/hdaudioids/8086' not found (WindowsDrivers.py|100)
(11911) [3] [Okt 08 15:39:05] USB_DEVICE vendor directory 'win10-x64/drivers/usbids/1D6B' not found (WindowsDrivers.py|100)

(11926) [5] [Okt 08 15:39:05] Creating work.cmd (setup.py|1332)
(12052) [5] [Okt 08 15:39:07] Adding found driver c:\drv\16\oem21.inf to drvloadlist_org.txt
(setup.py|1355)
(12068) [5] [Okt 08 15:39:07] Here comes the /mnt/hd/opsi/drvloadlist_org.txt (setup.py|1363)
(12079) [5] [Okt 08 15:39:08] Creating startnet.cmd (setup.py|1433)
(12080) [5] [Okt 08 15:39:08] Creating diskpart.txt to delete winpe (setup.py|1467)
(12081) [5] [Okt 08 15:39:08] No Partition IDs to backup - do not create /mnt/hd/opsi/partunhide.txt (setup.py|1514)
(12082) [5] [Okt 08 15:39:08] No Partition IDs to backup - do not create /mnt/hd/opsi/parthide.txt (setup.py|1535)
(12083) [5] [Okt 08 15:39:08] write disk and partition infos to /mnt/hd/opsi/diskinfo.ini (setup.py|1541)
(12084) [5] [Okt 08 15:39:08] Here comes the /mnt/hd/opsi/diskinfo.ini (setup.py|1546)
(12125) [5] [Okt 08 15:39:08] Creating opsi-script-infos.ini (setup.py|1554)
(12126) [5] [Okt 08 15:39:08] Patching unattend.xml and config.ini (setup.py|1574)
(12139) [5] [Okt 08 15:39:08] Here comes the unattend.xml (setup.py|1580)
(12388) [5] [Okt 08 15:39:08] Reading config.ini data: config_service.url: https://10.1.211.13:4447 (setup.py|1597)
(12389) [5] [Okt 08 15:39:08] config_service.url from clientconfig: https://10.1.211.13:4447/rpc (setup.py|1598)
(12390) [4] [Okt 08 15:39:08] service url from config.ini: https://10.1.211.13:4447 is different to clientconfig.configserver.url (commandline or input mask): https://10.1.211.13:4447/rpc (setup.py|1600)
(12391) [5] [Okt 08 15:39:08] Using config.ini data as service url: config_service.url: https://10.1.211.13:4447 (setup.py|1601)
(12434) [5] [Okt 08 15:39:08] umount /dev/sda4 >> /tmp/gpt.log 2>&1 (setup.py|1611)
(12438) [5] [Okt 08 15:39:12] diskcounter is still 0 (setup.py|1616)

(12449) [2] [Okt 08 15:39:14] Traceback: (Logger.py|798)
(12450) [2] [Okt 08 15:39:14] File "/usr/local/bin/master.py", line 1387, in <module>
(12451) execfile(actionScript)
(12452) (Logger.py|798)
(12453) [2] [Okt 08 15:39:14] File "/tmp/setup.py", line 1622, in <module>
(12454) currentbootentry = uefiGetActBootEntry()
(12455) (Logger.py|798)
(12456) [2] [Okt 08 15:39:14] File "/tmp/opsisetuplib.py", line 683, in uefiGetActBootEntry
(12457) firstEntry = getBootCurrent(output)[0]
(12458) (Logger.py|798)
(12459) [2] [Okt 08 15:39:14] File "/tmp/opsisetuplib.py", line 610, in getBootCurrent
(12460) raise Exception('Could not detect current boot!')
(12461) (Logger.py|798)
(12462) [2] [Okt 08 15:39:14] ==>>> Could not detect current boot! (master.py|1437)

(12473) [5] [Okt 08 15:39:14] Writing log to service (master.py|1465)


Viele Grüße
isnoguter

Benutzeravatar
m.radtke
Beiträge: 615
Registriert: 10 Jun 2015, 12:19

Re: UEFI Netboot - Could not detect current boot!

Beitragvon m.radtke » 09 Okt 2018, 09:25

Hi

benutzt du die aktuelle stable Version des Bootimages und Netboot Produktes?

Ich glaube der Aufruf der in die Hose geht ist

Code: Alles auswählen

 eifbootmanager -v

führ den mal auf der entsprechenden Maschine aus.

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

isnoguter
Beiträge: 50
Registriert: 23 Jul 2014, 07:03

Re: UEFI Netboot - Could not detect current boot!

Beitragvon isnoguter » 09 Okt 2018, 10:47

Hallo,

den Befehl

Code: Alles auswählen

eifbootmanager -v
gibt es nicht.

Mit

Code: Alles auswählen

efibootmgr -v
bekomme ich folgendes.

Code: Alles auswählen

(miniroot-x64)root@nu2001:/# efibootmgr -v
Timeout: 1 seconds
BootOrder: 0001,0002,0004,0000,0003
Boot0000* Windows Boot Manager   VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...in...............
Boot0001* UEFI : LAN : PXE IP4 Intel(R) Ethernet Connection I219-LM   PciRoot(0x0)/Pci(0x1f,0x6)/MAC(d45ddf0b4c5f,0)/IPv4(0.0.0.0:0<->0.0.0.0:0,0,0)..BO
Boot0002* UEFI : LAN : PXE IP6 Intel(R) Ethernet Connection I219-LM   PciRoot(0x0)/Pci(0x1f,0x6)/MAC(d45ddf0b4c5f,0)/IPv6([::]:<->[::]:,0,0)..BO
Boot0003* opsitempwinpe   VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0004* UEFI : SATA : PORT 0 : WDC WDS120G2G0A-00JH30 : PART 3 : OS Bootloader   PciRoot(0x0)/Pci(0x17,0x0)/Sata(0,65535,0)/HD(4,GPT,3876a88b-1264-44a0-941d-9eaf654b91a6,0xd646800,0x7d0000)..BO


Die Version sollte aktuell sein:

Code: Alles auswählen

opsi@opsi01:/var/lib/opsi/workbench$ dpkg -l | grep opsi-
ii  opsi-configed                 4.0.7.6.34-2                   all          OPSI config editor
ii  opsi-linux-bootimage          20180813-1                     all          opsi bootimage for netboot tasks.
ii  opsi-server                   4.1.1.4-10                     all          opsi server configuration package
ii  opsi-tftpd-hpa                5.2.8-47                       amd64        HPA's tftp server
ii  opsi-utils                    4.1.1.22-1                     all          utilites for working with opsi.
ii  opsi-windows-support          4.1.1-5                        all          Install utilities useful for deploying Windows with opsi.


Viele Grüße
isnoguter

Benutzeravatar
m.radtke
Beiträge: 615
Registriert: 10 Jun 2015, 12:19

Re: UEFI Netboot - Could not detect current boot!

Beitragvon m.radtke » 09 Okt 2018, 13:31

ok
im Code wird nach dem Aufruf

Code: Alles auswählen

 efibootmgr -v

nach

Code: Alles auswählen

^BootCurrent:\s+(.*)

gesucht.

Das kann ich in Deinem Output nicht erkennen.
Wie startest Du denn das PXE Boot?

Auf einem UEFI Rechner der bei mir gerade rumsteht erhalte ich folgendes

Code: Alles auswählen

# efibootmgr -v
BootCurrent: 0009
Timeout: 2 seconds
BootOrder: 0000,0009,000A
Boot0000* opsitempwinpe   HD(4,GPT,7fc82106-5b68-415d-b41e-7c9c00117f1b,0x1d3a1800,0x7d0000)/File(\EFI\boot\bootx64.efi)
Boot0009* Onboard NIC(IPV4)   PciRoot(0x0)/Pci(0x1f,0x6)/MAC(8cec4b8eaaed,0)/IPv4(0.0.0.0:0<->0.0.0.0:0,0,0)..BO
Boot000A* Onboard NIC(IPV6)   PciRoot(0x0)/Pci(0x1f,0x6)/MAC(8cec4b8eaaed,0)/IPv6([::]:<->[::]:,0,0)..BO
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

isnoguter
Beiträge: 50
Registriert: 23 Jul 2014, 07:03

Re: UEFI Netboot - Could not detect current boot!

Beitragvon isnoguter » 10 Okt 2018, 09:18

Was meinst du mit
Wie startest Du denn das PXE Boot?


Ich aktiviere einfach das Netboot win10-x64

Es ist ja auch nur ein Client-Typ betroffen: Intel NUC7i5DNB (einen anderen NUC-Typ zum testen habe ich gerade nicht)

Im Intel-Forum habe ich folgendes gefunden: https://communities.intel.com/thread/117127

Ich habe die Treiber-Version 0.0.18, habe aber trotzdem noch ein Update auf die neue BIOS-Version gemacht. Der Treiber bleibt nach dem Update bei Version 0.0.18 und die Installation bleibt an der selben Stelle hängen.

Edit 10 Okt 2018, 11:37
Ich habe den Client gerade manuell von der SSD gebootet, die OPSI Windows Installation ist danach problemlos durchgelaufen.

D.h. Das Netboot bleibt nach der Treiberintegration stehen, wird der Client anschließend manuell von der SSD gebootet, läuft die Installation durch.

Benutzeravatar
n.wenselowski
Beiträge: 2898
Registriert: 04 Apr 2013, 12:15

Re: UEFI Netboot - Could not detect current boot!

Beitragvon n.wenselowski » 11 Okt 2018, 11:08

Hi,

isnoguter hat geschrieben:Edit 10 Okt 2018, 11:37
Ich habe den Client gerade manuell von der SSD gebootet, die OPSI Windows Installation ist danach problemlos durchgelaufen.

D.h. Das Netboot bleibt nach der Treiberintegration stehen, wird der Client anschließend manuell von der SSD gebootet, läuft die Installation durch.

Das klingt nach fehlerhafter UEFI-Implementation, bei der es nicht möglichst ist korrekt den Nextboot zu setzen. Das kommt leider immer wieder mal vor, dass die Hersteller da pfuschen. Klappt das Setzen des Nextboot bspw. wenn ein Ubuntu von USB installiert (ohne opsi)? Wenn nicht, dann würde ich mich an den Hersteller wenden, denn das muss er fixen.


Gruß

Niko
Kein Support per DM!
_________________________
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.

isnoguter
Beiträge: 50
Registriert: 23 Jul 2014, 07:03

Re: UEFI Netboot - Could not detect current boot!

Beitragvon isnoguter » 11 Okt 2018, 15:44

Ich habe noch ein bisschen getestet und bin zu folgendem Ergebnis gekommen.

1. Der Intel Intel NUC7i5DNB kann mittels F12 direkt per Netzwerk gestartet werden.
2. Alternativ kann durch F10 das Bootmenü aufgerufen werden und dann die Netzwerkkarte ausgewählt werden.

Nummer 1 führt zu dem beschriebenen Fehler.
Nummer 2 funktioniert und die Installation läuft sauber durch.

Die Installation mittels OPSI Paket "opsi-uefi-netboot" funktioniert ebenfalls.

Das Problem ist damit für mich gelöst.

Viele Grüße
isnoguter