opsi client agent startet zu spät bzw. garnicht

micha_1989
Beiträge: 22
Registriert: 25 Sep 2014, 13:35

opsi client agent startet zu spät bzw. garnicht

Beitragvon micha_1989 » 27 Jul 2017, 11:56

Hallo zusammen,

ich bin gerade dabei den Opsi Client Agent auszurollen. Mir ist nun über den configed aufgefallen, dass einige Clients nicht verfügbar sind, obwohl ich diese getestet habe. Nun habe ich hersausgefunden, dass es daran liegt, dass der Client Agent beim Hochfahren (Windows 10) zu spät startet. Die User melden sich natürlich an, sobald sie die Möglichkeit dazu haben. Tun sie dies bevor das Opsi-Fenster erscheint, startet der Dienst nicht und der Client ist nicht erreichbar. Der Loginblocker scheint also garnicht zu funktionieren? Mir ist aufgefallen, dass das Schlosssymbol oben rechts auch verspätet kommt, bei einem Client sogar garnicht. In der Client config habe ich nur die Timeouts angepasst (von 30sek auf 5sek). Loginblockerstart ist auf 1 gesetzt (aktiv).
Eine Idee woran es liegen kann? Bei Win7 hat es wunderbar geklappt...

weener
Beiträge: 8
Registriert: 02 Aug 2017, 17:54

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon weener » 02 Aug 2017, 18:07

Hallo,

dieses Problem haben wir aktuell auch. Umgebung bei uns: Ubuntu 16.04, aktuelle opsi-Version.
Wir installieren Windows 10 Pro (1703) per PXE-Boot.

Bei jedem Boot kommt nur kurz oben rechts das Schloß und danach kann sich der User anmelden. Wenn man das nicht tut, werden auch ganz normal Pakete installiert. Man hat aber immer per ALT-TAB Zugriff auf das Login.

Kleines Zusatz-Phänomen: Wenn Pakete einen Reboot auslösen, erfolgt dies (auch wenn niemand angemeldet ist) nicht sofort, sondern es kommt unten rechts der Hinweis, dass in 5 Min. neu gestartet wird.

Hat jemand eine Idee, wie man den Loginblocker wieder normal ans Laufen bekommt?

Michael

hmarius
Beiträge: 11
Registriert: 14 Jun 2017, 11:55

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon hmarius » 03 Aug 2017, 10:01

Hallo,

ich schließe mich euch mal an genau das gleiche Problem tritt bei mir auch bei Neuinstallationen auf. Ich habe schon die Logs und die Einstellungen kontrolliert konnte aber nichts auffälliges finden alles ist so wie bei den vorhandenen PCs wo es funktioniert. Anbei auch mal das log vom Loginblocker von einem eben neuinstallierten PC.

Code: Alles auswählen

[5] 2017-08-03 09:45:34 ------------------------------------------------------------------------------------
[5] 2017-08-03 09:45:34 START OpsiLoginBlocker
[5] 2017-08-03 09:45:34 ------------------------------------------------------------------------------------
[5] 2017-08-03 09:45:34 Getting config from registry
[5] 2017-08-03 09:45:34 LoginBlockerLogLevel is: 5
[5] 2017-08-03 09:45:34 Read LoginBlockerLogDir from Registry and switch to Logfile 'c:\opsi.org\log'
[5] 2017-08-03 09:45:34 According to LoginBlockerLogDir Logfile='c:\opsi.org\log\opsi_loginblocker.log'
[5] 2017-08-03 09:45:34 LoginBlockerStart is: 1
[5] 2017-08-03 09:45:34 LoginBlockerTimeoutConnect is: 120 seconds
[5] 2017-08-03 09:45:34 Config read from registry.
[5] 2017-08-03 09:45:34 handleLogfileAging started.
[5] 2017-08-03 09:45:34 Check logfile age: 3.8.2017 - current date: 3.8.2017
[5] 2017-08-03 09:45:34 ------------------------------------------------------------------------
[5] 2017-08-03 09:45:34 Keep current logfile.
[5] 2017-08-03 09:45:34 ------------------------------------------------------------------------
[5] 2017-08-03 09:45:34 OS Version: 10.0 (unknown version)
[5] 2017-08-03 09:45:34 Filtering credential providers
[5] 2017-08-03 09:45:34 Registry: start of opsiclientd service is enabled, waiting for service to start ...
[5] 2017-08-03 09:45:34 Service opsiclientd is running (SERVICE_RUNNING).
[5] 2017-08-03 09:45:34 Stop blocking!
[5] 2017-08-03 09:53:31 ------------------------------------------------------------------------------------
[5] 2017-08-03 09:53:31 START OpsiLoginBlocker
[5] 2017-08-03 09:53:31 ------------------------------------------------------------------------------------
[5] 2017-08-03 09:53:31 Getting config from registry
[5] 2017-08-03 09:53:31 LoginBlockerLogLevel is: 5
[5] 2017-08-03 09:53:31 Read LoginBlockerLogDir from Registry and switch to Logfile 'c:\opsi.org\log'
[5] 2017-08-03 09:53:31 According to LoginBlockerLogDir Logfile='c:\opsi.org\log\opsi_loginblocker.log'
[5] 2017-08-03 09:53:31 LoginBlockerStart is: 1
[5] 2017-08-03 09:53:31 LoginBlockerTimeoutConnect is: 120 seconds
[5] 2017-08-03 09:53:31 Config read from registry.
[5] 2017-08-03 09:53:31 handleLogfileAging started.
[5] 2017-08-03 09:53:31 Check logfile age: 3.8.2017 - current date: 3.8.2017
[5] 2017-08-03 09:53:31 ------------------------------------------------------------------------
[5] 2017-08-03 09:53:31 Keep current logfile.
[5] 2017-08-03 09:53:31 ------------------------------------------------------------------------
[5] 2017-08-03 09:53:31 OS Version: 10.0 (unknown version)
[5] 2017-08-03 09:53:31 Filtering credential providers
[5] 2017-08-03 09:53:31 Registry: start of opsiclientd service is enabled, waiting for service to start ...
[5] 2017-08-03 09:53:31 Service opsiclientd is running (SERVICE_RUNNING).
[4] 2017-08-03 09:53:31 Could not open opsiclientd pipe \\.\pipe\opsiclientd: 2
[5] 2017-08-03 09:53:32 Stop blocking!

Benutzeravatar
n.wenselowski
Beiträge: 2390
Registriert: 04 Apr 2013, 12:15

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon n.wenselowski » 11 Aug 2017, 15:51

Hi,

tritt das Problem nur mit Win10 1703 auf oder auch mit anderen Versionen?
Welche Version des opsi-client-agent wird verwendet?

Nur um sicher zu gehen: wurde vorher ein richtiger Shutdown ausgeführt oder sind die Rechner mit Microsofts "Fastboot" ausgestattet und machen dadurch nur in Hibernate?

Ist der Dienst opsiclientd als gestartet aufgeführt?
In seinem Logfile sollten Informationen darüber zu finden sein ob der Login freigegeben wurde.
Wir haben nur bedingt einen Einfluss darauf wann der opsiclientd startet. Was hier gemacht werden könnte wäre die Abhängigkeiten auf die Dienste über das Property depends_on_service anzupassen. Auch services_pipe_timeout kann helfen den Dienst starten zu lassen. DIe beste Möglichkeit eine konkrete Aktion abzuleiten ist ein Blick ins Event-Log.


Gruß

Niko
Kein Support per DM!
_________________________
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.

weener
Beiträge: 8
Registriert: 02 Aug 2017, 17:54

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon weener » 14 Aug 2017, 18:06

Hallo Niko,

danke, dass du dich dem Problem annimmst...
tritt das Problem nur mit Win10 1703 auf oder auch mit anderen Versionen?

Nach unseren Erkenntnissen besteht das Problem erst bei 1703. Gerade eben wurde eine 1607-Installation beendet, dort verhält sich der Loginblocker einwandfrei.
Nur um sicher zu gehen: wurde vorher ein richtiger Shutdown ausgeführt oder sind die Rechner mit Microsofts "Fastboot" ausgestattet und machen dadurch nur in Hibernate?

Fastboot ist deaktiviert. Die PCs werden immer "richtig" heruntergefahren.
In seinem Logfile sollten Informationen darüber zu finden sein ob der Login freigegeben wurde.
Wir haben nur bedingt einen Einfluss darauf wann der opsiclientd startet. Was hier gemacht werden könnte wäre die Abhängigkeiten auf die Dienste über das Property depends_on_service anzupassen. Auch services_pipe_timeout kann helfen den Dienst starten zu lassen. DIe beste Möglichkeit eine konkrete Aktion abzuleiten ist ein Blick ins Event-Log.

Werde ich noch prüfen und mich wieder melden..

weener
Beiträge: 8
Registriert: 02 Aug 2017, 17:54

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon weener » 15 Aug 2017, 09:59

Welche Version des opsi-client-agent wird verwendet?

4.0.7.15-1

weener
Beiträge: 8
Registriert: 02 Aug 2017, 17:54

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon weener » 15 Aug 2017, 10:20

In seinem Logfile sollten Informationen darüber zu finden sein ob der Login freigegeben wurde.

Hier das Log von Windows 10 1607:

Code: Alles auswählen

[5] 2017-08-14 17:52:32 ------------------------------------------------------------------------------------
[5] 2017-08-14 17:52:32 START OpsiLoginBlocker
[5] 2017-08-14 17:52:32 ------------------------------------------------------------------------------------
[5] 2017-08-14 17:52:32 Getting config from registry
[5] 2017-08-14 17:52:32 LoginBlockerLogLevel is: 5
[5] 2017-08-14 17:52:32 Read LoginBlockerLogDir from Registry and switch to Logfile 'c:\opsi.org\log'
[5] 2017-08-14 17:52:32 According to LoginBlockerLogDir Logfile='c:\opsi.org\log\opsi_loginblocker.log'
[5] 2017-08-14 17:52:32 LoginBlockerStart is: 1
[5] 2017-08-14 17:52:32 LoginBlockerTimeoutConnect is: 120 seconds
[5] 2017-08-14 17:52:32 Config read from registry.
[5] 2017-08-14 17:52:32 handleLogfileAging started.
[5] 2017-08-14 17:52:32 Check logfile age: 14.8.2017 - current date: 14.8.2017
[5] 2017-08-14 17:52:32 ------------------------------------------------------------------------
[5] 2017-08-14 17:52:32 Keep current logfile.
[5] 2017-08-14 17:52:32 ------------------------------------------------------------------------
[5] 2017-08-14 17:52:32 OS Version: 10.0 (unknown version)
[5] 2017-08-14 17:52:32 Filtering credential providers
[5] 2017-08-14 17:52:32 Registry: start of opsiclientd service is enabled, waiting for service to start ...
[5] 2017-08-14 17:52:32 Service opsiclientd is starting (SERVICE_START_PENDING).
[5] 2017-08-14 17:52:32 Service opsiclientd is starting (SERVICE_START_PENDING).
[5] 2017-08-14 17:52:35 Service opsiclientd is running (SERVICE_RUNNING).
[5] 2017-08-14 17:52:35 Continue blocking!
[5] 2017-08-14 17:52:36 Continue blocking!
[5] 2017-08-14 17:52:37 Continue blocking!
[5] 2017-08-14 17:52:38 Continue blocking!
[5] 2017-08-14 17:52:39 Continue blocking!
[5] 2017-08-14 17:52:40 Continue blocking!
[5] 2017-08-14 17:52:41 Continue blocking!
[5] 2017-08-14 17:52:42 Continue blocking!
[5] 2017-08-14 17:52:43 Continue blocking!
[5] 2017-08-14 17:52:44 Continue blocking!
[5] 2017-08-14 17:52:45 Continue blocking!
[5] 2017-08-14 17:52:46 Continue blocking!
[5] 2017-08-14 17:52:47 Continue blocking!
[5] 2017-08-14 17:52:48 Continue blocking!
[5] 2017-08-14 17:52:49 Continue blocking!
[5] 2017-08-14 17:52:50 Continue blocking!
[5] 2017-08-14 17:52:51 Continue blocking!
[5] 2017-08-14 17:52:52 Continue blocking!
[5] 2017-08-14 17:52:53 Continue blocking!
[5] 2017-08-14 17:52:54 Continue blocking!
[5] 2017-08-14 17:52:55 Continue blocking!
[5] 2017-08-14 17:52:56 Continue blocking!
[5] 2017-08-14 17:52:57 Continue blocking!
[5] 2017-08-14 17:52:58 Continue blocking!
[5] 2017-08-14 17:52:59 Continue blocking!
[5] 2017-08-14 17:53:00 Continue blocking!
[5] 2017-08-14 17:53:01 Continue blocking!
[5] 2017-08-14 17:53:02 Continue blocking!
[5] 2017-08-14 17:53:03 Continue blocking!
[5] 2017-08-14 17:53:04 Continue blocking!
[5] 2017-08-14 17:53:05 Continue blocking!
[5] 2017-08-14 17:53:06 Continue blocking!
[5] 2017-08-14 17:53:07 Continue blocking!
[5] 2017-08-14 17:53:08 Continue blocking!
[5] 2017-08-14 17:53:09 Continue blocking!
[5] 2017-08-14 17:53:10 Continue blocking!
[5] 2017-08-14 17:53:11 Continue blocking!
[5] 2017-08-14 17:53:12 Continue blocking!
[5] 2017-08-14 17:53:13 Continue blocking!
[5] 2017-08-14 17:53:14 Continue blocking!
[5] 2017-08-14 17:53:15 Continue blocking!
[5] 2017-08-14 17:53:16 Continue blocking!
[5] 2017-08-14 17:53:17 Continue blocking!
[5] 2017-08-14 17:53:18 Continue blocking!
[5] 2017-08-14 17:53:19 Continue blocking!
[5] 2017-08-14 17:53:20 Continue blocking!
[5] 2017-08-14 17:53:21 Continue blocking!
[5] 2017-08-14 17:53:22 Continue blocking!
[5] 2017-08-14 17:53:23 Continue blocking!
[5] 2017-08-14 17:53:24 Continue blocking!
[5] 2017-08-14 17:53:25 Continue blocking!
[5] 2017-08-14 17:53:26 Continue blocking!
[5] 2017-08-14 17:53:27 Continue blocking!
[5] 2017-08-14 17:53:28 Continue blocking!
[5] 2017-08-14 17:53:29 Continue blocking!
[5] 2017-08-14 17:53:30 Continue blocking!
[5] 2017-08-14 17:53:31 Continue blocking!
[5] 2017-08-14 17:53:32 Continue blocking!
[5] 2017-08-14 17:53:33 Continue blocking!
[5] 2017-08-14 17:53:34 Continue blocking!
[5] 2017-08-14 17:53:35 Continue blocking!
[5] 2017-08-14 17:53:36 Continue blocking!
[5] 2017-08-14 17:53:37 Continue blocking!
[5] 2017-08-14 17:53:38 Continue blocking!
[5] 2017-08-14 17:53:39 Continue blocking!
[5] 2017-08-14 17:53:40 Continue blocking!
[5] 2017-08-14 17:53:41 Continue blocking!
[5] 2017-08-14 17:53:42 Continue blocking!
[5] 2017-08-14 17:53:43 Continue blocking!
[5] 2017-08-14 17:53:44 Continue blocking!
[5] 2017-08-14 17:53:45 Continue blocking!
[5] 2017-08-14 17:53:46 Continue blocking!
[5] 2017-08-14 17:53:47 Continue blocking!
[5] 2017-08-14 17:53:48 Stop blocking!


...und so sieht es mit Windows 10 1703 aus:

Code: Alles auswählen

[5] 2017-08-14 14:59:43 ------------------------------------------------------------------------------------
[5] 2017-08-14 14:59:43 START OpsiLoginBlocker
[5] 2017-08-14 14:59:43 ------------------------------------------------------------------------------------
[5] 2017-08-14 14:59:43 Getting config from registry
[5] 2017-08-14 14:59:43 LoginBlockerLogLevel is: 5
[5] 2017-08-14 14:59:43 Read LoginBlockerLogDir from Registry and switch to Logfile 'c:\opsi.org\log'
[5] 2017-08-14 14:59:43 According to LoginBlockerLogDir Logfile='c:\opsi.org\log\opsi_loginblocker.log'
[5] 2017-08-14 14:59:43 LoginBlockerStart is: 1
[5] 2017-08-14 14:59:43 LoginBlockerTimeoutConnect is: 120 seconds
[5] 2017-08-14 14:59:43 Config read from registry.
[5] 2017-08-14 14:59:43 handleLogfileAging started.
[5] 2017-08-14 14:59:43 Check logfile age: 14.8.2017 - current date: 14.8.2017
[5] 2017-08-14 14:59:43 ------------------------------------------------------------------------
[5] 2017-08-14 14:59:43 Keep current logfile.
[5] 2017-08-14 14:59:43 ------------------------------------------------------------------------
[5] 2017-08-14 14:59:43 OS Version: 10.0 (unknown version)
[5] 2017-08-14 14:59:43 Filtering credential providers
[5] 2017-08-14 14:59:43 Registry: start of opsiclientd service is enabled, waiting for service to start ...
[5] 2017-08-14 14:59:43 Service opsiclientd is starting (SERVICE_START_PENDING).
[5] 2017-08-14 14:59:43 Service opsiclientd is starting (SERVICE_START_PENDING).
[5] 2017-08-14 14:59:46 Service opsiclientd is running (SERVICE_RUNNING).
[5] 2017-08-14 14:59:46 Stop blocking!

hmarius
Beiträge: 11
Registriert: 14 Jun 2017, 11:55

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon hmarius » 22 Aug 2017, 11:07

Hat schon jemand eine Lösung gefunden?

Problem tritt nur mit 1703 auf.
OPSI Client ist 4.0.7.15-1
Fastboot ist bei mir ebenfalls deaktiviert per GPO an allen PCs.
OPSI Loginblocker log:


Code: Alles auswählen

[5] 2017-08-22 07:41:53 Old Logfile from: 21.8.2017 renamed - new Logfile created: 22.8.2017
[5] 2017-08-22 07:41:53 ------------------------------------------------------------------------
[5] 2017-08-22 07:41:53 OS Version: 10.0 (unknown version)
[5] 2017-08-22 07:41:53 Filtering credential providers
[5] 2017-08-22 07:41:53 Registry: start of opsiclientd service is enabled, waiting for service to start ...
[5] 2017-08-22 07:41:53 Service opsiclientd is running (SERVICE_RUNNING).
[5] 2017-08-22 07:41:53 Stop blocking!

Benutzeravatar
n.wenselowski
Beiträge: 2390
Registriert: 04 Apr 2013, 12:15

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon n.wenselowski » 22 Aug 2017, 12:40

Hi,

wir haben eine neuen opsiclientd, mit welchem das Problem der Vergangenheit angehören sollte.
In den nächsten Tagen sollte eine entsprechende Version in Testing landen. Bitte die News beobachten und wenn diese Version nicht hilft, würde ich mich über eine Rückmeldung freuen!


Gruß

Niko
Kein Support per DM!
_________________________
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.

Benutzeravatar
ueluekmen
Beiträge: 1804
Registriert: 28 Mai 2008, 10:53

Re: opsi client agent startet zu spät bzw. garnicht

Beitragvon ueluekmen » 22 Aug 2017, 16:47

opsi support - uib gmbh
For productive opsi installations we recommend support contracts.
http://www.uib.de


Zurück zu „Freier Support“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast