Pfade in install-elilo-* unter UCS falsch

SirTux
Beiträge: 218
Registriert: 05 Feb 2011, 18:37

Pfade in install-elilo-* unter UCS falsch

Beitragvon SirTux » 02 Dez 2017, 23:42

Hallo,

unter UCS stimmen die Pfade in install-elilo-* nicht. Der Ordner "linux" muß entfernt werden.

Viele Grüße,
SirTux

Benutzeravatar
m.radtke
Beiträge: 567
Registriert: 10 Jun 2015, 12:19

Re: Pfade in install-elilo-* unter UCS falsch

Beitragvon m.radtke » 04 Dez 2017, 08:18

Hi SirTux,

danke für die Meldung.
Wird demnächst im Bootimage so auftauchen ;)

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

Benutzeravatar
m.radtke
Beiträge: 567
Registriert: 10 Jun 2015, 12:19

Re: Pfade in install-elilo-* unter UCS falsch

Beitragvon m.radtke » 04 Dez 2017, 14:23

Hi

Code: Alles auswählen

opsi-linux-bootimage_20171129-3

baut aktuell unter experimental und patcht das Verzeichnis raus

Grüße
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

SirTux
Beiträge: 218
Registriert: 05 Feb 2011, 18:37

Re: Pfade in install-elilo-* unter UCS falsch

Beitragvon SirTux » 04 Dez 2017, 16:26

Aber derzeit nicht für opsi 4.1 oder? Gibt es eigentlich beim Bootimage aktuell Unterschiede zwischen opsi 4.0 und 4.1?

Benutzeravatar
m.radtke
Beiträge: 567
Registriert: 10 Jun 2015, 12:19

Re: Pfade in install-elilo-* unter UCS falsch

Beitragvon m.radtke » 04 Dez 2017, 17:29

auf für 4.1 in experimental
opsi-linux-bootimage_20171129-2

Unterschiede:
opsi 4.1 bootimage hat einen splashscreen
opsi 4.1 bootimage hat kernel 4.14.2
opsi 4.0 bootimage hat kernel 4.13.16
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

SirTux
Beiträge: 218
Registriert: 05 Feb 2011, 18:37

Re: Pfade in install-elilo-* unter UCS falsch

Beitragvon SirTux » 04 Dez 2017, 18:38

Danke darauf hätte ich auch selbst können, wenn ich die Versionsnummern verglichen hätte ;)

Leider ist der Postinst noch nicht optimal. Denn darin wird ja versucht den Ordner /tftpboot/linux/pxelinux.cfg nach /var/lib/univention-client-boot/ zu verschieben. Dies schlägt aber fehl, wenn es den Ordner /var/lib/univention-client-boot/pxelinux.cfg schon gibt.

Idealerweise sollten nur die vom Paket verwalteten Dateien dorthin verschoben werden. Andere vorhandene Dateien sollten erhalten bleiben. Speziell der Symlink default sollte nicht angefaßt werden.

So könnte es eventuell funktionieren:

Code: Alles auswählen

if [ -L "$TFTPROOT"/pxelinux.cfg ]; then
   unlink "$TFTPROOT"/pxelinux.cfg
elif [ -d "$TFTPROOT"/pxelinux.cfg ]; then
   rm /tftpboot/linux/pxelinux.cfg/default
   mv /tftpboot/linux/pxelinux.cfg/* "$TFTPROOT"/pxelinux.cfg
   rmdir /tftpboot/linux/pxelinux.cfg
fi
mv /tftpboot/linux/* $TFTPROOT/

Benutzeravatar
m.radtke
Beiträge: 567
Registriert: 10 Jun 2015, 12:19

Re: Pfade in install-elilo-* unter UCS falsch

Beitragvon m.radtke » 20 Mär 2018, 07:47

Hi

sorry für die sehr späte Antwort.
In experimental findest du ein bootimage mit dem Fix dafür.
bitte auch dann den opsi-atftpd aus experimental aktualisieren, da das bootimage nun etwas größer als 90MB ist.#

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

SirTux
Beiträge: 218
Registriert: 05 Feb 2011, 18:37

Re: Pfade in install-elilo-* unter UCS falsch

Beitragvon SirTux » 21 Mär 2018, 21:52

Kein Problem, ich hab es auch so beim Aktualisieren gemerkt, als es dabei nicht mehr geknallt hat ;)