[solved] Update auf CentOS 7.4

Tobei
Beiträge: 18
Registriert: 10 Dez 2010, 00:29
Kontaktdaten:

[solved] Update auf CentOS 7.4

Beitragvon Tobei » 21 Sep 2017, 10:32

Hi,

ich habe am Wochenende mal testweise unsere OPSI-Server von CentOS 7.3 auf 7.4 aktualisiert. Die (reinen) Depot-Server haben es gut überstanden. Der Server auf dem der configed Dienst läuft kam soweit auch ohne Weiteres durch. Sprich in den Logs der einzelnen Dienste (configed, MariaDB usw.) sieht man keine Fehler.

Als ich mich dann mit dem opsi configed editor verbunden habe, hagelte es Fehlermeldungen. Ein clientseitiges Log des opsi config editors hätte ich griffbereit, mag ich hier aber nicht öffentlich einstellen. Da unser Support-Vertrag noch in der Mache ist ... ist dies bezüglich bei euch schon etwas bekannt?

Da diese Server produktiv sind, bin ich dann direkt wieder auf meinen Snapshot vor den Update gegangen.


Gruß Tobias
Zuletzt geändert von Tobei am 27 Sep 2017, 21:59, insgesamt 1-mal geändert.

Karl der Heinz
Beiträge: 28
Registriert: 07 Aug 2014, 11:33

Re: Update auf CentOS 7.4

Beitragvon Karl der Heinz » 25 Sep 2017, 11:20

Hi,

ich habe zwar nicht die gleichen Probleme, aber nach dem Update auf CentOS 7.4 hängt sich das opsiconfd beim Herunterladen der Anwendung auf. Ich Opsiconfd Log ist dann folgendes zu sehen:

Code: Alles auswählen

[7] [Sep 25 11:17:24] [twisted] Request error: Connection to the other side was lost in a non-clean fashion. (Logger.py|257)


Client und Serverseite haben beide Java 8 Update 144.

Ich habe allerdings einen Workaround gefunden: Wenn ich den Opsiconfd Dienst ,währenddessen ich auf "Anwendung wird heruntergeladen" warte, neustarte, kommt sofort das Anmeldefenster vom Opsiconfd.


Grüße
Karl der Heinz!

Benutzeravatar
n.wenselowski
Beiträge: 2526
Registriert: 04 Apr 2013, 12:15

Re: Update auf CentOS 7.4

Beitragvon n.wenselowski » 25 Sep 2017, 14:01

Hi,

ohne eine konkrete Fehlermeldung ist es für uns grundsätzlich schwer nachzuvollziehen wo das Problem liegt, da unsere Glaskugeln leider gerade in der Wartung sind ;)

Das was Karl der Heinz beschreibt klingt nach dem Problem mit TLS, welches gelegentlich auftaucht.
Wir haben dazu vielleicht eine Lösung über eine Einschränkung der zu verwendenden Ciphern gefunden. Bis dahin bitte ich unter viewtopic.php?p=42325#p42325 zu lesen wie mit dem Fehler umgegangen werden kann.


Gruß

Niko
Kein Support per DM!
_________________________
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.

Tobei
Beiträge: 18
Registriert: 10 Dez 2010, 00:29
Kontaktdaten:

Re: Update auf CentOS 7.4

Beitragvon Tobei » 27 Sep 2017, 21:34

n.wenselowski hat geschrieben:ohne eine konkrete Fehlermeldung ist es für uns grundsätzlich schwer nachzuvollziehen wo das Problem liegt, da unsere Glaskugeln leider gerade in der Wartung sind ;)

Schon klar, aber wie gesagt ich poste kein Log in dem IP-Adressen und anderer Kram drin steht mal so eben in einem öffentlichen Forum. ;)

n.wenselowski hat geschrieben:Das was Karl der Heinz beschreibt klingt nach dem Problem mit TLS, welches gelegentlich auftaucht.
Wir haben dazu vielleicht eine Lösung über eine Einschränkung der zu verwendenden Ciphern gefunden. Bis dahin bitte ich unter viewtopic.php?p=42325#p42325 zu lesen wie mit dem Fehler umgegangen werden kann.

Das Problem kennen wir bereits, allerdings reichte es bei uns bisher aus den opsi configed editor lokal von der Festplatte aus zu starten. Ich werde aber mal den Parameter

Code: Alles auswählen

-Dhttps.protocols=TLSv1

ausprobieren.

Gruß Tobias

Tobei
Beiträge: 18
Registriert: 10 Dez 2010, 00:29
Kontaktdaten:

Re: Update auf CentOS 7.4

Beitragvon Tobei » 27 Sep 2017, 22:10

Hi,

Tobei hat geschrieben:Ich werde aber mal den Parameter

Code: Alles auswählen

-Dhttps.protocols=TLSv1

ausprobieren.

das war die Lösung des Problems. Hatte in meinem Fall wohl damit zu tun, dass beim Update auf CentOS 7.4 sich irgendetwas geändert, was den Parameter dann zumindest bei mir notwendig gemacht hat.

Gruß Tobias


Zurück zu „Bugs“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast