Seite 1 von 1

Update auf opsi-client-agent 4.0.7.20 schlägt fehl

Verfasst: 06 Sep 2017, 17:10
von kinzi
Hallo,

ich wollte eben den opsi-client-agent 4.0.7.19 von 22.08.2017 installieren wegen dem bekannten Bug mit Windows 10 und dem Loginblocker. Jetzt gibt es aber schon 4.0.7.20 vom 25.08.2017. Wenn ich diese Version installiere, schlägt das setup fehl:

Code: Alles auswählen

Restoring previous files...
chmod: cannot access `/var/lib/opsi/depot/opsi-client-agent/files/opsi/dist/notifier/event.bmp.template': No such file or directory
   moving /var/lib/opsi/depot/opsi-client-agent/../opsi-client-agent.tmp/event.bmp to /var/lib/opsi/depot/opsi-client-agent/files/opsi/dist/notifier/event.bmp
mv: cannot move `/var/lib/opsi/depot/opsi-client-agent/../opsi-client-agent.tmp/event.bmp' to `/var/lib/opsi/depot/opsi-client-agent/files/opsi/dist/notifier/event.bmp': No such file or directory

Der Grund: Das Verzeichnis ...

Code: Alles auswählen

/var/lib/opsi/depot/opsi-client-agent/files/opsi/dist/

... existiert in der 4.0.7.20 offensichtlich nicht mehr und wurde durch die Verzeichnisse ...

Code: Alles auswählen

drwxrwx---  8 opsiconfd pcpatch 4.0K Sep  6 16:44 dist.nt5/
drwxrwx---  7 opsiconfd pcpatch 4.0K Sep  6 16:44 dist.win10/
drwxrwx---  7 opsiconfd pcpatch 4.0K Sep  6 16:44 dist.win7/
drwxrwx---  7 opsiconfd pcpatch 4.0K Sep  6 16:44 dist.win8/
drwxrwx---  7 opsiconfd pcpatch 4.0K Sep  6 16:44 dist.win81/

... ersetzt, wodurch das postinstall-script fehlschlägt, wenn es die gesicherten Dateien des customizing zurückspielen will.

Installiert war bisher von 4.0.7.7. Ich habe jetzt 4.0.7.15 aus dem Stable-Zweig installiert, da klappt die Installation. Kann es sein, dass da was umgebaut wurde? Auch bei 4.0.7.15 sind bereits dist.xy-Verzeichnisse dazugekommen, wie es scheint.

Bitte um Überprüfung.

Re: Update auf opsi-client-agent 4.0.7.20 schlägt fehl

Verfasst: 13 Sep 2017, 18:21
von d.oertel
Hallo kinzi,

Danke für den Hinweis.

Das sollte die Fixes enthalten:
http://download.uib.de/opsi4.0/experimental/opsi-v407/products/localboot/opsi-client-agent_4.0.7.23-1.opsi

gruß
detlef oertel

Re: Update auf opsi-client-agent 4.0.7.20 schlägt fehl

Verfasst: 04 Okt 2017, 12:28
von kinzi
Euch herzlichen Dank für's Fixen! :D