"del" Funktion nach Winst-Update

zylex
Beiträge: 43
Registriert: 23 Jan 2013, 08:55

"del" Funktion nach Winst-Update

Beitragvon zylex » 18 Jul 2017, 09:33

Hallo Forum,

seit einem Winst-Update auf meinem Testclient funktioniert bei meiner Firefox Installation das Löschen der Addons nicht mehr.

In meinem Script werden erst die Benutzerprofile ausgelesen, dann wird der Pfad zu den Firefox Addons pro Benutzerprofil erstellt, und danach werden in diesem Ordner alle .xpi Dateien gelöscht. Unter 4.11.4.21 (was meine alte Winst-Testversion war) hat das noch problemlos funktioniert, bei der neuen Winst-Version funktioniert das Löschen aber nicht mehr.

Nachdem der Pfad erstellt wurde (was in beiden Fällen funktioniert), ist der Aufruf zum löschen recht simpel:
[Files_Delete_Extensions]
del $prefs_path$\*.xpi

Anbei das Log der alten Version ab dem Punkt wo es ans löschen geht:

Code: Alles auswählen

[1] [Jul 18 08:43:55:746] opsi-winst 4.11.4.21 started at 18.07.2017 08:43:37
[...]       
[5] [Jul 18 08:44:50:389]           Execution of Files_Delete_Extensions
[7] [Jul 18 08:44:50:390]             del C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles/6et4nc7y.default\extensions\*.xpi
[9] [Jul 18 08:44:50:391]             r:C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles/6et4nc7y.default\extensions\*.xpi
[8] [Jul 18 08:44:50:392]             we try to delete: C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles\6et4nc7y.default\extensions\*.xpi
[6] [Jul 18 08:44:50:394]             Delete "C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles\6et4nc7y.default\extensions\*.xpi"
[6] [Jul 18 08:44:50:395]               Search "C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles\6et4nc7y.default\extensions\"
[6] [Jul 18 08:44:50:396]               File "C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles\6et4nc7y.default\extensions\cck2wizard@kaply.com.xpi"
[6] [Jul 18 08:44:50:397]                 The file has been deleted
[6] [Jul 18 08:44:50:398]               File "C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles\6et4nc7y.default\extensions\uBlock0@raymondhill.net.xpi"
[6] [Jul 18 08:44:50:400]                 The file has been deleted
[6] [Jul 18 08:44:50:401]         Else
[6] [Jul 18 08:44:50:402]         EndIf
[6] [Jul 18 08:44:50:403]       EndIf



Wie man sieht werden beide .xpi Dateien problemlos gelöscht. Nun das selbe Spiel aber mit der neuen Winst-version 4.11.6.12:

Code: Alles auswählen

[1] [Jul 18 09:04:51:123] opsi-script 4.11.6.12 started at 18.07.2017 09:04:22
[...]     
[5] [Jul 18 09:06:02:200]             Execution of Files_Delete_Extensions
[7] [Jul 18 09:06:02:201]               del C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles/6et4nc7y.default\extensions\*.xpi
[9] [Jul 18 09:06:02:202]               r:C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles/6et4nc7y.default\extensions\*.xpi
[9] [Jul 18 09:06:02:203]               No Getstring: " or ' expected
[9] [Jul 18 09:06:02:204]               after Getstring: rem : C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles/6et4nc7y.default\extensions\*.xpi expr:
[9] [Jul 18 09:06:02:205]               after DivideAtFirst: rem :  expr: C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles/6et4nc7y.default\extensions\*.xpi
[8] [Jul 18 09:06:02:206]               Remaining before Options:
[8] [Jul 18 09:06:02:207]               Expressionstr before Options: C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles/6et4nc7y.default\extensions\*.xpi
[8] [Jul 18 09:06:02:208]               Remaining:
[8] [Jul 18 09:06:02:209]               Expressionstr: C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles/6et4nc7y.default\extensions\*.xpi
[8] [Jul 18 09:06:02:210]               we try to delete: C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles/6et4nc7y.default\extensions\*.xpi
[8] [Jul 18 09:06:02:211]               we try to delete: C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles\6et4nc7y.default\extensions\*.xpi
[6] [Jul 18 09:06:02:212]               Delete "C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles\6et4nc7y.default\extensions\*.xpi"
[5] [Jul 18 09:06:02:213]               Notice: File or Directory C:\Users\Administrator\AppData\Roaming\Mozilla\Firefox\Profiles\6et4nc7y.default\extensions\*.xpi does not exist, nothing deleted
[6] [Jul 18 09:06:02:214]           Else
[6] [Jul 18 09:06:02:215]           EndIf
[6] [Jul 18 09:06:02:216]         EndIf


Wie man dort sieht wird nichts gelöscht, für mich sieht es so aus als wird nun in diesem Ordner nicht mehr nach *.xpi gesucht, es fehlt ja auch der "Search" Eintrag des ersten Logs. Was die anderen neuen Einträge bedeuten ist mir leider nicht ganz klar. Jemand eine Idee?

Grüße

zylex
Beiträge: 43
Registriert: 23 Jan 2013, 08:55

Re: "del" Funktion nach Winst-Update

Beitragvon zylex » 24 Jul 2017, 09:09

Ok, ich habe es selber herausgefunden, man muss "delete" anstatt "del" nehmen. Bei "delete" muss man aber wiederum bei Ordnern aufpassen, ist dieser nicht vorhanden wird das komplette Verzeichnis danach durchsucht, was die Script-Laufzeit unnötig verlängert.

Benutzeravatar
SisterOfMercy
Beiträge: 908
Registriert: 22 Jun 2012, 19:18

Re: "del" Funktion nach Winst-Update

Beitragvon SisterOfMercy » 29 Jul 2017, 13:11

del should still work by the way.
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

Benutzeravatar
n.wenselowski
Beiträge: 2860
Registriert: 04 Apr 2013, 12:15

Re: "del" Funktion nach Winst-Update

Beitragvon n.wenselowski » 25 Aug 2017, 13:26

Hi,

bei Delete und del gibt es einen kleinen Unterschied, aber ich hätte gesagt bei dem verwendeten Code trifft der nicht zu.

Ich leite das mal weiter in Richtung winst-Entwicklung.


Viele Grüße

Niko

PS: mal verschoben, weil ein geändertes Verhalten für mich eher nach Bug aussieht.
Kein Support per DM!
_________________________
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.

Benutzeravatar
d.oertel
Beiträge: 3255
Registriert: 04 Jun 2008, 14:27

Re: "del" Funktion nach Winst-Update

Beitragvon d.oertel » 25 Aug 2017, 15:09

Hallo,

ich kann das Problem bestätigen.
Es tritt auf wenn die Filemaske einen Teil-Wildcard hat (xyz.* oder *.xyz).

Hier sind die fixes:
http://download.uib.de/opsi4.0/experimental/opsi-v407/products/localboot/opsi-winst_4.11.6.15-1.opsi
bzw.
http://download.uib.de/opsi4.0/experimental/opsi-v407/products/localboot/opsi-winst_4.12.0.2-1.opsi

Feedback welcome ....

gruss
detlef oertel
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org