Problem OPSI WAN Erweiterung 4.0.7.7-1

dbeitz
Beiträge: 4
Registriert: 12 Sep 2016, 12:30
Wohnort: Hamburg
Kontaktdaten:

Problem OPSI WAN Erweiterung 4.0.7.7-1

Beitragvon dbeitz » 12 Sep 2016, 12:50

Hallo zusammen,

seit dem Update auf OPSI 4.0.7 haben wir Probleme mit allen unseren WAN Clients. Das Timer Event stürzt mit folgender Fehlermeldung ab:

Code: Alles auswählen

[ config cache service          ]      ==>>> SQLError: near ",": syntax error   (CacheService.pyo|222)


Anbei noch das komplette Log des Events:

Code: Alles auswählen

[5] [Sep 12 12:18:04] [ event processing timer        ] ============= EventProcessingThread for occurrcence of event 'timer' started =============   (EventProcessing.pyo|1116)
[5] [Sep 12 12:18:04] [ opsiclientd                   ] Block login now set to 'False'   (Opsiclientd.pyo|109)
[5] [Sep 12 12:18:04] [ event processing timer        ] Starting notification server on port 44003   (EventProcessing.pyo|194)
[6] [Sep 12 12:18:04] [ opsiclientd                   ] Notification server starting   (Message.pyo|594)
[5] [Sep 12 12:18:05] [ event processing timer        ] Notification server started   (EventProcessing.pyo|221)
[6] [Sep 12 12:18:05] [ event processing timer        ] Action processor name 'opsi-script', version '4.11.6.2'   (EventProcessing.pyo|351)
[5] [Sep 12 12:18:05] [ opsiclientd                   ] Block login now set to 'False'   (Opsiclientd.pyo|109)
[5] [Sep 12 12:18:05] [ config cache service          ] Creating opsi base   (SQL.pyo|462)
[5] [Sep 12 12:18:05] [ config cache service          ] Creating opsi base   (SQL.pyo|462)
[2] [Sep 12 12:18:05] [ config cache service          ] Traceback:   (Logger.pyo|753)
[2] [Sep 12 12:18:05] [ config cache service          ]   File "ocdlibnonfree\CacheService.pyo", line 216, in __init__
   (Logger.pyo|753)
[2] [Sep 12 12:18:05] [ config cache service          ]   File "ocdlibnonfree\CacheService.pyo", line 261, in initBackends
   (Logger.pyo|753)
[2] [Sep 12 12:18:05] [ config cache service          ]   File "OPSI\Backend\SQL.pyo", line 994, in backend_createBase
   (Logger.pyo|753)
[2] [Sep 12 12:18:05] [ config cache service          ]   File "OPSI\Backend\SQLite.pyo", line 223, in execute
   (Logger.pyo|753)
[2] [Sep 12 12:18:05] [ config cache service          ]   File "c:\apsw\src\cursor.c", line 1019, in APSWCursor_execute.sqlite3_prepare
   (Logger.pyo|753)
[2] [Sep 12 12:18:05] [ config cache service          ]   File "c:\apsw\src\statementcache.c", line 386, in sqlite3_prepare
   (Logger.pyo|753)
[2] [Sep 12 12:18:05] [ config cache service          ]      ==>>> SQLError: near ",": syntax error   (CacheService.pyo|222)
[5] [Sep 12 12:18:05] [ event processing timer        ] Writing log to service   (EventProcessing.pyo|257)
[4] [Sep 12 12:18:05] [ event processing timer        ] Cannot write log to service: not connected   (EventProcessing.pyo|260)
[5] [Sep 12 12:18:05] [ opsiclientd                   ] Shutdown request in Registry: 0   (Windows.pyo|327)
[5] [Sep 12 12:18:05] [ opsiclientd                   ] Reboot request in Registry: 0   (Windows.pyo|311)
[5] [Sep 12 12:18:05] [ opsiclientd                   ] Block login now set to 'False'   (Opsiclientd.pyo|109)
[6] [Sep 12 12:18:05] [ event processing timer        ] Stopping notification server   (EventProcessing.pyo|235)
[6] [Sep 12 12:18:06] [ event processing timer        ] Notification server stopped   (Message.pyo|636)
[3] [Sep 12 12:18:06] [ event processing timer        ] Failed to process event <ocdlib.Events.TimerEvent object at 0x01C979B0>: SQLError: near ",": syntax error   (EventProcessing.pyo|1266)
[2] [Sep 12 12:18:06] [ event processing timer        ] Traceback:   (Logger.pyo|753)
[2] [Sep 12 12:18:06] [ event processing timer        ]   File "ocdlib\EventProcessing.pyo", line 1158, in run
   (Logger.pyo|753)
[2] [Sep 12 12:18:06] [ event processing timer        ]   File "ocdlibnonfree\CacheService.pyo", line 88, in syncConfigToServer
   (Logger.pyo|753)
[2] [Sep 12 12:18:06] [ event processing timer        ]   File "ocdlibnonfree\CacheService.pyo", line 68, in initializeConfigCacheService
   (Logger.pyo|753)
[2] [Sep 12 12:18:06] [ event processing timer        ]   File "ocdlibnonfree\CacheService.pyo", line 227, in __init__
   (Logger.pyo|753)
[2] [Sep 12 12:18:06] [ event processing timer        ]      ==>>> SQLError: near ",": syntax error   (EventProcessing.pyo|1267)
[5] [Sep 12 12:18:06] [ opsiclientd                   ] Block login now set to 'False'   (Opsiclientd.pyo|109)
[5] [Sep 12 12:18:06] [ event processing timer        ] ============= EventProcessingThread for event 'timer' ended =============   (EventProcessing.pyo|1276)
[5] [Sep 12 12:18:06] [ opsiclientd                   ] Done processing event '<ocdlib.Events.TimerEvent object at 0x01C979B0>'   (Opsiclientd.pyo|419)


Ist dieser Fehler schon bekannt, bzw. hat jemand eine Lösung für dieses Problem?

Auf dem Server (debian8 x64) sind folgende Pakete installiert:

Code: Alles auswählen

ii  opsi-atftpd                    0.7.dfsg-6                  amd64        advanced TFTP server - opsi version with pcre, fifo and max-blksize patches
ii  opsi-configed                  4.0.7.1.3-1                 all          OPSI config editor
ii  opsi-depotserver               4.0.6.7-2                   all          opsi depotserver configuration package
ii  opsi-linux-bootimage           20160706-1                  amd64        opsi bootimage for netboot tasks.
ii  opsi-utils                     4.0.7.5-1                   all          utilites for working with opsi.
ii  opsiconfd                      4.0.7.4-1                   all          opsi configuration service
ii  opsipxeconfd                   4.0.7.1-1                   all          opsi pxe configuration daemon
ii  python-opsi                    4.0.7.17-1                  all          opsi python library


Alle anderen normalen Clients funktionieren ohne Probleme.

Gruß aus Hamburg

Dennis

dbeitz
Beiträge: 4
Registriert: 12 Sep 2016, 12:30
Wohnort: Hamburg
Kontaktdaten:

Re: Problem OPSI WAN Erweiterung 4.0.7.7-1

Beitragvon dbeitz » 12 Sep 2016, 12:54

Nachtrag: Eine "on_demand" Installation funktioniert ebenfalls ohne Probleme bei den WAN Clients.

Gruß

Dennis

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3120
Registriert: 04 Apr 2013, 12:15

Re: Problem OPSI WAN Erweiterung 4.0.7.7-1

Beitragvon n.wenselowski » 14 Sep 2016, 09:11

Hi Dennis,

welche Version des opsi-client-agent wird eingesetzt?
Welches OS läuft auf den Clients?
Kannst du uns ein Log mit Loglevel 8 von so einem Client zukommen lassen?

Um dein Problem anzugehen würde ich mal versuchen die SQLite-Datien aus dem Cache-Verzeichnis zu löschen.


Gruß

Niko

PS: Wir bieten auch professionellen Support an, wenn dringende Hilfe gefordert ist ;)
opsi development - uib gmbh
For productive opsi installations we recommend support contracts.

dbeitz
Beiträge: 4
Registriert: 12 Sep 2016, 12:30
Wohnort: Hamburg
Kontaktdaten:

Re: Problem OPSI WAN Erweiterung 4.0.7.7-1

Beitragvon dbeitz » 14 Sep 2016, 16:10

Moin Niko,

die opsi-client-agent Version ist 4.0.7.7.
Auf den Clients läuft Windows 10 Pro 1511 x64. (aktuelles Patch-Level).

Ich habe die Lösung test weise mal bei einem Client ausprobiert. Läuft! :)

Das Event läuft wieder wie gewollt und der Client kontaktiert das Depot wieder regelmäßig.

Vielen Dank für die schnelle Hilfe.

Ich suche mir morgen noch mal einen "defekten" Client raus und erstelle das Log auf Level 8.

Gruß

Dennis

Benutzeravatar
ueluekmen
uib-Team
Beiträge: 1889
Registriert: 28 Mai 2008, 10:53

Re: Problem OPSI WAN Erweiterung 4.0.7.7-1

Beitragvon ueluekmen » 15 Sep 2016, 09:35

Hi,

bei so einem Problem wäre es auch klasse, wenn wir so eine "kaputte" sqlite-db mal bekommen könnten. Dann können wir versuchen das nach zu Stellen und analysieren, wo das Problem entsteht. Wir haben bisher nur eine Meldung gehabt, die auch das selbe Problem auf einem Client hatten und auf dem selben Weg das Problem gelöst haben.
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.
http://www.uib.de

dbeitz
Beiträge: 4
Registriert: 12 Sep 2016, 12:30
Wohnort: Hamburg
Kontaktdaten:

Re: Problem OPSI WAN Erweiterung 4.0.7.7-1

Beitragvon dbeitz » 21 Sep 2016, 09:22

Moin zusammen,

hat etwas länger gedauert als erwartet, aber hier nun die Dateien. :)

In der ZIP Datei findet ihr einmal das komplette LOG auf Stufe 8 plus aller SQL Lite Dateien.

Link: https://owncloud.frachtcontor.de/index. ... H4fBgqR4tL
Pass: OPSI.01

Der Download ist nur 2 Wochen verfügbar. Danach läuft die Freigabe ab.

Gruß

Dennis

Benutzeravatar
ueluekmen
uib-Team
Beiträge: 1889
Registriert: 28 Mai 2008, 10:53

Re: Problem OPSI WAN Erweiterung 4.0.7.7-1

Beitragvon ueluekmen » 21 Sep 2016, 11:38

Vielen Dank für die Unterstützung. Wir haben die Daten bekommen. Wir werden versuchen die Daten zu analysieren.
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.
http://www.uib.de

Der-Matze
Beiträge: 66
Registriert: 16 Mär 2009, 11:00

Re: Problem OPSI WAN Erweiterung 4.0.7.7-1

Beitragvon Der-Matze » 27 Sep 2016, 11:28

Wir haben hier exakt das selbe Problem. Ich habe ein Supportticket aufgemacht und ebenfalls Log- und SQlite Dateien angehängt.

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3120
Registriert: 04 Apr 2013, 12:15

Re: Problem OPSI WAN Erweiterung 4.0.7.7-1

Beitragvon n.wenselowski » 10 Okt 2016, 15:39

Hi,

FYI: wir wissen wo genau der Fehler liegt und arbeiten gerade an einem Fix, dass der opsiclientd kein Problem mehr hat.


Gruß

Niko
opsi development - uib gmbh
For productive opsi installations we recommend support contracts.

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3120
Registriert: 04 Apr 2013, 12:15

Re: Problem OPSI WAN Erweiterung 4.0.7.7-1

Beitragvon n.wenselowski » 17 Okt 2016, 10:33

Hi,

die neue Version aus testing behebt das Problem hoffentlich.
Feedback hierzu erwünscht!


Viele Grüße

Niko
opsi development - uib gmbh
For productive opsi installations we recommend support contracts.