[fixed] opsi-client-agent 4.0.6.3-3

Benutzeravatar
Der-Matze
uib-Team
Beiträge: 69
Registriert: 16 Mär 2009, 11:00

[fixed] opsi-client-agent 4.0.6.3-3

Beitragvon Der-Matze » 07 Okt 2015, 09:13

Hallo zusammen,

ich habe einige Probleme mit dem aktuellsten opsi-client-agent.

1. Die Installation schlägt fehl wenn man bei der depends_on_service Property alle Einträge abwählt.

Code: Alles auswählen

 (13967)   [5] [Okt 07 08:53:34:394] [opsi-client-agent] Set  $OCD_depServicelist$ = emptyList($OCD_depServicelist$)
(13968)   [6] [Okt 07 08:53:34:395] [opsi-client-agent]     retrieving strings from $OCD_depServicelist$ [switch to loglevel 7 for debugging]
(13969)   [7] [Okt 07 08:53:34:395] [opsi-client-agent]         
(13970)   [6] [Okt 07 08:53:34:395] [opsi-client-agent]     retrieving strings from emptyList [switch to loglevel 7 for debugging]
(13971)   [7] [Okt 07 08:53:34:395] [opsi-client-agent]         
(13972)   [5] [Okt 07 08:53:34:395] [opsi-client-agent] comment: check if requested services are existing ....
(13973)   [6] [Okt 07 08:53:34:395] [opsi-client-agent]     retrieving strings from $INST_ResultList$ [switch to loglevel 7 for debugging]
(13974)   [7] [Okt 07 08:53:34:395] [opsi-client-agent]         
(13975)   [4] [Okt 07 08:53:34:395] [opsi-client-agent] Warning: list to loop through is empty - no loop ...
(13976)   [5] [Okt 07 08:53:34:395] [opsi-client-agent] Set  $OCD_depServices$ = composeString($OCD_depServicelist$,"|")
(13977)   [6] [Okt 07 08:53:34:396] [opsi-client-agent]     retrieving strings from $OCD_depServicelist$ [switch to loglevel 7 for debugging]
(13978)   [7] [Okt 07 08:53:34:396] [opsi-client-agent]         
(13979)   [3] [Okt 07 08:53:34:396] [opsi-client-agent] Exception in CreateAndProcessScript: Handling AktionslisteList index (-1) out of bounds


2. Nach erfolgreicher Installation wird beim Start des client-agents immer noch die Version 4.0.83 angezeigt und es kann keinerlei Software mehr installiert werden. Der client-agent startet, ruft die Konfiguration vom Server ab, verbindet das Netzlaufwerk und schließt sich daraufhin, ohne die angeforderte Software zu installieren. Im Log findet man folgenden Eintrag:

Code: Alles auswählen

(9307)    [3] [Okt 07 09:00:34:995] Error: retrieveJSONObject --- opsi service problem ----> {"message":"set([u'opsi-client-agent', u'apple_itunes', u'nodejs', u'adobe_reader', u'microsoft_vc_2010', u'adobe_flash_activex', u'image-einrichtung', u'dbvisualizer', u'mozillafirefox', u'java_jre8_x64', u'apple_mobile_device_support', u'paintnet', u'googledrive', u'apple_application_support', u'deploy_modifications', u'swaudit', u'python', u'admintools_hash_and_crc', u'shutdownwanted', u'inventory', u'hwaudit', u'libreoffice', u'teamviewer10', u'languagepacks', u'apple_bonjour', u'admintools_wuinstall', u'java_jre8_x86', u'adobe_acrobat_x', u'googlechrome', u'tortoise_git', u'java_jre7_x86', u'cdburnerxp', u'apple_quicktime', u'adobe_air', u'inventarisierung_silent', u'python3', u'mysysgit', u'java_jre7_x64', u'opsi-winst', u'setacl', u'adobe_flash_pluginbased', u'tortoise_svn', u'admintools_virtualbox', u'windows_config']) is not JSON serializable","class":"TypeError"}
(9308)    [3] [Okt 07 09:00:34:995] Received (first 512): {"id": 1, "result": null, "error": {"message": "set([u'opsi-client-agent', u'apple_itunes', u'nodejs', u'adobe_reader', u'microsoft_vc_2010', u'adobe_flash_activex', u'image-einrichtung', u'dbvisualizer', u'mozillafirefox', u'java_jre8_x64', u'apple_mobile_device_support', u'paintnet', u'googledrive', u'apple_application_support', u'deploy_modifications', u'swaudit', u'python', u'admintools_hash_and_crc', u'shutdownwanted', u'inventory', u'hwaudit', u'libreoffice', u'teamviewer10', u'languagepacks', u'apple
(


Der alte client-agent funktioniert einwandfrei.
Ich habe parallel ein Support Ticket aufgemacht und dort die kompletten Logs des Clients angehängt.

Vielen Dank schon einmal.
Schönen Gruß
Matze
Zuletzt geändert von Der-Matze am 07 Okt 2015, 10:58, insgesamt 1-mal geändert.

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3195
Registriert: 04 Apr 2013, 12:15

Re: opsi-client-agent 4.0.6.3-3

Beitragvon n.wenselowski » 07 Okt 2015, 09:50

Hallo,

damit auch das Forum informiert ist ;)

Zu 1.: Ist nicht empfohlen. Das Property ist gedacht bspw. für den Einsatz mit spezieller VPN-Software, die eigene Dienste für sowas hat und die Windows-Dienste dabei deaktiviert.


Gruß

Niko

Code: Alles auswählen

import OPSI

Benutzeravatar
Der-Matze
uib-Team
Beiträge: 69
Registriert: 16 Mär 2009, 11:00

Re: opsi-client-agent 4.0.6.3-3

Beitragvon Der-Matze » 07 Okt 2015, 10:31

Danke für die schnelle Antwort.
Der Fehler ist mir auch nur beim Testen aufgefallen. Wir setzen das so auch nicht produktiv ein.
Ich dachte ich erwähne es nur mal.

Besten Dank schon mal.

Benutzeravatar
Der-Matze
uib-Team
Beiträge: 69
Registriert: 16 Mär 2009, 11:00

Re: [fixed] opsi-client-agent 4.0.6.3-3

Beitragvon Der-Matze » 07 Okt 2015, 11:03

Das Problem lag auf Serverseite.
Vielen Dank für den schnellen Support im OPSI Chat!

Schöne Grüße
Matze

Benutzeravatar
n.wenselowski
uib-Team
Beiträge: 3195
Registriert: 04 Apr 2013, 12:15

Re: opsi-client-agent 4.0.6.3-3

Beitragvon n.wenselowski » 07 Okt 2015, 11:33

Hi,

Problem #2 kann mit einer aktualisierten Version von python-opsi (4.0.6.26) gelöst werden: https://build.opensuse.org/package/show ... ython-opsi


Gruß

Niko

Code: Alles auswählen

import OPSI