(Linux) Netboot friert auf aktueller AMD-Plattform ein

cgiesers
Beiträge: 24
Registriert: 22 Feb 2017, 02:11

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon cgiesers » 17 Apr 2019, 01:42

Also dann mal ein Update von mir:
# wget http://download.opensuse.org/repositori ... -3_all.deb
[...]
# dpkg -i opsi-linux-bootimage_20190325-3_all.deb
(Lese Datenbank ... 37566 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von opsi-linux-bootimage_20190325-3_all.deb ...
Entpacken von opsi-linux-bootimage (20190325-3) über (20190227-1) ...
opsi-linux-bootimage (20190325-3) wird eingerichtet ...

Das Verhalten bleibt identisch: Bildschirm bleibt schwarz, nix passiert.

Benutzeravatar
m.radtke
uib-Team
Beiträge: 841
Registriert: 10 Jun 2015, 12:19

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon m.radtke » 17 Apr 2019, 12:13

Hi

es wird ein Update geben, nur bin ich gerade voll mit Arbeit die aktuell eine höhere Priorität hat.
Ein anderer User meinte der Bildschirm ist zwar schwarz aber das Produkt installiert dennoch und irgendwann startet die Maschine neu.
Ist die Maschine per SSH erreichbar?
Benutzername: root; passwort: linux123
Wenn ja, kannst du dich auch in die anzuzeigende Grafik einhängen mit dem Befehl der im MOTD steht und von da aus weiter machen

Ich habe es nicht vergessen.

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

cgiesers
Beiträge: 24
Registriert: 22 Feb 2017, 02:11

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon cgiesers » 18 Apr 2019, 02:31

Hallo!

Der Eintrag von maxmem und das einloggen via SSH um die Konsole zu holen und das Setup zu starten haben funktioniert - aber nur in Kombination.

Allerdings ist opsi-Configed local noch buggy: Der hinterlegte Eintrag für das Linux Bootimage ist nach einem Reload nicht sichtbar.

Gruß
- Christof

Benutzeravatar
m.radtke
uib-Team
Beiträge: 841
Registriert: 10 Jun 2015, 12:19

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon m.radtke » 18 Apr 2019, 09:41

Moin,

der locale configed ist auch eine alter Version, besser ist es auf einem Client den configed auszurollen und die aktuelle Version zu verwenden.

Hast du die Installation manuel gestartet oder hast Du den 'dtach...' Befehl abgeschickt?

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

Benutzeravatar
m.radtke
uib-Team
Beiträge: 841
Registriert: 10 Jun 2015, 12:19

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon m.radtke » 26 Apr 2019, 13:57

Hi

im experimental Bereich gibt es ein neues Bootimage mit aktuellerem Kernel und einem weiteren Modul für AMD Geräte.

Liebe Grüße
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

SimonHSG
Beiträge: 7
Registriert: 17 Jul 2018, 11:37

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon SimonHSG » 30 Apr 2019, 15:11

Hallo Zusammen ich habe jetzt folgendes Packet installiert:

dpkg -i opsi-linux-bootimage_20190426-7_all.deb für debian 9

Leider ohne Erfolg. Bei mir hängt es im Bootimage bei: "[OK]Reached targed Sound Card"

Ich habe folgenden PC: Dell OptiPlex 5055 Ryzen APU mit der CPU "AMD Ryzen 5 Pro 2400G"

sollte Sie noch ein paar Info brauchen, kann ich diese gerne liefern.

EDIT: UEFI Boot wird verwendet(kann nur verwendet werden bei den neuen Dell PCs)

Gruß SimonHSG

SimonHSG
Beiträge: 7
Registriert: 17 Jul 2018, 11:37

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon SimonHSG » 06 Mai 2019, 09:11

Nochmal als Info:

ich habe jetzt die verschiedene Opsi-Client-Boot-CDs getestet.

Bis zur Version opsi4.1.0-client-boot-cd_20180928 funktioniert es mit meinem Ryzen Rechner einwandfrei.

Alles was danach kommt bootet nicht(siehe letzten Eintrag von mir)

Ich hoffe das hilft bei der Fehlersuche.

Kann man beim Opsi Server diese alte Version wieder einspielen? Wenn ja, woher bekomme ich diese Version her?

Gruß SimonHSG

Benutzeravatar
m.radtke
uib-Team
Beiträge: 841
Registriert: 10 Jun 2015, 12:19

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon m.radtke » 06 Mai 2019, 11:51

Hi

Danke für den Hinweis.
Du kannst den kernel und die miniroot der CD nehmen und diese im Verzeichnis /tftpboot/linux auf deinem Server austauschen. Dann hast du das Bootimage, das für Deinen Ryzen Rechner läuft.
In der Zwischenzeit wurde hauptsächlich der Kernel aktualisiert und es sind meistens keine neuen Module hinzugekommen, von denen ich jetzt sagen würde, das diese in Korrelation zu diesem Fehler stehen.
Ich schaue bei Gelegenheit noch mal rein, kann aber nicht genau sagen wann ich dazu komme.

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

cgiesers
Beiträge: 24
Registriert: 22 Feb 2017, 02:11

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon cgiesers » 18 Jun 2019, 01:14

m.radtke hat geschrieben:Moin,

der locale configed ist auch eine alter Version, besser ist es auf einem Client den configed auszurollen und die aktuelle Version zu verwenden.

Hast du die Installation manuel gestartet oder hast Du den 'dtach...' Befehl abgeschickt?

Gruß
Mathias


Hallo Mathias!

Entschuldige die späte Antwort, der PC war fertig und ich musste mich anderem widmen...
IIRC: Ich hatte mich via SSH verbunden und mit dem Befehl aus'm MOTD die Konsole "rübergeholt". Das hat einwandfrei funktioniert.

Aktuell habe ich wieder einen Ryzen vor mir, nachdem ich mit dem 201903er Image wieder Ärger hatte, habe ich den mem-Parameter gesetzt und das Image gleichzeitig auf opsi-linux-bootimage_20190522-1_all aktualisiert.
Damit Du auch hilfreicheres Feedback hast: Das Image ohne den mem-Parameter bleibt nach dem Laden des Kernels stehen:

Code: Alles auswählen

........................
Not enough memory to load specified image.
boot:


Mit dem 03er Kernel ist er direkt in den reboot gegangen.

Die Kombination aus 20190522 und mem=2048M funktioniert:
Nach einigen Sekunden schwarzer Bildschirm erscheinen die OPSI logos und er arbeitet sich bis ins Menü vor.
Wobei er eine Weile mit dem großen OPSI Logo (und dem Hinweis auf das 64 Bit Image) stehen bleibt.

m.radtke hat geschrieben:Moin,
der locale configed ist auch eine alter Version, besser ist es auf einem Client den configed auszurollen und die aktuelle Version zu verwenden.


Ich verwende dazu - seit jeher - den "opsi config editor" für Windows - in aktueller Version (aktuell 4.0.7.8.6).
Der Parameter rechts wird zwar angezeigt, der Stamm hat aber nach wie vor keinen Namen.

tl;dr: 20190522 + mem=2048M funktionieren!
Wäre schön, wenn man den Parameter nicht mehr händisch bei den neuen Clients eintragen muss. ;)

Gruß
- Christof

cgiesers
Beiträge: 24
Registriert: 22 Feb 2017, 02:11

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon cgiesers » 05 Okt 2019, 03:54

Nachdem ich von opsi-linux-bootimage_20190522-1_all auf opsi-linux-bootimage_20190923-4_all gesprungen bin, hatte ich mit einem AMD-System wieder Probleme: Das System blieb mit dem großen OPSI-Logo stehen.
Ein Druck auf Escape brachte dann die aussagendere Konsole hervor (eine Uploadfunktion für Screenshots wäre immer noch hilfreich!):

Code: Alles auswählen

[FAILED] Failed to start Dispatcher daemon for systemd-networkd.
[FAILED] Failed to start Set console scheme.


Die letzte Zeile - bei der er dann hängen blieb war:

Code: Alles auswählen

[  OK  ] Reached target Multi-User System.


Das System blieb über mehrere Stunden in dem Zustand.
Der Rücksprung zum Mai-Image hat das Problem behoben.

Getestet auf:
Name AMD A6-7470K Radeon R5, 6 Compute Cores 2C+4G
Hersteller Gigabyte Technology Co., Ltd.
Modell F2A78M-HD2
Modell RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

Ob der Ryzen 3200G mit dem Mai-Image ebenfalls problemlos bootet muss ich noch testen, die September-Version war jedenfalls nicht gängig.

Nachtrag:
Beim Ryzen 3200G endet der Boot sehr schnell mit:

Code: Alles auswählen

Failed to execute /init (error -8)