Kleiner Fehler im windows10-upgrade-Paket

andré
Beiträge: 267
Registriert: 07 Jan 2014, 10:48

Kleiner Fehler im windows10-upgrade-Paket

Beitragvon andré » 02 Jul 2018, 14:25

Mir ist aufgefallen, dass nach dem Upgrade beim Wiederherstellen der Autologon-Daten zwar der vorher angemeldete Nutzername in einen entsprechenden Registry-Wert geschrieben wird, nach einem Neustart steht aber immer noch der opsiSetupUser auf der Windows-Loginseite.

Ihr schreibt in der Sektion [Registry_restore_autologon] den alten Benutzer im Schlüssel

Code: Alles auswählen

HKLM\Software\Microsoft\Windows\CurrentVersion\Authentication\LogonUI
in den Wert "LastLoggedOnUser". Das reicht aber nicht, es muss auch der Wert "LastLoggedOnSAMUser" geschrieben werden. Ich habe das ein paar mal getestet und bei mir reichte das aus, diese beiden Werte zu ändern.

Ich habe aber noch eine Quelle, laut der "LastLoggedOnDisplayName" und "LastLoggedOnUserSID" auch geändert, oder zumindest gelöscht werden müssen. War zumindest bei mir nicht der Fall.
https://gist.github.com/dbirks/ec4416c9 ... ee934efd71

Könntet ihr euer Upgrade-Paket bitte dahingehend anpassen?

Benutzeravatar
wolfbardo
uib-Team
Beiträge: 1114
Registriert: 01 Jul 2008, 12:10

Re: Kleiner Fehler im windows10-upgrade-Paket

Beitragvon wolfbardo » 03 Jul 2018, 12:53

Danke für den Hinweis

andré hat geschrieben:Das reicht aber nicht, es muss auch der Wert "LastLoggedOnSAMUser" geschrieben werden. Ich habe das ein paar mal getestet und bei mir reichte das aus, diese beiden Werte zu ändern.


Wird bei Gelegenheit eingebaut

Gruss
Bardo Wolf


opsi workshops in Mainz

Basis 16.-19.7.2019
Basis 4.-7.11.2019
Basis 09.-12.2019

Einführung in die Software-Paketierung 12.-13.11.2019

opsi support by uib gmbh

http://www.uib.de

andré
Beiträge: 267
Registriert: 07 Jan 2014, 10:48

Re: Kleiner Fehler im windows10-upgrade-Paket

Beitragvon andré » 03 Jul 2018, 13:58

super, danke.