(Linux) Netboot friert auf aktueller AMD-Plattform ein

cgiesers
Beiträge: 29
Registriert: 22 Feb 2017, 02:11

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon cgiesers » 15 Jan 2020, 21:13

Ich habe das Ganze jetzt mal auf einer Threadripper Plattform getestet: Leider ohne Erfolg.
- Gigabyte TRX40 AORUS PRO WIFI
- AMD Threadripper 3960X

Code: Alles auswählen

Nach clocksource: ...

Geht er die USB-Geräte durch und strandet bei:

Code: Alles auswählen

usb 5-6: Product: ITE Device(8595)
usb 5-6: Manufacturer: ITE Tech. Inc.


Danach bleibt er mit blinkendem Cursor in der linken unteren Ecke stehen.
OPSI meldet keine IP-Adresse zurück.

Numlock ist auch eingefroren.

Witzigerweise_ Stecke ich einen USB-Stick ein (Diese Installation muss ich ja wohl zu Fuß machen), so kommt eine neue USB-Meldung auf der Konsole:

Code: Alles auswählen

usb-storage 8-2:1.0: USB Mass Storage device detected
scsi host3: usb-storage 8-2:1.0


Also irgendwie lebt das Ding, aber es hängt.

Gruß
- Christof

HSchweizer
Beiträge: 10
Registriert: 15 Mai 2018, 19:04

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon HSchweizer » 01 Sep 2020, 12:43

smariedl hat geschrieben:Wir hatten/haben das gleiche Problem mit Thinkpads mit Ryzen-Prozessoren. Wir haben alle möglichen Tipps ausprobiert, mit acpi=off und mem und dem experimental image usw., es half alles nichts. Die Laptops blieben bei

Code: Alles auswählen

[  OK  ] Reached target SoundCard.
hängen und nahmen auch keine Tastatureingaben mehr an. Wir konnten uns also die lokalen Log-Files nicht angucken.

Bis wir dann auf die Idee kamen, wir versuchen es mal per SSH, aber wenn SSH auf dem Laptop läuft, ist's ja komisch, dass sonst nichts passiert. Dann haben wir mal versucht, was

Code: Alles auswählen

dtach -A /tmp/bootimage master.py
so anzeigt und uns in die laufende Session gehangen und siehe da, tatsächlich lief der Bootprozess komplett durch und fragte nach Betätigung oder Abbruch der OS Installation, nur auf dem Laptopdisplay war immer noch Standbild von der Konsole. Nach der Bestätigung lief die Installation reibungslos durch, nach dem Neustart war das Bild auch wieder "live".

Installiert ist jetzt noch das experimental image 20191211-1, wir testen in Bälde, ob es mit dem stable doch auch funktioniert.

Edit: stable 20191015-3 tut's auch.



Ich habe einen Win10-Netboot beim Lenovo ThinkPad L15 Gen1 (20U70006GE) mit AMD Ryzen 5 4500U versucht.

Habe sämtliche opsi-linux-bootimage.append Parameter erfolglos versucht und auch das neueste experimental opsi-linux-bootimage_20200824-1_all.deb.
Ohne einen Parameter und mit der aktuellen stable (opsi-linux-bootimage_20200506-1) erhält man das Verhalten wie oben beschrieben:

Die Notebook-Bildschirmanzeige hängt direkt beim Laden des "miniroot".
Tatsächlich läuft der Bootprozess aber weiter und ich kann die Installation (blind) mit F12 bestätigen. Die Installation läuft durch und nach dem Neustart wird auch wieder das Windows-Setup korrekt auf dem Notebook-Bilschirm angezeigt.

Kann dies beim nächsten opsi-linux-bootimage gefixt werden?
Danke. ;-)

Benutzeravatar
m.radtke
uib-Team
Beiträge: 923
Registriert: 10 Jun 2015, 12:19

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon m.radtke » 01 Sep 2020, 13:56

Hi

hast Du auch die folgenden aus diesem Thread ausprobiert? Alle zusammen
viewtopic.php?f=6&t=11826&p=51642&hilit=nomodeset#p51616

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

HSchweizer
Beiträge: 10
Registriert: 15 Mai 2018, 19:04

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon HSchweizer » 01 Sep 2020, 15:10

m.radtke hat geschrieben:Hi

hast Du auch die folgenden aus diesem Thread ausprobiert? Alle zusammen
viewtopic.php?f=6&t=11826&p=51642&hilit=nomodeset#p51616

Gruß
Mathias



Ja, inklusive acpi=off.

Benutzeravatar
m.radtke
uib-Team
Beiträge: 923
Registriert: 10 Jun 2015, 12:19

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon m.radtke » 01 Sep 2020, 20:31

ACPI=Off ist bei ryzen kontraproduktiv

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

HSchweizer
Beiträge: 10
Registriert: 15 Mai 2018, 19:04

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon HSchweizer » 02 Sep 2020, 09:48

Okay, danke für die Info.

Ohne hatte es aber auch nicht funktioniert.
Wie bereits erwähnt, hatte ich mehrere Kombinationen getestet.

smariedl
Beiträge: 2
Registriert: 07 Nov 2019, 12:28

Re: (Linux) Netboot friert auf aktueller AMD-Plattform ein

Beitragvon smariedl » 07 Sep 2020, 17:37

HSchweizer hat geschrieben:...
Tatsächlich läuft der Bootprozess aber weiter und ich kann die Installation (blind) mit F12 bestätigen. Die Installation läuft durch und nach dem Neustart wird auch wieder das Windows-Setup korrekt auf dem Notebook-Bilschirm angezeigt.
...


Das blinde F12-Drücken kann übrigens umgangen werden, indem in der Property-Konfiguration "askbeforeinst" auf "false" gesetzt wird. Dann kommt diese Abfrage eben nicht mehr und nach der Installation startet der Rechner ja eh neu und das Bild ist wieder live.