opsi-client-agent (4.1.xx) Installation per configed fehler (not elevated)

tb-killa
Beiträge: 53
Registriert: 22 Okt 2017, 16:59

opsi-client-agent (4.1.xx) Installation per configed fehler (not elevated)

Beitragvon tb-killa » 30 Nov 2018, 19:07

Uns ist auf Windows 10 1709 und höher (mit UAC an) folgendes aufgefallen.
Agent wird mittels service_setup.cmd installiert.
Mittels ocasub.ps1 wird die winst32.exe nun mit runas gestartet (elevated), sodass hier alles installiert wird.

Wenn nun ein Agent installiert ist, man aber mittels configed den Agenten wieder auf installieren setzt,
bricht der Prozess ab, sobald die nicht als elevated gestartete winst32.exe in sich selbst arbeiten möchte.

Der Prozess startet ja direkt mit der "files\opsi\setup.opsiscript".

Es scheitert bereits am kopieren der Daten auf C:\Program Files (x86)\opsi.org\opsi-client-agent\ denn dort hat es in diesem Moment keine Rechte.

Gibt es hierzu bereits einen Fix oder Workaround (ohne UAC zu deaktivieren!) ?

tb-killa
Beiträge: 53
Registriert: 22 Okt 2017, 16:59

Re: opsi-client-agent (4.1.xx) Installation per configed fehler (not elevated)

Beitragvon tb-killa » 03 Dez 2018, 12:25

Okay wir haben heute nochmals den Test mit einem NB Windows 10 Pro 1607 mit UAC an gemacht.
Der gleiche Fehler, sobald Files kopieren möchte, kommt der "Access violation" Fehler.

Somit gleichzusetzen mit: https://forum.opsi.org/viewtopic.php?f=7&t=10741

Gibt es die Möglichkeit "Files_" Befehle auch als "runElevated" zu starten ?

Grüße

uncle_scrooge
Beiträge: 510
Registriert: 21 Feb 2012, 12:03
Wohnort: Mainz

Re: opsi-client-agent (4.1.xx) Installation per configed fehler (not elevated)

Beitragvon uncle_scrooge » 06 Dez 2018, 17:40

Ich möchte meine Zweifel anmelden, daß Deine Probleme etwas mit der UAC zu tun haben.
Ich habe mal versucht, daß von Dir beschriebene Verhalten auf einem Win10 1803 nachzustellen. Erfolglos.

Spannend wäre, was auf euren Rechnern an 'Sicherheitssoftware' drauf ist. Und ob ein wie auch immer geartetes Hardening erfolgt.

tb-killa
Beiträge: 53
Registriert: 22 Okt 2017, 16:59

Re: opsi-client-agent (4.1.xx) Installation per configed fehler (not elevated)

Beitragvon tb-killa » 06 Dez 2018, 21:15

Hi danke für deine Rückmeldung.
Vorweg, wir installieren die Agenten per gpo mittels msi, welche letztendlich das selber macht wie die silent setup batch. Somit ist der Agent im System Kontext installiert. Wir hatten auch erst eine Verhaltensüberwachung im Verdacht aber auch dies ließ sich mit einer Deinstallation schnell verwerfen (TrendMicro).

Die eingesetzten Windows 10 Prof Systeme sind normal in einer Windows Domäne, aufgrund von Vorgaben auch UAC an. Ich nehme mal stark an dass es etwas mit den expliziten und dem implizierten Rechten zu tun hat.
Auch für das System Konto gilt wie bei der Administratoren Gruppe das UAC.
Ich kann Z.B. eine Datei nicht nach c:/Programme x86/blah kopieren, aber mittels Patch Text file die Datei dort direkt hinschreiben. Dies bestätigt indirekt meine Vermutung wegen den oben genannten Rechten.

Grüße

Benutzeravatar
wolfbardo
Beiträge: 1088
Registriert: 01 Jul 2008, 12:10

Re: opsi-client-agent (4.1.xx) Installation per configed fehler (not elevated)

Beitragvon wolfbardo » 07 Dez 2018, 10:54

Hallo
tb-killa hat geschrieben:Hi danke für deine Rückmeldung.
Vorweg, wir installieren die Agenten per gpo mittels msi, welche letztendlich das selber macht wie die silent setup batch.


Bitte mal testen ob es in Eurer Umgebung wirklich dasselbe macht.

Eventuell liegt das Problem auch nicht am UAC-Level sondern an der Art wie NTFS-Rechte bei Euch wie auch immer gesetzt werden?

Gruss
Bardo Wolf


opsi workshops in Mainz

Basis 3.-6.12.2018


opsi support by uib gmbh

http://www.uib.de