Netboot-Installation Fehler auf Dell-Notebook

andré
Beiträge: 250
Registriert: 07 Jan 2014, 10:48

Netboot-Installation Fehler auf Dell-Notebook

Beitragvon andré » 09 Aug 2018, 19:29

Ich habe ein Dell Notebook (Vostro 5568) auf dem sich keine Netbook-Produkte installieren lassen. Getestet habe ich Windows 7 und 10 (jeweils x64).

Nach dem Eintrag im Bootimage "We install to disk", bricht der Installer mit der Fehlermeldung "Expected WinPE Directory: winpe not found in /mnt/opsi/win7-x64" ab.

Das NIC bekommt eine IP, daran sollte es also nicht liegen. Die Pakete selber funktionieren auch, ich habe die vorsichtshalber noch an einem anderen Gerät erfolgreich getestet.

Die Fehlermeldung aus der bootimage.log:

Code: Alles auswählen

(820)     [7] [Aug 09 19:17:34] Transfer in from <httplib.HTTPResponse instance at 0x7f456df3bf80> to <open file u'/tmp/opsisetuplib.py', mode 'wb' at 0x7f456df404b0>, dynamic bandwidth False, max bandwidth 0 (Repository.py|373)
(821)     [7] [Aug 09 19:17:34] Filesize is: 42085 (Repository.py|384)
(822)     [6] [Aug 09 19:17:34] Transfered 41.10 kByte in 0.00 minutes, average speed was 38885.67 kByte/s (Repository.py|425)
(823)     [6] [Aug 09 19:17:34] Copy done (Repository.py|629)
(824)     [5] [Aug 09 19:17:34] ############################################################## (setup.py|38)
(825)     [5] [Aug 09 19:17:34] initOpsiSetupLib() (opsisetuplib.py|30)
(826)     [5] [Aug 09 19:17:34] OpsiSetupLib $Revision$ (opsisetuplib.py|31)
(827)     [5] [Aug 09 19:17:34] OpsiSetupLib $Date$ (opsisetuplib.py|32)
(828)     [5] [Aug 09 19:17:34] nt6.py (setup.py|40)
(829)     [5] [Aug 09 19:17:34] ############################################################## (setup.py|42)
(830)     [5] [Aug 09 19:17:34] Installing Product: win7-x64_4.1.0.0-10 on w10nb.domain (setup.py|50)
(831)     [5] [Aug 09 19:17:34] ############################################################## (setup.py|53)
(832)     [7] [Aug 09 19:17:34] Executing jsonrpc method 'productOnDepot_getIdents' on host u'IP' (JSONRPC.py|113)
(833)     [7] [Aug 09 19:17:34] Posting request... (JSONRPC.py|628)
(834)     [7] [Aug 09 19:17:34] Starting new HTTPS connection (1) to IP:4447 (HTTP.py|579)
(835)     [7] [Aug 09 19:17:34] Connection established to: IP (HTTP.py|581)
(836)     [7] [Aug 09 19:17:34] Closing connection: <httplib.HTTPSConnection instance at 0x7f456f3d8128> (HTTP.py|499)
(837)     [7] [Aug 09 19:17:34] Expecting deflated data from server (JSONRPC.py|651)
(838)     [5] [Aug 09 19:17:34] Installed opsi-script: opsi-winst_4.12.0.23  (setup.py|63)
(839)     [7] [Aug 09 19:17:34] Unfulfilled condition: Version(product=u'4.12.0.23', package=u'0') < Version(product=u'4.12.0.13', package=u'0') (__init__.py|514)
(840)     [5] [Aug 09 19:17:34] try to load efivars module: modprobe efivars (opsisetuplib.py|490)
(841)     [6] [Aug 09 19:17:34] Executing: /sbin/modprobe efivars (Posix.py|854)
(842)     [6] [Aug 09 19:17:34] Using encoding 'UTF-8' (Posix.py|887)
(843)     [7] [Aug 09 19:17:34] >>> modprobe: ERROR: could not insert 'efivars': No such device (Posix.py|931)
(844)     [7] [Aug 09 19:17:34] Exit code: 1 (Posix.py|938)
(845)     [5] [Aug 09 19:17:34] we are not running in uefi mode (opsisetuplib.py|494)
(846)     [5] [Aug 09 19:17:34] We install to disk (setup.py|77)
(847)     [5] [Aug 09 19:17:34] useRaid1 is False (setup.py|209)
(848)     [5] [Aug 09 19:17:34] preserve_winpe_partition is False (setup.py|214)
(849)     [5] [Aug 09 19:17:34] preserve_winpe_partition is False (setup.py|218)
(850)     [5] [Aug 09 19:17:34] Using installfiles_dir: installfiles (setup.py|225)
(851)     [5] [Aug 09 19:17:34] winpe_debug_cmd_exe = False (setup.py|249)
(852)     [5] [Aug 09 19:17:34] We use as administrator: Administrator (setup.py|326)
(853)     [2] [Aug 09 19:17:35] Traceback: (Logger.py|798)
(854)     [2] [Aug 09 19:17:35]   File "/usr/local/bin/master.py", line 1387, in <module>
(855)         execfile(actionScript)
(856)      (Logger.py|798)
(857)     [2] [Aug 09 19:17:35]   File "/tmp/setup.py", line 336, in <module>
(858)         raise Exception(u"Expected WinPE Directory: %s not found in %s" % (winpeDir,depotsource))
(859)      (Logger.py|798)
(860)     [2] [Aug 09 19:17:35]      ==>>> Expected WinPE Directory: winpe not found in /mnt/opsi/win7-x64 (master.py|1437)
(861)     [7] [Aug 09 19:17:35] Backend: <JSONRPCBackend(host=u'IP', deflate=True)> (master.py|1440)
(862)     [7] [Aug 09 19:17:35] ProductId: win7-x64 (master.py|1441)
(863)     [7] [Aug 09 19:17:35] ClientId: w10nb.domain (master.py|1442)
(864)     [7] [Aug 09 19:17:35] ProductOnClient: <ProductOnClient(clientId=u'w10nb.domain', productId=u'win7-x64', installationStatus=u'unknown', actionRequest=u'none')> (master.py|1443)
(865)     [7] [Aug 09 19:17:35] Executing jsonrpc method 'productOnClient_updateObjects' on host u'IP' (JSONRPC.py|113)
(866)     [7] [Aug 09 19:17:35] Posting request... (JSONRPC.py|628)
(867)     [7] [Aug 09 19:17:35] Starting new HTTPS connection (1) to IP:4447 (HTTP.py|579)
(868)     [7] [Aug 09 19:17:35] Connection established to: IP (HTTP.py|581)
(869)     [7] [Aug 09 19:17:35] Closing connection: <httplib.HTTPSConnection instance at 0x7f456e18fc20> (HTTP.py|499)
(870)     [7] [Aug 09 19:17:35] Expecting deflated data from server (JSONRPC.py|651)
(871)     [5] [Aug 09 19:17:35] Writing log to service (master.py|1465)


Versionen auf dem Server:

Code: Alles auswählen

ii  opsi-configed                    4.0.7.6.34-2                  all          OPSI config editor
ii  opsi-linux-bootimage             20180713-1                    all          opsi bootimage for netboot tasks.
ii  opsi-server                      4.1.1.4-10                    all          opsi server configuration package
ii  opsi-tftpd-hpa                   5.2.8-47                      amd64        HPA's tftp server
ii  opsi-utils                       4.1.1.19-2                    all          utilites for working with opsi.
ii  opsiconfd                        4.1.1.10-7                    all          opsi configuration service
ii  opsipxeconfd                     4.1.1.13-1                    all          opsi pxe configuration daemon
ii  python-opsi                      4.1.1.40-1                    all          opsi python library


Version der Netboot-Pakete:

Code: Alles auswählen

4.1.0.0-10


Gibts noch weitere Infos, die ihr braucht?

Benutzeravatar
m.radtke
Beiträge: 573
Registriert: 10 Jun 2015, 12:19

Re: Netboot-Installation Fehler auf Dell-Notebook

Beitragvon m.radtke » 10 Aug 2018, 10:24

Hi
hast du denn ein winpe Ordner im win7-x64 Depotverzeichnis auf dem opsi Server?

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

andré
Beiträge: 250
Registriert: 07 Jan 2014, 10:48

Re: Netboot-Installation Fehler auf Dell-Notebook

Beitragvon andré » 10 Aug 2018, 11:12

Ja. Wie gesagt, auf anderen Rechnern funktioniert es zudem ja.

Code: Alles auswählen

root@opsi:/var/lib/opsi/depot/win7-x64# ls -al
total 2452
drwxrws---   8 opsiconfd pcpatch    4096 Aug  9 15:25 .
drwxrws--- 121 opsiconfd pcpatch    4096 Aug  9 17:29 ..
-rwxrwx---   1 opsiconfd pcpatch    9488 Jul 12 15:56 create_driver_links.py
drwxrws---   3 opsiconfd pcpatch    4096 Jul 26 14:27 custom
drwxrws---   8 opsiconfd pcpatch    4096 Feb 22 18:21 drivers
-rwxrwx---   1 opsiconfd pcpatch    1196 Jul 12 15:56 extract_driver_pack.py
drwxrws---   7 opsiconfd pcpatch    4096 May  2  2016 installfiles
-rw-rw----   1 opsiconfd pcpatch    6907 Jul 12 15:56 nt6_repartition.opsiscript
drwxrws---   3 opsiconfd pcpatch    4096 Aug  9 15:10 opsi
-rwxrwx---   1 opsiconfd pcpatch   31200 Jul 12 15:56 opsipreparelib.py
-rwxrwx---   1 opsiconfd pcpatch   42085 Jul 12 15:56 opsisetuplib.py
-rw-rw----   1 opsiconfd pcpatch   20387 Jul 12 15:56 setup.opsiscript
-rwxrwx---   1 opsiconfd pcpatch   76500 Jul 12 15:56 setup.py
-rwxrwx---   1 opsiconfd pcpatch   16909 Jul 12 15:56 show_drivers.py
-rw-rw----   1 opsiconfd pcpatch 2223261 Aug  9 15:25 win7-x64.files
-rw-rw----   1 opsiconfd pcpatch   29477 Jul 12 15:56 windows.png
drwxrws---   5 opsiconfd pcpatch    4096 Mar  8  2016 winpe
drwxrws---   2 opsiconfd pcpatch    4096 Oct 23  2014 winpe_uefi
root@opsi:/var/lib/opsi/depot/win7-x64# ls -al winpe
total 1052
drwxrws--- 5 opsiconfd pcpatch   4096 Mar  8  2016 .
drwxrws--- 8 opsiconfd pcpatch   4096 Aug  9 15:25 ..
drwxrws--- 3 opsiconfd pcpatch   4096 Mar  8  2016 boot
-rwxrw---- 1 opsiconfd pcpatch 383562 Jul 13  2009 bootmgr
-rwxrw---- 1 opsiconfd pcpatch 667712 Jul 13  2009 bootmgr.efi
drwxrws--- 4 opsiconfd pcpatch   4096 Mar  8  2016 EFI
drwxrws--- 2 opsiconfd pcpatch   4096 Mar  8  2016 sources