Java 8

klausvoelpel
Beiträge: 28
Registriert: 16 Dez 2009, 11:48

Java 8

Beitragvon klausvoelpel » 16 Apr 2015, 13:50

Hallo

da der aktuelle configed eine Java Version 7 vorraussetzt wollte ich fragen ob "irgendwann" es eine möglichkeit gibt denselben mit Java 8 zu betreiben?

Ich frage deshalb da der support für Java 7 demnächst auslaufen wird.

Falls es jetzt schon die Möglichkeit gibt configed mit Java 8 zu betreiben würde ich gerne wissen wie das funktionieren kann.

Viele Grüsse
Klaus

dkoch
Beiträge: 309
Registriert: 25 Nov 2011, 14:03

Re: Java 8

Beitragvon dkoch » 16 Apr 2015, 15:25

Ich verwende Oracle Java 8 auf Linux. Keine mir bekannten Probleme.

Benutzeravatar
r.roeder
uib-Team
Beiträge: 459
Registriert: 02 Jul 2008, 10:08

Re: Java 8

Beitragvon r.roeder » 16 Apr 2015, 16:50

Wenn wir sagen, "erfordert Java 7" ist immer gemeint, "mindestens Java 7". Die Abwärtskompatibilität der Java-Version ist sehr hoch, da passiert auch mit einer neueren Version nichts. Spätestens Anfangs des nächsten Jahres werden wir wahrscheinlich Java 8 voraussetzen, da Java 7 schon abgekündigt ist und Java 8 sehr mächtige und effiziente neue Möglichkeiten der Programmierung bietet (Streams, Lambda-Ausdrücke..) :D

Grüße
R. Röder
opsi support - uib gmbh
For productive opsi installations we recommend maintainance + support contracts which are the base of opsi development.


Wondering who's using opsi? Have a look at the opsi map: http://opsi.org/opsi-map/.