Installation Microsoft Surface Pro 7 fails

Benutzeravatar
m.radtke
uib-Team
Beiträge: 1011
Registriert: 10 Jun 2015, 12:19

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon m.radtke » 30 Jan 2020, 09:09

dark alex hat geschrieben:Hi Mathias,

Could you tell me what exactly you need? Then I could probably try to solve the problem here.
I don't think I will be able to send a device...

(You got my mail address if you got instructions not meant for public)

Regards alex.


Hi,
sorry i lost your mail from my overview, too much work :(
you could edit the install-elilo-x64 Netboot template and add a verbose=5 line to get more verbosity and maybe we will see more response from elilo

Code: Alles auswählen

default=opsi
timeout=0
verbose=5

image=/linux/install-x64
label=opsi
append="initrd=/linux/miniroot-x64.bz2 debug video=vesa:ywrap,mtrr vga=normal --no-log console=tty1 console=ttyS0"
initrd=/linux/miniroot-x64.bz2


Another try could be to change the boot file to grubx64.efi in the DHCP and start the Client in UEFI Netboot _without_ a netboot product on setup. This will use the Grub2 bootloader that is used by the Secureboot module. Maybe the result will be different.



Regards
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

dark alex
Beiträge: 308
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 31 Jan 2020, 13:15

Hi so the (very professional) "screenshot" below is made with elilo.
Bild

The grub boot just reports

Code: Alles auswählen

acpiphp_ibm: ibm_acpiphp_init: acpi_walk_namespace failed
after hitting enter on the opsi bootimage entry in the grub menu.

in both cases processing stops at this point.

Benutzeravatar
m.radtke
uib-Team
Beiträge: 1011
Registriert: 10 Jun 2015, 12:19

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon m.radtke » 31 Jan 2020, 13:54

Hi

Please add acpi=off and/or noapic to the grub.cfg localted in /tftpboot/grub/ pr /var/lib/tftpboot/grub/, depending on OS and see if this changes anything with grub. You can also try these options as bootimage.append parameters with elilo, of course after setting back the UEFI DHCP default to elilo.efi.

Regards
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

dark alex
Beiträge: 308
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 03 Feb 2020, 12:51

elilo:
Bild

with grub no console output at all (after selecting the boot entry).

unfortunately that didn't change anything useful.

Benutzeravatar
m.radtke
uib-Team
Beiträge: 1011
Registriert: 10 Jun 2015, 12:19

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon m.radtke » 03 Feb 2020, 15:14

dark alex hat geschrieben:elilo:
Bild

with grub no console output at all (after selecting the boot entry).

unfortunately that didn't change anything useful.


Hi

please remove the 'quiet splash' parameters and add 'verbose' to the grub.cfg. It should show more infos then.

Cheers
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

dark alex
Beiträge: 308
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 04 Feb 2020, 12:55

m.radtke hat geschrieben:
dark alex hat geschrieben:elilo:
please remove the 'quiet splash' parameters and add 'verbose' to the grub.cfg. It should show more infos then.

Hi Mathias,

Code: Alles auswählen

menuentry 'TEST Surface Pro 7' {
   set gfxpayload=keep
   linux (pxe)/linux/install-x64 initrd=miniroot-x64.bz2 video=vesa:ywrap,mtrr vga=791 --no-log console=tty1 console=ttyS0 acpi=off noapic verbose
   initrd (pxe)/linux/miniroot-x64.bz2
}


no changes at all. Immediately after pressing enter on that entry the screen goes black with a white cursor (frozen)
Even after several minutes no change.

Benutzeravatar
m.radtke
uib-Team
Beiträge: 1011
Registriert: 10 Jun 2015, 12:19

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon m.radtke » 04 Feb 2020, 19:19

Hi

pleased remoce acpi=off and noapic and try again

Regards
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

dark alex
Beiträge: 308
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 05 Feb 2020, 07:18

same... :roll: :|

dark alex
Beiträge: 308
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 05 Feb 2020, 07:47

Oh! After some more minutes suddenly a wild text appeared...

Bild

Benutzeravatar
m.radtke
uib-Team
Beiträge: 1011
Registriert: 10 Jun 2015, 12:19

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon m.radtke » 05 Feb 2020, 13:33

Hi Alex

does anything happen afterwards? How long did this stay in this state?
Did you check if the machine is responding to a ping?; if ping is not blocked in your network.

Regards
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.