[SOLVED] PXE/netboot: login failed

shade
Beiträge: 48
Registriert: 10 Aug 2012, 15:14

[SOLVED] PXE/netboot: login failed

Beitragvon shade » 22 Feb 2019, 12:52

Hello,

We are trying to install a computer with the win10 netboot product, and it fails with a similar failure as in this thread:

viewtopic.php?f=7&t=10928&p=47612&hilit=getrandom#p47612

After the PXE boots, we choose the name the computer shall be named, and the try to login with the adminuser, and gets this error:

"Login failed: getrandom() initialization failed. (_ssl.c:726)"

The error comes no mater what we write as login, seems that there is no connection to service.

The server is a Ubuntu 18.04.2 LTS running inside a VMware 6.5.

dpkg -l | grep opsi
ii opsi-linux-bootimage 20181213-1 all opsi bootimage for netboot tasks.
ii opsi-server 4.1.1.6-1 all opsi server configuration package
ii opsi-tftpd-hpa 5.2.8-49 amd64 HPA's tftp server
ii opsi-utils 4.1.1.27-1 all utilites for working with opsi.
ii opsiconfd 4.1.1.16-2 all opsi configuration service
ii opsipxeconfd 4.1.1.14-1 all opsi pxe configuration daemon
ii python-opsi 4.1.1.58-1 all opsi python library

opsi-package-manager -l | grep win10
config-win10 4.1.1-5 Configure Windows 10
mshotfix-win10-win2016-x64-glb 201902-1 Windows 10 and Windows 2016 x64
mshotfix-win10-x86-glb 201902-1 Windows 10 x86
win10 4.1.0.0-14 Windows 10
win10-captured 4.1.0.0-14 Windows 10
win10-x64 4.1.0.0-14 Windows 10 x64
win10-x64-captured 4.1.0.0-14 Windows 10 x64
win10-x64-ent-ltsb 4.1.0.0-5 Windows 10 x64 Enterprise LTSB
Zuletzt geändert von shade am 04 Mär 2019, 18:09, insgesamt 3-mal geändert.

Benutzeravatar
m.radtke
uib-Team
Beiträge: 1013
Registriert: 10 Jun 2015, 12:19

Re: PXE/netboot: login failed

Beitragvon m.radtke » 22 Feb 2019, 14:13

Hi

could you please ssh onto the machine
username: root, password: linux123
and run the following command:

Code: Alles auswählen

/usr/sbin/rngd -b -r /dev/urandom -o /dev/random

and then

Code: Alles auswählen

master.py

and see if this resolves your problem

are you running in UEFI or BIOS mode?

Cheers
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

shade
Beiträge: 48
Registriert: 10 Aug 2012, 15:14

Re: PXE/netboot: login failed

Beitragvon shade » 22 Feb 2019, 16:44

Hello,

Just FYI it is our own installed Ubuntu server, not your vmimage.

I ssh onto the server and installed rngd (apt install rng-tools) as is what missing, then ran:

Code: Alles auswählen

/usr/sbin/rngd -b -r /dev/urandom -o /dev/random


master.py is not to be found on our server

We are running in BIOS mode.

After running rngd I rebooted the server, and the rebooted the computer (client) to launch the bootimage also.

It ran once after the command, but now it is back to same error :(

Benutzeravatar
m.radtke
uib-Team
Beiträge: 1013
Registriert: 10 Jun 2015, 12:19

Re: PXE/netboot: login failed

Beitragvon m.radtke » 25 Feb 2019, 09:24

Hi

I was a bit unclear on where to run the rngd command
It is supposed to run on the client, what bootet into the bootimage.

Cheers
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

shade
Beiträge: 48
Registriert: 10 Aug 2012, 15:14

Re: PXE/netboot: login failed

Beitragvon shade » 25 Feb 2019, 13:22

Hi,

Okay, that explains alot. Will try on the client, is there a fix on the way to the bootimage?

Regards.

Benutzeravatar
m.radtke
uib-Team
Beiträge: 1013
Registriert: 10 Jun 2015, 12:19

Re: PXE/netboot: login failed

Beitragvon m.radtke » 25 Feb 2019, 14:16

Hi

yes there is an experimental version of the bootimage. it runs the rngd command twice with a little pause. Hope it helps. We had this issue when the bootimage was in internal testing but with the rngd command run once we didn't have it since then
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

shade
Beiträge: 48
Registriert: 10 Aug 2012, 15:14

Re: PXE/netboot: login failed

Beitragvon shade » 25 Feb 2019, 14:31

I will try and install the updated bootimage.

Benutzeravatar
m.radtke
uib-Team
Beiträge: 1013
Registriert: 10 Jun 2015, 12:19

Re: PXE/netboot: login failed

Beitragvon m.radtke » 25 Feb 2019, 14:53

wait. there is still an error inside

I will upload another version soon.
Cheers
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

Benutzeravatar
m.radtke
uib-Team
Beiträge: 1013
Registriert: 10 Jun 2015, 12:19

Re: PXE/netboot: login failed

Beitragvon m.radtke » 27 Feb 2019, 10:34

Hi

there's a new bootimage in opsi 4,.1 experimental (https://build.opensuse.org/package/show ... -bootimage).

This version starts the RNG command twice with a little break in between

Feedback is very welcome :D

Cheers
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

shade
Beiträge: 48
Registriert: 10 Aug 2012, 15:14

Re: PXE/netboot: login failed

Beitragvon shade » 27 Feb 2019, 13:38

The new image seems to solve the problem :)

I will try some more tests to be sure, but the first computer is installing Windows 10 now so I think it works.