Installation Microsoft Surface Pro 7 fails

dark alex
Beiträge: 296
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 05 Feb 2020, 14:52

Hi Mathias,

it's still in this state. Several hours later.

It's pingable before but stops being pingable when the text appears. (Just tried it again to make sure it's not the long delay)

Benutzeravatar
m.radtke
uib-Team
Beiträge: 823
Registriert: 10 Jun 2015, 12:19

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon m.radtke » 05 Feb 2020, 16:10

Ok I might have found something.

A new bootimage is currently being build internally and if it succeeds a new version (20200205-1) will be uploaded later in the experimental repository at download.opensuse.org.

please add

Code: Alles auswählen

modprobe.blacklist=intel_lpss_pci

to the grub.cfg line if you install the new opsi-linux-bootimage package.
At least this works on surface models when starting from USB.

The new build is needed as the required blacklisted module is currently compiled into the kernel instead of being modular and therefore cannot get blacklisted with the current bootimages.

Regards
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

dark alex
Beiträge: 296
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 06 Feb 2020, 07:43

Hi I could not find the bootimage yet.

Did it build? Am I looking in the wrong place?
Could you probably provide me with a direct link?

Benutzeravatar
m.radtke
uib-Team
Beiträge: 823
Registriert: 10 Jun 2015, 12:19

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon m.radtke » 06 Feb 2020, 09:46

Hi

yes it did build.
its here, depending on your Distribution.
In debian based distros it is located in the all subdir.

regards
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

dark alex
Beiträge: 296
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 07 Feb 2020, 10:20

it works!

the bootimage shows messages at the top stating "timeout waiting for data" but the assistant starts and I am currently running a test setup.

Benutzeravatar
m.radtke
uib-Team
Beiträge: 823
Registriert: 10 Jun 2015, 12:19

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon m.radtke » 07 Feb 2020, 10:58

hooray :geek:

waiting for further feedback.

Regards
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

dark alex
Beiträge: 296
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 11 Feb 2020, 07:59

Idk why but the setup freezed at some point in the PE and since this freeze I can't get the device booting from PXE at all anymore... Will report back when I found the cause.

dark alex
Beiträge: 296
Registriert: 11 Mär 2015, 10:09

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon dark alex » 14 Feb 2020, 08:13

Just wanted to let you know that I did not forget about you.
I was not able to solve my issue yet... Getting weird PXE errors on the surface now... There seems something to be broken in the EFI firmware... :lol:

Benutzeravatar
m.radtke
uib-Team
Beiträge: 823
Registriert: 10 Jun 2015, 12:19

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon m.radtke » 14 Feb 2020, 12:04

Hi Alex,

no need to hurry, have enough stuff to do :D

Broken EFIs aren't so uncommon. Meet them sometimes in the office.

Regards
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

ineedhelp
Beiträge: 4
Registriert: 07 Nov 2019, 08:56

Re: Installation Microsoft Surface Pro 7 fails

Beitragvon ineedhelp » 19 Feb 2020, 12:02

m.radtke hat geschrieben:Ok I might have found something.

A new bootimage is currently being build internally and if it succeeds a new version (20200205-1) will be uploaded later in the experimental repository at download.opensuse.org.

please add

Code: Alles auswählen

modprobe.blacklist=intel_lpss_pci

to the grub.cfg line if you install the new opsi-linux-bootimage package.
At least this works on surface models when starting from USB.

The new build is needed as the required blacklisted module is currently compiled into the kernel instead of being modular and therefore cannot get blacklisted with the current bootimages.

Regards
Mathias


Where should i add "modprobe.blacklist=intel_lpss_pci"? Can I get a short explanation?