ProjectLibre

Moderator: pandel

Tuborg
Beiträge: 53
Registriert: 10 Nov 2014, 14:42

ProjectLibre

Beitragvon Tuborg » 24 Nov 2016, 13:25

Hallo,
ich wollte ein Päckchen ProjectLibre bearbeiten allerdings bekomme ich wenn ich das Paket öffnen möchte immer diesen Fehler :

An unhandled exception occurred. Please report the problem
via the official opsi PackageBuilder forum:

viewforum.php?f=22

Thank you!

A log has been written to "C:\Users\admt4176\AppData\Local\Temp\opb-error-5gmlk8o2.log".

Error information:
--------------------------------------------------------------------------------
2016-11-24, 13:24:08
--------------------------------------------------------------------------------
<class 'ValueError'>:
Incorrect value for requirementType:
--------------------------------------------------------------------------------
File "oPB\gui\mainwindow.py", line 893, in open_project
File "oPB\controller\main.py", line 503, in project_load
File "oPB\controller\base.py", line 176, in load_backend
File "oPB\core\datadefinition.py", line 1059, in load_data
File "oPB\core\datadefinition.py", line 281, in requirementType
0.0.1

Woran kann das liegen ?

pandel
Beiträge: 560
Registriert: 25 Jan 2013, 16:47

Re: ProjectLibre

Beitragvon pandel » 24 Nov 2016, 13:58

Na das steht doch da:

Code: Alles auswählen

Incorrect value for requirementType:


Control Datei des Pakets hat bei den Product Properties ne Macke. Mehr kann ich nicht sagen, ohne die control Datei zu sehen...

Tuborg
Beiträge: 53
Registriert: 10 Nov 2014, 14:42

Re: ProjectLibre

Beitragvon Tuborg » 24 Nov 2016, 14:55

Also in der Control steht folgendes

[Package]
version: 4
depends:
incremental: False

[Product]
type: localboot
id: projectlibre
name: ProjectLibre - OpenSource Projektmanagement
description: Freie Projektmanagementsoftware mit Termin-, Ablauf- undRessourcenplanung (Leistungswertanalyse, Gantt- und PERT-Diagramme uvm.);kompatibel zu Microsoft Project 2010
advice:
version: 1.6.2
priority: 0
licenseRequired: False
productClasses:
setupScript: setup.opsiscript
uninstallScript: uninstall.opsiscript
updateScript:
alwaysScript:
onceScript:
customScript:
userLoginScript: login.opsiscript

[ProductDependency]
action: setup
requiredProduct: dfn_jre
requiredStatus: installed
requirementType:

[ProductProperty]
type: unicode
name: minimumspace
multivalue: False
editable: True
description: required minimum hdd space
values: [""]
default: ["71 MB"]

[ProductProperty]
type: bool
name: desktoplink
description: generate or delete DesktopLink
default: False

[ProductProperty]
type: unicode
name: setupmode
multivalue: False
editable: False
description: Un/Install MSI silent (/qb!) or very silent (/qn)
values: ["/qb!", "/qn"]
default: ["/qb!"]

[ProductProperty]
type: unicode
name: custom-post-install
multivalue: False
editable: False
description: Define filename for include script in custom directory after
values: ["none", "post-install.opsiinc"]
default: ["none"]

[ProductProperty]
type: unicode
name: custom-post-deinstall
multivalue: False
editable: False
description: Define filename for include script in custom directory after
values: ["none", "post-deinstall.opsiinc"]
default: ["none"]

[Changelog]

projectlibre (1.6.2-002) stable; urgency=low

* Bugfix Include
* Description gekürzt
* msi option /qb or /qb!
* CUSTEM Dir

-- Detlef Krummel <krummel@gei.de> 08.3.2016

projectlibre (1.6.2-002) stable; urgency=low

* Update
* depency "dfn_jre"

-- Detlef Krummel <krummel@gei.de> 09.10.2015 19:00:00

projectlibre (1.5.19.0-1) stable; urgency=low
* initial: created by opsi-setup-detector
-- opsisetupdetector.exe <info@uib.de> 09.05.2015 16:24:48

pandel
Beiträge: 560
Registriert: 25 Jan 2013, 16:47

Re: ProjectLibre

Beitragvon pandel » 24 Nov 2016, 17:14

(Sorry, hatte mich geirrt, ging um Dependencies und nicht Properties...)

Und da ist der Fehler:

Code: Alles auswählen

[ProductDependency]
action: setup
requiredProduct: dfn_jre
requiredStatus: installed
requirementType:


Da muss entweder requirementType: before oder requirementType: after stehen!

Hast du mal gem. Getting Started Handbuch per Hand ein Paket erstellt? Dann hätte dir das auffallen müssen!

Wenn nicht, dann hol das bitte nach, das sind wichtige Grundlagen! Sich nur auf den oPB zu verlassen ist ein wenig dünn... ;)

Benutzeravatar
GEI
Beiträge: 170
Registriert: 12 Feb 2010, 13:00
Wohnort: Braunschweig
Kontaktdaten:

Re: ProjectLibre

Beitragvon GEI » 29 Nov 2016, 17:43

pandel hat geschrieben:

Code: Alles auswählen

[ProductDependency]
action: setup
requiredProduct: dfn_jre
requiredStatus: installed
requirementType:

Da muss entweder requirementType: before oder requirementType: after stehen!


sorry, das war mein Fehler. :-(
Irgendwie scheint der bei den normalen CLI-Commands durch deren Defaults nicht aufzutreten.

Code: Alles auswählen

[Changelog]
projectlibre (1.6.2-5) stable; urgency=low
        * Bugfixe OPSI/control  Dependency dfn_jre requirementType: before
          (thanks @ Pandel)
-- Detlef Krummel  <krummel@gei.de>  29.11.2016
Georg-Eckert-Institut - Leibniz-Institut für internationale Schulbuchforschung (GEI)
---
'opsi4instituts' = Communityprojekt für wissenschaftliche Einrichtungen
offenes Repository, Update-Notifier
http://www.gei.de/o4i - https://opsi.wzb.eu/wiki

pandel
Beiträge: 560
Registriert: 25 Jan 2013, 16:47

Re: ProjectLibre

Beitragvon pandel » 30 Nov 2016, 10:14

Nur für mein Verständnis: GEI und Tuborg, ihr arbeitet im selben Laden :?: ;) ?

Zum Topic: ja, das mag sein, dass es da interne Defaults gibt, die bei den CLI Tools gesetzt werden, wenn man da mal fälschlicherweise was verpennt hat. Ich bin im oPB strickter in den Vorgaben. Den lässigen Umgang damit überlasse ich lieber dem Urheber des Ganzen :lol: :mrgreen:

Benutzeravatar
GEI
Beiträge: 170
Registriert: 12 Feb 2010, 13:00
Wohnort: Braunschweig
Kontaktdaten:

Re: ProjectLibre

Beitragvon GEI » 03 Dez 2016, 13:41

pandel hat geschrieben:Nur für mein Verständnis: GEI und Tuborg, ihr arbeitet im selben Laden :?: ;) ?

nicht das ich wüßte ... :roll: es sei denn, er versteckt sich irgendwo zwischen einer viertel Million Schulbüchern :mrgreen:
Ansonsten kann mich ja Tuborg gern mal anschreiben ...

@Pandel:
kennst du eigentlich diesen freien Service https://opsi.wzb.eu/wiki/index.php/Update-Notify/Public ?
Georg-Eckert-Institut - Leibniz-Institut für internationale Schulbuchforschung (GEI)
---
'opsi4instituts' = Communityprojekt für wissenschaftliche Einrichtungen
offenes Repository, Update-Notifier
http://www.gei.de/o4i - https://opsi.wzb.eu/wiki

pandel
Beiträge: 560
Registriert: 25 Jan 2013, 16:47

Re: ProjectLibre

Beitragvon pandel » 05 Dez 2016, 11:51

Ich hab davon mal gehört, aber die Seite kannte ich noch nicht. Cooler Service! Betreust du den auch?

Benutzeravatar
GEI
Beiträge: 170
Registriert: 12 Feb 2010, 13:00
Wohnort: Braunschweig
Kontaktdaten:

DFN-Notify (Re: ProjectLibre)

Beitragvon GEI » 10 Dez 2016, 14:08

pandel hat geschrieben:Ich hab davon mal gehört

wo hast du denn was davon gehört? .... wir haben keine 'Werbung' o.ä. gemacht.
Es ist halt ein kostenloser Service für Admins bzw. Anwender von Clientmanagementsystemen und die verwendete (public RO) DFN-Mailingliste 'opsi4instituts-notify' läßt sich einfach selbst Subscriben/unSubscriben ...

aber die Seite kannte ich noch nicht.

Die ist ja auch recht neu und für diejenigen Paket-Scripter gedacht, welche nicht der o4i-Community/Wiki angehören

https://opsi.wzb.eu/wiki/index.php/Update-Notify/Public
Cooler Service! Betreust du den auch?

ja, den mache ich. Momentan beinhaltet dieser ca. 140 SW-Produkte - auch dein oPB-python :D
(Liste der Produkte: http://www.gei.de/fileadmin/gei.de/bild ... Notify.pdf)
Mich hatte Anfang 2015 Adobe mit Flash-Updates extrem genervt.... (neue Version auf www, Download der alten ). Nach den dritten Rollout habe ich die Notwendigkeit eines derartigen Update-Monitorings erkannt und diesen Dienst konzipiert.
Bei vielen SW-Produkten steckt die Version# im Dateinamen, bei AdobeFlash gehe ich in der Bash mit "strings -n" in das Setup-File rein und suche dann nach der internen Version. Zum Glück haben nur einige SW-Produkte den Download immer an der gleichen Stelle und dann noch mit gleichbleibenden Filenamen (u.a. Chrome-Business).
Georg-Eckert-Institut - Leibniz-Institut für internationale Schulbuchforschung (GEI)
---
'opsi4instituts' = Communityprojekt für wissenschaftliche Einrichtungen
offenes Repository, Update-Notifier
http://www.gei.de/o4i - https://opsi.wzb.eu/wiki

Benutzeravatar
GEI
Beiträge: 170
Registriert: 12 Feb 2010, 13:00
Wohnort: Braunschweig
Kontaktdaten:

Re: ProjectLibre

Beitragvon GEI » 10 Dez 2016, 14:29

pandel hat geschrieben: Cooler Service! Betreust du den auch?

ich bin gerade deshalb in diesen Forumbereich rein ...

Code: Alles auswählen

root@opsi:~/o/oPB-python# ./opsicheck_oPB-python.sh DISPLAY
./opsicheck_oPB-python.sh DISPLAY => Script laeuft im TEST-Modus mit zusaetzlichen Ausgaben!

Working Path: /home/opsiproducts/Paketerstellung/oPB-python
... checke CLIENT_DATA
OPSI-DEPOT  ->    Version:
CLIENTDATA  ->    Version: 8.1.3    Filename: opsiPackageBuilder-v8.1.3.exe
... downloading STATUS (Version, Link)
{oPB-python}  https://forum.opsi.org/viewtopic.php?f=22&t=7573 Downloadfehler!

Der Service ist nicht 100 %ig, die Fehlerquote liegt bei (vernachläsigbaren) ca. 5% ... Hersteller ändern Homepages, Download-Links oder gar die Systematik des Dateinamens :-(
Deshalb muss man der Menge an SW-Produkten 2...4 x in der Woche den DFN-Notify-Service modifizieren,
hier war es nur ein Zertifkatsproblem beim wget ;)

So, jetzt wird oPB wieder sauber gemonitort:

Code: Alles auswählen

CLIENTDATA  ->    Version: 8.1.3    Filename: opsiPackageBuilder-v8.1.3.exe
... downloading STATUS (Version, Link)
DOWNLOAD    ->    Version: 8.1.3    Filename: opsiPackageBuilder-v8.1.3.exe
                     Link: https://dl.dropboxusercontent.com/u/5454651/opsiPackageBuilder/python/opsiPackageBuilder-v8.1.3.exe
{oPB-python} ist identisch. [8.1.3]
Dec 10 09:08:03 opsi opsipackage: {oPB-python}  https://forum.opsi.org/viewtopic.php?f=22&t=7573 Downloadfehler!
Dec 10 14:21:57 opsi opsipackage: {oPB-python}  https://forum.opsi.org/viewtopic.php?f=22&t=7573 Downloadfehler!
Dec 10 14:32:54 opsi opsipackage: {oPB-python} ist identisch. [8.1.3]
Dec 10 14:34:53 opsi opsipackage: {oPB-python} ist identisch. [8.1.3]
Georg-Eckert-Institut - Leibniz-Institut für internationale Schulbuchforschung (GEI)
---
'opsi4instituts' = Communityprojekt für wissenschaftliche Einrichtungen
offenes Repository, Update-Notifier
http://www.gei.de/o4i - https://opsi.wzb.eu/wiki


Zurück zu „OPSI PackageBuilder“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast