Package Builder geht plötzlich nicht mehr

Moderator: pandel

Senku
Beiträge: 7
Registriert: 12 Feb 2019, 11:52

Package Builder geht plötzlich nicht mehr

Beitragvon Senku » 16 Apr 2020, 08:50

Hallo,

ich arbeite noch nicht so lange mit opsi. Daher habe ich mir den Package Builder auf dem Rechner installiert da damit die verwaltung der Packete auf dem Server nicht über die Kommandozeile erfolgen muss das geht so einfacher.

Mein Problem ist wenn ich ein Pcket packen möchte kommt folgender Fehler

Code: Alles auswählen

[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - Locking package
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - Package info
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - ----------------------------------------------------------------------------
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    version              : 1
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    custom package name  :
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    package dependencies :
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - Product info
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - ----------------------------------------------------------------------------
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    product id           : normal_ohne_acess
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    product type         : localboot
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    version              : 1.0
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    name                 : normal_ohne_Acess
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    description          : Please ad a valuable description.
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    advice               :
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    priority             : 0
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    licenseRequired      : False
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    product classes      :
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    windows software ids :
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - Product scripts
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - ----------------------------------------------------------------------------
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    setup                :
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    uninstall            :
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    update               :
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    always               :
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    once                 :
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    custom               :
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -    user login           :
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - Package file '/var/lib/opsi/workbench/normal ohne Acess/normal_ohne_acess_1.0-1.opsi' already exists.
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - Press <O> to overwrite, <C> to abort or <N> to specify a new version: Cleaning up
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - Unlocking package
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - info: Source dir: /var/lib/opsi/workbench/normal ohne Acess
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - info: Temp dir: /tmp
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - info: Custom name:
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - info: Archive format: cpio
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - debug: Trying to lock file '/var/lib/opsi/workbench/normal ohne Acess/OPSI/control' (0/2000)
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - debug: File '/var/lib/opsi/workbench/normal ohne Acess/OPSI/control' locked after 0 millis
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - debug: Trying to lock file '/var/lib/opsi/workbench/normal ohne Acess/OPSI/control' (0/2000)
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - debug: File '/var/lib/opsi/workbench/normal ohne Acess/OPSI/control' locked after 0 millis
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - info: Cleaning up
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - debug: Finished cleaning up
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - critical: Traceback:
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - critical:   File "/usr/bin/opsi-makepackage", line 467, in <module>
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -     main(sys.argv[1:])
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - critical:   File "/usr/bin/opsi-makepackage", line 320, in main
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH -     savedSettings = termios.tcgetattr(fd)
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -      SSH - critical:      ==>>> (25, 'Inappropriate ioctl for device')
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing            -    ERROR - ERROR: (25, 'Inappropriate ioctl for device')


das Packet normal ohne Acess wurde von mir schonmal mithilfe des Package builders erstellt und befindet sich auch schon auf dem Server es ist ein leeres Packet das nur aus abhängigkeiten besteht. Es hat also keine Scripte drin sondern nur Abhängigkeiten.

Für den Fall das das hilft:
Ich habe bei Entwicklungsordner bei Einstellungen S:\ angegeben und dort habe ich auch die opsi_workbench gemountet bzw das ist das netzlaufwerk.

Das einzige was ich möchte ist mir dem Packet builder Packete erstellen und diese auf den Server übertragen.
Früher ging das mahl, ich habe am Server auch nichts geändert aber jetzt geht es nicht mehr übersehe ich etwas oder habe ich etwas vergessen?
Ich habe den builder auch schon deinstalliert und wieder neu installiert.

Kann mir jemand sagen wo das Problem ist oder was ich tun kann?

pandel
Beiträge: 794
Registriert: 25 Jan 2013, 16:47

Re: Package Builder geht plötzlich nicht mehr

Beitragvon pandel » 16 Apr 2020, 12:39

Hi!

Wenn du mal die Logausgabe liest...

[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing - SSH - critical: File "/usr/bin/opsi-makepackage", line 320, in main
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing - SSH - savedSettings = termios.tcgetattr(fd)
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing - SSH - critical: ==>>> (25, 'Inappropriate ioctl for device')
[2020-04-16 08:31:04 AM] - oPB.core.processing.OpsiProcessing - ERROR - ERROR: (25, 'Inappropriate ioctl for device')

...dann siehst du, dass die Meldung direkt durch opsi-makepackage erzeugt wird, also gar nicht durch den oPB. Wenn du das mal gegoogelt hättest, wäre dir aufgefallen, dass es damit zusammenhängen könnte, dass ein File Deskriptor sprich eine Datei, Terminal, wasauchimmer nicht angesprochen werden kann.

Also würde ich das Paket mal einfach direkt am Server via Konsole mit erhöhtem Loglevel bauen lassen um zu sehen, ob die Meldung nochmal auftaucht und ob dazu noch weitere Informationen erfolgen.

Dann kannst du da ansetzen. Der Rest ist Glaskugelleserei... da kann dir so niemand weiterhelfen.

Gruß