Paketinstallation schlägt fehl

Moderator: pandel

tranceman84
Beiträge: 1
Registriert: 11 Jun 2017, 11:21

Paketinstallation schlägt fehl

Beitragvon tranceman84 » 11 Jun 2017, 11:31

Hi Holger,

ich bin gerade bei der Problemsuche auf diesen Beitrag gestoßen.
Ich finde es auch sehr schade, dass keine Lösung zu dem o. g. Problem gepostet wurde, daher kann ich das vielleicht weiterführen.

Nun erstmal zu mir. Ich bin vor 2 Wochen auf OPSI gestoßen und teste gerade die aktuelle Test-VM auf Lubuntubasis.
Jetzt bin ich auch beim Thema Paketerstellung mit dem opsi-package-detector in Zusammenarbeit mit dem oPB angekommen.
Als Paketerzeugungssystem verwende ich eine Win7x64 VM.

Als ich mit dem oPB das Paket auf dem Server installieren wollte habe ich auch folgenden Fehler erhalten:
C:\Program Files (x86)\opsi PackageBuilderNG\paramiko\client.py:683: UserWarning: Unknown ssh-rsa host key for 10.111.112.99: b'914de5a5e210860212528948d462efd3'

Hier der Auszug aus dem Log.
Als Test hatte ich versucht ein Notepad Plus Plus Paket zu erstellen.
[2017-06-10 04:41:16 PM] - oPB.core.processing.OpsiProcessing - SSH - --------------------ACTION: INSTALL--------------------
[2017-06-10 04:41:18 PM] - oPB.core.processing.OpsiProcessing - SSH -
[2017-06-10 04:41:18 PM] - oPB.core.processing.OpsiProcessing - SSH - ERROR: Package file '/home/opsiproducts/npp-7-3-3-Installer-x64/npp-7-3-3-Installer-x64_1.0-1.opsi' does not exist or access denied
[2017-06-10 04:41:18 PM] - oPB.core.processing.OpsiProcessing - SSH -
[2017-06-10 04:41:18 PM] - oPB.core.processing.OpsiProcessing - ERROR - ERROR: Package file '/home/opsiproducts/npp-7-3-3-Installer-x64/npp-7-3-3-Installer-x64_1.0-1.opsi' does not exist or access denied
[2017-06-10 04:42:18 PM] - oPB.core.processing.OpsiProcessing - SSH - --------------------ACTION: INSTALL--------------------
[2017-06-10 04:42:20 PM] - oPB.core.processing.OpsiProcessing - SSH -
[2017-06-10 04:42:20 PM] - oPB.core.processing.OpsiProcessing - SSH - ERROR: Package file '/home/opsiproducts/npp-7-3-3-Installer-x64/npp-7-3-3-Installer-x64_1.0-1.opsi' does not exist or access denied
[2017-06-10 04:42:20 PM] - oPB.core.processing.OpsiProcessing - SSH -
[2017-06-10 04:42:20 PM] - oPB.core.processing.OpsiProcessing - ERROR - ERROR: Package file '/home/opsiproducts/npp-7-3-3-Installer-x64/npp-7-3-3-Installer-x64_1.0-1.opsi' does not exist or access denied
[2017-06-11 11:16:46 AM] - oPB.core.processing.OpsiProcessing - SSH - --------------------ACTION: INSTALL--------------------
[2017-06-11 11:16:49 AM] - oPB.core.processing.OpsiProcessing - SSH -
[2017-06-11 11:16:49 AM] - oPB.core.processing.OpsiProcessing - SSH - ERROR: Package file '/home/opsiproducts/npp-7-3-3-Installer-x64/npp-7-3-3-Installer-x64_1.0-1.opsi' does not exist or access denied
[2017-06-11 11:16:49 AM] - oPB.core.processing.OpsiProcessing - SSH -
[2017-06-11 11:16:49 AM] - oPB.core.processing.OpsiProcessing - ERROR - ERROR: Package file '/home/opsiproducts/npp-7-3-3-Installer-x64/npp-7-3-3-Installer-x64_1.0-1.opsi' does not exist or access denied

Auch bei mir funktioniert der Zugriff auf den Server per Putty einwandfrei.

Hoffe du kannst mir hier weiterhelfen.

Gruß Tranceman84

P.S.: Bitte entschuldige falls ich wichtige Daten vergessen haben sollte, diese werde ich dann auch gerne nachliefern. Bin leider noch ein OPSI-Neuling.

pandel
Beiträge: 560
Registriert: 25 Jan 2013, 16:47

Re: Paketinstallation schlägt fehl

Beitragvon pandel » 13 Jun 2017, 11:12

Thema abgetrennt, da zu 99,9% kein Problem mit SSH vorliegt, wie vom TO vermutet...

Hey Tranceman84,

dass mit dem unknown ssh-rsa host key ist völlig normal und nur eine Infomeldung der Paramiko Library, die ich für SSH verwende. Diese Meldung bekomme ich immer bei all meinen Servern.

Du solltest in den Einstellungen bei Meldungen und Logging mal die Logerstellung einschalten und den Log Level auf DEBUG setzen. Dann probierst du das nochmal. Du brauchst auch nicht, wie hier, 4x auf Install drücken, einmal reicht ;-), der Logauswurf wird entsprechend lang sein. Dann schickst du mir das Log bitte per PN - NICHT hier posten!!

Ich schau es mir an und überlege mir, wo der Bock liegt...

Gruß
Holger

pandel
Beiträge: 560
Registriert: 25 Jan 2013, 16:47

Re: Paketinstallation schlägt fehl

Beitragvon pandel » 14 Jun 2017, 11:25

Nur der Vollständigkeit halber: nach eingehender Analyse hat sich der Fehler netterweise in Luft aufgelöst :mrgreen:


Zurück zu „OPSI PackageBuilder“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast