Important: Changements du opsipxeconfd peuvent causer des problèmes avec UEFI Netboot

Ce forum est dédié au nouveautés, événements autour du projet Opsi
otto
Beiträge: 107
Registriert: 08 Aug 2017, 12:16

Important: Changements du opsipxeconfd peuvent causer des problèmes avec UEFI Netboot

Beitragvon otto » 29 Sep 2020, 17:18

Chers utilisateurs d'opsi,

l'actuel opsipxeconfd de stable mène sous quelques environnements aux problèmes avec le Netboot UEFI. Cela concerne seulement des envirennements où opsipxeconfd.conf n'était pas adapté.

Nous avons récemment décidé de libérer le bootloader shim/grub pour l'extension UEFI Secureboot pour tous clients UEFI.
Pour cela, on a changé l'entrée de défaut pour

Code: Alles auswählen

uefi netboot config template x64

de

Code: Alles auswählen

/tftpboot/linux/pxelinux.cfg/install-elilo-x64

à

Code: Alles auswählen

/tftpboot/linux/pxelinux.cfg/install-grub-x64
.
Dans les systèmes RPM, le chemin est peut-être différent.

Cela avait comme but que toutes les nouvelles envirennement opsi peuvent reçevoir le template correct pour le Netboot UEFI. La documentation dans la section UEFI a aussi été adapté.

Malheureusement ce changement est aussi appliqué dans des environnements qui n'ont pas touché opsipxeconfd.conf. Cela à comme conséquence que UEFI ne fonctionne pas correctement comme le Bootloader ne colle avec le template.

La solution est comme la suite:
Veuillez changer votre filname pour le Netboot UEFI dans le DHCP de

Code: Alles auswählen

elilo.efi

à

Code: Alles auswählen

shimx64.efi.signed
.

En faisant cela, le template marche avec ce bootloader et le Netboot UEFI devrait fonctionner à nouveau.

Le modèle d'erreur est comme la suite:

Code: Alles auswählen

near line 1: Unknow option
near line 2: Unknow option
forcing interactive mode due to config file error(s)


On vous prie d'excuser l'oublie de cette annonce.

Cordialement
Mathias