Paquets actualisés dans opsi 4.1 et 4.2

Ce forum est dédié au nouveautés, événements autour du projet Opsi
Antworten
otto
Beiträge: 118
Registriert: 08 Aug 2017, 12:16

Paquets actualisés dans opsi 4.1 et 4.2

Beitrag von otto »

Chers utilisateurs d'opsi,

nous publions des nouveaux paquets pour opsi 4.1 / 4.2 dans testing et stable.

Points importants dans cette version:
  • Les paquets Netboot basés sur NT6 corrigent maintenant le problème timout qui est apparu récemment.
  • Les paquets Netboot avec version 4.2.0.1-1 ou plus récent ont besoins de l'opsi-linux-client-agent 4.2.0.1-1, opsi-script 4.12.4.27-1 ou opsi-linux-bootimage 20210806-1 ou plus nouveau.
  • L'opsi-linux-bootimage 20210901-1 (opsi 4.2) apporte maintenant le module kernel pour l'hardware X2APIC et soutient 8021Q VLAN.

=====================================
Paquets actualisés dans testing:
=====================================

Localboot Windows:

* opsi-client-agent 4.1.1.47-1
* opsi-client-agent 4.2.0.7-1

Localboot Linux:

* aucun

Localboot opsi-local-image:

* aucun

Localboot macOS:

* aucun

Netboot Windows:

* aucun

Netboot Linux:

* aucun

Netboot opsi-local-image:

* aucun

serveur opsi:

opsi-linux-bootimage 20210901-1 (opsi 4.2)

manuels opsi:

* aucun

=====================================
Paquets actualisés dans stable:
=====================================

Localboot Windows:

* aucun

Localboot Linux:

* opsi-linux-client-agent 4.2.0.5-1
* opsi-script 4.12.4.26-1

Localboot opsi-local-image:

* aucun

Localboot macOS:

* aucun

Netboot Windows:

* windows NT6 4.2.0.1-4

Netboot Linux:

* centos70 4.2.0.1-2
* centos8 4.2.0.1-2
* debian 4.2.0.1-1
* debian11 4.2.0.1-2 (nur opsi 4.2)
* debian10 4.2.0.1-2
* debian9 4.2.0.1-2
* mint20-1 4.2.0.1-1 (nur opsi 4.2)
* mint20-1 4.2.0.1-1 (nur opsi 4.2)
* opensusel15-2 4.2.0.1-2
* opensusel15-3 4.2.0.1-2
* redhat70 4.2.0.1-2
* redhat8 4.2.0.1-2
* sles12* 4.2.0.1-2
* sles15-1 4.2.0.1-2
* sles15-2 4.2.0.1-2
* sles15-3 4.2.0.1-2
* ubuntu 4.2.0.1-1
* ubuntu18-04 4.2.0.1-2
* ubuntu20-04 4.2.0.1-2

Netboot opsi-local-image:

* opsi-local-image-backup 4.2.0.0-1
* opsi-local-image-restore 4.2.0.0-1
* opsi-local-image-NT6 4.2.0.1-4
* opsi-vhd-win10-x64 4.2.0.1-4

serveur opsi:

* opsiconfd 4.2.0.194
* opsi-utils 4.2.0.118
* opsi-linux-bootimage 20210806-1 (opsi 4.1)
* opsi-utils 4.1.1.37-1

manuels opsi:

* aucun


##########

Cordialement
votre équipe opsi
Au nom de Mathias Radtke

##########

Voilà les

Changelogs

Code: Alles auswählen

opsiconfd (4.2.0.194-1) stable; urgency=medium

  * Improvement:  Follow jsonrpc 2.0 spec
  * Improvement:  Update python packages
  * Feature:  WebDAV ignore case filesystem access on depot

 -- uib GmbH <info@uib.de>  Fri, 27 Aug 2021 13:23:37 +0200

opsiconfd (4.2.0.193-1) stable; urgency=medium

  * Feature:  Show username
  * Feature:  Logout button
  * Improvement:  Require file admin rights to access depot
  * Feature:  Show Server-Timinig on JSONRPC-Interface page

 -- uib GmbH <info@uib.de>  Tue, 24 Aug 2021 15:49:34 +0200

opsiconfd (4.2.0.192-1) stable; urgency=medium

  * Bugfix:  problem with file logging

 -- uib GmbH <info@uib.de>  Tue, 10 Aug 2021 12:08:21 +0000

-------------------------------------------------------------------

opsi-utils (4.2.0.118-1) stable; urgency=medium

  * Improvement:  updated python-opsi to 4.2.0.229, fixed opsi-set-rights with ambiguous PermissionRegistry

 -- uib GmbH <info@uib.de>  Mon, 30 Aug 2021 11:28:11 +0200

opsi-utils (4.2.0.117-1) stable; urgency=medium

  * Improvement:  incremented version number to 4.2.0.117
  * Improvement:  updated python-opsi to 4.2.0.228, fixed opsi-package-updater download behaviour
  * Feature:  added --ignore-errors option, changed session handling to use one session per repo

 -- uib GmbH <info@uib.de>  Tue, 24 Aug 2021 17:41:14 +0200

-------------------------------------------------------------------

opsi-linux-client-agent (4.2.0.5-1) testing; urgency=low

  * updated opsiclientd to 4.2.0.87
  * fixed installation with custom files

-- Nils Doerrer <n.doerrer@uib.de> Tue, 24 Aug 2021 10:00:00 +0100

opsi-linux-client-agent (4.2.0.4-1) testing; urgency=low

  * updated opsiclientd to 4.2.0.86

-- Nils Doerrer <n.doerrer@uib.de> Thu, 19 Aug 2021 17:00:00 +0100

opsi-linux-client-agent (4.2.0.3-1) testing; urgency=low

  * updated opsiclientd to 4.2.0.85
  * Update oca-installation-helper to 4.2.0.1

-- Nils Doerrer <n.doerrer@uib.de> Wed, 18 Aug 2021 14:00:00 +0100

opsi-linux-client-agent (4.2.0.2-1) testing; urgency=low

  * Update opsiclientd to 4.2.0.83
  * Update opsi-script to 4.12.4.26
  * Update opsi-deploy-client-agent to 4.2.0.13

-- Nils Doerrer <n.doerrer@uib.de> Thu, 12 Aug 2021 15:25:00 +0100

-------------------------------------------------------------------

opsi-client-agent (4.1.1.47-1) stable; urgency=low

  * Update opsiclientd to 4.2.0.88

-- Jan Schneider <j.schneider@uib.de> Tue, 24 Aug 2021 07:50opsi-client-agent (4.2.0.7-1):00 +0100

-------------------------------------------------------------------

opsi-client-agent (4.2.0.7-1) stable; urgency=low

  * Update opsiclientd to 4.2.0.88
  * Update oca-installation-helper to 4.2.0.2

-- Jan Schneider <j.schneider@uib.de> Mon, 30 Aug 2021 11:00:00 +0100

-------------------------------------------------------------------

opsi-utils (4.1.1.37-1) stable; urgency=medium

  * opsi-product-updater: added --no-zsync option

 -- Nils Doerrer <n.doerrer@uib.de>  Fri, 18 Sep 2020 10:36:03 +0200

-------------------------------------------------------------------

linux netboot (4.2.0.1-2) testing; urgency=low

  * intendation fixed
  * minimal required bootimage version changed

 -- Mathias Radtke <m.radtke@uib.de> Tue Aug 17 14:42:00 2021 +0100

-------------------------------------------------------------------

mint20-2 (4.2.0.1-1) testing; urgency=low

  * initial release

-- Mathias Radtke <m.radtke@uib.de> Mon Jul 27 2021 10:31:00 +0200

------------------------------------------------------------------

mint20-1 (4.2.0.1-1) testing; urgency=low

  * initial release

-- Mathias Radtke <m.radtke@uib.de> Mon Jul 27 2021 10:31:00 +0200

------------------------------------------------------------------

windows (4.2.0.1-4) testing; urgency=low

  * fixed opsi-python test in postinst

 -- Mathias Radtke <m.radtke@uib.de> Thu Aug 19 10:16:31 2021 +0200


windows (4.2.0.1-3) testing; urgency=low

  * try-except-pass on hardware inventory

 -- Mathias Radtke <m.radtke@uib.de> Thu Aug  5 08:50:17 2021 +0200

-------------------------------------------------------------------

opsi-local-image-backup (4.2.0.1-1) stable; urgency=low

  * fix progressbar output

-- detlef oertel <d.oertel@uib.de>  Mon, 12 Jul 2021 15:00:00 +0200

-------------------------------------------------------------------

opsi-local-image-restore (4.2.0.1-1) stable; urgency=low

  * fix progressbar output

-- detlef oertel <d.oertel@uib.de>  Mon, 12 Jul 2021 15:00:00 +0200

-------------------------------------------------------------------

opsi-linux-bootimage (20210901-1) testing; urgency=low

  * added 8021Q VLAN config

 -- Mathias Radtke <m.radtke@uib.de> Wed, 01 Sep 2021 15:22:00 +0200

opsi-linux-bootimage (20210825-1) testing; urgency=low

  * patcha: Use original value if escape decoding fails

 -- Jan Schneider <j.schneider@uib.de> Wed, 25 Aug 2021 10:00:00 +0200

opsi-linux-bootimage (20210818-2) testing; urgency=low

  * using new clientconfig.depot.protocol.netboot if available, fallback to old value of not

 -- Mathias Radtke <m.radtke@uib.de> Wed, 18 Aug 2021 14:01:00 +0200

opsi-linux-bootimage (20210818-1) testing; urgency=low

  * kernel 5.13.11

 -- Mathias Radtke <m.radtke@uib.de> Wed, 18 Aug 2021 10:00:00 +0200

------------------------------------------------------------------

opsi-linux-bootimage (20210806-1) testing; urgency=low

  * added new key value pairs to support new linux netboo packages

 -- Mathias Radtke <m.radtke@uib.de> Fri, 06 Aug 2021 16:00:00 +0200

-------------------------------------------------------------------
-------------------------------------------------------------------

[code]
Antworten