opsi 4.1: Actualisations dans testing

Ce forum est dédié au nouveautés, événements autour du projet Opsi
otto
Beiträge: 48
Registriert: 08 Aug 2017, 12:16

opsi 4.1: Actualisations dans testing

Beitragvon otto » 05 Dez 2018, 09:45

Chers utilisateurs d'opsi,

nous avons publié des actualisations pour opsi 4.1 dans testing.

RAPPEL:
Le soutien pour opsi 4.0 n'est que assuré jusqu'à fin 2018.
N'oubliez pas de changer assez tôt à opsi 4.1.


Disponsible pour opsi 4.1 dans testing:
Paquets serveur:
  • opsiconfd 4.1.1.16-2
  • opsipxeconfd 4.1.1.14-1
  • opsi-server 4.1.1.6-1
  • python-opsi 4.1.1.53-1



Cordialement

Niko Wenselowski


PS: Changelogs:

Code: Alles auswählen

opsiconfd (4.1.1.16-2) stable; urgency=medium

  * Removed rotating /var/log/opsi/package.log.
    This logfile is used by opsi-package-manager and logrotate config for this
    file is part of the package opsi-utils.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Thu, 22 Nov 2018 10:55:44 +0100


Code: Alles auswählen

opsipxeconfd (4.1.1.14-1) stable; urgency=medium

  * Make print Python 3 compatible.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 21 Nov 2018 09:42:41 +0100


Code: Alles auswählen

opsi-server (4.1.1.6-1) stable; urgency=medium

  * Fix unattended setup.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 26 Nov 2018 15:11:44 +0100

opsi-server (4.1.1.5.1-1) stable; urgency=medium

  * Remove unsupported translation functions.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Fri, 23 Nov 2018 18:17:00 +0100

opsi-server (4.1.1.5-1) stable; urgency=medium

  * Registering a depot will now provide the user with the option to delete an
    existing client if the ID of the server to register and the client at the
    destination server are the same.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Fri, 23 Nov 2018 17:39:22 +0100


Code: Alles auswählen

python-opsi (4.1.1.53-1) stable; urgency=medium

  * OPSI.System.Posix: isOpenSuse will return False if not running on openSuse.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Fri, 30 Nov 2018 11:26:37 +0100

python-opsi (4.1.1.52-2) testing; urgency=medium

  * OPSI.System.Posix: isOpenSUSE refactored to not use platform

 -- Mathias Radtke <m.radtke@uib.de>  Mon, 26 Nov 2018 12:07:10 +0100

python-opsi (4.1.1.52-1) testing; urgency=medium

  * OPSI.System.Posix: correctly detecting openSUSE Leap 15.0 and above
  * OPSI.System.Posix: using isOpenSUSE() to determine Leap, isOpenSUSELeap()
    is obsolete
  * OPSI.Util.Task.Rights: replaced isOpenSUSELeap() with isOpenSUSE()

 -- Mathias Radtke <m.radtke@uib.de>  Fri, 23 Nov 2018 09:58:13 +0100

python-opsi (4.1.1.51-3) stable; urgency=medium

  * RPM: openSUSE Leap 15 needs net-tools-deprecated to work with 'ifconfig'

 -- Mathias Radtke <m.radtke@uib.de>  Thu, 22 Nov 2018 15:30:36 +0100

python-opsi (4.1.1.51-2) stable; urgency=medium

  * RPM: requires python-mysqlclient on openSUSE Leap 15.0

 -- Mathias Radtke <m.radtke@uib.de>  Mon, 19 Nov 2018 15:43:29 +0100

python-opsi (4.1.1.51-1) stable; urgency=medium

  * Fixed opsiDepotId Usage for opsi-package-updater

 -- Erol Ueluekmen <e.ueluekmen@uib.de>  Mon, 19 Nov 2018 14:48:57 +0100

python-opsi (4.1.1.50-1) stable; urgency=medium

  * OPSI.Util.Task.UpdatePackages: Certificate authentication implemented
    for opsi-package-updater.

 -- Erol Ueluekmen <e.ueluekmen@uib.de>  Fri, 16 Nov 2018 12:38:45 +0100