no splash screen for bootimage

Benutzeravatar
SisterOfMercy
Beiträge: 875
Registriert: 22 Jun 2012, 19:18

no splash screen for bootimage

Beitragvon SisterOfMercy » 22 Jun 2018, 15:49

I like being able to see what the bootimage is doing (i.e. not hanging), and previously this was easily set by removing the 'splash' from the append line in the tftp configuration.
However, recent bootimages seem to have been changed, and now it shows a splash screen again. I think this one is different from the one set in the append line, this one happens later in the startup.
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

Benutzeravatar
m.radtke
Beiträge: 566
Registriert: 10 Jun 2015, 12:19

Re: no splash screen for bootimage

Beitragvon m.radtke » 25 Jun 2018, 15:12

Hi
the opsi 4.1 bootimage has a splash screen
the splash screen was removed in opsi 4.0.6 because of size limitations of the tftpd.
However opsi 4.1 uses the tftpd-hpa, which doesnt have this restriction. Also opsi 4.0 experimental repositories have a opsi 4.1 bootimage along with a patched opsi-atftpd which also doesnt have the size limitation.
as it was the default in opsi 4.0.5 we wanted to return tro this default. A lot of people had issues with the missing splash screen becasue they saw some errors and were insecure about if everything is correct.
You can disable the splash screen by removing 'splash' from the pipe templates.

Cheers
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

Benutzeravatar
SisterOfMercy
Beiträge: 875
Registriert: 22 Jun 2012, 19:18

Re: no splash screen for bootimage

Beitragvon SisterOfMercy » 25 Jun 2018, 18:34

m.radtke hat geschrieben:You can disable the splash screen by removing 'splash' from the pipe templates.


If these are the ones in /tftpboot/linux/pxelinux.cfg/, I have done that. It seemed to remove the first part of the splash screen but it comes on after booting the kernel. Hm, I will unpack a bootimage and look if I can find what it is doing or I will record the startup with and without splash in the tftp configuration.
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!

Benutzeravatar
SisterOfMercy
Beiträge: 875
Registriert: 22 Jun 2012, 19:18

Re: no splash screen for bootimage

Beitragvon SisterOfMercy » 27 Jun 2018, 16:27

The bootimage has this file: /etc/systemd/system/display.service

Code: Alles auswählen

[Unit]
DefaultDependencies=no
After=local-fs.target
Conflicts=getty@tty1.service

[Service]
StandardInput=tty
StandardOutput=tty
ExecStart=/usr/bin/fbi -d /dev/fb0\
  --once --noverbose --autozoom /etc/opsi.png

[Install]
WantedBy=sysinit.target


I think this shows the 'second' splash screen I was talking about.
Bitte schreiben Sie Deutsch, when I'm responding in the German-speaking part of the forum!