New testing packages for opsi 4.0 and 4.1

Benutzeravatar
d.oertel
Beiträge: 3250
Registriert: 04 Jun 2008, 14:27

New testing packages for opsi 4.0 and 4.1

Beitragvon d.oertel » 30 Apr 2018, 14:58

Dear opsi users,

we have now some new packages for opsi 4.0 and opsi 4.1 in testing.

The manuals opsi-winst-manual and opsi-winst-reference-card are
in new versions in the testing section.

The components of the opsi-client-agent
* opsi-winst / opsi-script
* opsi-notifier
* opsi-kiosk
* opsi-systray
are re build with a new Versione of the compiler (Lazarus 1.8.2).
As one important effect of this change they should be now HighDPI aware (at least at Windows 10).

Most important in this release is the opsi-script / opsi-winst Version 4.12.0.17:

defined local functions:
* now defined functions without parameters are possible
* now defined functions without return value (void) are possible
* in case of a syntax error, you get better information about the origin of the code line
* the opsi-config (Host Parameter) debug_lib will now work correct

Additional Features:
* the result of splitstring / splitstringOnWhiteSpace is now confidential, if
the input was confidential
* new function : asConfidential(<string>) : string
* new function : upper(<string>) : string
* new function : RegKeyExists(<keystr> [,<access str>]) : boolean
possible values for the optional parameter <access str> are: 32Bit, 64Bit or sysnative. The default is sysnative.
* new function : RegVarExists(<keystr> [,<access str>]) : boolean
possible values for the optional parameter <access str> are: 32Bit, 64Bit or sysnative. The default is sysnative.
* new function : GetRegistryValue(<keystr> ,<name str>[,<access str>]) : string
possible values for the optional parameter <access str> are: 32Bit, 64Bit or sysnative. The default is sysnative.
* new function : powershellCall(<commandstr> [,<access str>] [,<policy bool>]) : string
possible values for the optional parameter <access str> are: 32Bit, 64Bit or sysnative. The default is sysnative.
* new function : getSubListByMatch(<search string>, <target list>) :stringlist
* new function : getSubListByMatch(<search list>, <target list>) :stringlist
* new function : getSubListByContaining(<search string>, <target list>) :stringlist
* new function : getSubListByContaining(<search list>, <target list>) :stringlist
* new function : getSubListByKey(<search string>, <target list>) :stringlist
* new function : getSubListByKey(<search list>, <target list>) :stringlist
* new function : getKeyList(<list>) :stringlist

For detailed information of the new functions have a look at the
opsi-winst-manual

opsi-client-agent:
If you install the new opsi-client-agent using a opsi-winst 4.12.0.17
a new installation script is used, which uses a lot defined functions.
In this case a opsiclientdguard will be installed as new component which
check if the opsiclientd is running and restarts it if needed.
We hope to fix som opsiclientd start problems on Windows 10 with this new
component.

As testing we publish:

Windows netboot packages
none

Windows localboot packages

* opsi-winst 4.12.0.17
* opsi-client-agent 4.1.0.0-4
* opsi-script-test 4.12.0.17
* config-win10 4.1.0-1

opsi-linux packages

Linux netboot packages
none

Linux localboot packages

* opsi-linux-client-agent (4.1.0.3-1)

opsi-local-image / opsi-vhd:

* opsi-local-image-backup (4.1.0.0-3)
* opsi-local-image-restore (4.1.0.0-4)
* opsi-local-image-prepare (4.1.0.0-3)

Server packages:

opsi 4.0:

* opsi-directory-connector 26-2

opsi 4.1:

* opsi-directory-connector 26-2
* opsi4ucs 4.1.1.4-15
* opsi-utils 4.1.1.19-2
* opsiconfd 4.1.1.10-7
* opsipxeconfd 4.1.1.9-1

Misc:

* The support for UCS 4.1 is dicontinued (end of life of the product)


detlef oertel


Changelogs:
=============================

opsi-winst/opsi-script (4.12.0.17) stable; urgency=low

* osparser: processcall: log Executing on LLNotice
* new unit osparserhelper in common (Skip / getword / ...)
* osdefinedfunctions: int new local string vars
* osdefinedfunctions: isVisibleLocalVar check for empty varname
* osparser: catch powershellCall at Linux
* OsDefinedFunction.parseCallParameter: fix handling parameters with ')'

-- Detlef Oertel <d.oertel@uib.de> Fri, 13 Apr 2018:15:00:00 +0200

opsi-winst/opsi-script (4.12.0.16) stable; urgency=low

* update to openssl-1.0.2o

* typo of log messages
* change to Lazarus 1.8.2
* switch HighDPI awareness on (8.1+, per monitor)
* osparser: reportError: more info on defined functions at syntax error
* osfunc: getsectionlines: include leading comments and empty lines
* osdefinedfunctions, osparser: allow defined functions with no parameters; fixes #3182
* osdefinedfunctions, osparser: allow defined functions with data type void
* oslog: fixed check for library logging
* activate normal debug_lib again (see 4.12.0.13 temporary always true)
* osparser: doAktionen: tsDefineFunction: try-excepts
* osparser: reread opsi.conf parameters for every script; fixes #3337
* osparser: splitstring: if string is confidential all parts are confidential as well; fixes #3186
* osparser: splitStringOnWhiteSpace: if string is confidential all parts are confidential as well; fixes #3186
* osfunc: FSaveToFile new param raise_on_error ; fixes #3253
* new string function asConfidential:
1. backup and set loglevel to warning |2 get the input | 3 make it confidential
| 4 give it to output |5 restore loglevel #3441
* found undocumented string function upper(<str>); fixes #3283
* new boolean function RegKeyExists(<keystr> [,<access str>])
<access str> = one of 32bit, 64bit, sysnative ; default sysnative ; fixes #3078
* new boolean function RegVarExists(<keystr> [,<access str>])
* no warning for not existing releaseid ; fixes #2595
* new boolean function isConfidential(<str>) for testing
* initvars in CreateAndProcessScript ; hopefully fixes errors on restart modified scripts
* redesign of origin detection
* osfuncwin2: reimplementation of getProfileImagePathfromSid
viewtopic.php?f=7&t=9941
* osfuncwin2: reimplementation of delUserProfile
* osfunclin: getpackagelock: look also for UCS ; fixes #3189
* oslindesktopfile: DeleteShellLink: del hard in /usr/share/applications/ ; fixes #3402
* osparser: getregistryvalue(<keystr>, <varstr> [, <access str>]) : string ; fixes #3279
* osparser: powershellcall(<commandstr> [,<access str>='sysnative' [,<policy bool str>='true']]) : [void,str,stringlist] ; fixes #3442

-- Detlef Oertel <d.oertel@uib.de> Wed, 14 Mar 2018:15:00:00 +0200

=============================
opsi-script-test (4.12.0.17-1) stable; urgency=low

* localfunctions.: local functions in loop
* standalone tests subsub
* standalone tests: local functions in loop

-- detlef oertel <d.oertel@uib.de> Tue, 24 Apr 2018 15:00:00 +0200

opsi-script-test (4.12.0.16-1) stable; urgency=low

* ExecWith_powershell: added trap { write-output $_ ; exit 1 }
* ExecWith_powershell: added exit $LASTEXITCODE
* fuction with no parameters
* fuction with no (void) result
* using isConfidential to test:
** SetConfidential
** asConfidential
** splitStringOnWhiteSpace
** splitString
* asConfidential
* upper(<str>)
* lower(str)
* RegKeyExists
* RegVarExists
* %opsiapplog%
* %opsidata%
* getIndexFromListByContaining
* new function : getSubListByMatch(<search string>, <target list>) :stringlist
* new function : getSubListByMatch(<search list>, <target list>) :stringlist
* new function : getSubListByContaining(<search string>, <target list>) :stringlist
* new function : getSubListByContaining(<search list>, <target list>) :stringlist
* new function : getSubListByKey(<search string>, <target list>) :stringlist
* new function : getSubListByKey(<search list>, <target list>) :stringlist
* new function : getKeyList(<list>) :stringlist
* getregistryvalue(<keystr>, <varstr> [, <access str>]) : string
* powershellCall

-- detlef oertel <d.oertel@uib.de> Tue, 27 Mar 2018 15:00:00 +0200

=============================
opsi-client-agent (4.1.0.0-4) stable; urgency=low

* fix integration of opsiclientdguard
* upgrade to opsi-winst 4.12.0.17

-- Detlef Oertel <d.oertel@uib.de> Fri, 20 Apr 2018:15:00:00 +0200

opsi-client-agent (4.1.0.0-3) stable; urgency=low

* setup411.opsiscript renamed to setup.opsiscript
* setup script is setup.opsiscript (change also in postinst.d 50_oca)
* change a lot of files back from DOS to unix lineendings

-- Detlef Oertel <d.oertel@uib.de> Wed, 18 Apr 2018:15:00:00 +0200

opsi-client-agent (4.1.0.0-2) stable; urgency=low

* added opsiclientdguard service
* upgrade to opsi-winst 4.12.0.16
* setup script is setup411.opsiscript (change also in postinst.d 50_oca)
* fork setup scripts by winst version >= 4.12.0.16 calls setup412.opsiscript
* notifier upgrade to 4.1.0.0
* notifier configuration now in opsi-notifier/notifier.d
* systray upgrade 4.1.0.0
* update to openssl-1.0.2o
* kiosk upgrade 4.1.0.0

-- Detlef Oertel <d.oertel@uib.de> Fri, 16 Mar 2018:15:00:00 +0200

=============================
config-win10 (4.1.0-1); stable; urgency=low

* fixed flashplayer architecture logic

-- Andre Neugebauer <a.neugebauer@uib.de> Mon, 16 Apr 2018 14:50:00 +0200
=============================
opsi-local-image-backup (4.1.0.0-3) stable; urgency=low

* remove old existing image file before create new one
* code cleanup

-- detlef oertel <d.oertel@uib.de> Thu, 26 Apr 2018 15:00:00 +0200

opsi-local-image-backup (4.1.0.0-2) stable; urgency=low

* backup also new compressed format
* remove rsync restore from code
* remove ntfs acl backup

-- detlef oertel <d.oertel@uib.de> wed, 07 Feb 2018 15:00:00 +0200


=============================
opsi-local-image-restore (4.1.0.0-4) stable; urgency=low

* fix blocksize 0 bug with old images
* code cleanup

-- detlef oertel <d.oertel@uib.de> Thu, 26 Apr 2018 15:00:00 +0200

=============================

opsi-directory-connector (26-2) stable; urgency=medium

* RPM: Make use of python-rpm-macros for building.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 22 Mar 2018 13:43:00 +0100

=============================

opsi4ucs (4.1.1.4-15) stable; urgency=medium

* Removed UCS 3.x style overview pages.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 24 Apr 2018 15:24:27 +0200

opsi4ucs (4.1.1.4-14) stable; urgency=medium

* More consistent backend update approach.
* Added the possibility to install / update packages during the join
script.

-- Niko Wenselowski <n.wenselowski@uib.de> Fri, 20 Apr 2018 16:32:42 +0200

opsi4ucs (4.1.1.4-13) stable; urgency=medium

* For (un)registering opsi4ucs we rely on debian/rules.

-- Niko Wenselowski <n.wenselowski@uib.de> Fri, 20 Apr 2018 11:25:56 +0200

=============================

opsi-utils (4.1.1.19-2) stable; urgency=medium

* Updated manpages for opsi-makepackage and opsi-package-updater.

-- Niko Wenselowski <n.wenselowski@uib.de> Wed, 21 Mar 2018 13:45:54 +0100

opsi-utils (4.1.1.19-1) stable; urgency=medium

* opsi-package-manager: --differences will show a message if the depots
have no differences.

-- Niko Wenselowski <n.wenselowski@uib.de> Wed, 21 Mar 2018 11:48:02 +0100

opsi-utils (4.1.1.18-1) stable; urgency=medium

* example.repo.template: dirs point to opsi 4.1.
* Provide longopts also with "packages" (and not only "products").
* Update the descriptions of functions.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 08 Mar 2018 11:10:47 +0100

=============================

opsiconfd (4.1.1.10-7) stable; urgency=medium

* Added python-setuptools as an explicit requirement so that script
entry points work.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 24 Apr 2018 16:41:08 +0200

opsiconfd (4.1.1.10-6) testing; urgency=medium

* RPM: On openSUSE 42.3 require python-rrdtool.

-- Niko Wenselowski <n.wenselowski@uib.de> Wed, 21 Mar 2018 15:41:15 +0100

opsiconfd (4.1.1.10-5) testing; urgency=medium

* opsiconfd.spec: Clean up specfile.
* opsiconfd.spec: Less branches - a lot of this is now considered our
standard environment.
* opsiconfd.spec: Removed BuildRequires python-opsi on SUSE.
* opsiconfd.spec: Directories required for using rrdtool from within
opsiconfd are now created by default.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 20 Mar 2018 18:02:37 +0100

=============================

opsipxeconfd (4.1.1.9-1) stable; urgency=medium

* Small change in log message of PXEConfigWriter.
* ClientConnection: Socket timeout set to 2.0 seconds.
* ClientConnection: callback is executed as long as thread is running.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 12 Apr 2018 16:17:20 +0200

=============================
opsi-local-image-prepare (4.1.0.0-3) stable; urgency=low

* fix sgdisk --zap on uefi boxes

-- detlef oertel <d.oertel@uib.de> Fri, 27 Apr 2018 15:00:00 +0200

=============================
opsi-linux-client-agent (4.1.0.3-1) stable; urgency=medium

* opsi-script 4.12.0.17

-- d.oertel <d.oertel@uib.de> Mon, 30 Apr 2018 15:00:00 + 0100

opsi-linux-client-agent (4.1.0.2-1) stable; urgency=medium

* opsi-script 4.12.0.16

-- d.oertel <d.oertel@uib.de> Fri, 06 Apr 2018 15:00:00 + 0100

=============================
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org