Updates für opsi 4.1 / 4.2 stable und testing

Neuigkeiten und Ankündigungen
Benutzeravatar
d.oertel
uib-Team
Beiträge: 3291
Registriert: 04 Jun 2008, 14:27

Updates für opsi 4.1 / 4.2 stable und testing

Beitragvon d.oertel » 22 Mär 2021, 16:40

Sehr geehrte opsi-Anwenderinnen und -Anwender,

hiermit haben wir weitere Pakete für opsi 4.1 / 4.2 in Testing und Stable veröffentlicht.

=====================================
Aktualisierte Pakete in Testing:
=====================================

Windows Localboot Pakete:

* opsi-client-agent 4.1.1.30-1
* opsi-client-kiosk 4.1.1.9-8

Linux Localboot Pakete:

* l-opsi-server 4.2.0.3-1
* l-opsi-server-migrate 4.2.3-2
* opsi-linux-client-agent 4.1.1.11-2

opsi-local-image Localboot Pakete:

* none

macOS Localboot Pakete:

* m-homebrew 4.1.0.3-1
* m-javavm (4.1.0.0-2)
* opsi-mac-client-agent 4.1.1.5-1

Windows Netboot Pakete:

* win_nt6 4.1.0.2-13
* opsi-clonezilla 4.1.0.2-2

Linux Netboot Pakete:

* ucs44 4.1.0.4-1
* sles15-1 (4.1.0.2-2)
* sles15-2 (4.1.0.2-2)

opsi-local-image Netboot Pakete:

* windows NT6: opsi-local-image-win* (4.1.0.2-13)
* windows NT6: opsi-vhd-win10-x64 (4.1.0.2-13)


opsi Server Pakete:

* opsi-script 4.12.4.13
* python-opsi 4.1.1.101-1 (opsi 4.1)
* opsi-utils (4.2.0.80-1) (opsi 4.2)
* opsiconfd (4.2.0.139-1) (opsi 4.2)


opsi Manuals:

* none

=====================================
Aktualisierte Pakete in Stable:
=====================================
=====================================


Windows Localboot Pakete:

* opsi-winst 4.12.4.13-1


Linux Localboot Pakete:

* none


opsi-local-image Localboot Pakete:

* none


Windows Netboot Pakete:

* win_nt6 4.1.0.2-10
* opsi-clonezilla 4.1.0.2-2

Linux Netboot Pakete:

* debian 4.1.0.4-3
* debian10 4.1.0.6-4
* opsi-clonezilla 4.1.0.2-2


opsi-local-image Netboot Pakete:

* windows NT6: opsi-local-image-win* (4.1.0.2-10)
* windows NT6: opsi-vhd-win10-x64 (4.1.0.2-10)
* opsi-local-image-restore (4.1.0.1-5)


opsi Server Pakete:

* opsi-winst 4.12.4.13-1
* python-opsi 4.1.1.99-1 (opsi 4.1)

opsi Manuals:

* none


#################################################################################

mit freundlichen Grüßen

detlef oertel

##########

Hier kommen die

Changelogs

Code: Alles auswählen

===========================================================================================

opsi-clonezilla (4.1.0.2-2) stable; urgency=low

  * changed architecture default to 64bit

 -- Mathias Radtke <m.radtke@uib.de> Wed 24 Feb 2021 10:00:00 +0100

===========================================================================================

sles15 (4.1.0.2-2) testing; urgency=low

  * cpio now running without --no-absolute-filenames

 -- Mathias Radtke <m.radtke@uib.de> Wed Dec 02 12:30:00 2020 +0100

sles15 (4.1.0.2-1) testing; urgency=low

  * performing hwaudit

 -- Mathias Radtke <m.radtke@uib.de> Thu Nov 26 10:30:00 2020 +0100

sles15 (4.1.0.1-5) testing; urgency=low

  * corrected handling of forked packages

 -- Mathias Radtke <m.radtke@uib.de> Mon Nov 16 10:44:00 +0100

sles15 (4.1.0.1-4) testing; urgency=low

  * added some diffs from autoyast config from manually installed system

 -- Mathias Radtke <m.radtke@uib.de> Tue Nov 10 10:00:00 2020 +0100

sles15 (4.1.0.1-3) testing; urgency=low

  * using shadow_password_hash function to encode passwords

 -- Mathias Radtke <m.radtke@uib.de> Mon Nov 02 10:15:00 2020 +0100

sles15 (4.1.0.1-2) testing; urgency=low

  * made usage of kexec more versatile

 -- Mathias Radtke <m.radtke@uib.de> Wed Oct 28 13:54:51 2020 +0200


sles15 (4.1.0.1-1) stable; urgency=low

  * python3 compatible code base

 -- Mathias Radtke <m.radtke@uib.de> Mon Jul 20 18:31:44 2020 +0200


sles15 (4.1.0.0-1) testing; urgency=low

  * forked from sles12sp3

-- Mathias Radtke <m.radtke@uib.de> Mon Aug 20 11:48:00 2018 +0200

===========================================================================================

debian (4.1.0.4-3) tetsing; urgency=low

  * installing netplan.io when release = buster
  * runnig netplan apply to make network work on first boot

 -- Mathias Radtke <m.radtke@uib.de> Thu Feb 11 11:09:00 +0100

debian (4.1.0.4-2) testing; urgency=low

  * fixed error when using netplan

 -- Mathias Radtke <m.radtke@uib.de> Wed Feb 10 10:20:00 2020 +0100

===========================================================================================

debian10 (4.1.0.6-4) testing; urgency=low

  * kernel update

 -- Mathias Radtke <m.radtke@uib.de> Fri Feb 12 09:21:00 2021 +0100

===========================================================================================

opsi-local-image-restore (4.1.0.1-5) stable; urgency=low

  * changed architecture default to 64bit

 -- Mathias Radtke <m.radtke@uib.de> Wed 24 Feb 2021 10:00:00 +0100

===========================================================================================

opsi-local-image (4.1.0.2-13) testing; urgency=low

  * adapted setup py script to work with new (4.12.4.15) opsi-script structure

 -- Mathias Radtke <m.radtke@uib.de> Thu Mar 11 14:40:58 2021 +0200


opsi-local-image (4.1.0.2-12) testing; urgency=low

  * raising exception of hostname is longer than 15 characters

 -- Mathias Radtke <m.radtke@uib.de> Thu Mar  4 09:18:40 2021 +0200


opsi-local-image (4.1.0.2-11) testing; urgency=low

  * fixed an error while parsing output
  * moving from opsi-winst to opsi-script

 -- Mathias Radtke <m.radtke@uib.de> Mon Mar  1 10:33:50 2021 +0200


opsi-local-image (4.1.0.2-10) testing; urgency=low

  * small changes for webdav support

 -- Mathias Radtke <m.radtke@uib.de> Fri Feb  5 17:27:29 2021 +0200

 ===========================================================================================

ucs44 (4.1.0.4-1) testing; urgency=low

  * updated to ucs 4.4-7

 -- Mathias Radtke <m.radtke@uib.de> Wed Feb 24 11:25:00 2020 +0100

===========================================================================================

windows (4.1.0.2-13) testing; urgency=low

  * adapted setup py script to work with new (4.12.4.15) opsi-script structure

 -- Mathias Radtke <m.radtke@uib.de> Thu Mar 11 14:39:33 2021 +0200


windows (4.1.0.2-12) testing; urgency=low

  * raising exception of hostname is longer than 15 characters

 -- Mathias Radtke <m.radtke@uib.de> Thu Mar  4 09:18:31 2021 +0200


windows (4.1.0.2-11) testing; urgency=low

  * fixed an error while parsing output
  * moving from opsi-winst to opsi-script

 -- Mathias Radtke <m.radtke@uib.de> Mon Mar  1 10:32:19 2021 +0200


windows (4.1.0.2-10) testing; urgency=low

  * small changes for webdav support

 -- Mathias Radtke <m.radtke@uib.de> Fri Feb  5 17:27:18 2021 +0200

===========================================================================================

opsi-linux-client-agent (4.1.1.11-2) testing; urgency=medium

 * included apt dependency install fix

  -- Nils Doerrer <n.doerrer@uib.de> Wed, 10 Mar 2021 15:00:00 + 0100
 
opsi-linux-client-agent (4.1.1.11-1) testing; urgency=medium

 * updated opsiclientd to 4.2.0.66
 * differentiate between system with or without gui to install only necessary packages

  -- Nils Doerrer <n.doerrer@uib.de> Tue, 02 Feb 2021 15:00:00 + 0100

opsi-linux-client-agent (4.1.1.10-1) testing; urgency=medium

 * updated opsi-script to 4.12.4.13
 * changed uninstall to preserve opsi-script if it was installed as server-package

  -- Nils Doerrer <n.doerrer@uib.de> Tue, 26 Jan 2021 10:00:00 + 0100

===========================================================================================

opsi-winst/opsi-script (4.12.4.13) stable; urgency=low

 * osfunc: new: TUibIniFile.ReadRawSection (by j.laajili)
 * new function getSectionFromIniFile based on ReadRawSection (by j.laajili)
 * osxmlsections: fix for xml2 delnode

-- d.oertel <d.oertel@uib.de> Mon, 25 Jan 2021 15:00   

===========================================================================================

m-homebrew 4.1.0.3-1 stable urgency=low

 * using $homebrewbasedir$ to keep HOMEBREW_PREFIX consistent on INTEL and ARM

 -- Mathias Radtke <m.radtke@uib.de> Tue, 16 Mat 2021 11:28:00 +0100

m-homebrew 4.1.0.2-1 stable urgency=low

 * pre create /usr/local/Homebrew as root and chown it to opsisetupadmin

 -- d.oertel <d.oertel@uib.de> Thu, 28 Jan 2021 15:00:00 + 0100
 
m-homebrew 4.1.0.1-1 stable urgency=low

 * change from ruby to bash version

 -- d.oertel <d.oertel@uib.de> Thu, 31 Dec 2020 15:00:00 + 0100
 
m-homebrew 4.1.0.0-1 stable urgency=low

 * inital
 * require m-xcode-tools

 -- d.oertel <d.oertel@uib.de> Wed, 18 Dec 2019 15:00:00 + 0100
 
===========================================================================================

m-javavm (4.1.0.0-2) stable; urgency=medium

  * using $homebrewbasedir$ variable as now compatible with ARM64

-- Mathias Radtke <m.radtke@uib.de> Thu, 18 Mar 2021 15:35:00 +0100

m-javavm (4.1.0.0-1) stable; urgency=medium

  * switch to berw install --cask
  * switch install generic actual sapmachine-sdk

-- d.oertel <d.oertel@uib.de> Thu, 31 Dec 2020 15:00:00 +0100


m-javavm (11.0.6.0.1-1) stable; urgency=medium

  * inital

-- d.oertel <d.oertel@uib.de> Tue, 25 Feb 2020 15:00:00 +0100

===========================================================================================

opsi-mac-client-agent (4.1.1.5-1) stable; urgency=medium

 * opsi-script / opsi-script-gui update to 4.12.4.15 (signed)
 * update opsiclientd to 4.2.0.67
 * update opsi-notifier to 4.1.1.6 (notarized)
 * update opsi-client-systray to 4.1.2.3
 * add firewall configuration
 * modified libssl call (now safe)

-- d.oertel <d.oertel@uib.de> Mon, 15 Feb 2021 15:00:00 + 0100

opsi-mac-client-agent (4.1.1.4-1) stable; urgency=medium

 * opsi-script / opsi-script-gui update to 4.12.4.12
 * update opsiclientd to 4.2.0.53
 * update opsi-notifier to 4.1.1.6

-- d.oertel <d.oertel@uib.de> Mon, 21 Dec 2020 15:00:00 + 0100

opsi-mac-client-agent (4.1.1.3-1) stable; urgency=medium

 * opsi-script / opsi-script-gui update to 4.12.4.10
 * postinst hardlink opsi-script to opsi-script-nogui
 * the opsi-script nogui version is now opsi-script
 * the opsi-script gui version is now opsi-script-gui
 * opsi-script tests via opsi-laz-gui-test if a gui can be used
   and if yes calls opsi-script-gui (via execv)
 * fix font defaults in notifier event.ini
 * add opsi-laz-gui-test 4.1.0.0
 * update opsiclientd to 4.2.0.36
 * add opsi-client-systray 4.1.2.2
 * add opsiclientd_event_starter 4.1.01
 * update opsi-notifier to 4.1.1.5
 * tests with on_shutdown
  * do not recursive chown opsisetupadmin:admin /var/opsisetupadmin
    (this would try to chown the mounted opsi_depot share)
  * added complete uib opsi-script lib

-- d.oertel <d.oertel@uib.de> Sun, 06 Dec 2020 15:00:00 + 0100

===========================================================================================

opsi-client-kiosk (4.1.1.9-8) experimental; urgency=low

  * fix: product detail view (tiles view) now displayes an update button also in the case if the installation-now-button is enabled and an action request was already set on the server.

 -- Jan Werner <j.werner@uib.de>  Wed, 03 Mar 2021 17:00:00 +0000
 
===========================================================================================

python-opsi (4.1.1.101-1) stable; urgency=medium

  * updated hwaudit locales to include TPM data

 -- Nils Doerrer <n.doerrer@uib.de>  Fri, 19 Mar 2021 09:23:33 +0100

python-opsi (4.1.1.100-1) stable; urgency=medium

  * introduced TPM section and fields for MacOS data in opsihwaudit.conf

 -- Nils Doerrer <n.doerrer@uib.de>  Fri, 12 Mar 2021 09:29:43 +0100

python-opsi (4.1.1.99-1) testing; urgency=medium

  * adding more opsi-bootimage.append parameters

 -- Mathias Radtke <m.radtke@uib.de>  Wed, 27 Jan 2021 17:08:46 +0100

===========================================================================================

opsi-client-agent (4.1.1.30-1) stable; urgency=low

  * Update opsiclientd to 4.2.0.68
  * Update opsi-login-blocker to 4.2.0.0
  * Create and lock TLS dir c:\opsi.org\tls

-- Jan Schneider <j.schneider@uib.de> Mon, 08 Mar 2021 14:29:00 +0100

===========================================================================================

l-opsi-server (4.2.0.3-1); testing; urgency=low

  * opsi 4.2: UCS: installing univention-samba if not running on memberserver
  * opsi 4.2: ubuntu/debian/ucs: grafana repo added in grafana.list
  * opsi 4.2: sles15-1: installing opsi-server-full twice because of
  unpredictable errno -8
  * opsi 4.2: installing opsi-server-full on UCS 4.4
  * opsi 4.1: splitting UCS distRelease string to prevent error when comparing

-- Mathias Radtke <m.radtke@uib.de> Fri, 05 Mar 2021 16:08:00 +0100

===========================================================================================

l-opsi-server-migrate 4.2.3-2; stable; urgency=low

  * downloading and installing grafana

 -- Mathias Radtke <m.radtke@uib.de> Tue, 09 Mar 2021 10:00:00 +0100

l-opsi-server-migrate 4.2.3-1; stable; urgency=low

  * added Support for Univention UCS 4.4

 -- Mathias Radtke <m.radtke@uib.de> Mon, 01 Mar 2021 15:00:00 +0100

===========================================================================================

opsi-utils (4.2.0.80-1) stable; urgency=medium

  * Feature:  added --repo-remove feature to opsi-package-manager to clean files...
  * Feature:  added --repo-remove feature to opsi-package-manager to clean files from local repositories

 -- uib GmbH <info@uib.de>  Fri, 19 Mar 2021 10:03:19 +0000

opsi-utils (4.2.0.79-1) stable; urgency=medium

  * Improvement:  Update python-opsi

 -- uib GmbH <info@uib.de>  Wed, 17 Mar 2021 16:26:08 +0100

opsi-utils (4.2.0.78-1) stable; urgency=medium

  * Improvement:  Update python-opsi

 -- uib GmbH <info@uib.de>  Tue, 16 Mar 2021 12:24:47 +0100

opsi-utils (4.2.0.77-1) stable; urgency=medium

  * Improvement:  Update python-opsi

 -- uib GmbH <info@uib.de>  Mon, 15 Mar 2021 18:59:56 +0100

opsi-utils (4.2.0.76-1) stable; urgency=medium

  * Improvement:  Update python packages

 -- uib GmbH <info@uib.de>  Mon, 15 Mar 2021 18:11:47 +0100

===========================================================================================

opsiconfd (4.2.0.143-1) stable; urgency=medium

  * Improvement:  Improve help text for --ssl-ciphers

 -- uib GmbH <info@uib.de>  Thu, 18 Mar 2021 10:34:59 +0100

opsiconfd (4.2.0.142-1) stable; urgency=medium

  * Feature:  Log warning if client calls deprecated method

 -- uib GmbH <info@uib.de>  Wed, 17 Mar 2021 14:41:30 +0100

opsiconfd (4.2.0.141-1) stable; urgency=medium

  * Improvement:  Update python-opsi

 -- uib GmbH <info@uib.de>  Tue, 16 Mar 2021 12:19:38 +0100

opsiconfd (4.2.0.140-1) stable; urgency=medium

  * Improvement:  Update python-opsi

 -- uib GmbH <info@uib.de>  Mon, 15 Mar 2021 19:00:50 +0100

opsiconfd (4.2.0.139-1) stable; urgency=medium

  * Bugfix:  Fix redis reconnect

 -- uib GmbH <info@uib.de>  Mon, 15 Mar 2021 12:34:35 +0100
 
===========================================================================================
===========================================================================================
===========================================================================================
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org