Updates für opsi 4.1 stable und testing

Neuigkeiten und Ankündigungen
Benutzeravatar
d.oertel
uib-Team
Beiträge: 3291
Registriert: 04 Jun 2008, 14:27

Updates für opsi 4.1 stable und testing

Beitragvon d.oertel » 17 Aug 2020, 19:24

Sehr geehrte opsi-Anwenderinnen und -Anwender,

hiermit haben wir weitere Pakete für opsi 4.1 in Testing und Stable veröffentlicht.

Weiterhin wurden die Dokumentationen aktualisiert.

Wichtige Neuerungen in diesem Release:

* Die opsi-server installation auf der Plattform openSuse Leap 15.1 ist in stable verfügbar

* Die opsi-winst/opsi-script Version 4.12.4 beinhaltet eine Vereinheitlichung
der internen Implementierung von winbatch und shellBatch Sektionen
und ermöglicht damit die lange erwünschten /runelevated Parameter
auch für ShellBatch (& Co) Sektionen.

* hwaudit liegt jetzt in einer einheitlichen und plattformübergreifenden Version vor.
(Das Produkt l-hwaudit ist damit obsolet)

* Das Produkt windows10-upgrade (20.04-1) setzt voraus: opsi-client-agent (4.1.0.0-47)

=====================================
Aktualisierte Pakete in Testing:
=====================================

Windows Localboot Pakete:

* opsi-auto-update 4.1.0.3-1
* hwaudit 4.1.1.0-1
* opsi-uefi-netboot (4.1.0.0-1)
* opsi-winst / opsi-script 4.12.4.0
* opsi-script-test (4.12.4.0-1)
* opsi-client-agent (4.1.0.0-47)
* windows10-upgrade (20.04-1)
* opsi-wim-capture (4.1.0.1-8)
* swaudit (4.1.0.4-1)

Linux Localboot Pakete:

* opsi-auto-update 4.1.0.3-1
* hwaudit 4.1.1.0-1
* opsi-uefi-netboot (4.1.0.0-1)
* opsi-linux-client-agent_4.1.1.0-4
* swaudit (4.1.0.4-1)

opsi-local-image Localboot Produkte:

* opsi-auto-update 4.1.0.3-1
* opsi-local-image-backup-starter (4.1.0.0-1)

Windows Netboot Produkte:

* windows (4.1.0.1-16)


Linux Netboot Pakete:

* debian9 (4.1.0.3-4)
* debian10 (4.1.0.4-4)
* ubuntu18-04 (4.1.0.3-4)
* ubuntu20-04 (4.1.0.3-6)


opsi-local-image Netboot Produkte:

* windows (4.1.0.1-16)


opsi Server Produkte:

* keine

opsi Manuals

* opsi-script-manual

=====================================
Aktualisierte Pakete in Stable
=====================================
=====================================


Windows Localboot Pakete:

* opsi-auto-update (4.1.0.2-1)

Linux Localboot Pakete:

* l-debuntu-upgrade (4.1.0.0-6)
* opsi-auto-update (4.1.0.2-1)


opsi-local-image Localboot Produkte:

* opsi-auto-update (4.1.0.2-1)


Windows Netboot Produkte:

* keine


Linux Netboot Pakete:

* keine


opsi-local-image Netboot Produkte:

* keine

opsi Server Produkte:

* keine

opsi Manuals

* opsi-script-manual

#################################################################################

mit freundlichen Grüßen

detlef oertel

##########

Hier kommen die

Changelogs
--------------------

Code: Alles auswählen

===========================================================================================
opsi-auto-update (4.1.0.3-1) stable; urgency=low

   * property description changed: blacklist to 'deny list', whitelist to 'allow list'
   * https://www.heise.de/news/Nichtrassistische-Sprache-Abschied-von-Blacklist-und-Whitelist-4784291.html

-- detlef oertel <d.oertel@uib.de>  Tue, 28 Jul 2020 15:00:00 +0200

opsi-auto-update (4.1.0.2-1) stable; urgency=low

   * property setup_after_install removed
   * new bool property: shutdown_on_finish (default=false)
      if true we have a final shutdown
      if false we have no reboot / shutdown
   * uefi support for opsi-local-image-restore start

-- detlef oertel <d.oertel@uib.de>  Thu, 14 May 2020 15:00:00 +0200
===========================================================================================

l-debuntu-upgrade (4.1.0.0-6) stable; urgency=low

  * bionic to focal upgrade added
  * reboot if needed after initial update

-- detlef oertel <d.oertel@uib.de>  Tue, 19 May 2020 15:00:00 +0000
===========================================================================================
opsi-local-image-backup-starter (4.1.0.0-1) stable; urgency=low

   * use library: "uib_bootutils"
   * use library: "uib_reboot_lib"

 -- detlef oertel <d.oertel@uib.de>  Thu, 14 May 2020 15:00:00 +0200
===========================================================================================
opsi-uefi-netboot (4.1.0.0-1) stable; urgency=low

   * code redesign
   * new property prefer_boot_option (network / local-stored-bootimage)
   * complete code is now in library that may be used also in other products

-- detlef oertel <d.oertel@uib.de>  Mon, 13 May 2019 15:00:00 +0200
===========================================================================================
windows (4.1.0.1-16) testing; urgency=low

  * new property: force_del_winpe_boot_entry
  * nt6.opsiscript: on pe-preserve=false do remove opsitempwinpe from display order
 
 -- detlef oertel <d.oertel@uib.de>  Mon, 31 Jul 2020 15:00:00 +0200
 
windows (4.1.0.1-15) testing; urgency=low

  * supplied boot devices to fix broken HP UEFIs
  * merged and packed by do
 
 -- Mathias Radtke <m.radtke@uib.de> Thu Jul  23 15:00:00 2020 +0200
 
opsi-local-image (4.1.0.1-14) skipped

opsi-local-image (4.1.0.1-13) skipped

===========================================================================================
opsi-winst/opsi-script (4.12.4.0) experimental; urgency=low

  * includes changes from github merge request "Feature / Implementation parity between WinBatch, DosBatch and ExecWith"
    * DosBatch-Sections to be executed with elevated privileges like WinBatch could be using /RunElevated
    * /Run*-Parameters for ExecWith
    * Output catching, /showouput and getOutStreamFromSection support for WinBatch
  * compiled with lazarus 2.0.10
  * fix for /showoutput at win64
  * fix for runningonuefi if w10 release >= 2004
  * osparser: execDosBatch: additional parameters now allowed for shellInAnIcon &co:
     /runElevated
     /TimeoutSeconds <number>
     /WaitForProcessEnding <string>
     /LetThemGo

-- j.werner <j.werner@uib.de> Thu, 30 Jul 2020 17:54

opsi-winst/opsi-script (4.12.3.18) experimental; urgency=low

  * UTF8String replaced by String
  * AnsiToUTF8() removed accordingly
  * compiled with lazarus 2.0.10

-- j.werner <j.werner@uib.de> Thu, 30 Jul 2020 16:56

opsi-winst/opsi-script (4.12.3.17) stable; urgency=low

  * osfunc: StartProcess_cp: log message: 'Started process' now in utf8 encoding
  * osfunc: StartProcess_cp: use filename and parameters
  * compiled with lazarus 2.0.10

-- d.oertel <d.oertel@uib.de> Thu, 23 Jul 2020 15:00

opsi-winst/opsi-script (4.12.3.16) stable; urgency=low

  * oswebservice:sendlog: Log that using default if getLogsize failed
  * osfuncwin: some logprog in WinIsUefi
  * osfuncwin:  getW10Release
  * osfuncwin: WinIsUefi: fix uefi detection if w10 release >= 2004
  * osparser: good bye to cmd64.exe
  * osfunc: alldelete: change loglevel for not deleted files

-- d.oertel <d.oertel@uib.de> Fri, 19 Jun 2020 15:00

opsi-winst/opsi-script (4.12.3.15) experimental; urgency=low

  * oswebservice: avoid double /rpc in service url;
  * osfunclin: better getProfilesDirListLin
  * osparser: doTextpatch: Do not crash on not creatable files
  * osprocessess: ProcessIsRunning: more info in warning

-- d.oertel <d.oertel@uib.de> Tue, 09 Jun 2020 15:00

opsi-winst/opsi-script (4.12.3.14) experimental; urgency=low

  * osparser: new flag: cmd64checked to avoid repeated checks for cmd64.exe
  * osmain: bool var runSilent used in cli parameter check and to call
    FBatchOberflaeche.setVisible(True/False);
  * osbatchgui: start FBatchOberflaeche visible=false ; fixes #4485

-- Detlef Oertel <d.oertel@uib.de>  Thu, 04 Jun 2020:15:00:00 +0200

opsi-winst/opsi-script (4.12.3.13) experimental; urgency=low

  * osmain: bootmode: now using opsiclientagentconf
  * linux: osprocesses: ProcessIsRunning: look for exact match in 15 char shortcmd
  * osfunclin: os_shutdown()
  * osmain: (linux) try to direct reboot or shutdown

-- Detlef Oertel <d.oertel@uib.de>  thu, 12 Mar 2020:15:00:00 +0200 
===========================================================================================
opsi-client-agent (4.1.0.0-47) testing; urgency=low

  * opsiclientkiosk Version 4.1.1.4 (fix in detailed product view, no limitation to 255 characters anymore for description text and advice text)
  * backport from 4.1.1 to open or close  c:\opsi.org: DosInAnIcon_open_dir:

-- Jan Werner <j.werner@uib.de>  Tue  11 Aug 2020:12:09:00 +0200

opsi-client-agent (4.1.0.0-46) testing; urgency=low

  * backport from 4.1.1 to open c:\tmp: DosInAnIcon_open_dir:
    update setacl.exe

-- Detlef Oertel <d.oertel@uib.de>  Wed  05 Aug 2020:15:00:00 +0200

opsi-client-agent (4.1.0.0-45) testing; urgency=low

  * backport from 4.1.1 to open c:\tmp: DosInAnIcon_open_dir

-- Detlef Oertel <d.oertel@uib.de>  Fri  31 Jul 2020:15:00:00 +0200

opsi-client-agent (4.1.0.0-44) testing; urgency=low

  * fix rights for c:\opsi.org\usrtmp
  * update to opsiclientdguard 4.0.0.1

-- Detlef Oertel <d.oertel@uib.de>  Mon  22 Jun 2020:15:00:00 +0200

opsi-client-agent (4.1.0.0-43) testing; urgency=low

  * fix for opsiclientkiosk:
    * clean up folder opsiclientkiosk: unnecessary files/folders removed (e.g. files_to_copy)
    * edit subconfig section [Files_copy_kiosk_client]
    * edit postinst/preinst (edit path to ock_custom)
    * changed paths in images_to_depot

-- Jan Werner <j.werner@uib.de>  Tue, 9 June 2020:18:20:00 +0200

opsi-client-agent (4.1.0.0-42) experimental; urgency=low

  * update to opsiclientd : ????????

-- Detlef Oertel <d.oertel@uib.de>  Thu  09 Apr 2020:15:00:00 +0200

opsi-client-agent (4.1.0.0-41) experimental; urgency=low

  * update to opsi-client-systray 4.1.1.0
    * change to synapse
    * no backend_exit
  * update for win10 to opsiclientd : 4.0.100
  * requires opsi-script 4.12.0.17

-- Detlef Oertel <d.oertel@uib.de>  Mo, 06 Apr 2020:15:00:00 +0200
===========================================================================================
opsi-script-test (4.12.4.0-1) stable; urgency=low

  * shellInAnIcon with /runelevated
 
-- detlef oertel <d.oertel@uib.de>  Mon,  03 Aug 2020 15:00:00 +0200

opsi-script-test (4.12.3.15-3) stable; urgency=low

  * encodingtest: call of binary with umlaut: test winbatch
 
-- detlef oertel <d.oertel@uib.de>  Thu,  23 Jul 2020 15:00:00 +0200

opsi-script-test (4.12.3.15-2) stable; urgency=low

  * controlfunctions: runningOnUefi test
  * new property adminuser_password (default=linux123)
 
-- detlef oertel <d.oertel@uib.de>  Mon,  22 Jun 2020 15:00:00 +0200

opsi-script-test (4.12.3.15-1) stable; urgency=low

  * winbatch: always with timeout to avoid endless runs
 
-- detlef oertel <d.oertel@uib.de>  Fri,  12 Jun 2020 15:00:00 +0200

opsi-script-test (4.12.3.10-1) stable; urgency=low

  * fix an error in opsi-script-test.opsiscript
      Instead of using the default format of date, display the current unix timestamp.
      This way we avoid format inconsistencies across platforms and
      simplify the test because we don not need to parse the output of date anymore.
  * fix in login.opsiscript
      $HomeTestFiles$ was missing
      paths to opsiscripttesthelper.exe were outdate
  * fix in winbatch.opsiscript
      Ensure that $HomeTestFiles$ exists for Winbatch Tests
   
  Many thanks to sternenseemann (github) for these improvments.
 
-- jan werner <j.werner@uib.de>  Wed,  13 May 2020 11:50:00 +0200

opsi-script-test (4.12.3.9-2) stable; urgency=low

  * regex test find file with given extension in list
  * fix some errors from move tests to sub-scripts
 
-- detlef oertel <d.oertel@uib.de>  Thu,  06 Feb 2020 15:00:00 +0200
===========================================================================================
opsi-wim-capture (4.1.0.1-8) stable; urgency=low

  * new: changelog file
  * prop target_product: changed default to win10-x64-captured

-- detlef oertel <d.oertel@uib.de>  Fri, 19 Jun 2020 15:00:00 +0000
===========================================================================================
swaudit (4.1.0.4-1) stable; urgency=low

  * mark linux and mac software in subversion data field
  * code cleanup and beautify
  * avoid warnings at debian

-- detlef oertel <d.oertel@uib.de>  Wed, 10 Jun 2020 15:00:00 +0100

===========================================================================================
windows10-upgrade (20.04-1) experimental; urgency=low
   * IMPORTANT: requires opsi-client-agent 4.1.0.0-47 or higher
   * IMPORTANT: changes to the handling of Win7 -> Win10 Upgrades:
      * the opsi-client-agent folder is now a symlink to the servers opsi-client-agent folder
      * for WAN/VPN mode to work correctly the following command needs to be run manually after the package installation:
         * opsi-package-manager -i windows10-upgrade_20.04-1.opsi --suppress-pcf-generation
   * added support for Windows 10 20.04
   * further code cleanup
   * separated the auto logon handling code from the windows10-upgrade code
   * removed ProductProperty copy_files_locally. The functionality is handled by the ProductProperty execution_method now
   * replaced ProductProperty lock_keyboard with ProductProperty debug. If set to true passwords will be logged and keyboard/mouse input will be enabled during auto logon
   * added new ProductProperty delete_windows_old. Deletes the Windows.old folder after a successful upgrade if set to true
   * added new ProductProperty execution_method. Allows you to select how the installation is run during autologon
      * event_starter triggers an on-demand event from the client. No admin rights are needed for the opsiSetupUser. The installation files can either be read from the opsi_depot samba share or copied locally
      * local_winst uses the locally installed opsi-winst for the installation. Admin rights will be granted for the opsiSetupUser. The installation files will be copied locally
      * This property is ignored if WAN mode is detected. The WAN installation automatically uses the local_winst and the cached installation files
   * removed ProductProperty temp_dir_for_eventstarter. The proper temp dir is selected automatically now
   * removed ProductProperty temp_user_password. Each run a random password is generated for the opsiSetupUser instead
   * added new ProductProperty unset_after_install. Allows you to select opsi products that will be set to not_installed after a successful upgrade. Thanks to Tobias Scheinert from the Kommunikations- und Informationszentrum (kiz) Universität Ulm
   * the local installation is now triggered by a scheduled task instead of using run/runonce registry entries
   * added checks to make sure the scheduled tasks are created correctly
   * the execution of the scheduled task opsi_auto_logon_setup is monitored. In case the scheduled task does not run, a reboot is triggered and the cleanup phase will be run. The scheduled tasks last exit code will be included in the logfile
   * split wims and .esd images will be recognized correctly now while checking if $Target_Image$ exists
   * automatically disables the Windows 7 support has ended window
   * automatically disables the Windows 10 FirstRunPage window (works only if windows is activated...)
   * improved error handling
   * improved error messages for easier debugging
   * improved cleanup handling after a successful upgrade or if an error occured
   * in case the upgrade fails the following logfiles from the client will be appended to the installation logfile for easier debugging:
      * %SystemDrive%\$WINDOWS.~BT\Sources\Panther\*APPRAISER*.xml
      * %SystemDrive%\$WINDOWS.~BT\Sources\Panther\*CompatData*.xml
      * %SystemDrive%\$WINDOWS.~BT\Sources\Panther\setuperr.log
      * %SystemDrive%\$WINDOWS.~BT\Sources\Panther\diagerr.xml
      * %SystemRoot%\Logs\MoSetup\Bluebox.log
   * Upgraded wimlib to version 1.13.1
   * known bug: setup_after_install and unset_after_install will not work if using WAN mode and if the client has no connection to depot server. will be fixed in an upcoming opsi-client-agent release
-- Matthias Knauer <m.knauer@uib.de> Wed 22 Jul 2020 11:11:11 +0200

windows10-upgrade (19.09-8) experimental; urgency=low
   * further cleanup of all scripts
   * requires opsi-winst_4.12.3.12-1 or higher
   * included opsi-client-agent folder (needed for upgrades from older windows versions (i.e Win7) while using WAN mode)
   * WAN mode should finally work now
   * Determines automatically if client is in WAN mode
   * removed ProductProperty wan-extension
   * added ProductProperty copy_files_locally. Determines if the installation files should be copied to the local machine (Ignored if using WAN mode)
   * if $upgrade-to-version$ is empty when using auto=true (i.e installfiles_dir does not contain a valid release id) the value from the ProductProperty upgrade-to-version will be used as fallback instead of failing
   * fixed bug where temp_dir_for_eventstarter could not be accessed.
   * the local opsiSetupUser will now be created as local admin in all cases
   * fails if $target_wim$ is missing
   * known bug: setup_after_install does not work if using WAN mode and if client has no connection to depot server. will be fixed in an upcoming opsi-client-agent release
-- Matthias Knauer <m.knauer@uib.de> Tue 29 Apr 2020 11:11:11 +0200
===========================================================================================
debian9 (4.1.0.3-4) testing; urgency=low

  * reworked code when usign local repository
  * removed opsiclientd deletion in setup.py

-- Mathias Radtke <m.radtke@uib.de> Mon 25 May 2020 16:10:00 +0200

debian9 (4.1.0.3-3) testing; urgency=low

  * add fix for vda block devices

-- Terry Strooband <t.strooband@dgip.nl> Fri May 8 2020 18:48:12 +0200
===========================================================================================
debian10 (4.1.0.4-4) testing; urgency=low

  * reworked code when usign local repository
  * removed opsiclientd deletion in setup.py

-- Mathias Radtke <m.radtke@uib.de> Mon 25 May 2020 16:10:00 +0200
===========================================================================================
  ubuntu18-04 (4.1.0.3-4) testing; urgency=low

  * reworked code when usign local repository
  * removed opsiclientd deletion in setup.py

-- Mathias Radtke <m.radtke@uib.de> Mon 25 May 2020 16:10:00 +0200

ubuntu18-04 (4.1.0.3-3) testing; urgency=low

  * add fix for vda block devices

-- Terry Strooband <t.strooband@dgip.nl> Fri May 8 2020 18:48:12 +0200
===========================================================================================
  ubuntu20-04 (4.1.0.3-6) testing; urgency=low

  * reworked code when usign local repository
  * removed opsiclientd deletion in setup.py

-- Mathias Radtke <m.radtke@uib.de> Mon 25 May 2020 16:10:00 +0200

ubuntu20-04 (4.1.0.3-5) testing; urgency=low

  * add fix for vda block devices

-- Terry Strooband <t.strooband@dgip.nl> Fri May 8 2020 18:48:12 +0200
===========================================================================================
opsi-linux-client-agent (4.1.1.0-4) testing; urgency=medium

* fixes #4501

-- d.oertel <d.oertel@uib.de> Mon, 13 Jul 2020 15:00:00 + 0100
===========================================================================================
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org

Benutzeravatar
tobias
Beiträge: 1287
Registriert: 20 Aug 2008, 12:36
Wohnort: Braunschweig
Kontaktdaten:

Re: Updates für opsi 4.1 stable und testing

Beitragvon tobias » 21 Sep 2020, 11:43

Moin,

im opsi-client-agent gibt's scheinbar noch einen Bug:

Ich erhalte folgende Meldung nach einem durch opsi initiierten Reboot (Screenshot):

https://ibb.co/Zx9FyDQ

getestet auf Windows 10 1909 Enterprise, nicht Bitlocker verschlüsselt.
Opsi-Client-Agent version: 4.1.0.0-47
Veröffentliche deine WINST Scripte im OPSI Wiki und leiste so einen wertvollen Beitrag für die Community !!!
https://forum.opsi.org/wiki/

Benutzeravatar
wolfbardo
uib-Team
Beiträge: 1238
Registriert: 01 Jul 2008, 12:10

Re: Updates für opsi 4.1 stable und testing

Beitragvon wolfbardo » 25 Sep 2020, 13:36

bitte testen, ob das Problem auch hier auftritt

http://download.uib.de/opsi4.1/testing/ ... 1.1-1.opsi

Danke!

Bardo Wolf


opsi remote-workshops

https://uib.de/de/support-schulung/schulung/

Basis

14.-17.06. 2021
06.-09.09 2021

Einführung in die Software-Paketierung
09./10.06 2021

opsi support by uib gmbh

http://www.uib.de

Benutzeravatar
tobias
Beiträge: 1287
Registriert: 20 Aug 2008, 12:36
Wohnort: Braunschweig
Kontaktdaten:

Re: Updates für opsi 4.1 stable und testing

Beitragvon tobias » 25 Sep 2020, 13:39

Die Testing Version habe ich seit gestern Abend auf meiner Testumgebung, da kam bei mir die Meldung bisher nicht.


Gruß
Tobias
Veröffentliche deine WINST Scripte im OPSI Wiki und leiste so einen wertvollen Beitrag für die Community !!!
https://forum.opsi.org/wiki/

HSchweizer
Beiträge: 11
Registriert: 15 Mai 2018, 19:04

Re: Updates für opsi 4.1 stable und testing

Beitragvon HSchweizer » 24 Okt 2020, 02:26

Mit dem opsi-client-agent 4.1.0.0-48 bekommt man reproduzierbar auch noch die genannte Bitlocker-Meldung, obwohl auch wir kein Bitlocker einsetzen.
Wird dies mit der nächsten Stable behoben?

t.roncari
Beiträge: 0
Registriert: 12 Nov 2020, 09:14

Re: Updates für opsi 4.1 stable und testing

Beitragvon t.roncari » 12 Nov 2020, 09:27

Die genannte Bitlocker-Meldung tritt bei uns mit dem opsi-client-agent 4.1.0.0-48 auch auf.
Gibt es einen groben Plan, wann eine neue stable Version released wird ?

Benutzeravatar
n.doerrer
uib-Team
Beiträge: 17
Registriert: 23 Okt 2020, 16:11

Re: Updates für opsi 4.1 stable und testing

Beitragvon n.doerrer » 13 Nov 2020, 17:39

Das BitLocker-Problem ist mit der Version 4.1.1.10-1, die sich nun in testing befindet behoben.