Aktualisierungen in opsi 4.1 stable und testing

Neuigkeiten und Ankündigungen
Benutzeravatar
ueluekmen
uib-Team
Beiträge: 1919
Registriert: 28 Mai 2008, 10:53

Aktualisierungen in opsi 4.1 stable und testing

Beitragvon ueluekmen » 29 Jun 2020, 15:37

Sehr geehrte opsi-Anwenderinnen und -Anwender,

es wurden Updates für opsi 4.1 in Stable & Testing veröffentlicht. Dieses Release-Posting hat sich etwas verzögert, da wir ein etwas größeres Problem beim veröffentlichen hatten. Wir bitten dies zu entschuldigen.

Neuigkeiten zu den aktualisierten Paketen:

windows10-upgrade:
Dieses Paket legt nach der Installation einen symbolischen Link auf das opsi-client-agent Paket. Dies wird vor allem für das Upgrade von Windows7 auf Windows10 benötigt. Das aktuell in Testing veröffentlichte Paket unterstützt auch ein Upgrade über WAN/VPN. Damit das funktioniert muss das Paket einmal mit folgendem Befehl manuell installiert wird, auch wenn es schon über den opsi-package-updater installiert wurde:

Code: Alles auswählen

opsi-package-manager -i windows10-upgrade_19.09-9.opsi --suppress-pcf-generation


Das Paket erstellt die Synchronisationsdatei selbst. Diese Besonderheit betrifft nur das Upgrade von Clients im WAN/VPN-Modus. (Mit dem python-opsi 4.1.1.91-1 Paket in testing aus diesem Release, entfällt dieser Schritt ebenfalls).

opsi-client-agent:
Der opsiclientd-Service im Paket unter Testing unterstützt nun auch das Suspending des Bitlockers vor einem Reboot. Näheres dazu im opsi-manual:

https://download.uib.de/opsi4.1/testing/documentation/html/opsi-manual-v4.1/opsi-manual-v4.1.html#opsi-manual-clientagent

Aktualisierte Pakete in Stable:

Server Pakete opsi 4.1:
* opsi-linux-bootimage (20200506-1)
* opsi-tftpd-hpa (5.2.8-52)
* opsipxeconfd (4.1.1.19-2)
* python-opsi (4.1.1.89-1)
* opsi-script (4.12.3.13-2)
* opsi-utils (4.1.1.35-1)

Windows Localboot Pakete:
* opsi-auto-update (4.1.0.1-1)
* opsi-configed (4.1.9.3.3-1)
* windows10-upgrade (19.09-9)
* opsi-script-test (4.12.3.9-1)
* opsi-wan-config-off (4.1.0-1)
* opsi-wan-config-on (4.1.0-1)

Linux Localboot Pakete:
* l-system-update (4.1.0.0-2)
* opsi-linux-client-agent (4.1.1.0-3)

Windows Netboot Pakete:
* Windows-NT6 (4.1.0.1-14)

opsi-local-image Produkte:
* opsi-local-image-NT6 (4.1.0.1-12)
* opsi-auto-update (4.1.0.1-1)

Linux Netboot Pakete:
* debian (4.1.0.2-3)
* debian8 (4.1.0.1-4)
* debiab9 (4.1.0.3-2)
* debian10 (4.1.0.4-3)
* ubuntu (4.1.0.3-2)
* ubuntu16-04 (4.1.0.1-4)
* ubuntu18-04 (4.1.0.3-2)
* ubuntu20-04 (4.1.0.3-4)


Aktualisierte Pakete in Testing:

Server Pakete opsi 4.1:
* python-opsi (4.1.1.91-1)
* opsipxeconfd (4.1.1.20-3)

Windows Localboot Pakete:
* opsi-auto-update (4.1.0.2-1)
* opsi-client-agent (4.1.0.0-42)
* opsi-winst (4.12.3.14)

Linux Localboot Pakete:
* l-debuntu-upgrade (4.1.0.0-6)
* opsi-auto-update (4.1.0.2-1)
* opsi-linux-client-agent (4.1.1.0-3)

opsi-local-image Localboot Produkte:
* opsi-auto-update (4.1.0.2-1)


Changelogs:

Code: Alles auswählen

python-opsi (4.1.1.91-1) stable; urgency=medium
 
  * Follow links at PackageContentFile generation after opsi-package installation

 -- Erol Ueluekmen <e.ueluekmen@uib.de>  Fri, 26 Jun 2020 16:08:05 +0200

python-opsi (4.1.1.90-1) stable; urgency=medium

  * PackageUpdater: autosetup excludes implemented.

 -- Erol Ueluekmen <e.ueluekmen@uib.de>  Fri, 22 May 2020 16:11:12 +0200

===========================================================================================
opsipxeconfd (4.1.1.20-3) testing; urgency=medium
 
  * corrected typo

 -- Mathias Radtke <m.radtke@uib.de>  Wed, 17 Jun 2020 14:03:09 +0200

opsipxeconfd (4.1.1.20-2) testing; urgency=medium

  * opsipxeconfd.conf: grub template is now default for UEFI netboot

 -- Mathias Radtke <m.radtke@uib.de>  Wed, 17 Jun 2020 09:25:10 +0200

opsipxeconfd (4.1.1.20-1) testing; urgency=medium

  * opsipxeconfd: check if any pxeConfigTemplate.efi file exists to overwrite
    uefi netboot config template

 -- Mathias Radtke <m.radtke@uib.de>  Mon, 18 May 2020 20:06:31 +0200
===========================================================================================

opsi-auto-update (4.1.0.2-1) stable; urgency=low

   * property setup_after_install removed
   * new bool property: shutdown_on_finish (default=false)
      if true we have a final shutdown
      if false we have no reboot / shutdown
   * uefi support for opsi-local-image-restore start

-- detlef oertel <d.oertel@uib.de>  Thu, 14 May 2020 15:00:00 +0200

opsi-auto-update (4.1.0.1-1) stable; urgency=low

   * new property: products_to_exclude_by_regex
   * extend default and values for products_to_exclude
   * requiredWinstVersion >= "4.12.1.5"
   * property: do_cleanup :new default=false
   * property: do_merge :new default=false
   * setProductsToUninstall: no waring on empty list

-- detlef oertel <d.oertel@uib.de>  Thu, 23 Apr 2020 15:00:00 +0200

===========================================================================================
opsi-wan-config-off (4.1.0-1) stable; urgency=low

   * changed to use json objects
   
-- detlef oertel <d.oertel@uib.de>  Wed, 27 May 2020 15:00:00 +0200
===========================================================================================
opsi-wan-config-on (4.1.0-1) stable; urgency=low

   * changed to use json objects
   
-- detlef oertel <d.oertel@uib.de>  Wed, 27 May 2020 15:00:00 +0200
===========================================================================================

opsi-script-test (4.12.3.9-1) stable; urgency=low

  * var_as_param tests (variable as parameter for section calls)
      tests statement: executeSection( < string expr with section call>)
  * registry tests now in sub-script
  * new stand alone test: TestVarAsParam.opsiscript
  * test for new function setValueByKey in stringlist test
 
-- detlef oertel <d.oertel@uib.de>  Tue,  21 Jan 2020 15:00:00 +0200

===========================================================================================
l-debuntu-upgrade (4.1.0.0-6) stable; urgency=low

  * bionic to focal upgrade added
  * reboot if needed after initial update

-- detlef oertel <d.oertel@uib.de>  Tue, 19 May 2020 15:00:00 +0000
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.
http://www.uib.de

SirTux
Beiträge: 428
Registriert: 05 Feb 2011, 18:37

Re: Aktualisierungen in opsi 4.1 stable und testing

Beitragvon SirTux » 29 Jun 2020, 16:38

Unter Testing habe ich gerade das hier bekommen:

Code: Alles auswählen

Traceback:
  File "/usr/bin/opsi-package-updater", line 341, in <module>
    exitCode = main()

  File "/usr/bin/opsi-package-updater", line 312, in main
    opu.processUpdates()

  File "/usr/lib/python2.7/dist-packages/OPSI/Util/Task/UpdatePackages/Updater.py", line 393, in processUpdates
    if any(exclude.search(package['productId']) for exclude in repository.autosetupexcludes):

     ==>>> global name 'repository' is not defined

Benutzeravatar
ueluekmen
uib-Team
Beiträge: 1919
Registriert: 28 Mai 2008, 10:53

Re: Aktualisierungen in opsi 4.1 stable und testing

Beitragvon ueluekmen » 30 Jun 2020, 10:24

Danke für den Hinweis. Da war tatsächlich noch ein Bug drin. Wir haben in Experimental jetzt neue Versionen von python-opsi und opsi-utils veröffentlicht. Kannst du die bitte noch probieren. Vielen Dank.
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.
http://www.uib.de

SirTux
Beiträge: 428
Registriert: 05 Feb 2011, 18:37

Re: Aktualisierungen in opsi 4.1 stable und testing

Beitragvon SirTux » 01 Jul 2020, 20:43

Ich habe den Fix eingespielt. Der Fehler trat bis jetzt nicht mehr auf.