Seite 1 von 1

opsi-setup-detector Prototyp (2. update)

Verfasst: 06 Nov 2018, 20:59
von d.oertel
(2. Update)
die neue Version geht jetzt schon als 'opsi-setup-detector' (ohne experimental) an den start.
Übersetzungen in de, en, es sind bereits dabei.

https://download.uib.de/opsi4.1/experimental/packages/windows/localboot/opsi-setup-detector_4.1.0.5-1.opsi

Bei uns ist die neue Version schon fleissig im Einsatz.
Die templates greifen auf opsi-script libraries zurück welch mit opsi-script/opsi-winst aus geliefert werden.
Also einen aktuellen opsi-script verwenden.

Für Rückmeldungen weiterhin dankbar.

gruß
detlef oertel




(1. Update)
Natürlich gab es ein paar schwerwiegende Fehler im Install script aber auch im Programm.
Hier ist der erste fix:
https://download.uib.de/opsi4.0/experimental/opsi-v407/products/localboot/opsi-setup-detector-experimental_4.1.0.1-1.opsi

Hallo opsi-user,

der Prototyp des neuen opsi-setup-detectors ist fertig.

Der Umbau ist darauf ausgelegt, das es nun viel einfacher ist,
weitere Installer zu erkennen und mit Ihnen umzugehen.
Dazu mussten nicht nur die internen Datenstrukturen komplett geändert werden,
sondern auch die GUI.
Der ProtoTyp dient dazu zu erkunden, wo im jetzigen Design grundsätzliche
Probleme liegen und wo Änderungs- und Erweiterungswünsche sind.

Dazu gibt es das Paket:
https://download.uib.de/opsi4.0/experimental/opsi-v407/products/localboot/opsi-setup-detector-experimental_4.1.0.0-1.opsi

Dieses Paket läßt sich neben den normalen 'opsi-setup-detector' installieren und parallel betreiben.

Hinweise:
Wie die alte Version kann auch die neue mit dem opsi-package-builder zusammenarbeiten.
(https://forum.opsi.org/viewtopic.php?f=22&t=7573).
Der Pfad zum opsipackagebuilder muss in der Konfiguration angegeben werden.
In der Konfiguration können auch Erweiterungen des Scripts hinterlegt werden:
'preInstall','PostInstall','PreUninstall','PostUninstall'

Der neue opsi-setup-detector läuft auch unter Linux.
Das oben genannte opsi-Paket installiert unter Windows und Linux.
Einschränkungen bei der Linux Version:
* Unter Gnome kann es bei Eingaben zu Dopplungen kommen. Lösungen siehe unter:
http://wiki.freepascal.org/Lazarus_Faq#Typing_in_edit_fields_generte_duplicate_letters
* Die Analyse von *.msi Dateien unter Linux per msitools ist noch nicht implementiert - kommt aber noch.
* Setups vom Typ Inno werden erkannt. Die Analyse von Inno Dateien unter Linux ist (mangels innounp.exe)unter Linux eingeschränkt.

Was fehlt:
* Die Übersetzungen
* Neue Installer
* Die Dokumentation
* Die Hilfe
* Feinschliff
* ....

Bevor ich damit Anfange, wollte ich allen Interessierten die Möglichkeit geben,
Ihre Meinung und Wünsche zu äußern.

Ich bin nun bis Anfang Dezember in Urlaub.

In der Zwischenzeit bitte ich die Interessierten
Ihre Kommentare als Antwort auf diesen Forumsthread zu posten.
Dann könnt Ihr die Vorschläge gleich diskutieren.

Wer Vorschläge und Beispiele zu weiteren zu erkennenden Installern hat
oder aus anderen Gründen größere Anlagen, der
kann mir auch ergänzend eine eMail an d.oertel(at) uib.de schreiben,
dann kann ich mich für die Beispiele besser zurückmelden.

Nach meinem Urlaub werde ich versuchen das alles unter einen Hut zubringen,
und das Produkt dann fertig zu machen.

Ich bin sehr gespannt.

Happy testing.

detlef oertel

Re: opsi-setup-detector Prototyp

Verfasst: 06 Nov 2018, 21:04
von GEI
d.oertel hat geschrieben:der Prototyp des neuen opsi-setup-detectors ist fertig.
Dieses Paket läßt sich neben den normalen 'opsi-setup-detector' installieren und parallel betreiben.

ich freue mich ganz besonders, dieses Produkt ab morgen testen zu können!

PS: benötigt wird opsi-winst 4.12.0.28 - also derzeitig kein 4.0, ab opsi 4.1

Re: opsi-setup-detector Prototyp (1. update)

Verfasst: 12 Nov 2018, 08:48
von larsg
Das klingt ja mal sehr viel versprechend!
Insbesondere die Möglichkeit damit unter Linux zu arbeiten bringt mich wieder auf ganz andere Ideen.
Ich werde mich gleich drauf stürzen D:


nachtrag:
bin gerade hierauf gestoßen, hilft euch das vielleicht weiter? gibts auch für linux:
http://constexpr.org/innoextract/

Re: opsi-setup-detector Prototyp

Verfasst: 19 Nov 2018, 07:05
von GEI
GEI hat geschrieben:PS: benötigt wird opsi-winst 4.12.0.28 - also derzeitig kein 4.0, ab opsi 4.1


ab dem heutigen 19.11. auch unter 4.0.x, da der WInst 4.12.0.30 wohl gebackported wurde.
DANKE@ uib

Re: opsi-setup-detector Prototyp (1. update)

Verfasst: 07 Dez 2018, 10:54
von pandel
Wow! Das habe ich total übersehen, aber es liest sich super vielversprechend ;) ! Wird sofort heruntergeladen und getestet!

Re: opsi-setup-detector Prototyp (1. update)

Verfasst: 24 Jan 2019, 21:04
von tobias
Moin,

ich habs mal ausprobiert. Sieht sehr cool aus nur werden bei mir keine Pakete erzeugt, da die Templates fehlen (eine Fehlermeldung gibt es aber auch nicht).
Ist das so gewollt und nur noch nicht implementiert?


Gruß
Tobias

Re: opsi-setup-detector Prototyp (2. update)

Verfasst: 28 Jan 2019, 14:41
von wolfbardo
Von Detlef aktualisierte Version nun unter

https://download.uib.de/opsi4.1/experim ... 0.5-1.opsi

Gruss
Bardo Wolf