Neue opsi4.0/4.1 Pakete für testing und stable

Neuigkeiten und Ankündigungen
Benutzeravatar
d.oertel
Beiträge: 3250
Registriert: 04 Jun 2008, 14:27

Neue opsi4.0/4.1 Pakete für testing und stable

Beitragvon d.oertel » 30 Mai 2018, 15:34

Sehr geehrter opsi-Anwenderinnen und -Anwender,

es wurden Pakete für opsi 4.0 und opsi 4.1 in Testing und stable veröffentlicht.

Hinweise zu den Paketen:
----------------------------------------------
Neuer opsi-configed:
Der neue opsi-configed enthält, neben kleineren Bugfixes, vor allem zwei Änderungen:

* Sobald mehr als ein Client selektiert ist, wird eine tabellarische Übersicht
über die Hardware-Konfiguration der ausgewählten Rechner angezeigt.
Welche Spalten diese Tabelle enthält, ist aus dem gesamten Spektrum des
opsi-Hardware-Inventory-Tabellen konfigurierbar.

* Das opsi-configed-Paket hat keine Abhängigkeit von javavm mehr,
sondern installiert als Default, entsprechend den oracle-Empfehlungen,
eine eigene, gebundeltes Java Runtime Engine und startet mit dieser.
Dabei kann per Produktproperty ausgewählt werden,
ob Java 8.x (derzeit die Java-Longterm-Version)
oder Java 10.x installiert wird.
Letzteres unterstützt unter Windows die Skalierung auf High-DPI-Monitoren.
Man kann aber auch auswählen, ob der configed wie bisher mit der Runtime Engine
aus dem Produkt javavm (oder einem anderen, nun auch wählbaren Produkt) arbeiten soll.

Bitte auch beachten:
Aus Security-Gründen ist der TLSv1-Fallback nicht mehr Default,
sondern stattdessen die Verwendung einer Cipher-Suite, die nach unseren
bisherigen Beobachtungen nicht zu Kommunikationsproblemen
zwischen configed und opsiconfd führt.

-------------------------------------------
* opsi-winst / opsi-script: Fixes im Umfeld von 'defined functions'
* opsi-(linux)-client-agent: update opsi-winst / opsi-script

#####################################
Als Testing veröffentlichen wir:

Windows Netboot:
keine

Windows LocalBoot Pakete:

* opsi-winst 4.12.0.21
* opsi-client-agent 4.1.0.0-8
* opsi-configed (4.0.7.7.6-3)
* windows10-upgrade (18.03-2)

opsi-linux Pakete:

Linux Netboot Pakete:

* ubuntu18.04 (4.1.0.0-2)
* ubuntu (4.1.0.0-1)

Linux LocalBoot Pakete:

* opsi-linux-client-agent (4.1.0.4-1)
* opsi-configed (4.0.7.7.6-3)

opsi-local-image / opsi-vhd:

* opsi-vhd-win10-x64 (4.1.0.0-8)

Server Pakete:
opsi 4.0:


opsi 4.1:


#####################################
Als Stable veröffentlichen wir:


Windows Netboot:
keine

Windows LocalBoot Pakete:

* opsi-client-agent 4.1.0.0-7
* swaudit (4.1.0.0-1)
* config-win10 (4.1.0-2)

opsi-linux Pakete:

Linux Netboot Pakete:
keine

Linux LocalBoot Pakete:

* swaudit (4.1.0.0-1)

opsi-local-image / opsi-vhd:

* opsi-local-image NT6 (4.1.0.0-6)
* opsi-local-image-backup (4.1.0.0-4)
* opsi-local-image-restore (4.1.0.0-5)
* opsi-local-image-prepare (4.1.0.0-4)

Server Pakete:
opsi 4.0:
keine

opsi 4.1:
keine

Sonstiges:
nichts

########################
Sonstiges:

* Der Support für Debian 7 als Server und Client ist abgelaufen (End of Life des Produktes)




detlef oertel


Changelogs:
=============================
opsi-winst/opsi-script (4.12.0.21) stable; urgency=low

* osconf: default for debuglib = true
* osparser: doAktionen: additional log for indefFunc3
* osparser: doAktionen: inc/dec indefFunc3 only if keyword is at begining of line

-- Detlef Oertel <d.oertel@uib.de> Thu, 17 May 2018:15:00:00 +0200

opsi-winst/opsi-script (4.12.0.20) stable; urgency=low

* osparserhelper: GetWord: search backwards=true;backwardfirst=true : / get from "hu)hu)))" as expr "hu)hu" with remaining ")))"
* osparserhelper: GetWord: search backwards=true;backwardfirst=false : / get from "hu)hu)))" as expr "hu)hu))" with remaining ")"
* osparserhelper: GetWordOrStringConstant: new params search backwards=true;backwardfirst=false
* osparser: producestringlist: do not delete remaining after call of defined function
* osdefinedfunctions: parseCallParameter: better error messages
* osdefinedfunctions: parseCallParameter: trim paramstr ; fixes #3526
* osdefinedfunctions: call: set inDefFuncIndex on leaving function ; fixes #3528
* osparser: executeWith: use autoactivitydisplay
* osparser: execShellCall: use autoactivitydisplay
* osparser: execPowerShellCall: use autoactivitydisplay

-- Detlef Oertel <d.oertel@uib.de> Mon, 14 May 2018:15:00:00 +0200

=============================
opsi-client-agent (4.1.0.0-8) stable; urgency=low

* upgrade to opsi-winst 4.12.0.21

-- Detlef Oertel <d.oertel@uib.de> Wed, 23 May 2018:15:00:00 +0200

opsi-client-agent (4.1.0.0-7) stable; urgency=low

* upgrade to opsi-winst 4.12.0.20

-- Detlef Oertel <d.oertel@uib.de> Wed, 23 May 2018:15:00:00 +0200

=============================
config-win10 (4.1.0-2); stable; urgency=low

* fixes #3496 windows 10 1803: websuche abschalten geändert
* adding loginscript and fixes allntuserdats

-- Bardo Wolf <b.wolf@uib.de> Mon, 07 May 2018 10:50:00 +0200

config-win10 (4.1.0-1); stable; urgency=low

* fixed flashplayer architecture logic

-- Andre Neugebauer <a.neugebauer@uib.de> Mon, 16 Apr 2018 14:50:00 +0200
=============================
opsi-local-image-backup (4.1.0.0-4) stable; urgency=low

* new opsisetuplib.py : fix in checkOliPartitions (with dataPartitionNumber)

-- detlef oertel <d.oertel@uib.de> Fri, 04 May 2018 15:00:00 +0200

opsi-local-image-backup (4.1.0.0-3) stable; urgency=low

* remove old existing image file before create new one
* code cleanup

-- detlef oertel <d.oertel@uib.de> Thu, 26 Apr 2018 15:00:00 +0200

opsi-local-image-backup (4.1.0.0-2) stable; urgency=low

* backup also new compressed format
* remove rsync restore from code
* remove ntfs acl backup

-- detlef oertel <d.oertel@uib.de> wed, 07 Feb 2018 15:00:00 +0200

=============================
opsi-local-image-restore (4.1.0.0-5) stable; urgency=low

* new opsisetuplib.py : fix in checkOliPartitions (with dataPartitionNumber)

-- detlef oertel <d.oertel@uib.de> Fri, 04 May 2018 15:00:00 +0200

opsi-local-image-restore (4.1.0.0-4) stable; urgency=low

* fix blocksize 0 bug with old images
* code cleanup

-- detlef oertel <d.oertel@uib.de> Thu, 26 Apr 2018 15:00:00 +0200

=============================
opsi-local-image-prepare (4.1.0.0-4) stable; urgency=low

* new opsisetuplib.py : fix in checkOliPartitions (with dataPartitionNumber)

-- detlef oertel <d.oertel@uib.de> Fri, 04 May 2018 15:00:00 +0200

opsi-local-image-prepare (4.1.0.0-3) stable; urgency=low

* fix sgdisk --zap on uefi boxes

-- detlef oertel <d.oertel@uib.de> Fri, 27 Apr 2018 15:00:00 +0200

=============================
opsi-local-image Win NT6 (4.1.0.0-6) stable; urgency=low

* new opsisetuplib.py : fix in checkOliPartitions (with dataPartitionNumber)

-- detlef oertel <d.oertel@uib.de> Fri, 04 May 2018 15:00:00 +0200
=============================
swaudit (4.1.0.0-1) stable; urgency=low

* if wmic call for hotfixes failed retry with powershell

-- detlef oertel <d.oertel@uib.de> Thu, 19 Apr 2018 15:00:00 +0100
=============================
windows10-upgrade (18.03-2) stable; urgency=low

* fix Restore shutdown warning time in ($RebootFlag$ = "4")

-- detlef oertel <d.oertel@uib.de> Thu 24 May 2018 15:00:00 +0200

windows10-upgrade (18.03-1) stable; urgency=low
-- bardo wolf <b.wolf@uib.de> 02 May 2018
=============================
opsi-configed (4.0.7.7.6-3) stable; urgency=medium

* new packaging: included bundled oracle jre version 8.x (longterm, 32 bit) and 10.x (has high dpi support)
* can be installed with opsi java package or with bundled java runtime

-- roeder <roeder@asusvivo01.uib.local> Tue, 29 May 2018 14:45:43 +0200

-- roeder <roeder@asusvivo01.uib.local> Tue, 29 May 2018 14:45:43 +0200

opsi-configed (4.0.7.7.6-1) stable; urgency=medium

* added a selection menu option

-- roeder <r.roeder@uib.de> Tue, 22 May 2018 14:51:45 +0200

opsi-configed (4.0.7.7.5-1) stable; urgency=medium

* added font sizing buttons and Ctrl-+, Ctrl-- in logpanes
* local saving and setting again of last selected shown log level

-- roeder <r.roeder@uib.de> Wed, 16 May 2018 16:16:00 +0200

opsi-configed (4.0.7.7.4-1) stable; urgency=medium

* UTF8 repaired for java version >= 9

-- roeder <r.roeder@uib.de> Fri, 20 Apr 2018 12:26:38 +0200

opsi-configed (4.0.7.7.3-1) stable; urgency=medium

* hardware table for all or selected clients (more than 1) with configuration of columns

-- roeder <roeder@uib.de> Fri, 13 Apr 2018 11:33:29 +0200

opsi-configed (4.0.7.7.2-1) experimental; urgency=medium

* new command line option for choosing a directory for keeping saved states
* excluding java.awt.IllegalComponentStateException from errors via UncaughtExceptionHandler according to https://bugs.openjdk.java.net/browse/JDK-8179665
* restart button in clientselection form in order to rebuild comboboxes after a data change
* trying to eliminate a hanging loading message frame

-- Rupert Roeder <r.roeder@uib.de> Wed, 07 Mar 2018 11:36:08 +0100

opsi-configed (4.0.7.7.1-1) experimental; urgency=medium

* trying to eliminate a further bad location exception

-- Rupert Roeder <r.roeder@uib.de> Thu, 06 Feb 2018 11:36:08 +0100

opsi-configed (4.0.7.7.0-1) experimental; urgency=medium

* multi-client hw overview

-- Rupert Roeder <r.roeder@uib.de> Mon, 05 Feb 2018 10:48:50 +0100
=============================
opsi-vhd-win10-x64:
windows (4.1.0.0-8) stable; urgency=low

* //nt6.opsiscript: if uefi remove opsiwinpe bootentry
* nt6.py: canged property: debug_cmd_inpe to winpe_debug_cmd_exe
* nt6.py: vhdmode: fix use of windowspartitionsize

-- Detlef Oertel <d.oertel@uib.de> Wed, 09 May 2018:15:00:00 +0200

windows (4.1.0.0-7) stable; urgency=low

* nt6.opsiscript: do not stop if network drive is ready even if there is no opsiservice
* nt6.opsiscript: switch setup call from shellCall to processCall
* nt6.py: addtional property: winpe_debug_cmd_exe
* nt6.opsiscript copy opsi-script log to winpe-partition (c:)

-- Detlef Oertel <d.oertel@uib.de> Wed, 09 May 2018:15:00:00 +0200

windows (4.1.0.0-6) stable; urgency=low

* postinst: 99_cleanup: 64 bit switch fix: viewtopic.php?f=6&t=10016
* nt6.opsiscript: get and log winPE version from registry ; fixes #3403
* nt6.opsiscript: stopinpe on errors

-- Detlef Oertel <d.oertel@uib.de> Fri, 16 Mar 2018:15:00:00 +0200
=============================
ubuntu (4.1.0.0-1) testing; urgency=low

* support for Ubuntu 18.04 (bionic beaver)

-- Mathias Radtke <m.radtke@uib.de> Thu Apr 27 10:00:00 +0200
=============================

ubuntu18-04 (4.1.0.0-2) testing; urgency=low

* setting global Variable HTTP(S)_PROXY when proxy is set

-- Mathias Radtke <m.radtke@uib.de> Wed May 23 09:45:00 +0200

ubuntu18.04 (4.1.0.0-1) testing; urgency=low

* initial product creation, forked from ubuntu16-04

-- Mathias Radtke <m.radtke@uib.de> Fri Apr 27 13:23:00 2018 +0200
=============================
opsi-linux-client-agent (4.1.0.4-1) stable; urgency=medium

* opsi-script 4.12.0.21

-- d.oertel <d.oertel@uib.de> Mon, 28 May 2018 15:00:00 + 0100

=============================
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org