Neue opsi4.0/4.1 Pakete für testing und stable

Neuigkeiten und Ankündigungen
Benutzeravatar
d.oertel
Beiträge: 3257
Registriert: 04 Jun 2008, 14:27

Neue opsi4.0/4.1 Pakete für testing und stable

Beitragvon d.oertel » 13 Sep 2018, 14:30

Neue opsi4.0/4.1 Pakete für testing und stable

Sehr geehrter opsi-Anwenderinnen und -Anwender,

es wurden Pakete für opsi 4.0 und opsi 4.1 in Testing und Stable veröffentlicht.

Weiterhin wurden die Dokumentationen aktualisiert.

ERINNERUNG:
Der Support für opsi 4.0 läuft nur noch bis Ende des Jahres 2018.
Denken Sie daran rechtzeitig nach opsi 4.1 zu wechseln.

#####################################
Als Testing veröffentlichen wir:


Windows Netboot:

* memtest86 5.01-2

Windows LocalBoot Pakete:

* opsi-winst 4.12.0.27
* opsi-script-test 4.12.0.27-1
* shutdownwanted 1.0-6

opsi-linux Pakete:

Linux Netboot Pakete:

* memtest86 5.01-2
* ucs43 4.1.0.0-2

Linux LocalBoot Pakete:

* l-opsi-server 4.1.1.7-6
* opsi-script-test 4.12.0.27-1
* shutdownwanted 1.0-6
* opsi-linux-client-agent (4.1.0.8-1)

opsi-local-image / opsi-vhd:

* opsi-local-image-wim-capture 4.1.0.1-5

Server Pakete:
opsi 4.0:

none

opsi 4.1:

none

#####################################
Als Stable veröffentlichen wir:


Windows Netboot:

none

Windows LocalBoot Pakete:

* opsi-client-agent (4.1.0.0-19)
* config-win10 (4.1.0-5)
* windows10-upgrade 18.03-7

opsi-linux Pakete:

Linux Netboot Pakete:

* debian8 (4.1.0.1-1)
* debian9 (4.1.0.2-1)
* ubuntu16-04 (4.1.0.1-1)
* ubuntu18-04 (4.1.0.1-1)

Linux LocalBoot Pakete:

* opsi-linux-client-agent 4.1.0.7-1

opsi-local-image / opsi-vhd:

none

Server Pakete:
opsi 4.0:

* opsi-linux-bootimage (20180813-1)
* opsipxeconfd (4.0.7.9-4)
* opsi4ucs (4.0.7.5-12)
* opsi-atftpd (0.7.dfsg-14)

opsi 4.1:

* opsi-linux-bootimage (20180813-1)
* python-opsi (4.1.1.43-1)


########################

gruss
detlef oertel


Changelogs:
=============================

memtest86 (5.01-2) stable; urgency=low

* Provide a setup script to allow for being started from inside the
opsi-linux-bootimage. This script will set the product to setup and
make a reboot.

-- Niko Wenselowski <n.wenselowski@uib.de> Web, 15 Aug 2018 09:04:21 +0200

=============================

opsi-client-agent (4.1.0.0-19) stable; urgency=low

* fixes #3630 opsi-local-image-wim-capture bleibt auf setup stehen

-- Bardo Wolf <b.wolf@uib.de> Thu, 09 Aug 2018:15:00:00 +0200

opsi-client-agent (4.1.0.0-18) stable; urgency=low

* opsiclientd 4.0.93

-- Erol Ueluekmen <e.ueluekmen@uib.de> Mon, 08 Aug 2018:15:00:00 +0200

opsi-client-agent (4.1.0.0-17) stable; urgency=low

* subconfig.opsiscript: more readable interpretation of opsiservicecall_get_configState_software-on-demand.active
* subconfig.opsiscript: LinkFolder_uninstall_softwareOnDemand: marker for #3624

-- Detlef Oertel <d.oertel@uib.de> Mon, 06 Aug 2018:15:00:00 +0200

opsi-client-agent (4.1.0.0-16) stable; urgency=low

* update to opsi-notifier 4.1.0.3
* try to make memo transparent
* add opsiclientdguard to uninstall

-- Detlef Oertel <d.oertel@uib.de> Fri, 03 Aug 2018:15:00:00 +0200

=============================

opsi-winst/opsi-script (4.12.0.27) stable; urgency=low

* osparser: (fix) registry: new parameter /AllUsrClassDats
new function doRegistryAllUsrClassDats ; fix from Terry Strooband (thank you)
flag_all_usrclass

-- Detlef Oertel <d.oertel@uib.de> Mon, 10 Sep 2018:15:00:00 +0200

opsi-winst/opsi-script (4.12.0.26) stable; urgency=low

* osparser: more log_prog in folderlink and getstring
* osparser: reporterror: catch unknown origin and exceptions ; references #3655
* osparser: doAktionen: endif: catch exception in log message ; references #3655
* osparser: execDosBatch: log8 temp file content
* osparser: executeWith: log8 temp file content
* osparser: execPowershellCall: log executing ; fixes #3621
* osparser: doAktionen: registry: Ignoring parameter /32bit for /AllNTUserdats. ; fixes #3643
* osjson: jsonAsArrayToStringList: "[true]" now results to "true" ; fixes #3627
* oswebservice: createSocket: log openssl version
* osfunclin: getLinuxDistroType: read /etc/os-release ; fixes #3651
* osparserhelper: GetOuterFunctionOrExp
* OsDefinedFunction.parseCallParameter: handle functions as parameter ; fixes #3623
* osparser: registerSectionOrigins: fix origin for external sub sections
* osparser: registry: new parameter /AllUsrClassDats
new function doRegistryAllUsrClassDats ; fix from Terry Strooband (thank you)

-- Detlef Oertel <d.oertel@uib.de> Tue, 28 Aug 2018:15:00:00 +0200

=============================

opsi-script-test (4.12.0.27-1) stable; urgency=low

* registry: Registry_hkcu_userclasses_test /AllUsrClassDats
from Terry Strooband
small fix

-- detlef oertel <d.oertel@uib.de> Mon, 10 Sep 2018 15:00:00 +0200

opsi-script-test (4.12.0.26-1) stable; urgency=low

* registry: Registry_hkcu_userclasses_test /AllUsrClassDats
from Terry Strooband

-- detlef oertel <d.oertel@uib.de> Thu, 06 Sep 2018 15:00:00 +0200

opsi-script-test (4.12.0.25-1) stable; urgency=low

* json: array functions for array like "[true]"

-- detlef oertel <d.oertel@uib.de> Tue, 07 Aug 2018 15:00:00 +0200

=============================

shutdownwanted (1.0-6) stable; urgency=low

* Updated product description and advice.

-- Niko Wenselowski <n.wenselowski@uib.de> Thu, 16 Aug 2018 14:20:10 +0200

=============================

config-win10 (4.1.0-5); stable; urgency=low

* New property: disable_updates_service
* on 64bit systems: set registry sysnative and 32bit

-- Mathias Radtke <m.radtke@uib.de> Fri, 31 Aug 2018 11:08:00 +0200

config-win10 (4.1.0-4); stable; urgency=low

* reworked disable_updates function

-- Mathias Radtke <m.radtke@uib.de> Tue, 21 Aug 2018 10:33:00 +0200

config-win10 (4.1.0-3); stable; urgency=low

* Added registry settings to diable dualscan when using disable_updates property

-- Mathias Radtke <m.radtke@uib.de> Fri, 17 Aug 2018 11:46:00 +0200

=============================

windows10-upgrade (18.03-7) stable; urgency=low

* setup.opsiscript / sections-local: rename winbatch_1607 to winbatch_upgrade
* update.opsiscript: changed Error message from "Wrong Targetversion" to "Failed: Not on Targetversion"
* sub_setup: ident cleanup

-- detlef oertel <d.oertel@uib.de> Fri 03 Aug 2018 15:00:00 +0200

=============================

opsi-wim-capture (4.1.0.1-5) stable; urgency=low

* new property winpe_debug_cmd_exe
* new property no_reboot_in_pe

-- detlef oertel <d.oertel@uib.de> Mon, 13 Aug 2018 15:00:00 +0000

opsi-local-image-capture (4.1.0.1-4) stable; urgency=low

* fix capture.opsiscript: fix double authenticate

-- detlef oertel <d.oertel@uib.de> Thu, 05 Jul 2018 15:00:00 +0000

opsi-local-image-capture (4.1.0.1-3) stable; urgency=low

* workaround in call of enablePEPartition

-- detlef oertel <d.oertel@uib.de> Fri, 05 May 2018 15:00:00 +0000

=============================

ucs43 (4.1.0.0-2) testing; urgency=low

* installing UCS 4.3-1

-- Mathias Radtke <m.radtke@uib.de> Tue Jun 26 07:43:00 2018 +0200

ucs43 (4.1.0.0-1) testing; urgency=low

* initial release

-- Mathias Radtke <m.radtke@uib.de> Wed Mar 14 14:50:00 2018 +0100

=============================

debian8 (4.1.0.1-1) testing; urgency=low

* Question to load additional firmware is negated

-- Mathias Radtke <m.radtke@uib.de> Thu Aug 09 2018 11:43:00 +0200

=============================

debian9 (4.1.0.2-1) testing; urgency=low

* Question to load additional firmware is negated

-- Mathias Radtke <m.radtke@uib.de> Thu Aug 09 2018 11:43:00 +0200

debian9 (4.1.0.1-1) testing; urgency=low

* Kernel update

-- Mathias Radtke <m.radtke@uib.de> Wed Jul 25 09:25:00 +0200

=============================

ubuntu16-04 (4.1.0.1-1) testing; urgency=low

* Question to load additional firmware is negated

-- Mathias Radtke <m.radtke@uib.de> Thu Aug 09 2018 11:43:00 +0200

=============================

ubuntu18-04 (4.1.0.0-4) testing; urgency=low

* corrected behaviour when using a proxy

-- Mathias Radtke <m.radtke@uib.de> Thu Jul 26 09:12:00 +0200

=============================

l-opsi-server (4.1.1.7-6); stable; urgency=low

* Use setProductActionRequestWithDependencies for setup after install.

-- Niko Wenselowski <n.wenselowski@uib.de> Tue, 06 Aug 2018 09:48:44 +0200

l-opsi-server (4.1.1.7-5); stable; urgency=low

* UCS 4.3: patching smb.conf with actual network device instead of eth0
* UCS 4.3: waiting for package lock prior installing packages

--Mathias Radtke <m.radtke@uib.de> Wed, 01 Aug 2018 10:51:00 +0200

=============================

opsi-linux-client-agent (4.1.0.8-1) stable; urgency=medium

* opsi-script 4.12.0.26
* opsi-script-starter 4.1.0.2
* exp opensuse 15

-- d.oertel <d.oertel@uib.de> Thu, 06 Sep 2018 15:00:00 + 0100

opsi-linux-client-agent (4.1.0.7-1) stable; urgency=low

* changelog.txt created
* CentOS 7 and RedHat 7 Support

-- Erol Ueluekmen <e.ueluekmen@uib.de> Tue, 14 Aug 2018 14:30:00 +0200

opsi-linux-client-agent (4.1.0.6-2) stable; urgency=low

* SLES12*: Waiting 120 seconds between dependency package installation retry

-- Mathias Radtke <m.radtke@uib.de> Tue, 14 Aug 2018 14:30:00 +0200

opsi-linux-client-agent (4.1.0.6-1) stable; urgency=low

* SLES12 SP2/3 support added

-- Mathias Radtke <m.radtke@uib.de> Fri, 03 Aug 2018 08:04:00 +200

opsi-linux-client-agent (4.1.0.5-3) stable; urgency=low

* ucs 4.3: rerunning dependency install on failure with 120 seconds sleep

-- Mathias Radtke <m.radtke@uib.de> Wed, 01 Aug 2018 11:00:00 +0200

=============================

opsi4ucs (4.0.7.5-12) testing; urgency=medium

No linking of bootimage files as they are moved to $TFTPROOT earlier

-– Mathias Radtke m.radtke@uib.de Tue, 28 Aug 2018 12:23:27 +0200

=====================================================

opsi-atftp (0.7.dfsg-14) testing; urgency=medium

postinst: corrected missspelled filename

– Mathias Radtke m.radtke@uib.de Mon, 27 Aug 2018 14:49:18 +0200

opsi-atftp (0.7.dfsg-13) testing; urgency=medium

postsinst: corrected typo

– Mathias Radtke m.radtke@uib.de Mon, 27 Aug 2018 14:38:17 +0200

opsi-atftp (0.7.dfsg-12) testing; urgency=medium

UCS: patching TFTPROOT at end of postinst

– Mathias Radtke m.radtke@uib.de Mon, 27 Aug 2018 14:27:37 +0200

opsi-atftp (0.7.dfsg-11) testing; urgency=medium

had to readd stdc89 standard usage

– Mathias Radtke m.radtke@uib.de Mon, 27 Aug 2018 12:05:08 +0200

opsi-atftp (0.7.dfsg-10) testing; urgency=medium

settting TFTPBOOT directory to UCS default

-– Mathias Radtke m.radtke@uib.de Mon, 27 Aug 2018 11:47:09 +0200

=====================================================

opsi-linux-bootimage (20180813-1) testing; urgency=medium

kernel 4.17.13
kexec-tools installed via .deb file

– Mathias Radtke m.radtke@uib.de Mon, 13 Aug 2018 09:29:05 +0200

opsi-linux-bootimage (20180803-1) testing; urgency=medium

upgraded e2fsck to Version 1.43

– Mathias Radtke m.radtke@uib.de Fri, 03 Aug 2018 11:49:51 +0200

=====================================================

opsipxeconfd (4.0.7.9-4) testing; urgency=medium

UCS: postinst: patching tftpboot directory

– Mathias Radtke m.radtke@uib.de Mon, 20 Aug 2018 14:03:28 +0200

=====================================================
opsi support - uib gmbh

For productive opsi installations we recommend support contracts.
http://www.uib.de
http://www.opsi.org