Aktualisierte Pakete für opsi 4.0.7 in testing

Neuigkeiten und Ankündigungen
Benutzeravatar
n.wenselowski
Beiträge: 2274
Registriert: 04 Apr 2013, 12:15

Aktualisierte Pakete für opsi 4.0.7 in testing

Beitragvon n.wenselowski » 09 Aug 2017, 11:45

Sehr geehrter opsi-Anwenderinnen und -Anwender,

es gibt Aktualisierungen für opsi 4.0.7 in testing.

Mit den Paketen aus testing werden folgende neue Distributionen unterstützt:
  • Debian 9
  • openSUSE Leap 42.3
  • Univention Corporate Server (UCS) 4.2

Support für die folgenden Distributionen wird abgekündigt, da diese End-of-Life sind:
  • openSUSE Leap 42.1
  • Ubuntu 12.04 "Precise Pangolin"
  • Univention Corporate Server (UCS) 3.x
  • Univention Corporate Server (UCS) 4.0

Wir empfehlen für diese Distributionen die Aktualisierung auf ein weiterhin unterstütztes Betriebssystem.


Das Paket digitec-opsi-listener wird nicht mehr über die Repositories bereitgestellt, da es nicht weiter gepflegt wird.
Wir empfehlen den Umstieg auf die von uib gepflegte Erweiterung opsi-directory-connector.


Localboot-Pakete:
  • l-opsi-server 4.0.7.2-3

Netboot-Pakete:
  • debian 4.0.7.2-3
  • debian8 4.0.7.2-3
  • debian9 4.0.7.2-3
  • opensusel42-3 4.0.7.2-2
  • ubuntu 4.0.7.2-2
  • ubuntu14-04 4.0.7.2-3
  • ubuntu16-04 4.0.7.2-3
  • ucs41 4.0.7.2-2
  • ucs42 4.0.7.2-2

Server-Pakete:
  • opsi-linux-bootimage 20170720-1
  • opsi-utils 4.0.7.17-2
  • opsiconfd 4.0.7.13-1
  • opsipxeconfd 4.0.7.8-3
  • python-opsi 4.0.7.45-3


Mit freundlichen Grüßen

Niko Wenselowski


PS: Changelogs:

Code: Alles auswählen

opsipxeconfd (4.0.7.8-3) stable; urgency=medium

  * Always using the version from the changelog.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 31 Jul 2017 10:24:38 +0200

opsipxeconfd (4.0.7.8-2) stable; urgency=medium

  * systemd: always restart once the service exits.
  * systemd: Dependency to smbd is now soft.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Tue, 18 Jul 2017 13:47:23 +0200


Code: Alles auswählen

opsi-utils (4.0.7.17-2) stable; urgency=medium

  * Updated Spanish and Russian translations.
  * Added Dutch translation.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 07 Aug 2017 13:50:25 +0200

opsi-utils (4.0.7.17-1) stable; urgency=medium

  * opsi-product-updater: Depot connections will use a specific user agent.
  * opsi-package-manager: Setting the default config will be done later
    to avoid problems displaying the help if DNS is broken.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 26 Jul 2017 12:10:34 +0200


Code: Alles auswählen

python-opsi (4.0.7.45-3) stable; urgency=medium

  * openSuse 42.3: We depend on python-setuptools because python-cryptography
    requires it during runtime but the package from the openSuse repos
    misses that requirement.
    See https://bugzilla.opensuse.org/show_bug.cgi?id=1052927

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 09 Aug 2017 10:35:06 +0200

python-opsi (4.0.7.45-2) stable; urgency=medium

  * Updated Spanish and Russian translation.
  * Added Dutch translation.
  * Updated Russian hwaudit translation.
  * Added Dutch hwaudit translation.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 07 Aug 2017 14:17:14 +0200

python-opsi (4.0.7.45-1) stable; urgency=medium

  * 10_opsi.conf: setProductActionRequestWithDependencies will relay a call
    with actionRequest = 'none' to setProductActionRequest.
  * OPSI.Backend.Backend.ConfigDataBackend: improved log truncation when
    processing unicode characters that use more than one byte.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Thu, 27 Jul 2017 14:02:39 +0200

python-opsi (4.0.7.44-1) experimental; urgency=medium

  * OPSI.Util.Task.Certificate: replaced gendh with dhparam
  * OPSI.Util.Task.Rights: Default access rights for workbench set to 664.

 -- Mathias Radtke <m.radtke@uib.de>  Tue, 25 Jul 2017 14:28:31 +0200

python-opsi (4.0.7.43-2) stable; urgency=medium

  * Debian packaging: Depending on net-tools for ifconfig.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Tue, 25 Jul 2017 09:19:10 +0200

python-opsi (4.0.7.43-1) stable; urgency=medium

  * opsihwaudit.conf: Memory clock speed is now handled as a bigint.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 17 Jul 2017 17:35:54 +0200


Code: Alles auswählen

opsiconfd (4.0.7.13-1) experimental; urgency=medium

  * gendh is obsolete: replaced with dhparam

 -- Mathias Radtke <m.radtke@uib.de>  Tue, 25 Jul 2017 15:56:14 +0200

opsiconfd (4.0.7.12-1) stable; urgency=medium

  * opsi-nagios-connector: checkShortProductStatus added reference version for check in output.

 -- Erol Ueluekmen <e.ueluekmen@uib.de>  Mon, 24 Jul 2017 13:34:42 +0200

opsiconfd (4.0.7.11-5) stable; urgency=medium

  * systemd: Dependency to smbd is now soft.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Tue, 18 Jul 2017 13:33:39 +0200

opsiconfd (4.0.7.11-4) stable; urgency=medium

  * systemd: Fix typo in service regarding the restart.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 17 Jul 2017 21:46:07 +0200

opsiconfd (4.0.7.11-3) stable; urgency=medium

  * systemd: always restart once the service exits.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 17 Jul 2017 12:16:09 +0200


Code: Alles auswählen

opsi-linux-bootimage (20170720-1) testing; urgency=medium

  * serial driver is now modular

 -- Mathias Radtke <m.radtke@uib.de>  Wed, 19 Jul 2017 15:49:02 +0200

opsi-linux-bootimage (20170714-1) experimental; urgency=medium

  * kernel 4.12.1
  * disabled ipmi_watchdog driver

 -- Mathias Radtke <m.radtke@uib.de>  Thu, 13 Jul 2017 15:24:19 +0200

opsi-linux-bootimage (20170713-2) experimental; urgency=medium

  * version bump die to typo in debian/changelog

 -- Mathias Radtke <m.radtke@uib.de>  Thu, 13 Jul 2017 14:38:04 +0200

opsi-linux-bootimage (20170713-1) experimental; urgency=medium

  * disabled watchdog driver
  * added intel_pmc driver
  * added tpm_crb driver

 -- Mathias Radtke <m.radtke@uib.de>  Tue, 11 Jul 2017 14:38:04 +0200


Code: Alles auswählen

opensusel42-3 (4.0.7.2-2) testing; urgency=medium

  * initial creation
  * UEFI compatible installation

-- Mathias Radtke <m.radtke@uib.de> Mon Apr 03 2017 14:50:00 +0200


Code: Alles auswählen

debian (4.0.7.2-3) testing; urgency=low

  * corrected NVME + UEFI behaviour

-- Mathias Radtke <m.radtke@uib.de> Wed Jul 19 2017 15:35:00 +0200


Code: Alles auswählen

debian8 (4.0.7.2-3) testing; urgency=low

  * corrected NVME + UEFI behaviour
  * corrected proxy behaviour

-- Mathias Radtke <m.radtke@uib.de> Wed Jul 19 2017 15:35:00 +0200


Code: Alles auswählen

debian9 (4.0.7.2-3) testing; urgency=low

  * corrected NVME + UEFI behaviour
  * corrected proxy behaviour

-- Mathias Radtke <m.radtke@uib.de> Wed Jul 19 2017 15:35:00 +0200


Code: Alles auswählen

ubuntu (4.0.7.2-2) testing; urgency=low

  * corrected NVME + UEFI behaviour

-- Mathias Radtke <m.radtke@uib.de> Wed Jul 19 2017 15:35:00 +0200


Code: Alles auswählen

ubuntu14-04 (4.0.7.2-2) stable; urgency=low

  * corrected NVME + UEFI behaviour

-- Mathias Radtke <m.radtke@uib.de> Wed Jul 19 2017 15:35:00 +0200


Code: Alles auswählen

ubuntu16-04 (4.0.7.2-3) testing; urgency=low

  * corrected NVME + UEFI behaviour
  * corrected proxy behaviour

-- Mathias Radtke <m.radtke@uib.de> Wed Jul 19 2017 15:35:00 +0200


Code: Alles auswählen

ucs41 (4.0.7.2-2) testing; urgency=low

  * corrected NVME behaviour

-- Mathias Radtke <m.radtke@uib.de> Wed Jul 19 2017 15:35:00 +0200


Code: Alles auswählen

ucs42 (4.0.7.2-2) testing; urgency=low

  * corrected NVME

-- Mathias Radtke <m.radtke@uib.de> Wed Jul 19 2017 15:35:00 +0200

ucs42 (4.0.7.2-1) experimental; urgency=low

  * postinst: sudo command may fail -> echo to inform user
  * forked from ucs41

-- Mathias Radtke <m.radtke@uib.de> Thu Mar 16 15:15:00 +0100


Code: Alles auswählen

l-opsi-server 4.0.7.2-3; testing; urgency=low

  * added debian9 compatability
  * Removed debian6 compatability
  * added OpenSUSE Leap42.3 compatability

-- Mathias Radtke <m.radtke@uib.de> Tue, 25 Jul 2017 07:37:00 +0200

l-opsi-server 4.0.7.2-2; experimental; urgency=low

  * UCS4.2: not installing digitec-listener( not avail.)

-- Mathias Radtke <m.radtke@uib.de> Tue, 11 Jun 2017 15:43:00 +0200

l-opsi-server 4.0.7.2-1; experimental; urgency=low

  * added support for UCS4.2

-- Mathias Radtke <m.radtke@uib.de> Tue, 07 Jun 2017 08:53:00 +0100
Kein Support per DM!
_________________________
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.

thomas.besser
Beiträge: 219
Registriert: 09 Sep 2009, 09:40

Re: Aktualisierte Pakete für opsi 4.0.7 in testing

Beitragvon thomas.besser » 09 Aug 2017, 16:07

n.wenselowski hat geschrieben:es gibt Aktualisierungen für opsi 4.0.7 in testing.

Mit den Paketen aus testing werden folgende neue Distributionen unterstützt:
  • Debian 9


Hab die Meldung zum Anlass genommen, ein neues Debian 9 Stretch aufzusetzen und darauf einen OPSI-Server zu installieren.

Leider hat es nach Hinzufügen der APT-Quelle (deb http://download.opensuse.org/repositori ... Debian_9.0 ./)
und nach "wget -O - http://download.uib.de/opsi4.0/uibmz_key.pub | apt-key add -" folgende Fehlermeldung gegeben:

W: GPG-Fehler: http://download.opensuse.org/repositori ... Debian_9.0 ./ Release: Die folgenden Signaturen waren ungültig: 2371C96FC045365D00729A19520B97144DC87421
E: The repository 'http://download.opensuse.org/repositories/home:/uibmz:/opsi:/opsi40-testing/Debian_9.0 ./ Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Zum Testen habe ich spaßeshalber mal "deb http://download.opensuse.org/repositori ... Debian_8.0 ./" genommen. Derselbe Fehler! Es scheint also an Debian Stretch zu liegen.

Ich würde vermuten, dass der Schlüssel für die Signatur noch mit SHA1 erstellt wurde?! Zumindest habe ich zur Fehlermeldung folgenden Beitrag gefunden: https://github.com/piwik/piwik-package/issues/50

Gruß
Thomas

Benutzeravatar
m.radtke
Beiträge: 413
Registriert: 10 Jun 2015, 12:19

Re: Aktualisierte Pakete für opsi 4.0.7 in testing

Beitragvon m.radtke » 10 Aug 2017, 07:19

Die Leute vom Open Buildservice wissen bescheid.

Wir nerven die auch regelmäßig wegen den Keys. Aber da tut sich nichts von deren Seite aus.

BTW: es ist ne Warning, also man kann das Repo nutzen, wird aber auf potenzielle Gefahren, da unsigniert, hingeweisen.

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

thomas.besser
Beiträge: 219
Registriert: 09 Sep 2009, 09:40

Re: Aktualisierte Pakete für opsi 4.0.7 in testing

Beitragvon thomas.besser » 10 Aug 2017, 07:23

Alles klar, danke.

Dann muss ich wohl die Pakete manuell runterladen und mit dpkg reinprügeln. :roll:

EDIT: ist IMO nicht nur eine Warnung. Ich schaue nochmal nach.

thomas.besser
Beiträge: 219
Registriert: 09 Sep 2009, 09:40

Re: Aktualisierte Pakete für opsi 4.0.7 in testing

Beitragvon thomas.besser » 10 Aug 2017, 07:30

Nope, ist nicht mehr nur eine Warnung wie im "Getting Started" beschrieben!

Code: Alles auswählen

W: GPG-Fehler: http://download.opensuse.org/repositories/home:/uibmz:/opsi:/opsi40-testing/Debian_9.0 ./ Release: Die folgenden Signaturen waren ungültig: 2371C96FC045365D00729A19520B97144DC87421
E: The repository 'http://download.opensuse.org/repositories/home:/uibmz:/opsi:/opsi40-testing/Debian_9.0 ./ Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

root@opsi-dev:~# aptitude install opsi-atftpd
Es konnte kein Paket gefunden werden, dessen Name oder Beschreibung auf »opsi-atftpd« passt.
Unable to apply some actions, aborting

Benutzeravatar
m.radtke
Beiträge: 413
Registriert: 10 Jun 2015, 12:19

Re: Aktualisierte Pakete für opsi 4.0.7 in testing

Beitragvon m.radtke » 10 Aug 2017, 07:38

Hi

Code: Alles auswählen

apt install --allow-unauthenticated PAKET
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.

thomas.besser
Beiträge: 219
Registriert: 09 Sep 2009, 09:40

Re: Aktualisierte Pakete für opsi 4.0.7 in testing

Beitragvon thomas.besser » 10 Aug 2017, 07:55

Ah, eine bislang unbekannte Option. Danke.

der Vollständigkeit halber: man muss vorher auch 'apt-get --allow-unauthenticated update' ausgeführt haben.

Benutzeravatar
m.radtke
Beiträge: 413
Registriert: 10 Jun 2015, 12:19

Re: Aktualisierte Pakete für opsi 4.0.7 in testing

Beitragvon m.radtke » 10 Aug 2017, 08:17

thomas.besser hat geschrieben:Ah, eine bislang unbekannte Option. Danke.

der Vollständigkeit halber: man muss vorher auch 'apt-get --allow-unauthenticated update' ausgeführt haben.


danke für den Hinweis.

wir werden unsere Doku entsprechend anpassen.

Gruß
Mathias
Kein Support per DM!
_________________________
opsi support - http://www.uib.de/
For productive opsi installations we recommend support contracts.


Zurück zu „News“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast